Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libreoffice-4.1.1.2 and 4.1.2.2 failed to emerge [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
yzg
Apprentice
Apprentice


Joined: 18 Jun 2005
Posts: 192

PostPosted: Thu Sep 19, 2013 6:19 am    Post subject: libreoffice-4.1.1.2 and 4.1.2.2 failed to emerge [SOLVED] Reply with quote

The problem: There is a moc file generated by older version of Qt
Code:

In file included from /store/portage/tmp/portage/app-office/libreoffice-4.1.1.2/work/libreoffice-4.1.1.2/vcl/unx/kde4/KDEXLib.cxx:399:0:
/var/tmp/portage/app-office/libreoffice-4.1.1.2/work/libreoffice-4.1.1.2/workdir/unxlngx6.pro/CustomTarget/vcl/unx/kde4/KDEXLib.moc:14:2: error: #error "This file was generated using the moc from 4.7.4. It"
/var/tmp/portage/app-office/libreoffice-4.1.1.2/work/libreoffice-4.1.1.2/workdir/unxlngx6.pro/CustomTarget/vcl/unx/kde4/KDEXLib.moc:15:2: error: #error "cannot be used with the include files from this version of Qt."
/var/tmp/portage/app-office/libreoffice-4.1.1.2/work/libreoffice-4.1.1.2/workdir/unxlngx6.pro/CustomTarget/vcl/unx/kde4/KDEXLib.moc:16:2: error: #error "(The moc has changed too much.)"


The solution: regenerate this moc file
Code:

ebuild /usr/portage/app-office/libreoffice/libreoffice-4.1.1.2.ebuild unpack
cd /store/portage/tmp/portage/app-office/libreoffice-4.1.1.2/work/libreoffice-4.1.1.2/workdir/unxlngx6.pro/CustomTarget/vcl/unx/kde4/
moc ../../../../../../vcl/unx/kde4/KDEXLib.hxx > KDEXLib.moc
ebuild /usr/portage/app-office/libreoffice/libreoffice-4.1.1.2.ebuild compile
ebuild /usr/portage/app-office/libreoffice/libreoffice-4.1.1.2.ebuild install
ebuild /usr/portage/app-office/libreoffice/libreoffice-4.1.1.2.ebuild qmerge
ebuild /usr/portage/app-office/libreoffice/libreoffice-4.1.1.2.ebuild clean
emerge --noreplace  libreoffice


Last edited by yzg on Tue Sep 24, 2013 3:45 am; edited 1 time in total
Back to top
View user's profile Send private message
yzg
Apprentice
Apprentice


Joined: 18 Jun 2005
Posts: 192

PostPosted: Tue Sep 24, 2013 3:43 am    Post subject: Reply with quote

The same problem is still there in libreoffice-4.1.2.2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum