Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how to stop emerge from give me a certain message.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
papandreoos
n00b
n00b


Joined: 17 Dec 2014
Posts: 37

PostPosted: Tue Jan 20, 2015 2:55 pm    Post subject: how to stop emerge from give me a certain message. Reply with quote

i uninstalled gnome-keyring to try to remove the annoying message when i use chromium.
this is (sort of) the message:
http://wiki.onsever.ru/_media/linux/untitled_window_008.png
i can just press cancel and it's gone away, but it keeps coming every now and then, and i don't like it :-).

after i uninstalled this package(which belongs to gnome-base) i put:
gnome-base/gnome-keyring
in the file:
/etc/portage/package.mask/gnome-keyring
to mask this packege from being installed again when i emerge @world.

but when i emerge world, i get this message now(which i want to get rid of):
Code:
Calculating dependencies... done!
[ebuild  N    #] gnome-base/gnome-keyring-3.14.0  USE="caps filecaps pam ssh-agent -debug (-selinux) {-test}"

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by gnome-base/gnome-core-apps-3.14.0
# required by gnome-base/gnome-3.14.0
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/gnome-keyring:
=gnome-base/gnome-keyring-3.14.0

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


how do i prevent portage from giving me this message every time i'm updating world?
i just want portage to ignore gnome-keyring and not try to install it again.
Back to top
View user's profile Send private message
sebB
Guru
Guru


Joined: 02 Mar 2011
Posts: 341
Location: S.O. France

PostPosted: Tue Jan 20, 2015 5:22 pm    Post subject: Reply with quote

You can't.
gnome-core-apps depend on gnome-keyring (see the ebuild)

You can't disable it in the gnome options or kill the daemon?
Back to top
View user's profile Send private message
papandreoos
n00b
n00b


Joined: 17 Dec 2014
Posts: 37

PostPosted: Tue Jan 20, 2015 7:45 pm    Post subject: Reply with quote

"You can't disable it in the gnome options or kill the daemon?"

well, i don't know :-).
i'll check in the gnome options if there is an option to do this.
Back to top
View user's profile Send private message
papandreoos
n00b
n00b


Joined: 17 Dec 2014
Posts: 37

PostPosted: Tue Jan 20, 2015 11:06 pm    Post subject: Reply with quote

i think i solve this.
in gnome get to passwords and keys.
there, there is in the left pannel a "login" menu with an image of a folder.
right click on it and press delete.
it will open a warning and you have to sign a check box and then you can delete.
it seems that now i don't have this keyring message while i'm using chromium.

thanks :-)
Back to top
View user's profile Send private message
mubai
n00b
n00b


Joined: 10 Jul 2004
Posts: 26
Location: Sweden

PostPosted: Wed Jan 21, 2015 6:30 am    Post subject: Reply with quote

There's a USE flag for www-client/chromium. Just add
Code:
www-client/chromium -gnome-keyring
to package.use and re-emerge chromium. Hopefully this will do it (but only for that specific package, of course).
Back to top
View user's profile Send private message
papandreoos
n00b
n00b


Joined: 17 Dec 2014
Posts: 37

PostPosted: Wed Jan 21, 2015 1:21 pm    Post subject: Reply with quote

mubai wrote:
There's a USE flag for www-client/chromium. Just add
Code:
www-client/chromium -gnome-keyring
to package.use and re-emerge chromium. Hopefully this will do it (but only for that specific package, of course).


thanks mate!
the message of the keyring is poping up just when i'm using chromium so it's OK this is just in chromium.

as i said in a message before this, i managed to solve this (so it seems) in a different way, but maybe (in the futute) i'll install again gnome-keyring and then emerge chromium with the USE flag you suggested and see if this is also working
Back to top
View user's profile Send private message
Joseph K.
Guru
Guru


Joined: 07 Jun 2006
Posts: 401
Location: Melbourne, Australia

PostPosted: Mon Apr 20, 2015 12:51 am    Post subject: Reply with quote

Now that chromium-42 requires app-crypt/libsecret it transitively requires gnome-keyring regardless of what USE flag is set.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum