Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Проблема с обновлением
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
plisket
n00b
n00b


Joined: 07 Mar 2019
Posts: 16
Location: Москва

PostPosted: Thu Mar 07, 2019 11:02 am    Post subject: Проблема с обновлением Reply with quote

Помогите, пожалуйста - как разрешить конфликты слотов? :
Пробую так:

emerge --update --newuse --deep --ask --verbose-conflicts --backtrack 150 @world

Quote:
Total: 451 packages (361 upgrades, 1 downgrade, 57 new, 8 in new slots, 24 reinstalls), Size of downloads: 2 780 257 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

(dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) pulled in by
=dev-lang/perl-5.26* required by (virtual/perl-version-0.991.700:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-IO-1.380.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Perl-OSType-1.10.0-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Storable-2.620.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Digest-1.170.100_rc-r7:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-JSON-PP-2.274.0.200_rc:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Exporter-5.720.0-r3:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Time-Local-1.250.0-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-podlators-4.90.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Test-Harness-3.380.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Getopt-Long-2.490.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Module-Metadata-1.0.33-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-IO-Socket-IP-0.380.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-MIME-Base64-3.150.0-r4:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-ExtUtils-ParseXS-3.340.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Text-ParseWords-3.300.0-r4:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Encode-2.880.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Time-HiRes-1.974.100-r2:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-libnet-3.100.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Data-Dumper-2.167.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Compress-Raw-Zlib-2.74.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Compress-Raw-Bzip2-2.74.0-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-CPAN-2.180.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-ExtUtils-Manifest-1.700.0-r5:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Carp-1.420.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-Digest-MD5-2.550.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-ExtUtils-MakeMaker-7.240.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::gentoo, installed)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-XSLoader-0.270.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-IO-Compress-2.74.0-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-parent-0.236.0-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
=dev-lang/perl-5.26* required by (virtual/perl-File-Spec-3.670.0:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^

(dev-lang/perl-5.24.4:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
dev-lang/perl:0/5.24= required by (virtual/perl-ExtUtils-Manifest-1.700.0-r5:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/XML-SAX-Expat-0.510.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-Text-ParseWords-3.300.0-r4:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Digest-SHA1-2.130.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/Text-CSV-1.950.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/HTML-Parser-3.720.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-MIME-Base64-3.150.0-r4:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/URI-1.730.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/MailTools-2.190.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (net-dialup/freeradius-3.0.15:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/XML-Simple-2.250.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/XML-NamespaceSupport-1.120.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/XML-SAX-1.0.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Unicode-Map-0.112.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/MIME-tools-5.509.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/Locale-gettext-1.70.0:0/0::gentoo, installed)
^^^^^^^^
>=dev-lang/perl-5:0/5.24= required by (mate-base/caja-1.18.5:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/NetAddr-IP-4.79.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Regexp-IPv6-0.30.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/SGMLSpm-1.1-r1:0/0::gentoo, installed)
^^^^^^^^
>=dev-lang/perl-5:0/5.24= required by (mate-base/mate-panel-1.18.7:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-File-Path-2.130.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Digest-Perl-MD5-1.900.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-Exporter-5.720.0-r3:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/Text-CSV_XS-1.340.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/Text-Unidecode-1.300.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Spreadsheet-ParseExcel-0.650.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Crypt-PasswdMD5-1.400.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/IO-stringy-2.111.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-tex/html2latex-1.1-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/OLE-StorageLite-0.190.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/HTML-Tree-5.70.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/XML-Parser-2.440.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/XML-LibXML-2.13.200:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/IO-Stty-0.30.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-Digest-1.170.100_rc-r7:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Text-CharWidth-0.40.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/libintl-perl-1.280.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (perl-core/File-Path-2.130.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/Socket6-0.280.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/IO-Tty-1.120.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Crypt-RC4-2.020.0-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (app-text/po4a-0.47-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24= required by (dev-perl/XML-SAX-Base-1.90.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/TimeDate-2.300.0:0/0::gentoo, installed)
^^^^^^^^
dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed)
^^^^^^^^

dev-qt/qtcore:5

(dev-qt/qtcore-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtcore-5.12.1 required by (dev-qt/qtgui-5.12.1-r1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^
>=dev-qt/qtcore-5.11.1:5 required by (kde-frameworks/kdoctools-5.54.0-r1:5/5.54::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^
>=dev-qt/qtcore-5.11.1:5 required by (kde-frameworks/ki18n-5.54.0:5/5.54::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^
~dev-qt/qtcore-5.12.1 required by (dev-qt/qtdbus-5.12.1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^
>=dev-qt/qtcore-5.11.1:5 required by (kde-frameworks/karchive-5.54.0:5/5.54::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^
>=dev-qt/qtcore-5.11.1:5 required by (kde-frameworks/breeze-icons-5.54.0:5/5.54::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^
(and 2 more with the same problems)

(dev-qt/qtcore-5.11.3-r2:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtcore-5.11.3 required by (dev-qt/linguist-tools-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtnetwork-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtgui-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtsvg-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qttest-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtscript-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtwebengine-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtwidgets-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtprintsupport-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtbluetooth-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtconcurrent-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtopengl-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtdbus-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtxml-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtxmlpatterns-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtdeclarative-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtx11extras-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtquickcontrols-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
>=dev-qt/qtcore-5.11.1:5 required by (kde-frameworks/breeze-icons-5.54.0:5/5.54::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtwebchannel-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtsql-5.11.3:5/5.11.3::gentoo, ebuild scheduled for merge)
^ ^^^^^^
>=dev-qt/qtcore-5.11.1:5 required by (kde-frameworks/kdoctools-5.54.0-r1:5/5.54::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qttranslations-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
>=dev-qt/qtcore-5.11.1:5 required by (kde-frameworks/ki18n-5.54.0:5/5.54::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtwebsockets-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
>=dev-qt/qtcore-5.11.1:5 required by (kde-frameworks/karchive-5.54.0:5/5.54::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qthelp-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtcore-5.11.3 required by (dev-qt/qtmultimedia-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 24 more with the same problems)

(dev-qt/qtcore-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtcore-5.9.6 required by (dev-qt/qtdbus-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^
~dev-qt/qtcore-5.9.6 required by (dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^
~dev-qt/qtcore-5.9.6 required by (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed)
^ ^^^^^
(and 3 more with the same problems)

dev-qt/qtgui:5

(dev-qt/qtgui-5.12.1-r1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-qt/qtgui-5.11.3:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtgui-5.11.3[gles2=] required by (dev-qt/qtdeclarative-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3[gles2=] required by (dev-qt/qtprintsupport-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3[gles2=] required by (dev-qt/qtopengl-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3[xcb] required by (dev-qt/qtx11extras-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3[gles2=,png=,xcb?] required by (dev-qt/qtwidgets-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3 required by (dev-qt/qtquickcontrols-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3[gles2=] required by (dev-qt/qtmultimedia-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3 required by (dev-qt/qthelp-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3[dbus] required by (dev-qt/qtwidgets-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3 required by (dev-qt/qtwebengine-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtgui-5.11.3 required by (dev-qt/qtsvg-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 11 more with the same problems)

(dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtgui-5.9.6[dbus] required by (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed)
^ ^^^^^
~dev-qt/qtgui-5.9.6[-gles2,png,xcb] required by (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed)
^ ^^^^^
(and 2 more with the same problems)

dev-qt/qtdbus:5

(dev-qt/qtdbus-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtdbus-5.12.1 required by (dev-qt/qtgui-5.12.1-r1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 1 more with the same problem)

(dev-qt/qtdbus-5.11.3:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtdbus-5.11.3 required by (dev-qt/qtgui-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtdbus-5.11.3 required by (dev-qt/qtbluetooth-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 2 more with the same problems)

(dev-qt/qtdbus-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtdbus-5.9.6 required by (dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^
(and 1 more with the same problem)

dev-qt/qtwidgets:5

(dev-qt/qtwidgets-5.11.3:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtwidgets-5.11.3[gles2=] required by (dev-qt/qtprintsupport-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtwidgets-5.11.3[gles2=] required by (dev-qt/qtdeclarative-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtwidgets-5.11.3 required by (dev-qt/qtsvg-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtwidgets-5.11.3 required by (dev-qt/qthelp-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtwidgets-5.11.3 required by (dev-qt/qtquickcontrols-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtwidgets-5.11.3 required by (dev-qt/qtwebengine-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^
~dev-qt/qtwidgets-5.11.3[gles2=] required by (dev-qt/qtopengl-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^^^^

(dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed) pulled in by
>=dev-qt/qtwidgets-5.9.1:5/5.9= required by (dev-qt/qtwebkit-5.212.0_pre20180120:5/5.212::gentoo, installed)
^^^^^^^

dev-libs/icu:0

(dev-libs/icu-63.1-r1:0/63.1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-libs/icu-60.2:0/60.2::gentoo, installed) pulled in by
>=dev-libs/icu-4.4:0/60.2= required by (dev-tex/bibtexu-3.71_p20170524:0/0::gentoo, installed)
^^^^^^^^
dev-libs/icu:0/60.2= required by (media-libs/libzmf-0.0.2:0/0::gentoo, installed)
^^^^^^^^
dev-libs/icu:0/60.2= required by (dev-qt/qtwebkit-5.212.0_pre20180120:5/5.212::gentoo, installed)
^^^^^^^^
dev-libs/icu:0/60.2= required by (app-text/libmspub-0.1.4:0/0::gentoo, installed)
^^^^^^^^
dev-libs/icu:0/60.2= required by (media-libs/libvisio-0.1.6:0/0::gentoo, installed)
^^^^^^^^
dev-libs/icu:0/60.2= required by (app-text/libebook-0.1.2-r1:0/0::gentoo, installed)
^^^^^^^^
dev-libs/icu:0/60.2= required by (dev-db/clickhouse-18.12.17:0/stable::gentoo, installed)
^^^^^^^^
dev-libs/icu:0/60.2= required by (dev-qt/qtcore-5.9.6:5/5.9::gentoo, installed)
^^^^^^^^

dev-libs/double-conversion:0

(dev-libs/double-conversion-3.0.3:0/2::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-libs/double-conversion-3.0.0:0/1::gentoo, installed) pulled in by
dev-libs/double-conversion:0/1= required by (dev-qt/qtcore-5.9.6:5/5.9::gentoo, installed)
^^^^^

media-libs/libvpx:0

(media-libs/libvpx-1.7.0:0/5::gentoo, ebuild scheduled for merge) pulled in by
<media-libs/libvpx-1.8 required by (dev-qt/qtwebengine-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
^ ^^^
<media-libs/libvpx-1.8 required by (www-client/firefox-65.0.2:0/0::gentoo, ebuild scheduled for merge)
^ ^^^

(media-libs/libvpx-1.8.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
>=media-libs/libvpx-1.7.0:0=[postproc] required by (www-client/firefox-65.0.2:0/0::gentoo, ebuild scheduled for merge)
^^^^^^^^

dev-libs/re2:0

(dev-libs/re2-0.2018.10.01:0/gentoo-2017-03-01::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-libs/re2-0.2016.05.01:0/0.2016.05.01::gentoo, installed) pulled in by
dev-libs/re2:0/0.2016.05.01= required by (dev-db/clickhouse-18.12.17:0/stable::gentoo, installed)
^^^^^^^^^^^^^^^^

x11-base/xorg-server:0

(x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, ebuild scheduled for merge) pulled in by
>=x11-base/xorg-server-1.20[glamor] required by (x11-base/xorg-drivers-1.20:0/0::gentoo, ebuild scheduled for merge)
^^ ^^^^

(x11-base/xorg-server-1.19.5-r2:0/1.19.5::gentoo, installed) pulled in by
x11-base/xorg-server:0/1.19.5= required by (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, installed)
^^^^^^^^^^
x11-base/xorg-server:0/1.19.5= required by (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, installed)
^^^^^^^^^^
x11-base/xorg-server:0/1.19.5= required by (x11-drivers/xf86-input-mouse-1.9.3:0/0::gentoo, installed)
^^^^^^^^^^

sys-libs/binutils-libs:0

(sys-libs/binutils-libs-2.30-r4:0/2.30-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(sys-libs/binutils-libs-2.30-r2:0/2.30::gentoo, installed) pulled in by
sys-libs/binutils-libs:0/2.30= required by (dev-lang/ocaml-4.04.2-r1:0/4.04.2::gentoo, installed)
^^^^^^^^
sys-libs/binutils-libs:0/2.30= required by (dev-util/perf-4.14.33:0/0::gentoo, installed)
^^^^^^^^

app-text/poppler:0

(app-text/poppler-0.74.0:0/85::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(app-text/poppler-0.62.0-r1:0/73::gentoo, installed) pulled in by
>=app-text/poppler-0.58.0:0/73= required by (app-text/texlive-core-2017-r4:0/0::gentoo, installed)
^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

(dev-qt/qtcore-5.9.6:5/5.9::gentoo, installed): ebuild is masked or unavailable
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 540

PostPosted: Fri Mar 08, 2019 5:32 pm    Post subject: Reply with quote

Да, всё-плохо

а что выдаёт
Code:
emerge world -up

_________________
Do not use gentoo, it die
Back to top
View user's profile Send private message
plisket
n00b
n00b


Joined: 07 Mar 2019
Posts: 16
Location: Москва

PostPosted: Mon Mar 11, 2019 10:14 am    Post subject: Reply with quote

TigerJr wrote:
Да, всё-плохо

а что выдаёт
Code:
emerge world -up


очень длинный вывод, не знаю как его убрать под кат(
Quote:

[blocks B ] <dev-qt/qtdeclarative-5.12.0_beta4:5 ("<dev-qt/qtdeclarative-5.12.0_beta4:5" is blocking dev-qt/qtxmlpatterns-5.12.1)

Total: 222 packages (142 upgrades, 1 downgrade, 11 new, 3 in new slots, 65 reinstalls), Size of downloads: 2 144 382 KiB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libvpx:0

(media-libs/libvpx-1.8.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
>=media-libs/libvpx-1.7.0:0=[postproc] required by (www-client/firefox-65.0.2:0/0::gentoo, ebuild scheduled for merge)
^^^^^^^^

(media-libs/libvpx-1.7.0:0/5::gentoo, ebuild scheduled for merge) pulled in by
<media-libs/libvpx-1.8 required by (www-client/firefox-65.0.2:0/0::gentoo, ebuild scheduled for merge)
^ ^^^

dev-lang/perl:0

(dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) pulled in by
=dev-lang/perl-5.26* required by (virtual/perl-Time-Local-1.250.0-r1:0/0::gentoo, ebuild scheduled for merge)
^ ^^^^^
(and 29 more with the same problem)

(dev-lang/perl-5.24.3-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
=dev-lang/perl-5.24* required by (virtual/perl-Getopt-Long-2.480.0-r1:0/0::gentoo, installed)
^ ^^^^^
dev-lang/perl:0/5.24= required by (virtual/perl-CPAN-Meta-2.150.5-r1:0/0::gentoo, installed)
^^^^^^^^
(and 2 more with the same problems)

dev-qt/qtwidgets:5

(dev-qt/qtwidgets-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtwidgets-5.12.1[gles2=] required by (dev-qt/qtprintsupport-5.12.1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 2 more with the same problem)

(dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtwidgets-5.9.6[-gles2] required by (dev-qt/qtopengl-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^
(and 4 more with the same problem)

dev-qt/qtgui:5

(dev-qt/qtgui-5.12.1-r1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtgui-5.12.1 required by (dev-qt/qtwebengine-5.12.1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 4 more with the same problem)

(dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtgui-5.9.6 required by (dev-qt/qtquickcontrols-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^
(and 8 more with the same problem)

dev-qt/qtcore:5

(dev-qt/qtcore-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtcore-5.12.1 required by (dev-qt/qtwebchannel-5.12.1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 9 more with the same problem)

(dev-qt/qtcore-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtcore-5.9.6 required by (dev-qt/qtxmlpatterns-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^
(and 18 more with the same problem)

dev-qt/qtdbus:5

(dev-qt/qtdbus-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtdbus-5.12.1 required by (dev-qt/qtgui-5.12.1-r1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^

(dev-qt/qtdbus-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtdbus-5.9.6 required by (dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^
(and 1 more with the same problem)

dev-qt/qtnetwork:5

(dev-qt/qtnetwork-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtnetwork-5.12.1 required by (dev-qt/qtxmlpatterns-5.12.1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 2 more with the same problem)

(dev-qt/qtnetwork-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtnetwork-5.9.6[ssl] required by (dev-qt/qtwebsockets-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^
(and 4 more with the same problem)

dev-qt/qtdeclarative:5

(dev-qt/qtdeclarative-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtdeclarative-5.12.1 required by (dev-qt/qtwebengine-5.12.1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^
(and 2 more with the same problem)

(dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtdeclarative-5.9.6 required by (dev-qt/qtquickcontrols-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^

dev-qt/qttest:5

(dev-qt/qttest-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qttest-5.12.1 required by (dev-qt/qtdeclarative-5.12.1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^

(dev-qt/qttest-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qttest-5.9.6 required by (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^

dev-qt/qtxmlpatterns:5

(dev-qt/qtxmlpatterns-5.12.1:5/5.12::gentoo, ebuild scheduled for merge) pulled in by
~dev-qt/qtxmlpatterns-5.12.1 required by (dev-qt/qtdeclarative-5.12.1:5/5.12::gentoo, ebuild scheduled for merge)
^ ^^^^^^

(dev-qt/qtxmlpatterns-5.9.6:5/5.9::gentoo, installed) pulled in by
~dev-qt/qtxmlpatterns-5.9.6 required by (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, installed)
^ ^^^^^

app-emulation/libvirt:0

(app-emulation/libvirt-4.9.0:0/4.9.0::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(app-emulation/libvirt-4.5.0-r1:0/4.5.0::gentoo, installed) pulled in by
app-emulation/libvirt:0/4.5.0 required by (dev-python/libvirt-python-4.5.0:0/0::gentoo, installed)
^^^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 540

PostPosted: Wed Mar 13, 2019 10:40 pm    Post subject: Reply with quote

Попробуй удалить блокирующий пакет:
Code:
emerge -Ca qtdeclarative


и затем попробуй обновить world а затем заново его накатить
_________________
Do not use gentoo, it die
Back to top
View user's profile Send private message
plisket
n00b
n00b


Joined: 07 Mar 2019
Posts: 16
Location: Москва

PostPosted: Tue Mar 19, 2019 2:01 pm    Post subject: Reply with quote

TigerJr wrote:
Попробуй удалить блокирующий пакет:
Code:
emerge -Ca qtdeclarative


и затем попробуй обновить world а затем заново его накатить


Спасибо большое!
В итоге помогло ручное обновление Qt по рецепту отсюда:
https://wiki.gentoo.org/wiki/Qt/FAQ

Вручную удаляем все пакеты, затем также вручную устанавливаем новые:

Code:
export INSTALLED_QT_PACKAGES=$(eix --only-names -IC dev-qt)
emerge -Ca ${INSTALLED_QT_PACKAGES} && emerge -av1 ${INSTALLED_QT_PACKAGES}
Back to top
View user's profile Send private message
globus
n00b
n00b


Joined: 24 Dec 2014
Posts: 42
Location: Newsiberianstadt, Rus

PostPosted: Fri Mar 22, 2019 12:52 pm    Post subject: Reply with quote

Удалить - это да, а вот зачем вручную потом накатывать? То что надо в процессе обновления само установится.
Back to top
View user's profile Send private message
plisket
n00b
n00b


Joined: 07 Mar 2019
Posts: 16
Location: Москва

PostPosted: Sat Mar 23, 2019 6:28 pm    Post subject: Reply with quote

globus wrote:
Удалить - это да, а вот зачем вручную потом накатывать? То что надо в процессе обновления само установится.

Да, и правда) но мне просто нужен был QT побыстрее. А так - можно было подождать пока вся система обновится
Back to top
View user's profile Send private message
ivan-gentoo
n00b
n00b


Joined: 12 Mar 2020
Posts: 2

PostPosted: Thu Mar 12, 2020 8:43 am    Post subject: Reply with quote

Добрый день.
Сильно не пинайте, с gentoo совсем недавно.
Gentoo не обновлялся с 2014 сейчас 2020. крутиться samba dhcp и т.д.
Это шлюз. Хочу развернуть openvpn:
Code:
 sudo emerge =openvpn-2.3.1
* IMPORTANT: 21 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

 * Last emerge --sync was Sun Oct 26 22:05:01 2014.
Calculating dependencies... done!
Traceback (most recent call last):
  File "/usr/bin/emerge", line 43, in <module>
    retval = emerge_main()
  File "/usr/lib64/portage/pym/_emerge/main.py", line 2041, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/lib64/portage/pym/_emerge/actions.py", line 298, in action_build
    settings, trees, myopts, myparams, myaction, myfiles, spinner)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6937, in backtrack_depgraph
    myaction, myfiles, spinner)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6969, in _backtrack_depgraph
    success, favorites = mydepgraph.select_files(myfiles)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 2267, in select_files
    return self._resolve(myfavorites)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 2385, in _resolve
    if not self._create_graph():
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 879, in _create_graph
    if not self._pop_disjunction(allow_unsatisfied):
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 1893, in _pop_disjunction
    pkg, dep_root, dep_priority, dep_string, allow_unsatisfied):
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 1513, in _add_pkg_dep_string
    allow_unsatisfied)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 1536, in _wrapped_add_pkg_dep_string
    strict=strict, priority=dep_priority)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 2600, in _select_atoms_highest_available
    myroot=root, trees=trees)
  File "/usr/lib64/portage/pym/portage/dep/dep_check.py", line 631, in dep_check
    use_binaries=use_binaries, myroot=myroot, trees=trees)
  File "/usr/lib64/portage/pym/portage/dep/dep_check.py", line 111, in _expand_new_virtuals
    matches = portdb.match_pkgs(x.without_use)
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6859, in match_pkgs
    return [self._cpv_pkg_map[cpv] for cpv in self.match(atom)]
  File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6777, in match
    slot_atom = atom.with_slot(slots.pop())
  File "/usr/lib64/portage/pym/portage/dep/__init__.py", line 1267, in with_slot
    return Atom(atom, allow_repo=True, allow_wildcard=True)
  File "/usr/lib64/portage/pym/portage/dep/__init__.py", line 1113, in __init__
    raise InvalidAtom(self)
InvalidAtom: virtual/pam:




Я почитал что обновление portege может привести к падению сервера. Еще не понимаю к чему приведут эти изменения в файлах.
Так вот подскажите как мне можно установить opevpn без риска? я попытался старую версию установить но все равно эти же ошибки.
Заранее благодарен.
Back to top
View user's profile Send private message
globus
n00b
n00b


Joined: 24 Dec 2014
Posts: 42
Location: Newsiberianstadt, Rus

PostPosted: Thu Mar 12, 2020 10:15 am    Post subject: Reply with quote

Просто установить openvpn не получится, уже сменилась масса библиотек, компиляторов и прочего. Путь лежит обновлять всю систему, что из такой дали нелегко само по себе, а потом устанавливать.
Back to top
View user's profile Send private message
ivan-gentoo
n00b
n00b


Joined: 12 Mar 2020
Posts: 2

PostPosted: Thu Mar 12, 2020 10:30 am    Post subject: Reply with quote

Хорошо, понял, спасибо.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum