Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201908-24 ] MariaDB, MySQL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2231

PostPosted: Sun Aug 18, 2019 6:26 am    Post subject: [ GLSA 201908-24 ] MariaDB, MySQL Reply with quote

Gentoo Linux Security Advisory

Title: MariaDB, MySQL: Multiple vulnerabilities (GLSA 201908-24)
Severity: normal
Exploitable: local, remote
Date: 2019-08-18
Bug(s): #661500, #670388, #679024
ID: 201908-24

Synopsis

Multiple vulnerabilities have been found in MariaDB and MySQL, the
worst of which could result in privilege escalation.


Background

MariaDB is an enhanced, drop-in replacement for MySQL. MySQL is a
popular multi-threaded, multi-user SQL server. MySQL is a popular
multi-threaded, multi-user SQL server


Affected Packages

Package: dev-db/mariadb
Vulnerable: < 10.1.38-r1
Vulnerable: < 10.2.22
Unaffected: >= 10.1.38-r1
Unaffected: >= 10.2.22
Architectures: All supported architectures

Package: dev-db/mysql
Vulnerable: < 5.6.42
Vulnerable: < 5.7.24
Unaffected: >= 5.6.42
Unaffected: >= 5.7.24
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in MariaDB and MySQL.
Please review the CVE identifiers referenced below for details.


Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All MariaDB 10.1.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/mariadb-10.1.38-r1"
   
All MariaDB 10.2.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/mariadb-10.2.22"
   
All MySQL 5.6.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.6.42"
   
All MySQL 5.7.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.7.24"
   


References

CVE-2018-2755
CVE-2018-2759
CVE-2018-2761
CVE-2018-2766
CVE-2018-2771
CVE-2018-2777
CVE-2018-2781
CVE-2018-2782
CVE-2018-2784
CVE-2018-2786
CVE-2018-2787
CVE-2018-2810
CVE-2018-2813
CVE-2018-2817
CVE-2018-2819
CVE-2018-3143
CVE-2018-3156
CVE-2018-3162
CVE-2018-3173
CVE-2018-3174
CVE-2018-3185
CVE-2018-3200
CVE-2018-3251
CVE-2018-3252
CVE-2018-3277
CVE-2018-3282
CVE-2018-3284
CVE-2019-2510
CVE-2019-2529
CVE-2019-2537
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum