Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201709-04 ] mod_gnutls
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1969

PostPosted: Sun Sep 17, 2017 6:26 pm    Post subject: [ GLSA 201709-04 ] mod_gnutls Reply with quote

Gentoo Linux Security Advisory

Title: mod_gnutls: Certificate validation error (GLSA 201709-04)
Severity: normal
Exploitable: remote
Date: 2017-09-17
Bug(s): #541038
ID: 201709-04

Synopsis

A vulnerability in mod_gnutls allows remote attackers to spoof
clients via crafted certificates.


Background

mod_gnutls is an extension for ​Apache’s httpd. It uses the
​GnuTLS library to provide HTTPS. It supports some protocols and
features that mod_ssl does not.


Affected Packages

Package: www-apache/mod_gnutls
Vulnerable: < 0.7.3
Unaffected: >= 0.7.3
Architectures: All supported architectures


Description

It was discovered that the authentication hook in mod_gnutls does not
validate client’s certificates even when option
“GnuTLSClientVerify” is set to “require”.


Impact

A remote attacker could present a crafted certificate and spoof clients
data.


Workaround

There is no known workaround at this time.

Resolution

All mod_gnutls users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=www-apache/mod_gnutls-0.7.3"
   


References


CVE-2015-2091
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum