Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Нет изображения xf86-video-ati, черный экран (не подсветка)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Makubo
n00b
n00b


Joined: 28 Dec 2016
Posts: 3
Location: Russia, Orenburg

PostPosted: Wed Dec 28, 2016 6:17 pm    Post subject: Нет изображения xf86-video-ati, черный экран (не подсветка) Reply with quote

Добрый день.

У меня видеокарта Radeon Saymour HD6470M. Жил до недавних пор с fglrx, давно было желание поставить открытые драйвера, но руки никак не доходили да и вроде работает - не трож. Но пришло время обновляться на plasma 5, и вместе с ней затянулся новый 18-й xorg-server, с которым проприетарные дрова работать перестали. Ну думаю, пришло время и открытому драйверу. В итоге сейчас сижу на процессорной видеокарте i915 c нерабочей дискретной картой. Весь интернет перерыл, похожие жалобы видел, но решения не нашел.

Симптоматика такая: вырубаю иксы, и переключаюсь на дискретную видеокарту в итоге экран потухает, зажигаю экран (echo ON > /sys/kernel/debug/vgaswitcheroo/switch) - подсветка включается, но все черное. Иксы не трогаю, оставляю выключенными (представим что у меня их и нет, для начала)
    # lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] (rev ff)

Так все работает:
    # cat /sys/kernel/debug/vgaswitcheroo/switch
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Off:0000:01:00.0

Так гаснет даже консоль:
    # cat /sys/kernel/debug/vgaswitcheroo/switch
    0:IGD: :Pwr:0000:00:02.0
    1:DIS:+:Pwr:0000:01:00.0


Конфиг ядра: http://pastebin.com/PHhdKp4X
make.conf: http://pastebin.com/YTDKSR7x

Все время меня не покидает ощущение, что я упустил какую-то мелочь.
Back to top
View user's profile Send private message
Baritone
n00b
n00b


Joined: 16 Aug 2016
Posts: 10
Location: Москва

PostPosted: Wed Feb 15, 2017 5:52 am    Post subject: Re: Нет изображения xf86-video-ati, черный экран (не подсвет Reply with quote

Makubo wrote:
У меня видеокарта Radeon Saymour HD6470M. Жил до недавних пор с fglrx, давно было желание поставить открытые драйвера, но руки никак не доходили да и вроде работает - не трож. Но пришло время обновляться на plasma 5, и вместе с ней затянулся новый 18-й xorg-server, с которым проприетарные дрова работать перестали.

Извините за ответ в стиле "чего-то слышал", но сейчас я на винде на работе, поэтому посмотреть не могу. Помню, что тоже переходил со свободных драйверов на fglrx и обратно, и fglrx требует специффических настроек ядра, грозя в противном случае непредсказуемыми карами. Дефолтное ядро Gentoo ориентировано на модель управления, принятую в свободной ветке.

У меня сейчас противоположная проблема: сынишка хочет "War Thander", а он почему-то понимает только частнособственнические драйвера, а на мою карту это лишь fglrx, который уже замаскирован для исключения из кодовой базы. Сейчас спешно собираю версию Gentooс с устаревшими X-ами. Печалька.
Back to top
View user's profile Send private message
Makubo
n00b
n00b


Joined: 28 Dec 2016
Posts: 3
Location: Russia, Orenburg

PostPosted: Mon Feb 27, 2017 9:04 am    Post subject: Reply with quote

Baritone, спасибо за ответ.

Вопрос стоит как раз слезть с fglrx. Пока руки не доходят до проблемы, которая все еще висит. Пересборка старых иксов - это план Б, но я еще не потерял надежду.
Back to top
View user's profile Send private message
Tvin
n00b
n00b


Joined: 15 Sep 2010
Posts: 27

PostPosted: Sun May 21, 2017 9:05 am    Post subject: Reply with quote

Была подобная беда на ноуте с двумя АМД. Прописал в файле xorg.conf две видеокарты и какие дрова для каждой -- всё заработало. Попробуйте. Автоматическое определение при двух картах или плохо работает, или вообще не работает.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum