Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strano problema con il mouse in xorg e kernel2.6.31[RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
pask1970
n00b
n00b


Joined: 07 Dec 2003
Posts: 57
Location: Ischia

PostPosted: Thu Sep 24, 2009 5:04 pm    Post subject: Strano problema con il mouse in xorg e kernel2.6.31[RISOLTO] Reply with quote

Salve a tutti.
Allora, premetto che, anche se uso Gentoo da qualche annetto ormai, non sono un grande esperto di kernel e tutto ciò che attiene i moduli, driver ecc.
Il problema è questo. Uso Gentoo Testing, e xorg con l'opzione "evdev". Nello xorg.conf ho giusto un paio di opzioni relative alla scheda video (una Radeon X1950XTX).
Il mio problema riguarda il mouse; al primo avvio di X dopo l'upgrade, non funzionava. Al che, consultando il log di xorg, mi sono reso conto che lo vedeva come un "macintosh mouse" (!!!) e quindi caricava i driver relativi dal kernel. Pertanto ho provato disabilitare il supporto all'hardware macintosh (peraltro inutile).
Per un pò ha funzionato tutto correttamente, poi, del tutto casualmente, in alcuni riavvii il mouse continuava a non funzionare. Provando e riprovando, ho capito che normalmente, venivano creati nella cartella /dev/input i dispositivi da event0 a event4 (e mi sembra anche event 5). Mentre invece, quando il mouse non funzionava, venivano creati i dispositivi da event0 a event2. Il log di xorg, in tal caso, mi dice che sono relativi alla tastiera e a due pulsanti non meglio identificati. Ora però non posso postarlo, perchè non sono davanti al pc in questione e perchè sono ormai alcune sessioni che son tornato al kernel 2.6.30 che non mi da alcun problema.
Dopo questa lunga premessa, volevo chiedervi: è capitato anche a qualcun altro? Da cosa può dipendere? dal kernel o da Udev che non è ancora compatibile col 2.6.31?
Grazie in anticipo per le risposte, e scusate la prolissità :D
Il problema si è presentato anche nel kernel 2.6.30, ma a quanto pare compilando il driver "event interface" (Device Drivers -> Input Device support -> event interface) come modulo si è tutto risolto


Last edited by pask1970 on Sun Sep 27, 2009 9:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Fri Sep 25, 2009 7:08 am    Post subject: Reply with quote

usi hal per gestire i dispositivi di input?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Sep 25, 2009 8:29 am    Post subject: Re: Strano problema con il mouse in xorg e kernel 2.6.31 Reply with quote

pask1970 wrote:
Uso Gentoo Testing
gentoo ~arch? :?
pask1970 wrote:
xorg con l'opzione "evdev". Nello xorg.conf ho giusto un paio di opzioni relative alla scheda video
io direi che tra hal, kernel e udev c'è qualcosa che non va, verifica le versioni e la compatibilità tra di loro. Sempre che hal sia avviato e funzionante.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
pask1970
n00b
n00b


Joined: 07 Dec 2003
Posts: 57
Location: Ischia

PostPosted: Fri Sep 25, 2009 6:22 pm    Post subject: Re: Strano problema con il mouse in xorg e kernel 2.6.31 Reply with quote

devilheart wrote:
usi hal per gestire i dispositivi di input?
Esatto. Ho anche aggiornato xf86-input-evdev alla 2.2.5, niente da fare.
djinnZ wrote:
pask1970 wrote:
Uso Gentoo Testing
gentoo ~arch? :?
sì, intendevo dire Gentoo ~x86 :P
djinnZ wrote:
pask1970 wrote:
xorg con l'opzione "evdev". Nello xorg.conf ho giusto un paio di opzioni relative alla scheda video
io direi che tra hal, kernel e udev c'è qualcosa che non va, verifica le versioni e la compatibilità tra di loro. Sempre che hal sia avviato e funzionante.

Allora:
versione kernel 2.6.31
Hal 0.5.13-r2
Udev 146
Hal è perfettamente funzionante, infatti usando il kernel 2.6.30 non c'è nessun problema. Inoltre il problema si presenta apparentemente a caso, non sempre.
Come potrei fare per verificare la compatibilità tra questi 3 elementi?
Ah, vorrei aggiungere che ho provato a far ripartire xorg, hal e dbus, senza alcun risultato. L'unica cosa che non ho provato è riavviare il demone udev, ora che ci penso. Stasera non sarò davanti al pc, domani provo e magari vi faccio sapere :)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Sep 26, 2009 2:08 pm    Post subject: Reply with quote

Quote:
Chi è causa del suo mal pianga se stesso
usare tutto il sistema ~x86 non è utile (stai usando gentoo non debian, su debian si usa il sistema stabile o quello instabile) percho i singoli pacchetti vengono stabilizzati rispetto al sistema stabile (per capirci, se qualcuno ha voglia spieghi meglio come funziona lo sviluppo), ed il fatto che l'errore non sia sistematico indica chiaramente che potrebbe essere qualsiasi cosa nell'abero delle dipendenze di hal udev ed xorg a causare un crash od un blocco.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
pask1970
n00b
n00b


Joined: 07 Dec 2003
Posts: 57
Location: Ischia

PostPosted: Sat Sep 26, 2009 3:05 pm    Post subject: Reply with quote

djinnZ wrote:
Quote:
Chi è causa del suo mal pianga se stesso
usare tutto il sistema ~x86 non è utile (stai usando gentoo non debian, su debian si usa il sistema stabile o quello instabile) percho i singoli pacchetti vengono stabilizzati rispetto al sistema stabile (per capirci, se qualcuno ha voglia spieghi meglio come funziona lo sviluppo), ed il fatto che l'errore non sia sistematico indica chiaramente che potrebbe essere qualsiasi cosa nell'abero delle dipendenze di hal udev ed xorg a causare un crash od un blocco.

Hai ragione, speravo di potere riuscire a padroneggiare il tutto, ma a quanto sembra occorrono competenze superiori a quelle che io ho (del resto, non sono un programmatore).
Vorrà dire che reinstallerò tutto il sistema in x86, e avanzerò solo i pacchetti di cui avrò bisogno.
Voglio continuare ad usare Gentoo, anche se, ripeto, non sono un programmatore (di professione faccio il commercialista), perchè ho l'hobby dell'informatica e Gentoo mi consente di acquisire un bel pò di esperienza. Spero che se salterò su con qualche domanda stupida, mi aiuterete a dipanare i miei dubbi
Grazie comunque per la disponibilità :)
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sat Sep 26, 2009 3:12 pm    Post subject: Reply with quote

Io ho avuto un problema simile con il kernel 2.6.31. In pratica il 50% delle volte il touchpad non veniva riconosciuto dal kernel e il riavvio dell'intero sistema era l'unico modo di procedere. Si vedeva chiaramente nel "dmesg" una scritta(presente prima dell'inizio dell'init) tipo
Code:
input: PS/2 Mouse as /devices/platform/i8042/serio4/input/input5
.
Quando invece non veniva rilevato(sempre al tempo di boot) la codesta scritta non era presente.

Tutto questo mi è capitato quando ho fatto dei test per velocizzare il boot e ho incluso molte cose come builtin (invece del modulo). Ho risolto semplicemente impostando a moduli alcune cose.

Per pigrizia ti riporto tutto il "lsmod"
Code:

Module                  Size  Used by
usb_storage            28064  0
usb_libusual            8608  1 usb_storage
nvidia               8732024  38
iTCO_wdt                6784  0
mousedev                7688  0
ehci_hcd               26304  0
iTCO_vendor_support     1156  1 iTCO_wdt
psmouse                16976  0
rng_core                2456  0
iwl3945                46112  0
usbcore               101124  4 usb_storage,usb_libusual,ehci_hcd
iwlcore                62544  1 iwl3945
sony_laptop            21816  0
backlight               2024  1 sony_laptop

_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
pask1970
n00b
n00b


Joined: 07 Dec 2003
Posts: 57
Location: Ischia

PostPosted: Sat Sep 26, 2009 3:55 pm    Post subject: Reply with quote

Ti ringrazio, ma ormai ho già piallato tutto il sistema per fare una installazione "pulita" x86 e poi avanzare solo i pacchetti che mi servono :wink:
Grazie comunque. Siete davvero gentili. Spero un giorno di saperne abbastanza da poter aiutare anche io qualcuno
Back to top
View user's profile Send private message
pask1970
n00b
n00b


Joined: 07 Dec 2003
Posts: 57
Location: Ischia

PostPosted: Sun Sep 27, 2009 6:54 am    Post subject: Reply with quote

Ha iniziato a farmi lo stesso problema, anche con installazione x86. Ora ho provato a compilare il driver event come modulo... speriamo bene
Back to top
View user's profile Send private message
pask1970
n00b
n00b


Joined: 07 Dec 2003
Posts: 57
Location: Ischia

PostPosted: Sun Sep 27, 2009 8:59 am    Post subject: Reply with quote

Sembra funzionare... Ho compilato il driver CONFIG_EVDEV come modulo, così come suggerito da Apetrini... ho fatto alcuni riavvii e sembra funzionare tutto perfettamente. Provo ancora un pò, poi metterò il tag RISOLTO, e aggiorno pure il primo post :)
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Sun Sep 27, 2009 9:56 am    Post subject: Reply with quote

pask1970 wrote:
Hai ragione, speravo di potere riuscire a padroneggiare il tutto, ma a quanto sembra occorrono competenze superiori a quelle che io ho (del resto, non sono un programmatore).

non esageriamo
la guida a portage (che trovi alla fine dell'handbook) contiene tutte informazioni di cui necessiti in maniera chiara e semplice.
nello specifico per quanto riguarda pacchetti stabili e non, guarda il Capitolo 3.
Alla fine il sistema di gestione granulare dei pacchetti è uno dei punti di forza di gentoo, non usarlo significa veramente suicidarsi.
buona lettura ;)
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Sep 27, 2009 2:59 pm    Post subject: Reply with quote

pask1970 wrote:
Vorrà dire che reinstallerò tutto il sistema in x86, e avanzerò solo i pacchetti di cui avrò bisogno.
Ecco questa è la strada giusta in gentoo (e quella sbagliata in debian, slackware od altre "binarie"). Non ti crucciare bene o male ci cascano sempre tutti in questa trappola agli inizi.
Non è questione di competenze ma di come funziona lo sviluppo, poter impostare ~arch globalmente è una opzione utile solo ai tester ed ai devel non ad un comune utente, indipendentemente dal suo know-how
pask1970 wrote:
Voglio continuare ad usare Gentoo, anche se, ripeto, non sono un programmatore (di professione faccio il commercialista)
permettimi una grassa risata a tal proposito, per obbligo di legge, complice l'inettitudine della rappresentanza istituzionale, tu devi usare quell'altro sistema inoperativo e pagare la dovuta decima ai soliti noti. :twisted:
Detto da uno che ringraziando una certa cretina ed il DUI si deve convertire alla famigerata accoppiata Intecess Exploder + Outcess (dopo 30 anni di unix) pagando un servizio di posta elettronica certificata al doppio della media delle offerte di mercato.
pask1970 wrote:
Spero che se salterò su con qualche domanda stupida, mi aiuterete a dipanare i miei dubbi
giammai, non aiuto il nemico (sono un CdL) :lol:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 687
Location: tra veneto e friuli (italy)

PostPosted: Sun Sep 27, 2009 4:06 pm    Post subject: Reply with quote

pask1970 wrote:
(di professione faccio il commercialista)

Vado totalmente OT. Scusatemi.

Conosci/usi un software gestionale compatibile anche con linux?

Attualmente in ufficio utilizzano un sedicente software di contabilità basato su Access che praticamente oltre ai suoi limiti/bug/features si inchioda anche per problemi di Access/Office e ovviamente anche per problemi di WinXP/InterdetExploder.
Chi ci deve mettere una pezza è il sottoscritto. Inutile dire che non vedo l'ora di mandarlo dove si merita.
Essendo per usi aziendali non è necessario che sia gratuito o open, basta che funzioni (anche) con linux.
Ciao e grazie in anticipo.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sun Sep 27, 2009 5:44 pm    Post subject: Reply with quote

La domanda è troppo generica, dovresti dire cosa intendi per contabilità e la pubblicità è accettabile solo in pm per le regole di questo forum.

Ti rispondo sulla base della mia esperienza: se cerchi un software contabile realmente compatibile con linux od opensource non esiste.
Anche se sul sito/depliant parlano di linux quando arrivi al dunque negano di poterlo installare, dicono che linux richiede assistenza specifica (ovvero lo dovresti pagare il doppio o devi farti installare e gestire il sistema da loro) ed in genere tutti i problemi sono legati al fatto che vorrebbero fornirti anche assistenza e software generici.
Poi ci sono i falsi progetti open che in realtà non fanno altro che cercare di piazzarti sorgenti incomprensibili e datati ma sempre a pagamento.
In materia di software contabile l'offerta è ancora attestata sulle condizioni che si praticavano trent'anni fa.
Mandami un pm e ti posso indirizzare sulle poche soluzioni che conosco (dipende anche molto dalla zona e dal venditore, a Torino per il programma che uso io cercano a tutti i costi di convincere i clienti a passare alla versione linux, in campania ne negano l'esistenza, quello che usavo prima richiede l'acquisto di un loro server linux dalle mie parti) note, ma dipende molto da cosa intendi, una contabilità di magazzino/vendite "pura" esiste anche Open Source da molto tempo ma se devi fare contabilità gestionale vera e propria od analitica sono dolori di pancia e per la fiscale perdi semplicemente tempo (considera che in materia fiscale/lavoristica la necessità di aggiornamento ha cadenza reale di una settimana al massimo).
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
pask1970
n00b
n00b


Joined: 07 Dec 2003
Posts: 57
Location: Ischia

PostPosted: Sun Sep 27, 2009 6:23 pm    Post subject: Reply with quote

Io in Ufficio devo usare Windows... anche perchè non lavoro da solo, ed i miei colleghi sono allergici alle novità... Già non sopporterebbero di usare Openoffice o Firefox, figuriamoci 8O
Diciamo che Linux (anzi, Gentoo) è una passione, ho provato a più riprese a passare a distro più facili come Ubuntu (che odio cordialmente) o anche Arch Linux, ma alla fine son ritornato sempre a Gentoo. Sia pure con gioie e dolori.
Non mi sono mai, pertanto, posto il problema di cercare software gestionali compatibili con Linux :)
Tornando in topic, pare che il compilare il CONFIG_EVENT come modulo abbia funzionato... per chi non ha la pazienza di leggere i post precedenti ripeto che il problema ha iniziato a presentarsi anche con installazione x86... Se continua a fungere, metto il tag risolto e aggiorno il primo post con la soluzione :wink:
Ora però si è già appalesato un nuovo problema... una cosa completamente diversa... se non risolvo, apro un nuovo topic o continuo in questo?
Magari gli cambio il titolo e lo chiamo "i deliri di un commercialista" :lol:
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 687
Location: tra veneto e friuli (italy)

PostPosted: Sun Sep 27, 2009 7:04 pm    Post subject: Reply with quote

djinnZ wrote:
La domanda è troppo generica,

Putroppo (o per fortuna) non lo uso, quindi mi è difficile essere più specifico.

djinnZ wrote:
Mandami un pm e ti posso indirizzare sulle poche soluzioni che conosco

Provvedo, grazie.

djinnZ wrote:
ma se devi fare contabilità gestionale vera e propria od analitica sono dolori di pancia

Proprio l'analitica per l'attuale software è uno dei "moduli" che non vorrei acquistare, ma prima o poi ci dovremo attrezzare.

pask1970 wrote:
Io in Ufficio devo usare Windows... anche perchè non lavoro da solo, ed i miei colleghi sono allergici alle novità...

Sostanzialmente è la mia situazione e ti capisco :-(

pask1970 wrote:
apro un nuovo topic o continuo in questo?
Magari gli cambio il titolo e lo chiamo "i deliri di un commercialista" :lol:

Perchè deliri? Non stai mica proponendo di bandire i paradisi fiscali dopo averli usati a piene mani per anni :-D
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum