Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HPPA on 9000/819/K200 segfault with chroot /mnt/gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
bealpd
n00b
n00b


Joined: 15 Nov 2005
Posts: 2

PostPosted: Tue Nov 15, 2005 8:12 pm    Post subject: HPPA on 9000/819/K200 segfault with chroot /mnt/gentoo Reply with quote

Hello All,

I've decided to give the whole linux on a hppa another try. I did this prior with the old pateam, before any release existed for the HPPA architecture, but of course running linux then was a whole other story. Anyhow, I've pulled out my old K200, and was looking around for a distro to try on it. I tried the Debian CD's, but those wouldn't boot. Those failed with a Kernel Fault as soon as the MUX was initialized. I then tried the Gentoo Cd and it got further, but still got a little confused with the MUX also. So, I've removed the MUX card, and Gentoo boots like a dream! Ran a modprobe lasi_82596, and the ethernet card came right up without a hitch. I was able to partition the 2 disks, and extract the stage3 tarball, extract the portage and mount proc under /mnt/gentoo/proc, but then I ran into a problem.

During the setup where you are to enter the CHROOT enviroment through "chroot /mnt/gentoo /bin/bash" the command fails and just returns a simple "Segmentation Fault" I tried it without the /bin/bash, but same result. I can however just execute "chroot -help" and it returns the help info. It seems like I once found something about chroot and seg fault, but I don't remeber where it was now.

I downloaded the HPPA 2005.1 ISO image from http://gentoo.osuosl.org/releases/hppa/2005.1/installcd/, and I'm using the install-hppa-minimal-2005.1.iso image. I'm also using stage3-hppa2.0-2005.1.tar.bz2 from the same site, and the portaged http://gentoo.osuosl.org/snapshots/portage-20051114.tar.bz2. However, I dont think this is an issue with the stage3 or the portage, but the actual boot CD. I have not tried the universal CD as it is supposed to be the same as minimul plus a stage 3 tarball.

Anyone else seen this segmentation fault issue while trying to enter the chroot enviroment?

Thanks in Advance...
Back to top
View user's profile Send private message
bealpd
n00b
n00b


Joined: 15 Nov 2005
Posts: 2

PostPosted: Wed Nov 16, 2005 3:42 am    Post subject: Problem Fixed! Reply with quote

It looks as though the 9000/819/K200 system I am using doesn't like the hppa2.0 system, so I figured I'd try the hppa1.1 system. No segfault when I enter the chroot enviroment. On to the rest of the installation!
Back to top
View user's profile Send private message
HPRichard
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 94
Location: KA, Germany

PostPosted: Wed Nov 16, 2005 2:08 pm    Post subject: Reply with quote

The K200 sports a/multiple PA7200 CPU(s) which is/are only a 32bit capable (and hence are hppa1.1). hppa2.0 is only for PA8000 and above.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum