Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.6-love3 aka "Spice Must Flow"
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Sun May 16, 2004 3:57 pm    Post subject: 2.6.6-love3 aka "Spice Must Flow" Reply with quote

yay steel300 is back!, but he had to leave before he gets to announce this.
we have a little surprise for you ladies and gentlemen!
reiser4 is back!
and comes in 1 package with v30e!
the rest is just a surprise ;)
applies on top of vanilla.
http://www.public.iastate.edu/~jpcox/
(a side note, this is a bk-snapshot of reiser4 so it might have it's share of bugs. if you use reiser4 as a root you might wanna make backups first before trying this)

peace
Back to top
View user's profile Send private message
markfl
Apprentice
Apprentice


Joined: 10 Apr 2003
Posts: 240
Location: Kent, UK

PostPosted: Sun May 16, 2004 3:59 pm    Post subject: Reply with quote

suh-weeet !!! 8O

I can test reiser4 now

(yay first reply)

(yes i'm sad)

Mark
_________________
Life it seems, will fade away
Drifting further every day
Back to top
View user's profile Send private message
thoffmeyer
Apprentice
Apprentice


Joined: 11 Apr 2004
Posts: 208
Location: GMT -5 Hours

PostPosted: Sun May 16, 2004 4:01 pm    Post subject: Reply with quote

Awsome.. great job steel and same for you OneOfOne, now I can use the -love soruces again and drop OneOfOne's speedy sources which are very very nice.
_________________
Conrad Guide, Current Maintainer

Join us on IRC
Server: irc.freenode.net
Channel: #conrad
Back to top
View user's profile Send private message
Plastic
l33t
l33t


Joined: 24 Mar 2004
Posts: 649

PostPosted: Sun May 16, 2004 4:21 pm    Post subject: Reply with quote

This is definetly the best love patchset in a while! I love it!
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Sun May 16, 2004 4:57 pm    Post subject: Reply with quote

Very excited about this one but I get the same problem:
Code:
  CC [M]  arch/i386/mki-adapter26/mki-main.o
  CC [M]  arch/i386/mki-adapter26/mki26.o
arch/i386/mki-adapter26/mki26.c: In function `mkia_remove_page_ref':
arch/i386/mki-adapter26/mki26.c:1532: error: structure has no member named `counter'
make[1]: *** [arch/i386/mki-adapter26/mki26.o] Error 1
make: *** [arch/i386/mki-adapter26] Error 2


Any thoughts (apart from not having win4lin :D )

PS. @ thoffmeyer: What iconset is that in your screenshot? (Is it gant?)


Last edited by Pink on Sun May 16, 2004 5:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
CaribbeanKnight
Apprentice
Apprentice


Joined: 27 Apr 2003
Posts: 240
Location: Earth -> Europe -> Belgium -> Diest

PostPosted: Sun May 16, 2004 5:00 pm    Post subject: Reply with quote

compiled fine here on 3 of my machines...
quick status report ->
nvidia driver -> ok
vmware -> ok
reiser4 -> ok (for now... :) )

only 2 small comments:
1 - uname -r gives 2.6.6-mm3 instead of love3
2 - 4K stacks option appears twice in menuconfig

other than that, running fine here, so, great work steel, you really made my day!! :wink:
_________________
...we ain't shit...
Linux User #353893
Back to top
View user's profile Send private message
debstef
n00b
n00b


Joined: 09 Apr 2004
Posts: 4

PostPosted: Sun May 16, 2004 5:23 pm    Post subject: Reply with quote

- acpi in initrd is missing.
- bootsplash is missing.
- win4lin does not compile :cry:


but:
Reiser4 is finally in love :)
Back to top
View user's profile Send private message
Highlands
Guru
Guru


Joined: 22 Apr 2003
Posts: 366
Location: Sundsvall, Sweden

PostPosted: Sun May 16, 2004 5:28 pm    Post subject: Reply with quote

is nvidia working now?
_________________
If Windows is the answer, you don't understand the question!
http://counter.li.org/cgi-bin/certificate.cgi/339446
Back to top
View user's profile Send private message
CaribbeanKnight
Apprentice
Apprentice


Joined: 27 Apr 2003
Posts: 240
Location: Earth -> Europe -> Belgium -> Diest

PostPosted: Sun May 16, 2004 5:35 pm    Post subject: Reply with quote

oh, one more thing, i tried love-sources on my ppc machine and since compilation crashed horribly at lots of stuff i guess love-sources aren't 'ppc compatible' in this form, right..?
and would it be a lot of work to get love-sources going on ppc..? if there's anything i can do to help or something, i'd be happy to... :)
_________________
...we ain't shit...
Linux User #353893
Back to top
View user's profile Send private message
wdreinhart
Guru
Guru


Joined: 11 Jun 2003
Posts: 569
Location: 14SQB1124847710

PostPosted: Sun May 16, 2004 5:52 pm    Post subject: Re: 2.6.6-love3 aka "Spice Must Flow" Reply with quote

OneOfOne wrote:

reiser4


w00t!

Emerging now...
Back to top
View user's profile Send private message
steel300
Veteran
Veteran


Joined: 10 Jul 2003
Posts: 1155

PostPosted: Sun May 16, 2004 6:32 pm    Post subject: Reply with quote

2.6.6-love4 is out as well. Same place. I just fixed a few of my stupid mistakes. UDF packet writing compiles now. Bootsplash is back and working. And Win4Lin still won't compile. Sorry :-/

http://www.public.iastate.edu/~jpcox

EDIT: I forgot to tell you the name of this beast. It's Magical Mystery Hair. Inspired by Yanni. Anyone who has hair like that should be a magician.
_________________
Rationality is the recognition of the fact that nothing can alter the truth and nothing can take precedence over that act of perceiving it.
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Sun May 16, 2004 6:59 pm    Post subject: Reply with quote

steel300 wrote:
2.6.6-love4 is out as well. Same place. I just fixed a few of my stupid mistakes. UDF packet writing compiles now. Bootsplash is back and working.

And Win4Lin still won't compile. Sorry :-/


Oh well, time to go back to vmware then 'cos I ain't missing out on reiser4 and nick's scheduler :D

Great work again to both you and OneofOne.
Back to top
View user's profile Send private message
metalh34d
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 126

PostPosted: Sun May 16, 2004 7:26 pm    Post subject: Reply with quote

I used the latest ebuild file and my kernel doesn't have reiser4 support in it. =(
Back to top
View user's profile Send private message
Plastic
l33t
l33t


Joined: 24 Mar 2004
Posts: 649

PostPosted: Sun May 16, 2004 7:29 pm    Post subject: Reply with quote

Are alsa, acpi, vixie-cron, and syslog-ng working now? All of them broke in love3.
Back to top
View user's profile Send private message
hardcore
l33t
l33t


Joined: 01 Nov 2003
Posts: 626
Location: MSU, MI

PostPosted: Sun May 16, 2004 7:29 pm    Post subject: Reply with quote

Haven't been inspired to compile the last few love's, but this one caught my interest. The teething over bootsplash and other's seems to be over. Thanks OneOfOne and Steel!
Back to top
View user's profile Send private message
j-kidd
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 212

PostPosted: Sun May 16, 2004 8:03 pm    Post subject: Reply with quote

According to the mailing list, mki-adapter 1.3.5 is needed for Win4Lin to compile.

EDIT: well, 1.3.5 is identical to 1.3.4 :(
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1246
Location: C.C.A.A., Germania

PostPosted: Sun May 16, 2004 8:24 pm    Post subject: Reply with quote

Reiser4: Are any updated tools or alike necessary? If ebuilds are in portage, they haven't been updated since months...
Back to top
View user's profile Send private message
spb
Retired Dev
Retired Dev


Joined: 02 Jan 2004
Posts: 2135
Location: Cambridge, UK

PostPosted: Sun May 16, 2004 8:26 pm    Post subject: Reply with quote

Where did ACX100 go? It looks like I'm back to patching this by hand. :(
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1246
Location: C.C.A.A., Germania

PostPosted: Sun May 16, 2004 8:29 pm    Post subject: Reply with quote

btw,

could this patch be added? It makes gives usage stats, even if C1 is only power state:

Code:

cat /proc/acpi/processor/CPU0/power
active state:            C1
default state:           C1
bus master activity:     00000000
states:
   *C1:                  promotion[--] demotion[--] latency[000] usage[04076114]
    C2:                  <not supported>
    C3:                  <not supported>


Code:

--- linux-2.6.6/drivers/acpi/processor.c.org    2004-05-13 11:35:15.000000000 -0700
+++ linux-2.6.6/drivers/acpi/processor.c        2004-05-13 11:39:49.000000000 -0700
@@ -730,11 +732,12 @@ acpi_processor_get_power_info (
                return_VALUE(result);

        /*
-        * If this processor supports C2 or C3 we denote it as being 'power
+        * If this processor supports C1, C2 or C3 we denote it as being 'power
         * manageable'.  Note that there's really no policy involved for
         * when only C1 is supported.
         */
-       if (pr->power.states[ACPI_STATE_C2].valid
+       if (pr->power.states[ACPI_STATE_C1].valid
+               || pr->power.states[ACPI_STATE_C2].valid
                || pr->power.states[ACPI_STATE_C3].valid)
                pr->flags.power = 1;

@@ -2330,8 +2333,8 @@ acpi_processor_add (

        /*
         * Install the idle handler if processor power management is supported.
-        * Note that the default idle handler (default_idle) will be used on
-        * platforms that only support C1.
+        * Note that the acpi_processor_idle handler will be used on
+        * platforms that only support C1, just to keep the idle stats.
         */
        if ((pr->id == 0) && (pr->flags.power)) {
                pm_idle_save = pm_idle;

Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Sun May 16, 2004 8:29 pm    Post subject: Reply with quote

j-kidd wrote:
According to the mailing list, mki-adapter 1.3.5 is needed for Win4Lin to compile.

EDIT: well, 1.3.5 is identical to 1.3.4 :(


They are using the newer mki and the 2.6.6 patch. It is not a problem with the win4lin patches, it is a change made by mm2 on the 2.6.6 kernel that is causing the problems (specifically the page_count-fixups.patch). But mm is not designed to have win4lin running so I can't grumble too much, it's just that fixing it is beyond me. :D

/edit
Mind you, mm3 is now out, we'll see how it is with that one :?
Back to top
View user's profile Send private message
Plastic
l33t
l33t


Joined: 24 Mar 2004
Posts: 649

PostPosted: Sun May 16, 2004 8:38 pm    Post subject: Reply with quote

Any chance of getting swsusp2 into love? It would be really great, considering that I have to shut my PC down every night to sleep.
Back to top
View user's profile Send private message
ejohnson
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2004
Posts: 140

PostPosted: Sun May 16, 2004 9:57 pm    Post subject: Reply with quote

Right on!! Thanks OneOfOne, I'll give it a shot when I get home from work. (:
Back to top
View user's profile Send private message
HydroSan
l33t
l33t


Joined: 04 Mar 2004
Posts: 764
Location: The Kremlin (aka Canada)

PostPosted: Sun May 16, 2004 10:15 pm    Post subject: Reply with quote

*compile* Bootsplash is wai.
_________________
I was a Gangster for Capitalism, by Major General Smedley Butler.

Server status: Currently down, being replaced with fresh install - 20% completed.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Mon May 17, 2004 1:19 am    Post subject: Reply with quote

PrakashKC wrote:
Reiser4: Are any updated tools or alike necessary? If ebuilds are in portage, they haven't been updated since months...

Check out my ebuilds:
reiser4progs-0.5.4
libaal-0.5.1
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
ksuther
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2003
Posts: 86
Location: New York

PostPosted: Mon May 17, 2004 1:24 am    Post subject: Reply with quote

I got love4 to compile, but ati-drivers won't compile for me. It keeps failing with an error of:
Code:

make: Entering directory `/usr/src/linux-2.6.6-love4'
  CC [M]  /var/tmp/portage/ati-drivers-3.7.6-r1/work/lib/modules/fglrx/build_mod/agp3.o
  CC [M]  /var/tmp/portage/ati-drivers-3.7.6-r1/work/lib/modules/fglrx/build_mod/nvidia-agp.o
  CC [M]  /var/tmp/portage/ati-drivers-3.7.6-r1/work/lib/modules/fglrx/build_mod/agpgart_be.o
/var/tmp/portage/ati-drivers-3.7.6-r1/work/lib/modules/fglrx/build_mod/agpgart_be.c: In function `agp_generic_alloc_page':
/var/tmp/portage/ati-drivers-3.7.6-r1/work/lib/modules/fglrx/build_mod/agpgart_be.c:1405: error: structure has no member named `count'
make[1]: *** [/var/tmp/portage/ati-drivers-3.7.6-r1/work/lib/modules/fglrx/build_mod/agpgart_be.o] Error 1
make: *** [/var/tmp/portage/ati-drivers-3.7.6-r1/work/lib/modules/fglrx/build_mod] Error 2
make: Leaving directory `/usr/src/linux-2.6.6-love4'


Any ideas?

Also, bootsplash works on shutdown, but on startup it has the normal black framebuffer and then switches to the custom framebuffer at the end of boot. Is there something I need to do to get it working normally again?

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next
Page 1 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum