Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.13.2-nitro1 "Down with latency!'
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
seppe
Guru
Guru


Joined: 01 Sep 2003
Posts: 431
Location: Hove, Antwerp, Belgium

PostPosted: Tue Sep 20, 2005 3:16 pm    Post subject: 2.6.13.2-nitro1 "Down with latency!' Reply with quote

READ THIS FIRST: GENERAL
Nitro-sources is a patchset for the Linux kernel designed to improve desktop
performance and experience. Please note that nitro-sources *can* be unstable
and that neither me or the other nitro-sources developers are responsible
for breaking up your machine. ALWAYS keep a second, stable kernel image ready
in your boot manager! If something is broken while you run this release,
please retry with a clean vanilla kernel. Never bug the gentoo devs while
running this kernel, bug us instead in this thread ... although we can not
guarantee to fix your problems all the time.


READ THIS FIRST: RELEASE SPECIFIC
In the 'PATCH CONTENTS' section you can see what's new and what's updated. Please note that I haven't tested all the new stuff, but normally ... it should work. Please let me (and other viewers of this thread) know what works and what doesn't. I really wonder that the nitro-logo works since I haven't tested it. Let me know!


BASE
You have to apply this patch set to a clean 2.6.13.2 Linux kernel taken from
http://www.kernel.org


PATCH CONTENTS
Quote:

>> Filename: 01_2.6.13.2-ck5
>> Description: Various performance tweaks for the desktop by Con Kolivas
>> Author: Con Kolivas
>> Website: http://kernel.kolivas.org
>> UPDATED

>> Filename: 02_software-suspend-2.2-rc7
>> Description: Hibernate your machine
>> Author: Nigel Cunningham?
>> Website: http://www.suspend2.net
>> UPDATED

>> Filename: 03_vesafb-tng-0.9-rc7-r1-2.6.13-rc6
>> Description: Vesa framebuffer - The Next Generation
>> Author: Spock
>> Website: http://dev.gentoo.org/~spock/projects/vesafb-tng

>> Filename: 04_fbsplash-0.9.2-r4-2.6.13-rc6
>> Description: Gensplash/fbsplash, a bootsplash replacement for Gentoo
>> Author: Spock
>> Website: http://dev.gentoo.org/~spock/projects/gensplash

>> Filename: 05_reiser4_from_2.6.13-mm2
>> Description: Reiser4, a fast journalling filesystem under development
>> Author: Hans Reiser
>> Website: http://www.namesys.com

>> Filename: 06_squashfs2.2
>> Description: Squash File System
>> Author: Phillip Lougher
>> Website: http://squashfs.sourceforge.net

>> Filename: 07_daconfig-2.3.0
>> Description: Show kernelname in kernel menu's
>> Author: DaMouse
>> Website: http://kernel.damouse.co.uk
>> UPDATED

>> Filename: 08_config-nr-tty-devices
>> Description: config number of terminal devices
>> Author: unknown
>> Website: unknown

>> Filename: 09_tune_page_allocator
>> Description: Page allocator tuning patches from 2.6.13-mm3
>> Author: Andrew Morton
>> Website: http://www.kernel.org/pub/linux/kernel/people/akpm

>> Filename: 10_genetic_lib_and_genetic_as_sched
>> Description: Genetic lib + genetics for as io scheduler
>> Author: J. Moilanen
>> Website: http://kernel.jakem.net

>> Filename: 11_shfs-0.35
>> Description: SSH File System support
>> Author: Zemljanka core team
>> Website: http://shfs.sourceforge.net

>> Filename: 12_unionfs-1.0.13
>> Description: Unionfs stackable filesystem
>> Author: unknown
>> Website: http://www.fsl.cs.sunysb.edu/project-unionfs.html

>> Filename: 13_fix_PF_FREEZE_oops
>> Description: bugfix for missing PF_FREEZE in sched.h
>> Author: seppe
>> Website: unknown

>> Filename: 14_menucolors
>> Description: Give menuconfig pretty nitro colors ;)
>> Author: unknown, but I guess it was Tiger
>> Website: unknown

>> Filename: 15_chmp-r5-FULL
>> Description: Configurable Hid Mouse Polling
>> Author: Mikkel Krautz
>> Website: http://omfg.linux.dk/pub/configurable-hid-mouse-polling/

>> Filename: 16_win4lin3
>> Description: Kernel support for Win4Lin (Run Windows 9x on GNU/Linux)
>> Author: Netraverse
>> Website: http://www.netraverse.com

>> 17_nitro_sources_framebuffer_logo
>> Description: A nice nitro-sources logo for the framebuffer
>> Author: b3cks
>> Website: unknown

>> Filename: 18_Down_With_Latency
>> Description: Label this release "Down With Latency!"
>> Author: seppe
>> Website: http://sepi.be



DOWNLOAD AND LINKS
Ebuild
Patch set as bz2 file
Release notes
Broken-out directory


AMD 64 FIX (by bob_111)
1. Download this patch file
2. Apply the patch:
Code:

cd /usr/src/linux
patch -p1 < /path/to/fix_2.6.13.2-nitro1_amd64_oops

3. recompile ;)


ENJOY!
... and have a wonderful day!
_________________
nitro-sources, because between stable and experimental there exists only speed

Latest release I made: 2.6.13.2-nitro1


Last edited by seppe on Thu Sep 22, 2005 10:54 am; edited 6 times in total
Back to top
View user's profile Send private message
brot
Guru
Guru


Joined: 06 Apr 2004
Posts: 320

PostPosted: Tue Sep 20, 2005 3:43 pm    Post subject: ... Reply with quote

the ebuild has a wrong naming, but it is the right one :)

I am doing menuconfig atm... thank you very much...
Back to top
View user's profile Send private message
_sys/sid
Guru
Guru


Joined: 27 Aug 2004
Posts: 346
Location: Asola (Mantova)

PostPosted: Tue Sep 20, 2005 5:12 pm    Post subject: Reply with quote

Code:

  CC      drivers/video/logo/logo.o
drivers/video/logo/logo.c: In function `fb_find_logo':
drivers/video/logo/logo.c:84: error: `logo_nitro_clut224' undeclared (first use in this function)
drivers/video/logo/logo.c:84: error: (Each undeclared identifier is reported only once
drivers/video/logo/logo.c:84: error: for each function it appears in.)
make[3]: *** [drivers/video/logo/logo.o] Error 1
make[2]: *** [drivers/video/logo] Error 2
make[1]: *** [drivers/video] Error 2
make: *** [drivers] Error 2


:(
_________________
http://th30z.netsons.org/
Back to top
View user's profile Send private message
ClieX
n00b
n00b


Joined: 19 Jan 2005
Posts: 44
Location: Europe/Moscow

PostPosted: Tue Sep 20, 2005 6:44 pm    Post subject: Reply with quote

I compiled it, work is well! Thx.
_________________
Gentoo Base System version 1.6.13, Stage 1/3 with NPTL,UTF-8
GCC 3.4.4-r1, GLIBC 2.3.5-r1, 2.6.13.2-nitro1
GNOME 2.12
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Tue Sep 20, 2005 6:47 pm    Post subject: Reply with quote

Yeah it works well without the logo.

Code:

  CC      drivers/video/logo/logo.o
drivers/video/logo/logo.c: In function `fb_find_logo':
drivers/video/logo/logo.c:84: error: `logo_nitro_clut224' undeclared (first use in this function)
drivers/video/logo/logo.c:84: error: (Each undeclared identifier is reported only once
drivers/video/logo/logo.c:84: error: for each function it appears in.)
make[3]: *** [drivers/video/logo/logo.o] Error 1
make[2]: *** [drivers/video/logo] Error 2
make[1]: *** [drivers/video] Error 2
make: *** [drivers] Error 2


x2
Back to top
View user's profile Send private message
1U
Guru
Guru


Joined: 21 Jul 2005
Posts: 319

PostPosted: Tue Sep 20, 2005 7:34 pm    Post subject: Re: ... Reply with quote

brot wrote:
the ebuild has a wrong naming, but it is the right one.

I also noticed that. I renamed nitro-sources-2.6.13.1-r1.ebuild to nitro-sources-2.6.13.2-r1.ebuild and it seemed to be getting the new one. Is this correct or is there anything else I have to do?
Back to top
View user's profile Send private message
babykart
Guru
Guru


Joined: 08 Oct 2004
Posts: 415

PostPosted: Tue Sep 20, 2005 8:00 pm    Post subject: Reply with quote

works fine for me... :D
thx for the job... :wink:

but I can't see the Genetic lib + genetics for as io scheduler option... :(
_________________
>> Gentoo-FR <<
-----
Back to top
View user's profile Send private message
Zephyrus
Apprentice
Apprentice


Joined: 01 Sep 2004
Posts: 202

PostPosted: Tue Sep 20, 2005 8:22 pm    Post subject: Reply with quote

Thanks for the new release.

It works like a charm.


Last edited by Zephyrus on Tue Sep 20, 2005 9:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
brot
Guru
Guru


Joined: 06 Apr 2004
Posts: 320

PostPosted: Tue Sep 20, 2005 8:29 pm    Post subject: Reply with quote

babykart wrote:
works fine for me... :D
thx for the job... :wink:

but I can't see the Genetic lib + genetics for as io scheduler option... :(


First you have to enable the genetic library, which can be found in the Library Routines, and then, you only have to enable the genetic anticipatory under "Devices" -> "block devices" -> "IO Schedulers"..

Well done release, runs very smooth and stable here...
Back to top
View user's profile Send private message
wdreinhart
Guru
Guru


Joined: 11 Jun 2003
Posts: 569
Location: 14SQB1124847710

PostPosted: Tue Sep 20, 2005 9:10 pm    Post subject: Reply with quote

2.6.12-nitro4 contained a patch that added some sysctls for tuning scheduler parameters that made a big difference in the responsiveness of my machine. They didn't make it into the latest nitro. Anyone know where the broken-out patches for older -nitro releases have gone? I can't find them.

(edit)
...and no inotify? Forget this, I'm going back to 2.6.12-nitro4!
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2869
Location: Grenoble, France

PostPosted: Tue Sep 20, 2005 9:17 pm    Post subject: Reply with quote

wdreinhart wrote:

...and no inotify? Forget this, I'm going back to 2.6.12-nitro4!

Sure there is, have a better look!
Back to top
View user's profile Send private message
wdreinhart
Guru
Guru


Joined: 11 Jun 2003
Posts: 569
Location: 14SQB1124847710

PostPosted: Tue Sep 20, 2005 9:22 pm    Post subject: Reply with quote

kopp wrote:
wdreinhart wrote:

...and no inotify? Forget this, I'm going back to 2.6.12-nitro4!

Sure there is, have a better look!

Are you sure? It's not visible in menuconfig, and even though I reused my old .config with "CONFIG_INOTIFY=y" in it, /dev/inotify doesn't get created when I boot the new kernel.

(edit2)
Ok, disregard the inotify rant, somewhere between 2.6.12 w/ inotify-0.23 patch and 2.6.13, inotify lost it's device file and gained a sysctl interface. It's there and working, I just didn't STFW well enough.


Last edited by wdreinhart on Tue Sep 20, 2005 9:31 pm; edited 3 times in total
Back to top
View user's profile Send private message
vipernicus
Veteran
Veteran


Joined: 17 Jan 2005
Posts: 1462
Location: Your College IT Dept.

PostPosted: Tue Sep 20, 2005 9:23 pm    Post subject: Reply with quote

inotify is part of 2.6.13 now, no need to patch it.
_________________
Viper-Sources Maintainer || nesl247 Projects || vipernicus.org blog
Back to top
View user's profile Send private message
Cinder6
l33t
l33t


Joined: 05 Aug 2004
Posts: 767
Location: California

PostPosted: Tue Sep 20, 2005 10:55 pm    Post subject: Reply with quote

Woot for new nitro! Setting it up on my notebook now.
_________________
Knowledge is power.
Power corrupts.
Study hard.
Be evil.

Ugly Overload
Back to top
View user's profile Send private message
1U
Guru
Guru


Joined: 21 Jul 2005
Posts: 319

PostPosted: Wed Sep 21, 2005 12:22 am    Post subject: Reply with quote

From what I can tell, I don't see any difference between this one and the testing thread. I still get the same errors and nothing works, I can't even get past compiling nor does it have the mouse polling patch included like all the previous ones did. And also, what's with this being a .2 but the ebuild being a .1?
Back to top
View user's profile Send private message
babykart
Guru
Guru


Joined: 08 Oct 2004
Posts: 415

PostPosted: Wed Sep 21, 2005 12:36 am    Post subject: Reply with quote

brot wrote:
babykart wrote:
works fine for me... :D
thx for the job... :wink:

but I can't see the Genetic lib + genetics for as io scheduler option... :(


First you have to enable the genetic library, which can be found in the Library Routines, and then, you only have to enable the genetic anticipatory under "Devices" -> "block devices" -> "IO Schedulers"..

Well done release, runs very smooth and stable here...


thx for the support... :roll:
_________________
>> Gentoo-FR <<
-----
Back to top
View user's profile Send private message
Cinder6
l33t
l33t


Joined: 05 Aug 2004
Posts: 767
Location: California

PostPosted: Wed Sep 21, 2005 12:57 am    Post subject: Reply with quote

Dang, I got everyone's favorite error! /dev/hda3 is not a valid root block device!

I am recompiling now. This time, I decided to copy over my old config and just update it (got some weird results with oldconfig, as I always do).
_________________
Knowledge is power.
Power corrupts.
Study hard.
Be evil.

Ugly Overload


Last edited by Cinder6 on Wed Sep 21, 2005 1:03 am; edited 1 time in total
Back to top
View user's profile Send private message
babykart
Guru
Guru


Joined: 08 Oct 2004
Posts: 415

PostPosted: Wed Sep 21, 2005 1:03 am    Post subject: Reply with quote

Cinder6 wrote:
Dang, I got everyone's favorite error! /dev/hda3 is not a valid root block device!

your fs is ext3? (I'll not use ext3, never...)
_________________
>> Gentoo-FR <<
-----


Last edited by babykart on Wed Sep 21, 2005 1:05 am; edited 1 time in total
Back to top
View user's profile Send private message
Cinder6
l33t
l33t


Joined: 05 Aug 2004
Posts: 767
Location: California

PostPosted: Wed Sep 21, 2005 1:03 am    Post subject: Reply with quote

babykart wrote:
Cinder6 wrote:
Dang, I got everyone's favorite error! /dev/hda3 is not a valid root block device!

your fs is ext3?


No, reiser4.
_________________
Knowledge is power.
Power corrupts.
Study hard.
Be evil.

Ugly Overload
Back to top
View user's profile Send private message
babykart
Guru
Guru


Joined: 08 Oct 2004
Posts: 415

PostPosted: Wed Sep 21, 2005 1:06 am    Post subject: Reply with quote

:?
_________________
>> Gentoo-FR <<
-----
Back to top
View user's profile Send private message
Cinder6
l33t
l33t


Joined: 05 Aug 2004
Posts: 767
Location: California

PostPosted: Wed Sep 21, 2005 2:13 am    Post subject: Reply with quote

Heh, well, this post originally said that I got a panic when I tried to use a splashtheme, but it turns out that's because I put a / instead of a - on the kernel name, lol. Guess I should have paid more attention to the error message! All is working here! :)
_________________
Knowledge is power.
Power corrupts.
Study hard.
Be evil.

Ugly Overload
Back to top
View user's profile Send private message
RobbaZ
n00b
n00b


Joined: 18 Nov 2004
Posts: 63

PostPosted: Wed Sep 21, 2005 2:22 am    Post subject: Reply with quote

Everything works fine for me (excluding nitro-logo) on my P4 2.4ghz, 1,5gb ram with ext3 partitions.
My nvidia card has no problem with
Code:
media-video/nvidia-kernel-1.0.7667


:) thank you
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2869
Location: Grenoble, France

PostPosted: Wed Sep 21, 2005 6:47 am    Post subject: Reply with quote

Another error with the logo here :
Code:
 CC      drivers/video/logo/logo.o
drivers/video/logo/logo.c: In function `fb_find_logo':
drivers/video/logo/logo.c:84: erreur: « logo_nitro_clut224 » non déclaré (première utilisation dans cette fonction)
drivers/video/logo/logo.c:84: erreur: (Chaque identificateur non déclaré est rapporté une seule fois
drivers/video/logo/logo.c:84: erreur: pour chaque fonction dans laquelle il apparaît.)
make[3]: *** [drivers/video/logo/logo.o] Erreur 1
make[2]: *** [drivers/video/logo] Erreur 2
make[1]: *** [drivers/video] Erreur 2
make: *** [drivers] Erreur 2

It compile fines fine with logo disabled...
I have to rebuild it since oldconfig messed up everything, and i didn't pay to muich attention to what it did : no framebuffer for example....
Back to top
View user's profile Send private message
seppe
Guru
Guru


Joined: 01 Sep 2003
Posts: 431
Location: Hove, Antwerp, Belgium

PostPosted: Wed Sep 21, 2005 6:54 am    Post subject: Re: ... Reply with quote

1U wrote:
brot wrote:
the ebuild has a wrong naming, but it is the right one.

I also noticed that. I renamed nitro-sources-2.6.13.1-r1.ebuild to nitro-sources-2.6.13.2-r1.ebuild and it seemed to be getting the new one. Is this correct or is there anything else I have to do?

Nope, that's correct. I forgot to rename the ebuild, and I will rename it right now.

1U wrote:
From what I can tell, I don't see any difference between this one and the testing thread. I still get the same errors and nothing works, I can't even get past compiling nor does it have the mouse polling patch included like all the previous ones did. And also, what's with this being a .2 but the ebuild being a .1?

Could you be more specific? Like posting your error message for example? And configurable hid mouse polling patch *is* in this release.

Code:

  CC      drivers/video/logo/logo.o
drivers/video/logo/logo.c: In function `fb_find_logo':
drivers/video/logo/logo.c:84: error: `logo_nitro_clut224' undeclared (first use in this function)
drivers/video/logo/logo.c:84: error: (Each undeclared identifier is reported only once
drivers/video/logo/logo.c:84: error: for each function it appears in.)
make[3]: *** [drivers/video/logo/logo.o] Error 1
make[2]: *** [drivers/video/logo] Error 2
make[1]: *** [drivers/video] Error 2
make: *** [drivers] Error 2

I will look for it, but I can't promise anything because I don't have that much time today.
_________________
nitro-sources, because between stable and experimental there exists only speed

Latest release I made: 2.6.13.2-nitro1
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Wed Sep 21, 2005 8:30 am    Post subject: Reply with quote

hey something about you ebuilds in general: You should add RESTRICT="nomirror", becuase the patches are only on your server and not in portage mirrors. So they won't be checked for no use.
What do you mean?

Thanks

Phlogiston
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next
Page 1 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum