Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
p4p800 deluxe tips
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
smypee
n00b
n00b


Joined: 11 Oct 2003
Posts: 64
Location: Zurich

PostPosted: Sat Oct 11, 2003 8:25 am    Post subject: p4p800 deluxe tips Reply with quote

I read all of the posts here about problems installing gentoo on a computer with the p4p800 deluxe board. since I'm going to have one of these soon, I wondered what would be best to do now (now that I still have a working linux). I already compiled the nic driver from the asus page. can I put it on a livecd? should I already compile a kernel? put it where? I will also have a sata disk in that computer.

thanks for your advices
Back to top
View user's profile Send private message
Larynx
n00b
n00b


Joined: 06 Dec 2002
Posts: 11

PostPosted: Mon Oct 13, 2003 4:33 pm    Post subject: Reply with quote

If you want to install to your SATA disk without putting a PATA disk into your box - then you need a custom kernel.

I am using 2.4.22-bk33 with libata patch.
Currently im just trying to start my custom livecd in the box - a Dell Dimension 8300 with i875 chipset and ICH5 SATA controller.

If anyone interrested in details post here.
Back to top
View user's profile Send private message
smypee
n00b
n00b


Joined: 11 Oct 2003
Posts: 64
Location: Zurich

PostPosted: Tue Oct 14, 2003 6:00 am    Post subject: Reply with quote

so I have to use the libata patch. how did you put the customized kernel on a livecd? I have also the compiled nic module to put on the cd.
Back to top
View user's profile Send private message
subsnerd
n00b
n00b


Joined: 15 Oct 2003
Posts: 3

PostPosted: Wed Oct 15, 2003 9:48 am    Post subject: Reply with quote

Larynx wrote:
If you want to install to your SATA disk without putting a PATA disk into your box - then you need a custom kernel.

I am using 2.4.22-bk33 with libata patch.
Currently im just trying to start my custom livecd in the box - a Dell Dimension 8300 with i875 chipset and ICH5 SATA controller.

If anyone interrested in details post here.


I'm interested! Does your modded livecd work? I need to install on an intel 865g mboard with IHC5 SATA and I've get an SATA drive but no PATA drive available.

Thanks!
Back to top
View user's profile Send private message
Larynx
n00b
n00b


Joined: 06 Dec 2002
Posts: 11

PostPosted: Thu Oct 16, 2003 12:40 pm    Post subject: Reply with quote

My modded livecd works ! Yeah :) After a lot of fiddling around i finally got a working livecd.
I am posting this already from my new box.

For creating i used app-admin/livecd-ng.
By the way - great tool - tnx to DanBUK & Noltha

Important for ICH SATA to work:
Disable "Use DMA by default" in kernel.
The SATA drive gets mapped under /dev/sda if everything goes ok, when using the libata patch.
http://ftp.kernel.org/pub/linux/kernel/people/jgarzik/libata/2.4.22-bk32-libata1.patch.gz

First read:
https://forums.gentoo.org/viewtopic.php?t=95039

Then:
https://forums.gentoo.org/viewtopic.php?t=57754

For testing the iso vmware is great, just enter the path to the iso as the CD-ROM path.
It safed me a lot of CDs. And dont set the mem amount too low for the vm.
Back to top
View user's profile Send private message
Larynx
n00b
n00b


Joined: 06 Dec 2002
Posts: 11

PostPosted: Thu Oct 16, 2003 12:47 pm    Post subject: Reply with quote

subsnerd wrote:


I'm interested! Does your modded livecd work? I need to install on an intel 865g mboard with IHC5 SATA and I've get an SATA drive but no PATA drive available.

Thanks!


If you have some space somewhere i could upload the iso. Its about 250M.
Back to top
View user's profile Send private message
Truckle
n00b
n00b


Joined: 16 Oct 2003
Posts: 5

PostPosted: Thu Oct 16, 2003 7:16 pm    Post subject: Me too Reply with quote

I also have a p4p800 delux with a sata drive - So I'd like to give your livecd a try too :)

Perhaps you could DCC it to me over IRC and I could make it available for the others... you can catch me on irc.topgamers.net #topgamers

Only if someone else doesn't come up with a better idea ;)
Back to top
View user's profile Send private message
smypee
n00b
n00b


Joined: 11 Oct 2003
Posts: 64
Location: Zurich

PostPosted: Fri Oct 17, 2003 4:17 pm    Post subject: Reply with quote

sorry, I don't have 250mb space anywhere. but I'd be really interested in this livecd iso.
Back to top
View user's profile Send private message
NSpacer
n00b
n00b


Joined: 31 Mar 2003
Posts: 72
Location: Frisco, TX, USA

PostPosted: Fri Oct 17, 2003 7:12 pm    Post subject: What about... Reply with quote

What about putting this out on a P2P client?

It seems to me that this is kind of what they were designed for.

"Nudge, nudge. Know what I mean? Know what I mean? Say no more. Say no more."
Back to top
View user's profile Send private message
Redson
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2003
Posts: 137

PostPosted: Fri Oct 17, 2003 7:24 pm    Post subject: Re: What about... Reply with quote

NSpacer wrote:
What about putting this out on a P2P client?


Yeah, it seems like bittorrent would be perfect for this. Does anyone here have experience creating torrents?
_________________
Redson
http://watchred.com/
Back to top
View user's profile Send private message
Mambo
n00b
n00b


Joined: 18 Oct 2003
Posts: 12

PostPosted: Sat Oct 18, 2003 12:33 am    Post subject: Reply with quote

I could probably host it, if you are on efnet message me nick is just Mambo
Back to top
View user's profile Send private message
karl420
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2002
Posts: 142
Location: Nashville, TN, US

PostPosted: Mon Nov 10, 2003 8:33 am    Post subject: Reply with quote

I have a Western Digital Raptor 37gb SATA drive working with this motherboard (vanilla kernel, no libata patch, unless the ebuild does it automatically with the vanilla kernel, which i doubt). I've also got the onboard gigabit lan working recently. Not so much luck with the sound.

Please, if there is anything I can help you with, or you have some tips on getting the sound to work (where it doesn't sound scratchy, as with the intel alsa driver), drop me an email:

karlhaines@comcast.net

Thanks,
Karl Haines
Back to top
View user's profile Send private message
nitromullet
n00b
n00b


Joined: 27 Dec 2002
Posts: 19

PostPosted: Thu Dec 04, 2003 11:09 pm    Post subject: Reply with quote

I had issues with the LAN driver provided by ASUS not allowing me to access certain sites on the web (one of them being google.com). In doing some research, I found that I was not alone. I took care of the problem by installing an old 3com NIC I had laying around, but I was wondering if you also had problems with the NIC. I haven't tried the sound yet, since my Audigy works fine.

I really had a question about the SATA though... I run a dual boot system and want to run Windows XP from two Raptors in RAID 0, will the 2.4.22 vanilla kernel recognize the RAID array? I don't need to read/write to the XP (NTFS) partition, but I will need to install lilo on the MBR. I don't see the IHC5 listed as an option in the 2.4.22 kernel, and I an concerned that I won't be able to update my MBR after installing XP on the RAID array.
_________________
NitroMullet
Asus P4P800 Dlx
P4 2.6/800
BFG GeForce FX 5900
Back to top
View user's profile Send private message
karl420
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2002
Posts: 142
Location: Nashville, TN, US

PostPosted: Thu Dec 04, 2003 11:25 pm    Post subject: Reply with quote

I have actually had this SAME problem! And as a matter of fact, I fixed it in exactally the same way, put a 3com card in.

Really odd. The way that the problem occurs is exactally like an MTU problem, so I wonder if this shitty driver has some weird MTU stuff going on. Anyway, get a damn 3com from the closet, use it. This built-in NIC sucks.

Karl Haines
Back to top
View user's profile Send private message
nitromullet
n00b
n00b


Joined: 27 Dec 2002
Posts: 19

PostPosted: Fri Dec 05, 2003 5:39 am    Post subject: Reply with quote

It doesn't actually appear to be a problem with the hardware itself. If you run a dual boot system, you'll notice that it works fine under Windows. The problem appears to be driver related.

http://www.cs.helsinki.fi/linux/linux-kernel/2003-25/0023.html

Hopefully, this will get straightened out in the future.

I am going to try the advice in the last post of this thread:

http://www.hardwareanalysis.com/content/topic/13738/

The fact that it won't run at Gigabit speeds is irrelevant to me, since my router/hub is only 100 base-T anyway. It is more important to me to free up the pci slot and actually be able to use the hardware I paid extra for on the P4P800 Deluxe. Either way, I will follow up with a post of my success (or lack thereof).

I am still curious about your experiences with the Raptor as well... Did you have any problems with the kernel recognizing your SATA drives connected to the ICH5 controller? If not, what are the called /dev/hdx or are they recognized as /dev/sdx?
_________________
NitroMullet
Asus P4P800 Dlx
P4 2.6/800
BFG GeForce FX 5900
Back to top
View user's profile Send private message
nitromullet
n00b
n00b


Joined: 27 Dec 2002
Posts: 19

PostPosted: Fri Dec 05, 2003 6:02 am    Post subject: Reply with quote

Oh well... I recompiled my kernel after enabling the onboard LAN with the PCI NE2000 and ISA NE2000/NE1000 drivers as modules, added ne2k-pci and ne to my /etc/modules.autoload.d/kernel-2.4, but neither loaded after a reboot.
_________________
NitroMullet
Asus P4P800 Dlx
P4 2.6/800
BFG GeForce FX 5900
Back to top
View user's profile Send private message
brianhearn
n00b
n00b


Joined: 04 Nov 2003
Posts: 72

PostPosted: Sat Dec 06, 2003 12:27 pm    Post subject: Reply with quote

I got the onboard LAN working on my P4P800D using this driver http://www.syskonnect.de/syskonnect/support/driver/zip/linux/install-619.tar.bz2. I originally found a link to a prior release on these forums somewhere, but that link is dead now.

It was very easy to install. Run the install.sh script as root and add sk98lin to /etc/modules.autoload.d/kernel-2.4

Didn't need to recompile the kernel which was set up originally for a ne2k-pci module. I've had it working on both 2.4.20 & 2.4.22.

It doesn't suffer from the google problem. But I haven't got a clue if it works at the Gigabit speed because I've got nothing to test it with.
Back to top
View user's profile Send private message
nitromullet
n00b
n00b


Joined: 27 Dec 2002
Posts: 19

PostPosted: Tue Jan 13, 2004 5:53 am    Post subject: Reply with quote

I finally got the onboard 3c940 LAN working with the 2.6.1rc1 kernel driver by enabling the following as a module.

Device Drivers --->
[*] Networking support
Ethernet (1000 Mbit) --->
<M> Marvell Yukon Chipset / SysKonnect SK-98xx Support

and adding

sk98lin

to my

/etc/modules.autoload.d/kernel-2.6

took my old 3com card out, enabled the onboard LAN, and it works. I have gotten to every site I've tried.

I also have the ICH5 SATA RAID 0 driver working with two 37GB Raptors in a RAID 0 array. The kernel correctly recognizes my RAID array as /dev/sda. I have WinXP on that array, but I had to have the kernel recognize it to put the lilo bootloader on the MBR.

As far as the sound goes, my Audigy just plain sounds better than the onboard sound, so I'm sticking with the Audigy. This takes a bit more working with the 2.6 kernel, but there is a great thread at:
https://forums.gentoo.org/viewtopic.php?t=97157
I included support for the card in my kernel (no modules) and added the script in the thread to my default run level via /etc/init.d

I think that the 2.6 kernel is what the P4P800 Deluxe needed to really become a Linux usable board. Hats off to the kernel devs.

Cheers
_________________
NitroMullet
Asus P4P800 Dlx
P4 2.6/800
BFG GeForce FX 5900
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum