Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Genkernel for Linux 2.6?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
raid517
l33t
l33t


Joined: 06 Mar 2003
Posts: 946

PostPosted: Sun Aug 31, 2003 9:30 am    Post subject: Genkernel for Linux 2.6? Reply with quote

Ok well I know a lot of you guys hate genkernel. But I use genkernel --config which is pretty much the same as the old way of doing things, except instead of adding components, you simply remove what you don't want. Well anyway as a relative n00b I have found it very useful, as at least most of the time the kernels is suggests actually do compile - which is not always the case with those done by hand. On the whole, I'm all for saving time. Anyway, I was wondering if there was a version of Genkernel avaiable for the 2.6 kernel versions, or if maybe someone planned to write one. I know 2.6 is still in beta, but it's pretty advanced beta now and you can be almost certain that were going to see something final soon. (Within 8/12 weeks I heard). Anyhoo, I was wondering if there might be a beta version of genkernel for this beta kernel I could try? The reason I'm asking is because now that I used Genkernel on the old 2.4x kernels, it set up an initrd (whatever that might be) at boot time and it told be to install
hotplug so that all of my hardware would be recognised during boot.

Well to cut a long story short, since doing that I have not been able to compile kernels the old way - as the instructions for compiling the kernel with genkernel and using the traditional approach are somewhat different. I think whatever it was that Genkernel told me to set up is preventing any hand compiled kernels from booting.

I can easily point grub to my new kernel etc, but the traditional install instructions (and so far the only ones applicable to the 2.6 kernel) explicityly state that there should be no initrd line in Grub. So I simply opted to edit that out.

The end result is that any kernel now not compiled with Genkernel and the prerequisite initrd line do not appear able to boot. As soon as I use Genkernel and reintroduce the initrd line in grub, everything is fine again.

I'm sure this just displays my n00bness - and that it is entirely possible to manually create an initrd entry for the 2.6test4 kernel. But I'm afraid I don't know how to do that. In any case a genkernel version that can detect if you are using 2.4 or 2.6 kernel versions and configure itself accordingly would be very cool, especially for the many who are likely to make the switch to 2.6 as soon as it becomes officially avaiable.

In the mean time if any of you guys know how to get me out of this fix, and can help me compile my kernel so that it boots just like the one made with Genkernel (initrd, hotplug etc) your input and advice would be most welcome.

Thanks in advance.

Q
Back to top
View user's profile Send private message
raid517
l33t
l33t


Joined: 06 Mar 2003
Posts: 946

PostPosted: Sun Aug 31, 2003 10:55 am    Post subject: Reply with quote

Mmm... Well ok, just for the hell of it I decided to try genkernel on 2.6 anyway... And guess what? Yep, it worked flawlessly. Sure it did make dep, but when that didn't work it just carried on with make bzImage etc as normal.

Anyway, now I have a slightly different problem. My new kernel won't boot. All I get is a big nasty blank screen. I get into grub and the OS selection, I hit enter and zap, zilch, nothing.... If I wait a couple of minutes I can do ctrl, alt and delete to restart the computer, but that's it.

Here is my configuration files. They are all as far as I can tell accurate. Since I have 3 partitions on my second disc /hdb1 boot /hdb2 swap and hdb3 /root.

Code:
grub.conf

default 0
timeout 30
splashimage=(hd1,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux
root (hd1,0)
kernel (hd1,0)/boot/kernel-2.6.0-test4 root=/dev/discs/disc1/part3 vga=791
initrd (hd1,0)/boot/initrd-2.6.0-test4
# non linux partition
title=Windows
root (hd0,0)
chainloader (hd0,0)+1


Code:
fstab

# /etc/fstab: static file system information.
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.12 2003/03/11 02:50:53 azarah Exp $
#
# noatime turns of atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail and tail freely.

# <fs>             <mountpoint>    <type>     <opts>            <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/discs/disc1/part1   /boot      ext3      noauto,noatime      1 1
/dev/discs/disc1/part3   /      ext3      noatime         0 0
/dev/discs/disc1/part2   none      swap      sw         0 0
/dev/cdroms/cdrom0   /mnt/cdrom   iso9660      noauto,ro      0 0

# NOTE: The next line is critical for boot!
none         /proc      proc      defaults      0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
# Adding the following line to /etc/fstab should take care of this:

none         /dev/shm   tmpfs      defaults      0 0


So as you can probably see that at least eliminates all of the standard causes.

So if anyone has any ideas or suggestions at all, or might have some small hunts on how this might be resolved, please, please let me know. The future is the 2.6 kernel - and if it doesn't work on my system as far as staying with Linux goes (which is what I very much want to do) I'm pretty much screwed.

If this is a kernel bug, who exactly do I report it to?

Thanks in advance.

Q

PS

Just to be clear, and so noone thinks I'm not trying, I did compile a kernel the normal way too. But I still got the same blank screen. So for thos who don't like genkernel and might be inclined to blame it, that isn't the case, as I still get the same blank screen with or without genkernel. I hope this helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum