Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Desperate About Fuzzy Fonts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Tue Aug 19, 2003 10:03 pm    Post subject: Desperate About Fuzzy Fonts Reply with quote

I am new to linux, and I would really like it to work for me, but one issue is a killer. Why do I have "fuzzy" fonts? How do I get rid of them?

I am using gnome. The fonts in gnome, openoffice, firebird, and fuzzy enough to make me scream. I hooked the monitor up to a windows box, and the windows fonts look much better. There must be some way to fix this.

I have put enough time into getting gentoo up, and initial issues resolved that I am quite willing to spend hours getting the fonts right, if that's what it takes.
Back to top
View user's profile Send private message
devon
l33t
l33t


Joined: 23 Jun 2003
Posts: 943

PostPosted: Tue Aug 19, 2003 10:52 pm    Post subject: Reply with quote

I think you want to look into setting up Anti-Aliasing (AA) for your fonts. :) I personally use KDE and when I did that, my fonts looked a lot better. I would do a forum search.
Back to top
View user's profile Send private message
searcher
Apprentice
Apprentice


Joined: 13 Mar 2003
Posts: 175
Location: NL

PostPosted: Tue Aug 19, 2003 11:45 pm    Post subject: Reply with quote

Or you may want to look into disabling the AA for fonts below a certain size. Over-antialiasing causes fonts to go blurry. Follow the advice and search the forum. There are loads of topics about this.

~searcher
_________________
You are unique ... just like everyone else.
Back to top
View user's profile Send private message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Wed Aug 20, 2003 12:25 am    Post subject: Reply with quote

I tried some of the things mentioned in various posts. What a rat's nest of advice! The installation instructions tell newbies like me to use xft. Some posts say that that is obsolete. A good deal of the advice given seems obsolete, but I'm too new to know for sure. If there is a consensus on how to get reasonable looking fonts, I missed it.

There does seem to be a consensus that linux fonts are generally lousy looking and a problem. A few people claim to have fonts that look better than in windows xp. (A few of those people's screenshots look as fuzzy as my display does.) I read one post that said that everything was fine in Red Hat.
Back to top
View user's profile Send private message
Arker
Apprentice
Apprentice


Joined: 10 Sep 2002
Posts: 205

PostPosted: Wed Aug 20, 2003 12:41 am    Post subject: Reply with quote

Do you have a screenshot of your fuzzy fonts? Or even a screenshot of someone elses where the fonts look as fuzzy as yours? I could be that the normal Gnome anti-aliased fonts look too fuzzy to you coming from Windows.

Basically, it may be that there is nothing wrong at all. I realize that you still don't like the fonts as they are, but we may be able to help you better if we know if there is something wrong with your install or if your fonts just need some adjusting.

It could be simply a matter of changing the settings in gnome-font-properties. That may make a bit of difference.

Good luck,
~arker
Back to top
View user's profile Send private message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Wed Aug 20, 2003 12:54 am    Post subject: Reply with quote

How do I turn off anti-aliasing? I have tried setting it to "none" in gnome with the GConf editor (after reading a post that aliasing was a global flag in gnome), but it seems to reset itself. Is it an application by application thing?
Back to top
View user's profile Send private message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Wed Aug 20, 2003 12:58 am    Post subject: Reply with quote

Arker:

Thanks for the response. Tell me how to make a screenshot, and I'll do the best I can to post one! If this is the way the fonts usually look, I can at least surrender!
Back to top
View user's profile Send private message
searcher
Apprentice
Apprentice


Joined: 13 Mar 2003
Posts: 175
Location: NL

PostPosted: Wed Aug 20, 2003 1:43 am    Post subject: Reply with quote

Fonts can be a tricky business. As far as i know there are 2 ways of getting fonts into XFree86

1. You specify a fontdir in /etc/X11/XF86Config. There should be a few sample entries in there already. Font directories should be placed in /usr/X11R6/lib/X11/fonts. When you install a new font directory make sure you run fc-cache -fv as root. This will create a new font list with (hopefully) the new font dir you added. Type fc-list as user to see which fonts are available.

2. Xft. I love this. It's my favorite. It takes all the weird stuff out of my hands. No trouble. Just add a dir to fonts.local and run the server. It will even allow you to build a dedicated font server, so everyone can use the same fonts. The desktop guide in the docs section has some useful tips on how to set it up. Xft will also greatly improve configurability of seperate functions such as AA and subpixel hinting.

Also, make sure your freetype lib is up to date. For comparison, this is my gnome desktop with a few fonts. Doesn't look like much yet, but i just installed it today. The fonts you see are rendered by gnome and XFree86 self (to be honest, it's in slack, installed on my 2nd harddrive ;)). No Xft is used.

Try looking on google and the forum if you need some extra help on the above items. Or just post back.

good luck,
~searcher

*edit* in the gnome menu bar, under "actions" you will find "screenshot". Just click it and gnome will take a screenshot for you. Or you could use the gimp. Works either way.
_________________
You are unique ... just like everyone else.
Back to top
View user's profile Send private message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Wed Aug 20, 2003 11:46 am    Post subject: Reply with quote

searcher wrote:

1. You specify a fontdir in /etc/X11/XF86Config. There should be a few sample entries in there already. Font directories should be placed in /usr/X11R6/lib/X11/fonts. When you install a new font directory make sure you run fc-cache -fv as root. This will create a new font list with (hopefully) the new font dir you added. Type fc-list as user to see which fonts are available.


I uncommented all the font directories in the config file and made all the entries match the actual directories - no change. I have not run the fc-cache command. I'll give that a try.

The plan for the morning is try sort of the reverse. I am going to eliminate all but the truetype directory, fill the truetype directory with fonts, and see whether that helps. I'd also like to turn off anti-aliasing, but the only way I can see to do this is through the font setting gnome. If that's it, it hasn't helped much. (I did manage at one point to give the fonts an horrible rainbow cast.)

searcher wrote:

2. Xft. I love this. It's my favorite. It takes all the weird stuff out of my hands. No trouble. Just add a dir to fonts.local and run the server. It will even allow you to build a dedicated font server, so everyone can use the same fonts. The desktop guide in the docs section has some useful tips on how to set it up. Xft will also greatly improve configurability of seperate functions such as AA and subpixel hinting.


I think my brain has become pulp. I cannot find anything about xft in the desktop guide. xfs, yes. xft, no. I have read several posts saying to forget about xfs and use xft, but I don't know whether I am supposed to remove xfs - or how - or how to use xft. Does it have another name?

searcher wrote:
Also, make sure your freetype lib is up to date.


Did this as one of my first steps. Thanks for the instruction.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7697
Location: Pelotas, BR

PostPosted: Wed Aug 20, 2003 1:19 pm    Post subject: Reply with quote

moved to DE, thanks devon
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
pluto
n00b
n00b


Joined: 06 Feb 2003
Posts: 22
Location: Cracow, PL

PostPosted: Wed Aug 20, 2003 2:24 pm    Post subject: Reply with quote

vbenares wrote:
searcher wrote:

1. You specify a fontdir in /etc/X11/XF86Config. There should be a few sample entries in there already. Font directories should be placed in /usr/X11R6/lib/X11/fonts. When you install a new font directory make sure you run fc-cache -fv as root. This will create a new font list with (hopefully) the new font dir you added. Type fc-list as user to see which fonts are available.


I uncommented all the font directories in the config file and made all the entries match the actual directories - no change. I have not run the fc-cache command. I'll give that a try.


1). modify your /etc/fonts/fonts.conf (add path to truetype fonts)
Code:

<!-- Font directory list configured on  -->
(...)
        <dir>/usr/X11R6/lib/X11/fonts/TTF</dir>
        <dir>/usr/X11R6/lib/X11/fonts/truetype</dir>
(...)

2). run mkfontscale and mkfontdir in these ^^^ dirs.
3). run fc-cache
4). and finally create:

Code:
[pluto@vmx]-[~] # cat .xftconfig
match any size > 1 any size < 20 edit antialias = false;


Code:
[pluto@vmx]-[~] # cat .fonts.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <test compare="more" name="size" qual="any" >
   <double>1</double>
  </test>
  <test compare="less" name="size" qual="any" >
   <double>20</double>
  </test>
  <edit mode="assign" name="antialias" >
   <bool>false</bool>
  </edit>
 </match>
</fontconfig>
Back to top
View user's profile Send private message
Arker
Apprentice
Apprentice


Joined: 10 Sep 2002
Posts: 205

PostPosted: Wed Aug 20, 2003 2:31 pm    Post subject: Reply with quote

vbenares wrote:
Tell me how to make a screenshot, and I'll do the best I can to post one!


Is there not a "Screenshot" option in the Gnome foot menu?

If not, then you can right click on your panel, choose Add to Panel->Button->Screenshot, click the new button and follow the dialog.

Or you should be able to press PrintScrn to shoot the whole desktop, Alt-PrintScrn for just the selected window.

Or you can type "gnome-panel-screenshot" in a console to shoot the entire desktop, "gnome-panel-screenshot --window" for just the focused window.

There are many other ways to do this, but these are the ways I can think of to use the Gnome screenshot tool which I assume you have installed by default.

Good luck,

~arker
Back to top
View user's profile Send private message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Wed Aug 20, 2003 3:31 pm    Post subject: Reply with quote

New plan: follow pluto's advice. (Arker, there is indeed a screenshot utility in the menu, I just missed it. When I am done trying to do what pluto says, I will post a screenshot.)

pluto, where do .xftconfig and .fonts.conf go in /root? i.e. are they /root/.xftconfig and /root/.fonts.conf/ ?

BTW, despite all the posts about Firebird fonts being horrible, mine are fine. My problem seems to be everything else, i.e. gnome and ooffice.

Thanks for the help.
Back to top
View user's profile Send private message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Wed Aug 20, 2003 4:01 pm    Post subject: Reply with quote

Hooray! My gnome fonts look MUCH MUCH better! Great in fact.

I copied a bunch of TT fonts from another machine and put them in /usr/X11R6/lib/X11/fonts/TTF and added the directories - as listed by pluto - to /etc/fonts/fonts.conf (where they were formerly not listed.) Ran the commands suggested by Pluto. Changed the fonts in gnome to Arial.

BTW the /etc/fonts/fonts.conf warns against changing it directly - I didn't pay attention to the warning - should I have?

I would still like to make the alias adjustments to .xftconfig and .fonts.conf, if someone could tell me where those files go.

BUT, my openoffice fonts are still horrible, horrible, horrible. In fact, now that gnome looks better, openoffice looks worse in comparison.
Back to top
View user's profile Send private message
pluto
n00b
n00b


Joined: 06 Feb 2003
Posts: 22
Location: Cracow, PL

PostPosted: Wed Aug 20, 2003 4:44 pm    Post subject: Reply with quote

vbenares wrote:
pluto, where do .xftconfig and .fonts.conf go in /root? i.e. are they /root/.xftconfig and /root/.fonts.conf/ ?

in your ~ (home) directory :)
Back to top
View user's profile Send private message
pluto
n00b
n00b


Joined: 06 Feb 2003
Posts: 22
Location: Cracow, PL

PostPosted: Wed Aug 20, 2003 4:53 pm    Post subject: Reply with quote

vbenares wrote:
BUT, my openoffice fonts are still horrible, horrible, horrible. In fact, now that gnome looks better, openoffice looks worse in comparison.

1). Tools -> Options -> OpenOffice.org -> View -> "Screen font antialiasing" -> 0
2). Tools -> Options -> OpenOffice.org -> Accessibilty -> "Use system font for user interface" -> 1
Back to top
View user's profile Send private message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Wed Aug 20, 2003 6:14 pm    Post subject: Reply with quote

pluto you are a frigging GENIUS! Thank you so much. Everything looks absolutely perfect!

I cannot tell you how grateful I am to all of you (and how glad I am that I asked!) I was on the point of throwing all the whole thing (and the three days of work) away as unusable.

Thank you all very much.

pluto wrote:
2). Tools -> Options -> OpenOffice.org -> Accessibilty -> "Use system font for user interface" -> 1


I don't have this setting for some reason. But, everything - program and document window - look great without it.

(Now on to figuring out how to get my mouse wheel to work . . . )
Back to top
View user's profile Send private message
jatf
n00b
n00b


Joined: 05 Feb 2003
Posts: 72

PostPosted: Wed Aug 20, 2003 7:22 pm    Post subject: Reply with quote

I also followed pluto's advice and am very pleased with the results. Is there a document that specifies this that we n00b's just overlooked, or can this thread be posted to 'Tricks and Tips' so others can find it easily? I just stumbled on it, but it should definately make it into the 'official' HOWTO.
_________________
--JATF

Adopt an unanswered post HERE
Back to top
View user's profile Send private message
pluto
n00b
n00b


Joined: 06 Feb 2003
Posts: 22
Location: Cracow, PL

PostPosted: Fri Aug 22, 2003 6:48 pm    Post subject: Reply with quote

vbenares wrote:
Everything looks absolutely perfect!

absolutely perfect : http://149.156.124.14/~pluto/tmp/oo_01.png :)
Back to top
View user's profile Send private message
vbenares
Apprentice
Apprentice


Joined: 13 Aug 2003
Posts: 205

PostPosted: Fri Aug 29, 2003 3:58 pm    Post subject: Reply with quote

Here's some more information from Bug 27013:
Quote:
------- Additional Comment #4 From Kerin Millar 2003-08-28 10:49 EST -------

Re: Comment #3. No, xfs (and the various font modules which can be loaded such as
freetype, type1 and speedo) are all for core X font support. Fontconfig/Xft is the
new way of things, and is used by all qt/gtk2 apps as well as some others such as
mozilla. XF86Config has no bearing on fontconfig/xft functionality whatsoever.

Even for "old world" apps, I do nothing further than to ensure the following two
lines are in the appropriate places in XF86Config:

FontPath "/usr/X11R6/lib/X11/fonts/truetype/"
Load "freetype"

That way, at least the stock truetype fonts supplied by Gentoo's xfree ebuild are
available to non-gtk2/qt apps (run xfontsel to observe what X "sees" in terms of
this level of font support). I do not see *any* use for the xfs font server whatsoever
for most folks, and AFAIK there are no advantages over using the aforementioned modules.

As for fontconfig/Xft, the trick is to slightly modify /etc/fonts/fonts.conf (or
perhaps more correctly, local.conf) and to run fc-cache -f when there are any changes.
One of the best hacks I know of at present is simply to remove these lines from fonts.conf:

<dir>/usr/X11R6/lib/X11/fonts/75dpi</dir>
<dir>/usr/X11R6/lib/X11/fonts/100dpi</dir>

Those are stock X fonts which are scaleable bitmap Type1 fonts. That is, they only
have the proper definition at specific point sizes and, to be honest, truetype fonts
tend to render a lot better anyway. So, they are naff fonts and it is better to have
fontconfig/Xft ignore them. By doing this, the rendering of fonts addressed by the
name "sans" and "serif" will improve vastly (including the default configuration
of the Gnome desktop). Also, because the 75dpi/100dpi font collection includes fonts
such as Helvetica, a lot of web browsers will tend to use them _in preference_ to
far better looking fonts you may have. Just try removing those lines then visiting,
say, www.redhat.com or www.debian.org to see an instant difference.

There are a few other tricks too. For example, in the above case where Helvetica
isn't found, fontconfig/xft will substitute another font. Have a look at the <alias>
sections in fonts.conf. My opinion is that, say:

<alias>
<family>Bitstream Vera Serif</family>
<family>Times</family>
<family>Times New Roman</family>

should be:

<alias>
<family>Bitstream Vera Serif</family>
<family>Times New Roman</family>
<family>Times</family>

Because Times New Roman is a much more sensible choice for a serif font (Times looks
terrible). IMPORTANT: fonts are never substituted unless the preferred font is unavailable
which is why I recommend the removal of the 75dpi/100dpi dirs! Also, you wouldn't
want Bitstream at the top if you didn't have a preference for it. Of course, this
doesn't matter in the case of apps where you can explicitly set fonts, but the fact
is a lot of apps reference fonts by generic names such as "serif" and "sans-serif"
so this is quite important and the improvment in display quality (especially in a
default setup) is immediately palpable.

The other big issue is anti-aliased fonts. Great, but people fall into two categories
(whether they know it or not) (1) Those who don't like anti-aliased fonts displays
<= 15pt size (give or take) (2) Those who do like fonts anti-aliased regardless of
the size. There is no point stipulating on what is best, but I know that there are
many people who prefer situation (1) which is similar to the way Windows handles
things (I recall someone saying "thanks, now my fonts won't make me go blind!" when
I outlined how to do this on a now out-of-date forum thread). The thing is, fonts
rendered at low sizes just look fuzzy with anti-aliasing and it's not to everyone's
taste. Of course, fontconfig allows this to be easily rectified if desired too. Not
to mention that there are performance advantages :) See: https://forums.gentoo.org/viewtopic.php?p=187462


I can understand why one would be reticent to say "this is what you do to get good
fonts", but my opinion is that:

* This stuff needs to be better documented (it really isn't that complicated)
* I do think fonts.conf should be patched with those very minor tweaks
* In fact, maybe we could have a `font-config` binary? At least, some way to bring
these reasonably trivial issues to within the user's grasp without having to get
their hands dirty.
* Maybe fc-cache should maybe be run as part of the X startup script (that would
probably negate a lot of the forum posts I've see in that past ;-)

My 0.02p ...



And here's the link to the poster's fonts.conf file: https://bugs.gentoo.org/attachment.cgi?id=16747&action=view
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5350
Location: France, Old Europe

PostPosted: Fri Oct 24, 2003 12:16 pm    Post subject: Reply with quote

Quote:
in your ~ (home) directory


So I guess you you need to copy that across each time you add a non-root user as well.

Thanks to pluto (and others ) for the insider knowlege there.

I can't believe you need to get this technical just to get a decent display, it's madness. I seem to recall that the last time I tried RH Gnome looked perfect.

Surely this sort of thing should be set up in the distribution?

A lot of the hard work involved in setting up Gentoo is worthwhile in getting to know how Linux is pout together, but this is just daft.

Thanks again to pluto for the tips/
Back to top
View user's profile Send private message
Merlin-TC
l33t
l33t


Joined: 16 May 2003
Posts: 603
Location: Germany

PostPosted: Fri Oct 24, 2003 5:48 pm    Post subject: Reply with quote

Thank you soooo much Pluto.
You cannot imagine how much these font problems bugged me.
This was kinda the only problem I had left in my gentoo system.

This should really be part of an FAQ.
It especially helps KDE usere who run GTK2 apps under KDE.

Thanks again man, I owe you :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum