Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Simple Question: GDM for fluxbox
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ShadyMilkman
n00b
n00b


Joined: 20 Apr 2002
Posts: 57

PostPosted: Thu Jul 04, 2002 12:08 am    Post subject: Simple Question: GDM for fluxbox Reply with quote

Well I know pretty much how to do this, but I have some questions:

1) I really want to use GDM ( after seeing this: http://www.lucidus.uklinux.net/gdm/screenshot-800x600.png )

Can I get GDM w/o emerging Gnome? (I'm not at my home computer right now but I seem to remember kdm being integrated into the kde ebuild and there being no seperate one).

2) Well... I'll probly be able to figure this out after I get it, but to save me some time... How do I get it to use fluxbox?
Back to top
View user's profile Send private message
turbonium
n00b
n00b


Joined: 04 Jul 2002
Posts: 4

PostPosted: Thu Jul 04, 2002 2:58 am    Post subject: Glad you asked. . . Reply with quote

Just did this myself today. . . not quite straightforward as one would think. . .

1. Emerge xdm & gdm
2. rc-update add xdm default (yes, xdm is correct here!)
3. Modify /etc/rc.conf, uncomment DISPLAYMANAGER, and change to gdm

***FILE START***
# What display manager do you use ? [ xdm | gdm | kdm ]
DISPLAYMANAGER=gdm
***FILE END***

4. Modify /etc/X11/Sessions/fluxbox. Thanks to MarkG for the pointer here!
https://forums.gentoo.org/viewtopic.php?t=2414&highlight=xsession
This is blank. . . I had some problems with the way MarkG handled his, so I took out a lot of his code (I use tcsh as my shell). GDM will ignore ~home/.xinitrc (startx uses this file however).

***FILE START***
#!/bin/sh

startup=$HOME/.xsession

#xsession
if [ -f "$startup" ]; then
if [ -x "$startup" ]; then
source "$startup" &
else
source /bin/sh "$startup" &
fi
fi

# And finally we'll start fluxbox,
/usr/bin/fluxbox
***FILE END***

5. Modify ~home/.xsession to run whatever apps you want launched with fluxbox. Here's a copy of mine. . .

***FILE START***
xscreensaver &
gkrellm -w &
***FILE END***

6. That's it! Reboot and log in. Don't forget to set fluxbox as your default windows manager for subsequent logins. . .You can configure how GDM looks by clicking on the System button at the bottom of the GDM login screen and select configure. You'll need to know root's password.
Back to top
View user's profile Send private message
kachaffeous
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jun 2002
Posts: 86

PostPosted: Fri Jul 05, 2002 1:44 pm    Post subject: Reply with quote

Quote:
Can I get GDM w/o emerging Gnome?


Don't think it can be done. I wanted to do this myself. To get gdm you need all the GNOME dependencies. So you can emerge gnome and just not use it, use xdm, or use startx.

https://forums.gentoo.org/viewtopic.php?t=5903&postdays=0&postorder=asc&start=25[/quote]

Spider answered my post under this forum.
Back to top
View user's profile Send private message
Martin
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2002
Posts: 96
Location: Vancouver, Canada

PostPosted: Fri Jul 05, 2002 2:16 pm    Post subject: Reply with quote

Do
Code:
emerge --pretend gdm
and see that although there's a lot of it, there's a lot less than
Code:
emerge --pretend gnome
.

:D
Back to top
View user's profile Send private message
Martin
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2002
Posts: 96
Location: Vancouver, Canada

PostPosted: Fri Jul 05, 2002 2:49 pm    Post subject: Reply with quote

turbonium, I tried to follow your method but ran into some problems.

I rebooted and was loaded into GDM, but after logging it I was presented with the following error:

Quote:
Could not find the GNOME installation, will try running the "Failsafe xterm" session.


Any ideas?

Thanks in advance.
Back to top
View user's profile Send private message
turbonium
n00b
n00b


Joined: 04 Jul 2002
Posts: 4

PostPosted: Fri Jul 05, 2002 4:00 pm    Post subject: Reply with quote

Once you have the GDM login screen, don't just log in. :)

You need to select Fluxbox as your session choice. Otherwise, I think it tries to default to gnome (which isn't installed).
Back to top
View user's profile Send private message
ShadyMilkman
n00b
n00b


Joined: 20 Apr 2002
Posts: 57

PostPosted: Fri Jul 05, 2002 5:58 pm    Post subject: Thanks! Reply with quote

Hey I got it working. I alread had all of the gnome-libs (?) so an emerge -p gdm yielded only "gdm" and compiled in a minute or so. It's awesome... although I wish you could configure the graphical greeter the same way you can to the standard... oh well.
Back to top
View user's profile Send private message
Martin
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2002
Posts: 96
Location: Vancouver, Canada

PostPosted: Fri Jul 05, 2002 6:39 pm    Post subject: Reply with quote

turbonium wrote:
Once you have the GDM login screen, don't just log in. :)

You need to select Fluxbox as your session choice. Otherwise, I think it tries to default to gnome (which isn't installed).

Doh! There's my problem... it's not in the menu. (Theres last, xsession, failsafe Gnome and xterm)

Should I be picking XSession, or should there be an option for Flux?

Thanks again for your patience. :D


Last edited by Martin on Fri Jul 05, 2002 6:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
echu
n00b
n00b


Joined: 19 Apr 2002
Posts: 37
Location: Houston, TX

PostPosted: Fri Jul 05, 2002 6:49 pm    Post subject: Reply with quote

Create a file called /etc/X11/Sessions/fluxbox

Inside the file, have whatever you want executed, i.e.:

Code:
xscreensaver &
gkrellm -w &
/usr/bin/fluxbox


also, try running gdmsetup, which gives you a gui config tool for gdm. That should be able to address what you're looking for.
Back to top
View user's profile Send private message
Martin
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2002
Posts: 96
Location: Vancouver, Canada

PostPosted: Fri Jul 05, 2002 8:07 pm    Post subject: Reply with quote

Thanks for the feedback echu.
echu wrote:
Create a file called /etc/X11/Sessions/fluxbox

Inside the file, have whatever you want executed, i.e.:

Code:
xscreensaver &
gkrellm -w &
/usr/bin/fluxbox


Yep - I got that file exactly like above.

Quote:
also, try running gdmsetup, which gives you a gui config tool for gdm. That should be able to address what you're looking for.

What exactly am I looking for?

I seem to be messing something up here.. GDM loads okay, but flux doesn't after a login.

For those that have it working - what session WM do you have chosen? Do I need to somehow add a flux option?

Thanks agian. 8)
Back to top
View user's profile Send private message
kachaffeous
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jun 2002
Posts: 86

PostPosted: Sat Jul 06, 2002 3:33 am    Post subject: Reply with quote

Quote:

Create a file called /etc/X11/Sessions/fluxbox

Inside the file, have whatever you want executed, i.e.:

Code:
xscreensaver &
gkrellm -w &
/usr/bin/fluxbox


change the fluxbox line to this

exec /usr/bin/fluxbox

that should work

also check your error logs.
Back to top
View user's profile Send private message
echu
n00b
n00b


Joined: 19 Apr 2002
Posts: 37
Location: Houston, TX

PostPosted: Sat Jul 06, 2002 5:29 am    Post subject: Reply with quote

Quote:
What exactly am I looking for?

:oops:
Sorry about that!! The file i meant was /usr/share/gdm/gdmconfig, if your directories are set up in a default manner.

Under the expert menu, there's a tab called Login sessions, and I thought that might help. If its not in the menu, this should get it in the menu for you, hopefully!

Also, not sure if this might make a difference, but the file permissions on /etc/X11/Sessions/fluxbox - readable/executable by all users? It might be worth a shot, just
Code:
chmod --reference=Gnome fluxbox


Hope you get it figured out soon!
Back to top
View user's profile Send private message
Martin
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2002
Posts: 96
Location: Vancouver, Canada

PostPosted: Sat Jul 06, 2002 6:53 am    Post subject: Reply with quote

Thanks for all the input!

Quote:
change the fluxbox line to this

exec /usr/bin/fluxbox


Changed.

echu wrote:
Also, not sure if this might make a difference, but the file permissions on /etc/X11/Sessions/fluxbox - readable/executable by all users? It might be worth a shot, just
Code:
chmod --reference=Gnome fluxbox


Hope you get it figured out soon!


You guys rock. With the above two things (although I think it was more due to the permissions problem) I got everything working.

fluxbox now even appears in the Session menu...

The culprit: no x access on /etc/X11/Sessions/fluxbox (is it just me who presses tab when writing that out in here? :D )

A million thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum