Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sshd: colors in client?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
rukhoven
n00b
n00b


Joined: 18 Apr 2002
Posts: 54
Location: The flat lands of nether elevation

PostPosted: Sun Apr 21, 2002 2:30 pm    Post subject: sshd: colors in client? Reply with quote

I decided to migrate my server from redhat to gentoo,.. works great! If have however a few unresolved issues.

When I ssh into the server that has sshd running , I can log in fine and do everything I want. When I use MC however, it doesn't display any colors in the terminal. It did display colors with the same setup under redhat. I would then get the exact same screen setup from an ssh client as I would on a VT on the server itself. I compared the sshd.conf files of both distro's but clouldn't find any differences.

Anyone know the trick?

I know this is a minor issue, but it irritates me not being able to get it the way I want...
(Searched MAN, Google and the forum search engine...)

PS. Running something like make menuconfig for kernel confugation, does display colors.. so the the system is capable of it.

Rukhoven
_________________
*****************************
AMDXp 2000 per sis745 con 60 GB HD
......Is what I'd like to have....... :)
Back to top
View user's profile Send private message
Nitro
Bodhisattva
Bodhisattva


Joined: 08 Apr 2002
Posts: 661
Location: San Francisco

PostPosted: Sun Apr 21, 2002 3:09 pm    Post subject: Reply with quote

Maybe try setting your $TERM to 'vt102'
Code:
export TERM="vt102"


Might want to check to see what it was set to before changing it.
_________________
- Kyle Manna

Please, please SEARCH before posting.

There are three kinds of people in the world: those who can count, and those who can't.
Back to top
View user's profile Send private message
rukhoven
n00b
n00b


Joined: 18 Apr 2002
Posts: 54
Location: The flat lands of nether elevation

PostPosted: Sun Apr 21, 2002 7:34 pm    Post subject: Reply with quote

Nitro wrote:
Maybe try setting your $TERM to 'vt102'
Code:
export TERM="vt102"


Might want to check to see what it was set to before changing it.


Alas, that didn't work (everything is the same)...
Thanks for replying.
_________________
*****************************
AMDXp 2000 per sis745 con 60 GB HD
......Is what I'd like to have....... :)
Back to top
View user's profile Send private message
febisfebi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2002
Posts: 76
Location: seattle wa

PostPosted: Sun Apr 21, 2002 7:54 pm    Post subject: Reply with quote

you can try
Code:
export TERM=xterm-color

that has always worked for me
to set this permanently you can add it to your .profile
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Mon Apr 22, 2002 8:17 am    Post subject: Reply with quote

actually, a export TERM=xterm should be enough, but the terminal itself maybe isn't the problem: just be sure, you have /etc/DIR_COLORS and your [ba]sh and profile configured correctly (for the used terminal) on the system you are logging in.

if you want a very colorful sample configuration, tell me to email you mine ;)

hth

ElCondor
Back to top
View user's profile Send private message
rukhoven
n00b
n00b


Joined: 18 Apr 2002
Posts: 54
Location: The flat lands of nether elevation

PostPosted: Mon Apr 22, 2002 9:46 am    Post subject: Reply with quote

Thank you all for your advice, but I can't get it to work.

I want to point put a few things:

I DO get color display when I ssh in to my server!
/usr/src/linux/make menuconfig
shows with the normal colors.
I DO get a color prompt.

I DON'T get colors in MC and that's mainly the problem.

maybe external logins (from telnet/ssh ) have a different setting for how the colors are displayed than normal logins on the physical server istelf. I howerver do not know where to find a settings file for this...

Ps: I have just tried it with telnet and is has the same problem...
_________________
*****************************
AMDXp 2000 per sis745 con 60 GB HD
......Is what I'd like to have....... :)
Back to top
View user's profile Send private message
lude
Retired Dev
Retired Dev


Joined: 18 Apr 2002
Posts: 113
Location: New York, NY

PostPosted: Mon Apr 22, 2002 10:12 am    Post subject: Reply with quote

rukhoven wrote:
I DO get color display when I ssh in to my server!
/usr/src/linux/make menuconfig
shows with the normal colors.
I DO get a color prompt.


Try export TERM=linux

Works for me.
Back to top
View user's profile Send private message
rukhoven
n00b
n00b


Joined: 18 Apr 2002
Posts: 54
Location: The flat lands of nether elevation

PostPosted: Wed Apr 24, 2002 11:38 am    Post subject: Reply with quote

Yes that last one brought the color back in my life :) :)
Now the asci codes are not dealt with properly , because the borders of MC are built up with the wrong characters.... The funtion keys also seem to have a different mapping all at once...

Well, i'm one step further now....

Thanks for all your help
_________________
*****************************
AMDXp 2000 per sis745 con 60 GB HD
......Is what I'd like to have....... :)
Back to top
View user's profile Send private message
Target
Apprentice
Apprentice


Joined: 25 Apr 2002
Posts: 199

PostPosted: Thu Apr 25, 2002 9:43 am    Post subject: Reply with quote

Check the /etc/bashrc from your redhat distro (assuming you kept it).

For some reason an "if" section at the bottom of the default bashrc that does an eval dircolors and creates aliases will fail under gentoo... I just commented out the if and fi lines and got my colour back.

The point of the if statements is to make sure you're using bash so that the aliases are supported... but seeing as I don't use any other shells that reference bashrc, it was safe for me to do.
Back to top
View user's profile Send private message
SAngeli
l33t
l33t


Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Fri Apr 01, 2005 8:29 am    Post subject: Reply with quote

Hi ElCondor

could you please post colorful sample configuration file? I wish to be able to decide which color for.
Of, if you prefer to mail it please let me know.

Thank you,
Spiro
Back to top
View user's profile Send private message
lappen
Apprentice
Apprentice


Joined: 21 Jun 2004
Posts: 212

PostPosted: Fri Apr 01, 2005 3:04 pm    Post subject: Reply with quote

Instead of posting a new thread, I have a similar problem to..

1. When logging in as a regular user doing ls displays colors.
* Doing su or sudo ls doesn't display any colors?

2. piping output doesn't display colors, emerge -vp world | more or ls | more
* Getting rid of the pipes displays colors

Any suggestions on how to fix that?, my term is set to screen but I have the same problems if its set to xterm
Back to top
View user's profile Send private message
mantis006
n00b
n00b


Joined: 07 Jul 2007
Posts: 26
Location: Toledo, OH

PostPosted: Thu Dec 27, 2007 3:38 am    Post subject: Reply with quote

@ lappen

does more do color by default? i know less doesn't without using the -r flag (which is awsome!).

this is some aliases i put at the end of /etc/profile and just source it in my ~/.bashrc (works for me, obviously you could do it differently like put them directly into your user folder and roots if you want the same for su and sudo)

Code:
alias ls='ls --color'
alias grep='grep --color -n'
alias less='less -r'
alias diff='colordiff'


hope that helps, color output is useful.

@op,

I often ssh from windows machines and use mostly putty, it works fine with color prompts but plink hates them. I will be testing some of these settings to see if i can fix it so thanks ;-)
_________________
~Chris
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum