Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage-2.0.5 through 2.0.7 Semi-Broken
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Mon Jun 24, 2002 9:30 pm    Post subject: Portage-2.0.5 through 2.0.7 Semi-Broken Reply with quote

I upgraded to portage-2.0.5 and not only is it slower, it also will not show the status bar (rotating bar) when (thinking) about deps and such or while emerge rsync'ing it doesn't show anything until the list starts scrolling apps.

If anyone else experiences this I suggest downgrading to portage-2.0.4 as it worked great, I did it like this but there are other ways:

Code:

# make sure to merge the older portage first
ebuild /usr/portage/sys-apps/portage/portage-2.0.4.ebuild merge

# unmerge portage-2.0.5
ebuild /usr/portage/sys-apps/portage/portage-2.0.5.ebuild unmerge


I'm not going to submit a bugreport unless someone else experiences this, so if you do please post it :D
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
mksoft
l33t
l33t


Joined: 28 May 2002
Posts: 844

PostPosted: Mon Jun 24, 2002 10:24 pm    Post subject: Reply with quote

Here it is totaly messed up, I cannot run ebuild and emerge at all. This is what I get (for every operation I try with them):
Code:
$ emerge -s portage
!!! Invalid token (not "=") USE
Traceback (most recent call last):
  File "/usr/bin/emerge", line 2, in ?
    import os,sys,portage,xpak,string,re,commands,time,threading
  File "/usr/lib/python2.2/site-packages/portage.py", line 3457, in ?
    db["/"]["porttree"]=portagetree("/",virts)
  File "/usr/lib/python2.2/site-packages/portage.py", line 2254, in __init__
    self.portroot=settings["PORTDIR"]
  File "/usr/lib/python2.2/site-packages/portage.py", line 698, in __getitem__
    self.populate()
  File "/usr/lib/python2.2/site-packages/portage.py", line 684, in populate
    useorder=self["USE_ORDER"]
  File "/usr/lib/python2.2/site-packages/portage.py", line 705, in __getitem__
    if x.has_key(mykey):
AttributeError: 'NoneType' object has no attribute 'has_key'


Any ideas :?:
_________________
There's someone in my head but it's not me - Pink Floyd
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Mon Jun 24, 2002 11:57 pm    Post subject: Reply with quote

What caused this problem mksoft ?
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
Jyrinx
Tux's lil' helper
Tux's lil' helper


Joined: 03 May 2002
Posts: 92
Location: Carleton College - Northfield, MN

PostPosted: Tue Jun 25, 2002 12:02 am    Post subject: Reply with quote

While we're discussing our various Portage 2.0.5 woes ...

"emerge -s" no longer works as a non-root user. This is a pain in the ass, and I prefer to do as little as possible as root (in fact, I wish the emerge process would let me conveniently build as non-root and install as root ...).

Also, I tried an "emerge -s xscreensaver" to see if there was a new version around, and it crapped out, complaining of a missing file under /var/cache/edb/dep/app-misc/xscreensaver-4.05, I believe it was. "emerge -p xscreensaver", "emerge -pu xscreensaver", and "emerge xscreensaver" failed for the same reason. I finally did "cd /usr/portage/app-misc/xscreensaver; emerge ./xscreensaver-4.05-r1.ebuild", which did in fact emerge the new version (up from 4.05), but "emerge -s xscreensaver" still doesn't work. (Not a fatal problem, but an odd quirk ... especially as I downgraded librep and upgraded rep-gtk and sawfish without difficulty.)

Jyrinx
jyrinx@mindspring.com
Back to top
View user's profile Send private message
mksoft
l33t
l33t


Joined: 28 May 2002
Posts: 844

PostPosted: Tue Jun 25, 2002 12:04 am    Post subject: Reply with quote

Don't know. Updated portage to 2.0.5 and etc-update on make.conf and make.globals (keeping my settings).

I'm still trying to see if this is resolved. If not, I'll have to revert to portage's rescuse tar.bz2 (but only as last resort as it is quite old).
_________________
There's someone in my head but it's not me - Pink Floyd
Back to top
View user's profile Send private message
daos
n00b
n00b


Joined: 18 Apr 2002
Posts: 50
Location: Virginia, USA

PostPosted: Tue Jun 25, 2002 12:11 am    Post subject: Reply with quote

In portage 2.04, I see the file list received (number increasing) when run emerge sync. I do not see that in portage 2.05 and I think it's slower. Besides, when I run emerge --clean sync, the portage 2.04 ebuild is gone.
Only portage 2.05 and the previous ebuild version is 1.9.13-r1. Is there any problem with 2.04 versipon?
Back to top
View user's profile Send private message
fghellar
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 856
Location: Porto Alegre, BR

PostPosted: Tue Jun 25, 2002 1:34 am    Post subject: Reply with quote

mksoft wrote:
I'm still trying to see if this is resolved. If not, I'll have to revert to portage's rescuse tar.bz2 (but only as last resort as it is quite old).

I'd recommend you do the rescue and use it just long enough to install 2.0.4 again.
_________________
| www.gentoo.org | www.tldp.org | www.google.com |
Back to top
View user's profile Send private message
Dolio
l33t
l33t


Joined: 17 Jun 2002
Posts: 650

PostPosted: Tue Jun 25, 2002 1:36 am    Post subject: Bah. Reply with quote

And if you're like me, and you managed to unmerge portage without merging the old version ( :oops: I guess we've got an epidemic. rm'ing rm and unmerging emerge :) ) Just go to /usr/portage/sys-apps/portage/files and check out the handy-dandy README.RESCUE to be saved.

Also, I seem to be getting the same problems as others. Can't search as non-root user anymore, and it does seem much slower. I just did emerge -pu world, and it sat there for like a minute before showing the "Calculating world dependencies" thing, although it did do a little of the twirling pipe after a while.
_________________
They don't have a good bathroom to do coke in.
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Tue Jun 25, 2002 2:05 am    Post subject: Reply with quote

Could a mod post some type of sticky warning of the portage-2.0.5 issues, and maybe point to this thread also.

This is one I feel everyone will wan't to steer clear of.
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
lain iwakura
Apprentice
Apprentice


Joined: 09 May 2002
Posts: 176
Location: sd, ca

PostPosted: Tue Jun 25, 2002 2:46 am    Post subject: Reply with quote

well all seem to get a little update happy, don't we? :P

well, thanks for the warning.

common rule of thumb -- if it ain't broke, don't fix it. I know we all seem to love having "the cutting edge" but if you must, be prepared for some issues, yay?

personally, i stay clear of updating important sys apps like portage because, well, they're vital in the function of the OS. and if you break that, well, I don't have to tell you what happens! :D

(oh, and i learned my lesson a while back e.g. -- emerge unmerge portage don't be stupid like me! :oops: )
_________________
[resident anime junkie] -- not just a linux freak.
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Tue Jun 25, 2002 5:15 am    Post subject: Reply with quote

Actually with portage2 came speed and emerge -s foo-package as a normal user, updating was necessary.
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
lain iwakura
Apprentice
Apprentice


Joined: 09 May 2002
Posts: 176
Location: sd, ca

PostPosted: Tue Jun 25, 2002 8:31 am    Post subject: Reply with quote

AutoBot wrote:
Actually with portage2 came speed and emerge -s foo-package as a normal user, updating was necessary.


oh, yeah. don't get me wrong, i love testing new shit. and i updated to 2.0 for those reasons, as well (2.0.4 to be exact.) i was just saying, one should be careful and not get too update happy with certain apps if they're not prepared for the consequences.

on this note, is there a quick way to view an apps changelog -- like with emerge? (sadly, portage's changelog has not been updated since 1.9.13. :cry: )
_________________
[resident anime junkie] -- not just a linux freak.
Back to top
View user's profile Send private message
Alienswede
n00b
n00b


Joined: 25 Jun 2002
Posts: 1

PostPosted: Tue Jun 25, 2002 3:46 pm    Post subject: Reply with quote

I also noticed 2.04 being quite broken. However, a simple emerge /usr/portage/sys-apps/portage/portage-2.0.4.ebuild fixed it for me. I got the nice speed back and any error messages I was getting with 2.05 are gone.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Tue Jun 25, 2002 3:57 pm    Post subject: Reply with quote

If noone upgraded, these problems wouldn't be found. I say thanks to those who do and
are willing to put up/fix there systems so I don't have to. I really don't want to break any
system tools/functionality.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
mksoft
l33t
l33t


Joined: 28 May 2002
Posts: 844

PostPosted: Tue Jun 25, 2002 4:08 pm    Post subject: Reply with quote

Since this wasn't resolved :( , had to use the rescure tar.bz2 and emerged portage 2.0.4.

Everything is working again :)
_________________
There's someone in my head but it's not me - Pink Floyd
Back to top
View user's profile Send private message
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Tue Jun 25, 2002 10:34 pm    Post subject: Reply with quote

I emerged portage 2.0.6. It got worse, now 'update world' isn't working. :(

Code:

# emerge -pu world

These are the packages that I would merge, in order.

Calculating world dependencies /
!!! Error: couldn't find match for >=gnome-base/libglade-1.99.12 in x11-libs/crux-1.9.2


I have libglade 2.0.0 installed because of gnome2.
Back to top
View user's profile Send private message
mksoft
l33t
l33t


Joined: 28 May 2002
Posts: 844

PostPosted: Tue Jun 25, 2002 11:39 pm    Post subject: Reply with quote

For users having problems similar to mine (see the second post in this thread), drobbins suggested that updating /etc/make.globals should resolve this problem.

Unfortunately I already reverted to 2.0.4 and couldn't verify it. You might want to give it a try.
_________________
There's someone in my head but it's not me - Pink Floyd
Back to top
View user's profile Send private message
Tuxisuau
Apprentice
Apprentice


Joined: 04 May 2002
Posts: 213
Location: Catalunya (Europe)

PostPosted: Wed Jun 26, 2002 6:18 am    Post subject: package.mask Reply with quote

Why is portage 2.0.5 still unmasked?
_________________
IM me at tuxisuau@jabber.7a69ezine.org
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Wed Jun 26, 2002 6:29 pm    Post subject: Reply with quote

mksoft wrote:
For users having problems similar to mine (see the second post in this thread), drobbins suggested that updating /etc/make.globals should resolve this problem.

Unfortunately I already reverted to 2.0.4 and couldn't verify it. You might want to give it a try.


That didn't work for me, I'm sticking with 2.0.4 for now.
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
JefP@@
Apprentice
Apprentice


Joined: 09 May 2002
Posts: 179
Location: Belgium

PostPosted: Wed Jun 26, 2002 11:02 pm    Post subject: Reply with quote

I'm using version 2.0.6 now ....

Code:
emerge -p -u world

These are the packages that I would merge, in order.

Calculating world dependencies \
!!! Error: couldn't find match for virtual/opengl in media-libs/libsdl-1.2.4.20020601
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Wed Jun 26, 2002 11:42 pm    Post subject: Reply with quote

Damn. All these people having problems -- we should make more users aware of it! Would some moderator please get off their leaden ass and make this topic sticky!!!!

Oh...wait...

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Thu Jun 27, 2002 1:32 am    Post subject: Reply with quote

Thanks klieber :D
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Thu Jun 27, 2002 2:12 am    Post subject: Reply with quote

i just finished a clean install and am using the new portage with no issue at all...so this might be a conflict with some strangling file or something...i can emerge -s as normal user and apparently did the whole base build aswell as kde and every app thus far using it.
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Thu Jun 27, 2002 2:18 am    Post subject: Reply with quote

I don't know what file this could be, I completely removed (deleted) portage and python and then manually installed both.

Still no dice, back with 2.0.4 until the issue is resolved.
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
Dolio
l33t
l33t


Joined: 17 Jun 2002
Posts: 650

PostPosted: Thu Jun 27, 2002 2:54 am    Post subject: Portage 2.0.7 Reply with quote

I don't know how many people are trying Portage 2.0.7, but it seems to still have at least one problem. I haven't tried searching while a regular user yet, but I did just do emerge -pu world (which took about 20 seconds before I updated), and I watched the spinning pipes/slashes gradually slow down. So now my computer's been running at full CPU usage for about 4 1/2 minutes calculating world dependencies, so I guess I'll kill it and install 2.0.4.

I wonder what could be wrong. :?:

Edit: I can search as a normal user, but that doesn't really do me any good if I can't calculate dependencies and install anything.
_________________
They don't have a good bathroom to do coke in.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Goto page 1, 2, 3, 4, 5  Next
Page 1 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum