Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdebase-3.1.2 ebuild fails at kde_src_compile:configure
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 30 Sep 2002
Posts: 2
Location: Estonia

PostPosted: Sat May 24, 2003 5:47 pm    Post subject: kdebase-3.1.2 ebuild fails at kde_src_compile:configure Reply with quote


running emerge world --deep -u leaves me with:

checking for XkbSetPerClientControls in -lX11... yes
checking for Qt docs... NO
checking for dot... not found
checking for doxygen... not found
checking X11/extensions/XKBstr.h usability... no
checking X11/extensions/XKBstr.h presence... yes
configure: WARNING: X11/extensions/XKBstr.h: present but cannot be compiled
configure: WARNING: X11/extensions/XKBstr.h: check for missing prerequisite headers?
configure: WARNING: X11/extensions/XKBstr.h: proceeding with the preprocessor's result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to ##
configure: WARNING:     ## ------------------------------------ ##
checking for X11/extensions/XKBstr.h... yes
checking for OpenSSL... libraries /usr/lib, headers /usr/include
checking whether OpenSSL uses rsaref... no
checking for easter eggs... none found
checking for OpenSSL version... ok
checking for DPMS... yes
checking for fontconfig-config... not found
configure: WARNING: Could not find libfontconfig anywhere, check
./configure: line 33786: syntax error near unexpected token `LIBFONTCONFIG,'
./configure: line 33786: `PKG_CHECK_MODULES(LIBFONTCONFIG, fontconfig)'
!!! ERROR: kde-base/kdebase-3.1.2 failed.
!!! Function kde_src_compile, Line 118, Exitcode 2
!!! died running ./configure, kde_src_compile:configure

any ideas?

when i try to do the configure part myself i get the same error.
emerge says that i have fontconfig-2.2.0-r2 installed, also i installed it over again with -e --nodeps, but no change

output of my emerge info is:

Portage 2.0.48 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1)
System uname: 2.4.20-gentoo-r5 i686 Celeron (Mendocino)
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss apm avi crypt cups encode gif jpeg libg++ libwww mikmod mmx mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv zlib directfb gtkhtml alsa gdbm berkdb slang readline arts aalib bonobo svga ggi tcltk java guile mysql X sdl gpm tcpd pam ssl perl python esd imlib oggvorbis gnome gtk qt kde motif opengl mozilla gphoto2 ldap cdr dga dvb dvd evo fbcon flash gb gd gnomedb imap innodb ipv6 lcms libgda maildir mbox mozaccess mozcalendar mozinterfaceinfo mozp3p mozsvg mozxmlterm oav odbc samba sasl snmp sse tiff usb wmf xfs xinerama xml xosd -3dnow"
CFLAGS="-march=pentium2 -O3 -pipe"
CXXFLAGS="-march=pentium2 -O3 -pipe"
FEATURES="sandbox ccache"
Back to top
View user's profile Send private message

Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Thu Jul 03, 2003 12:57 pm    Post subject: Reply with quote

I've a same error.
Back to top
View user's profile Send private message

Joined: 01 Jul 2003
Posts: 3
Location: Denmark

PostPosted: Thu Jul 10, 2003 5:00 pm    Post subject: Reply with quote

nearly the same error i have.

!!! ERROR: kde-base/arts-1.1.2 failed.
!!! Function kde_src_compile, Line 123, Exitcode 2
!!! died running emake, kde_src_compile:make

have been searching the forum but did´t find anything. :cry:

any ideas ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum