Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] !!! cairo needs the X flag set
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
LZZ
n00b
n00b


Joined: 16 Apr 2006
Posts: 8
Location: Goiania

PostPosted: Sat Feb 17, 2007 12:24 pm    Post subject: [Solved] !!! cairo needs the X flag set Reply with quote

While emerging gnome

Quote:

!!! ERROR: x11-libs/gtk+-2.10.6 failed.
Call stack:
ebuild.sh, line 1630: Called dyn_setup
ebuild.sh, line 702: Called qa_call 'pkg_setup'
ebuild.sh, line 38: Called pkg_setup
gtk+-2.10.6.ebuild, line 52: Called die

!!! cairo needs the X flag set
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-libs/gtk+-2.10.6/temp/build.log'.


i searched the forum and i found ppl that had this eror but not how to fix it.

My comp:
Pentium 4 3.4Ghz HT
1GB DDR2 677Mhz Corsair XMAS dual chanel
Intel D955XBK
ATI Radeon x800
300GB MATOR SATA 1 Diamondmax 11.

PS: I'm completly noob, i don even know how i managed to get here.
thx alredy and sorry if it's a dumb question.


Last edited by LZZ on Sat Feb 17, 2007 7:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
ichbinsisyphos
Guru
Guru


Joined: 08 Dec 2006
Posts: 547

PostPosted: Sat Feb 17, 2007 12:41 pm    Post subject: Reply with quote

add the X USE flag in /etc/make.conf


theres a line which should look something like this:

Code:
USE="X gnome alsa ..."


put the 'X' in there, create the line if it doesnt exist

theoretically the X flag should be in your linked make.globals profile i think, god knows what went wrong there


and start reading in on USE flags, thats kinda very important, you can start here:

http://gentoo-wiki.com/USE_flag
http://gentoo-portage.com/USE
Back to top
View user's profile Send private message
LZZ
n00b
n00b


Joined: 16 Apr 2006
Posts: 8
Location: Goiania

PostPosted: Sat Feb 17, 2007 3:14 pm    Post subject: Reply with quote

thx man, i solved it myself a while ago, but thx anyway.

and the USE flags tutorial will be very good, thanks fot that too.
Back to top
View user's profile Send private message
madisonicus
Veteran
Veteran


Joined: 20 Sep 2006
Posts: 1130

PostPosted: Sat Feb 17, 2007 5:27 pm    Post subject: Reply with quote

I know you solved this, but it's normally caused by an incorrect profile. Most desktop users will want a desktop profile which should have X as one of the default USE flags. I'd suggest double checking your profile and making sure that it's what you would like.

-m
_________________
Please add [SOLVED] to your message title if you feel that your question has been answered.
------
Intel Q9300 Core2 Quad * Gigabyte GA-EP35C-DS3R
Samsung x360
AMD64 x2 4200+ * TF7050-M2 * HTPC
ZOTAC ION A-U Mini-ITX * HTPC
Back to top
View user's profile Send private message
LZZ
n00b
n00b


Joined: 16 Apr 2006
Posts: 8
Location: Goiania

PostPosted: Sat Feb 17, 2007 7:43 pm    Post subject: Reply with quote

[solved] add to title...

now i just have to lern how to make startx start gnome instead of this green thing that only can open shells.

i know it most be very simple but i am tryng for a while now and nothing change it.

is Xsession file? and what's it folder? cuz /etc/X11 wasn't...

thx for the help ppl!
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Wed Nov 07, 2007 6:15 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Desktop Environments.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
owatonnahacker
n00b
n00b


Joined: 11 Dec 2007
Posts: 2

PostPosted: Tue Dec 11, 2007 6:20 pm    Post subject: Reply with quote

LZZ wrote:
[solved] add to title...

now i just have to lern how to make startx start gnome instead of this green thing that only can open shells.

i know it most be very simple but i am tryng for a while now and nothing change it.

is Xsession file? and what's it folder? cuz /etc/X11 wasn't...

thx for the help ppl!


Have you modified your XSession variable in /etc/rc.conf to gnome?
_________________
The universe began in chaos, and has been going downhill ever since
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum