Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFree 4.3 / Radeon -- Lockup up when logging out.
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
john07af
n00b
n00b


Joined: 25 Nov 2002
Posts: 11
Location: Illinois

PostPosted: Fri Mar 07, 2003 5:42 am    Post subject: XFree 4.3 / Radeon -- Lockup up when logging out. Reply with quote

I have XFree 4.3 / KDE 3.1 running on my Dell Inspiron 8200 w/Radeon 64mb. I finally have 3d acceleration support under X. Everything works fine except for one problem. When I logout of my sessionn before kdm restarts my system freezes solid. Not Alt-F1, capslock, numlock, nothing. Power cycle is only way to get it back. Any clues? I did not have this problem with 4.2.x. The driver I used with 4.2 was a patched radeon driver made to recognize the Radeon LF250 chipset but without 3d support.


Thanks,


John
Back to top
View user's profile Send private message
bsolar
Bodhisattva
Bodhisattva


Joined: 12 Jan 2003
Posts: 2764

PostPosted: Fri Mar 07, 2003 2:16 pm    Post subject: Reply with quote

I'm fighting against this for days, it happens with the xfree DRM.
If you use the DRM of your kernel, no lockup but no DRI, if you use the DRM of xfree, DRI works but it locks... :evil:

If you halt the system, sometimes it goes, sometimes not... Tried to find the cause but nothing...

I am very interested in a solution for this.
_________________
I may not agree with what you say, but I'll defend to the death your right to say it.
Back to top
View user's profile Send private message
HunterWare
n00b
n00b


Joined: 05 Sep 2002
Posts: 10

PostPosted: Fri Mar 07, 2003 5:21 pm    Post subject: Reply with quote

I see this too...

Fully updated system with xfree-4.3.0 et all. Matrox G550 dual head.
Back to top
View user's profile Send private message
john07af
n00b
n00b


Joined: 25 Nov 2002
Posts: 11
Location: Illinois

PostPosted: Fri Mar 07, 2003 5:42 pm    Post subject: Reply with quote

I am wondering if this has anything to do with the Radeon chipset I am using. The DRI website only shows support for the R100 and R200. The R250 is probabely close enough to the R200 that it works, but with issues. Any 100 or 200 users out there have this problem? As a "temporary" solution to avoid the lockup instead of logging out I do a CTRL-ALT-BKSP. Yes, it aborts X, doesn't save my session, but it doesn't lock up and gets me back to the kdm login screen. This problem will probabely not be solved short term and I am hesitant to try the DRI-CVS route.


John
Back to top
View user's profile Send private message
bsolar
Bodhisattva
Bodhisattva


Joined: 12 Jan 2003
Posts: 2764

PostPosted: Fri Mar 07, 2003 5:44 pm    Post subject: Reply with quote

I have an ATI Radeon Mobility M6 LY
_________________
I may not agree with what you say, but I'll defend to the death your right to say it.
Back to top
View user's profile Send private message
MyZelF
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 2010
Location: Venice, Italy

PostPosted: Tue Mar 25, 2003 11:06 pm    Post subject: Reply with quote

Same problem here with my Radeon Mobility 7500 on Compaq Presario 2825.
Back to top
View user's profile Send private message
Cappy
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2003
Posts: 98

PostPosted: Thu Mar 27, 2003 3:14 am    Post subject: Reply with quote

Same problem here also.....I also posted on this issue. Definately the DRM module....I Emerged it and unmerged it quite a few times just to be sure....and it's reproduceable 100% of the time. I also have a Radeon based card...Radeon 9000 Pro (Giga-Byte Maya II).

Cap
_________________
Windows??....Yeah, I know what that is....I use that to look out at the pretty blue screen.....ahhh....I mean sky. :)
Back to top
View user's profile Send private message
johpe916
n00b
n00b


Joined: 13 Sep 2002
Posts: 45
Location: Sweden

PostPosted: Thu Mar 27, 2003 3:22 pm    Post subject: Reply with quote

Same trouble after upgrading xfree and drm, also with a radeon card. It's a bit annoying to have to type 'shutdown -h now' in a terminal everytime you want to shut the computer down. If I don´t the computer locks up trying to restart gdm.

/Johan


Last edited by johpe916 on Sun Apr 13, 2003 10:07 am; edited 1 time in total
Back to top
View user's profile Send private message
sputnik1969
Guru
Guru


Joined: 08 Aug 2002
Posts: 401
Location: Berlin / Germany

PostPosted: Fri Mar 28, 2003 1:01 am    Post subject: Reply with quote

Same Problem even with R200 (Radeon 8500) :(
_________________
'Cynic' is a word invented by optimists to criticize realists. - Nigel. In the ocean of Night by Gregory Benford
"Zyniker" ist ein Wort das Optimisten erfunden haben um Realisten zu kritisieren. - Nigel. Im Meer der Nacht von Gregory Benford
Back to top
View user's profile Send private message
Blue Lightning
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2003
Posts: 137
Location: Auckland, New Zealand

PostPosted: Fri Mar 28, 2003 7:24 am    Post subject: Reply with quote

Same problem here, with an AIW Radeon (R100). Perhaps this would be a good thing to enter into the new XFree86 bugzilla?
Back to top
View user's profile Send private message
Bastian9175
n00b
n00b


Joined: 11 Dec 2002
Posts: 29

PostPosted: Fri Mar 28, 2003 11:40 am    Post subject: Reply with quote

Same problem with ATI RAGE 128 PRO.
:(
Back to top
View user's profile Send private message
seemant
Retired Dev
Retired Dev


Joined: 16 Nov 2002
Posts: 61
Location: Oakland, CA

PostPosted: Fri Apr 11, 2003 10:59 am    Post subject: try xfree-4.3.0-r2 Reply with quote

Hi All,

I'm trying to narrow this down -- if y'all would be so kind as to try xfree-4.3.0-r2 (hard masked, currently, so first edit the package.mask and delete the entry for it), and report here or in bugs (open up a bug report please, if the problem persists).
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4546
Location: Suzhou, China

PostPosted: Fri Apr 11, 2003 11:06 am    Post subject: Reply with quote

Just an idea. I don't have this problem with xfree-4.3.0-r1 dri-enabled on Matrox G550 DH. Maybe you are trying to run 3d acceleration and framebuffer at the same time? They bite. The kernel documentation says to disable drm/dri when using framebuffer. I don't know if this causes your problems, but I think it's worth looking into.
Back to top
View user's profile Send private message
bsolar
Bodhisattva
Bodhisattva


Joined: 12 Jan 2003
Posts: 2764

PostPosted: Fri Apr 11, 2003 11:47 am    Post subject: Reply with quote

yngwin wrote:
Just an idea. I don't have this problem with xfree-4.3.0-r1 dri-enabled on Matrox G550 DH. Maybe you are trying to run 3d acceleration and framebuffer at the same time? They bite. The kernel documentation says to disable drm/dri when using framebuffer. I don't know if this causes your problems, but I think it's worth looking into.

AFAIK this happens only with Radeon cards (with or without framebuffer).
_________________
I may not agree with what you say, but I'll defend to the death your right to say it.
Back to top
View user's profile Send private message
MyZelF
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 2010
Location: Venice, Italy

PostPosted: Sat Apr 12, 2003 4:30 pm    Post subject: Reply with quote

seemant: I've just tried emerging xfree-4.3.0-r2 but it didn't solve the problem
Back to top
View user's profile Send private message
seemant
Retired Dev
Retired Dev


Joined: 16 Nov 2002
Posts: 61
Location: Oakland, CA

PostPosted: Sun Apr 13, 2003 2:37 am    Post subject: patch_level 1.0.5 Reply with quote

MyZelf,

is PATCH_LEVEL="1.0.5" the one being used?

To check do this:

grep PATCH_LEVEL /var/db/pkg/x11-base/xfree-4.3.0-r2/xfree-4.3.0-r2.ebuild

(don't grep the one in /usr/portage).

If it's not 1.0.5, please re-emerge xfree and try
Back to top
View user's profile Send private message
seemant
Retired Dev
Retired Dev


Joined: 16 Nov 2002
Posts: 61
Location: Oakland, CA

PostPosted: Sun Apr 13, 2003 9:12 am    Post subject: kernel question for all of you Reply with quote

By the way, and I just thought of this. In your kernel configuration step -- you didn't build the radeon dri thing into the kernel or as a module did you? I notice that it builds a radeon.o module, which is the same name as the module that xfree-drm builds. So, I'm not sure what happens when xfree tries to load a module called radeon.

Anyway, can y'all confirm that you have ONLY the radeon.o from xfree-drm, and that this is happening with that specific one?

Thanks,

Seemant
Back to top
View user's profile Send private message
samppa
n00b
n00b


Joined: 15 Jun 2002
Posts: 69
Location: Finland

PostPosted: Sun Apr 13, 2003 11:26 am    Post subject: Same problem with drm from linux-2.5.x Reply with quote

I have seen this same problem with the radeon.o module from the development kernel, which I use (currently 2.5.67-bk4). I don't have xfree-drm installed at all. I have kept kdm disabled for now, since I don't really need it.
Back to top
View user's profile Send private message
samppa
n00b
n00b


Joined: 15 Jun 2002
Posts: 69
Location: Finland

PostPosted: Sun Apr 13, 2003 11:30 am    Post subject: Re: patch_level 1.0.5 Reply with quote

seemant wrote:

is PATCH_LEVEL="1.0.5" the one being used?

To check do this:

grep PATCH_LEVEL /var/db/pkg/x11-base/xfree-4.3.0-r2/xfree-4.3.0-r2.ebuild


PATCH_LEVEL does not produce any hits for me, but PATCH_VER does:

PATCH_VER="1.0.5"

And I have the lockup with this build.
Back to top
View user's profile Send private message
fca
Guru
Guru


Joined: 22 Feb 2003
Posts: 345
Location: Germany

PostPosted: Sun Apr 13, 2003 11:57 am    Post subject: Reply with quote

Well, I have the same problem with my Radeon 9500 Pro (=R300 core), witht the xfree ati driver. I'm gonna try the new XFree, see if that works. I only use the radeon.o from the XFree.

BTW: did you use the update from xfree86?
xfree 4.3.99.2 seems to have fixed this
Quote:
31. Fix lockup on server shutdown/restart with the radeon driver
(Bugzilla #94, Michel Dänzer).
Back to top
View user's profile Send private message
fca
Guru
Guru


Joined: 22 Feb 2003
Posts: 345
Location: Germany

PostPosted: Sun Apr 13, 2003 1:58 pm    Post subject: Reply with quote

OK, the new XFree (4.3.0-r2) solves the locking up problem, but it does have a nasty side-effect for me: It doesn t recognize my second monitor, even though it works perfectly outside X and in the previous build, 4.3.0-r1, so I m going back to 4.3.0-r1, as the locking up is not a big problem.
Back to top
View user's profile Send private message
seemant
Retired Dev
Retired Dev


Joined: 16 Nov 2002
Posts: 61
Location: Oakland, CA

PostPosted: Sun Apr 13, 2003 2:10 pm    Post subject: and just when you downgrade... Reply with quote

I have an upgrade :P

The PATCH_VER should be 1.0.6 and should solve the second monitor issue. Please test.
Back to top
View user's profile Send private message
fca
Guru
Guru


Joined: 22 Feb 2003
Posts: 345
Location: Germany

PostPosted: Sun Apr 13, 2003 2:47 pm    Post subject: Reply with quote

I can't build it, as something goes seriously wrong when downloading the patches. It goes to many different mirrors, downloads the files, and then goes to the next server

Truly bizarre. I've tried downloading the file manually and placing it in distfiles, but that doesn't help.

Quote:
--16:44:51-- http://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.snt.utwente.nl... done.
Connecting to ftp.snt.utwente.nl[130.89.175.1]:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

The file is already fully retrieved; nothing to do.

>>> Resuming download...
>>> Downloading ftp://ftp.tu-clausthal.de/pub/linux/gentoo//distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:51-- ftp://ftp.tu-clausthal.de/pub/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.tu-clausthal.de... done.
Connecting to ftp.tu-clausthal.de[139.174.2.36]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/linux/gentoo/distfiles ... done.
==> SIZE XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
==> PASV ... done. ==> REST 415137 ... done.
==> RETR XFree86-4.3.0-patches-1.0.6.tar.bz2 ...
No such file `XFree86-4.3.0-patches-1.0.6.tar.bz2'.

>>> Resuming download...
>>> Downloading http://www.ibiblio.org/pub/linux/distributions/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:52-- http://www.ibiblio.org/pub/linux/distributions/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving www.ibiblio.org... done.
Connecting to www.ibiblio.org[152.2.210.81]:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2 [following]
--16:44:52-- http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving distro.ibiblio.org... done.
Connecting to distro.ibiblio.org[152.2.210.109]:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

The file is already fully retrieved; nothing to do.

>>> Resuming download...
>>> Downloading ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:52-- ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.gtlib.cc.gatech.edu... done.
Connecting to ftp.gtlib.cc.gatech.edu[130.207.108.134]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/gentoo/distfiles ... done.
==> SIZE XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
==> PASV ... done. ==> REST 415137 ... done.
==> RETR XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
Length: 415,137 [0 to go]

100%[==============================================>] 415,137 --.--K/s ETA --:--

16:44:54 (0.00 B/s) - `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2' saved [415137]

>>> Resuming download...
>>> Downloading http://gentoo.oregonstate.edu/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:54-- http://gentoo.oregonstate.edu/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving gentoo.oregonstate.edu... done.
Connecting to gentoo.oregonstate.edu[128.193.0.3]:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

The file is already fully retrieved; nothing to do.

>>> Resuming download...
>>> Downloading ftp://ftp.oregonstate.edu/pub/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:54-- ftp://ftp.oregonstate.edu/pub/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.oregonstate.edu... done.
Connecting to ftp.oregonstate.edu[128.193.0.3]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/gentoo/distfiles ... done.
==> SIZE XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
==> PASV ... done. ==> REST 415137 ... done.
==> RETR XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
Length: 415,137 [0 to go]

100%[==============================================>] 415,137 --.--K/s ETA --:--

16:44:57 (0.00 B/s) - `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2' saved [415137]

>>> Resuming download...
>>> Downloading http://mirrors.sunsite.dk/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:57-- http://mirrors.sunsite.dk/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving mirrors.sunsite.dk... done.
Connecting to mirrors.sunsite.dk[130.225.247.92]:80... connected.
HTTP request sent, awaiting response... 403 Forbidden

The file is already fully retrieved; nothing to do.

>>> Resuming download...
>>> Downloading ftp://sunsite.dk/mirrors/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:57-- ftp://sunsite.dk/mirrors/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving sunsite.dk... done.
Connecting to sunsite.dk[130.225.247.90]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /mirrors/gentoo/distfiles ...
No such directory `mirrors/gentoo/distfiles'.

>>> Resuming download...
>>> Downloading http://gentoo.linux.no/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:58-- http://gentoo.linux.no/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving gentoo.linux.no... done.
Connecting to gentoo.linux.no[193.201.220.90]:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

The file is already fully retrieved; nothing to do.

>>> Resuming download...
>>> Downloading ftp://gentoo.linux.no/pub/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:58-- ftp://gentoo.linux.no/pub/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving gentoo.linux.no... done.
Connecting to gentoo.linux.no[193.201.220.90]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/gentoo/distfiles ... done.
==> SIZE XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
==> PASV ... done. ==> REST 415137 ... done.
==> RETR XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
Length: 415,137 [0 to go]

100%[==============================================>] 415,137 --.--K/s ETA --:--

16:44:59 (0.00 B/s) - `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2' saved [415137]

>>> Resuming download...
>>> Downloading ftp://ftp.tu-clausthal.de/pub/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:44:59-- ftp://ftp.tu-clausthal.de/pub/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.tu-clausthal.de... done.
Connecting to ftp.tu-clausthal.de[139.174.2.36]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/linux/gentoo/distfiles ... done.
==> SIZE XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
==> PASV ... done. ==> REST 415137 ... done.
==> RETR XFree86-4.3.0-patches-1.0.6.tar.bz2 ...
No such file `XFree86-4.3.0-patches-1.0.6.tar.bz2'.

>>> Resuming download...
>>> Downloading http://ftp.gentoo.or.kr/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:45:00-- http://ftp.gentoo.or.kr/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.gentoo.or.kr... done.
Connecting to ftp.gentoo.or.kr[211.172.226.79]:80... connected.
HTTP request sent, awaiting response... 404 Not Found

Continued download failed on this file, which conflicts with `-c'.
Refusing to truncate existing file `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'.

>>> Resuming download...
>>> Downloading http://gentoo.gnukorea.org/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:45:00-- http://gentoo.gnukorea.org/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving gentoo.gnukorea.org... done.
Connecting to gentoo.gnukorea.org[211.202.2.240]:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

The file is already fully retrieved; nothing to do.

>>> Resuming download...
>>> Downloading ftp://ftp.dale.ro/pub/mirrors/ftp.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:45:01-- ftp://ftp.dale.ro/pub/mirrors/ftp.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.dale.ro... done.
Connecting to ftp.dale.ro[193.231.198.231]:21... failed: Connection refused.
>>> Resuming download...
>>> Downloading http://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:45:01-- http://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.snt.utwente.nl... done.
Connecting to ftp.snt.utwente.nl[130.89.175.1]:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

The file is already fully retrieved; nothing to do.

>>> Resuming download...
>>> Downloading ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:45:01-- ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.snt.utwente.nl... done.
Connecting to ftp.snt.utwente.nl[130.89.175.1]:21... connected.
Logging in as anonymous ...
Error in server greeting.
Retrying.

--16:45:02-- ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
(try: 2) => `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Connecting to ftp.snt.utwente.nl[130.89.175.1]:21... connected.
Logging in as anonymous ...
Error in server greeting.
Retrying.

--16:45:04-- ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
(try: 3) => `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Connecting to ftp.snt.utwente.nl[130.89.175.1]:21... connected.
Logging in as anonymous ...
Error in server greeting.
Retrying.

--16:45:07-- ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
(try: 4) => `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Connecting to ftp.snt.utwente.nl[130.89.175.1]:21... connected.
Logging in as anonymous ...
Error in server greeting.
Retrying.

--16:45:11-- ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
(try: 5) => `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Connecting to ftp.snt.utwente.nl[130.89.175.1]:21... connected.
Logging in as anonymous ...
Error in server greeting.
Giving up.

>>> Resuming download...
>>> Downloading ftp://ftp.rez-gif.supelec.fr/pub/Linux/distrib/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:45:11-- ftp://ftp.rez-gif.supelec.fr/pub/Linux/distrib/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving ftp.rez-gif.supelec.fr... done.
Connecting to ftp.rez-gif.supelec.fr[160.228.92.7]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /pub/Linux/distrib/gentoo/distfiles ... done.
==> SIZE XFree86-4.3.0-patches-1.0.6.tar.bz2 ... done.
==> PASV ... done. ==> REST 415137 ... done.
==> RETR XFree86-4.3.0-patches-1.0.6.tar.bz2 ...
No such file `XFree86-4.3.0-patches-1.0.6.tar.bz2'.

>>> Resuming download...
>>> Downloading http://distro.ibiblio.org/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
--16:45:12-- http://distro.ibiblio.org/gentoo/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2
=> `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'
Resolving distro.ibiblio.org... done.
Connecting to distro.ibiblio.org[152.2.210.109]:80... connected.
HTTP request sent, awaiting response... 404 Not Found

Continued download failed on this file, which conflicts with `-c'.
Refusing to truncate existing file `/usr/portage/distfiles/XFree86-4.3.0-patches-1.0.6.tar.bz2'.

!!! Couldn't download XFree86-4.3.0-patches-1.0.6.tar.bz2. Aborting.
Back to top
View user's profile Send private message
fca
Guru
Guru


Joined: 22 Feb 2003
Posts: 345
Location: Germany

PostPosted: Sun Apr 13, 2003 3:14 pm    Post subject: Reply with quote

it compiles now.
Will post results when ready.

edit: dual screen still doesn't work.
And how do I get rid of the alpha-blended cursors? I liked the old one, but in 4.3.0-r2 I can't seem to get them.

edit2: this seems to be the relevant error:
Quote:

(WW) RADEON(1): Only one monitor detected, Second screen will NOT be created


edit3:
It works now, with the ati 2.9.6 drivers. But now I get nasty artifacts with the whiteglass cursor.
Well, that's something I'm willing to search for.
Back to top
View user's profile Send private message
MyZelF
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 2010
Location: Venice, Italy

PostPosted: Sun Apr 13, 2003 8:32 pm    Post subject: Reply with quote

seemant:

I'm not using kernel drm at all: my radeon.o come from xfree-drm.

Now I'm trying re-emerging xfree with PATCH_VER="1.0.6" and I'll let you know soon.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum