Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pango doesnt compile when trying to emerge gnome2.2 final
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tolle
n00b
n00b


Joined: 05 Nov 2002
Posts: 42
Location: Dorotea in Lappland in Sweden

PostPosted: Thu Feb 06, 2003 4:27 pm    Post subject: Pango doesnt compile when trying to emerge gnome2.2 final Reply with quote

When I try to compile Pango 1.2.1 to install gnome 2.2 final I get this.

Code:

/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPANGO_ENABLE_BACKEND -DPANGO_ENABLE_ENGINE -DSYSCONFDIR=\"/etc\" -DLIBDIR=\"/usr/lib\" -DMODULE_VERSION=\"1.2.0\" -DG_DISABLE_DEPRECATED -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I/usr/include/freetype2 -I/usr/X11R6/include    -I/usr/include/freetype2 -I/usr/X11R6/include -I..    -march=athlon-xp -mcpu=athlon-xp -O3 -pipe -Wall -c pangoft2.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPANGO_ENABLE_BACKEND -DPANGO_ENABLE_ENGINE -DSYSCONFDIR=\"/etc\" -DLIBDIR=\"/usr/lib\" -DMODULE_VERSION=\"1.2.0\" -DG_DISABLE_DEPRECATED -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/X11R6/include -I.. -march=athlon-xp -mcpu=athlon-xp -O3 -pipe -Wall -c pangoft2.c  -fPIC -DPIC -o pangoft2.lo
pangoft2.c: In function `pango_ft2_font_get_face':
pangoft2.c:224: `FC_HINT_STYLE' undeclared (first use in this function)
pangoft2.c:224: (Each undeclared identifier is reported only once
pangoft2.c:224: for each function it appears in.)
pangoft2.c:225: `FC_HINT_FULL' undeclared (first use in this function)
pangoft2.c:227: `FC_HINT_NONE' undeclared (first use in this function)
pangoft2.c:231: `FC_HINT_SLIGHT' undeclared (first use in this function)
pangoft2.c:232: `FT_HINT_NO_INTEGER_STEM' undeclared (first use in this function)
pangoft2.c:232: `FT_HINT_NO_VSTEM_ALIGN' undeclared (first use in this function)
pangoft2.c:234: `FC_HINT_MEDIUM' undeclared (first use in this function)
pangoft2.c:281: warning: implicit declaration of function `FT_Set_Hint_Flags'
make[3]: *** [pangoft2.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/pango-1.2.1/work/pango-1.2.1/pango'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/pango-1.2.1/work/pango-1.2.1/pango'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/pango-1.2.1/work/pango-1.2.1'
make: *** [all-recursive-am] Error 2
 
!!! ERROR: x11-libs/pango-1.2.1 failed.
!!! Function src_compile, Line 46, Exitcode 2
!!! serial make failed


Could it be caused by the fact that I have patched my fontconfig and freetype some?(to fix the "ugly fonts when to large" problem)
Back to top
View user's profile Send private message
tolle
n00b
n00b


Joined: 05 Nov 2002
Posts: 42
Location: Dorotea in Lappland in Sweden

PostPosted: Thu Feb 06, 2003 5:09 pm    Post subject: Reply with quote

it was due to the patches
Back to top
View user's profile Send private message
marklynch2
Guest





PostPosted: Fri Feb 07, 2003 1:55 am    Post subject: What patches? Reply with quote

I'm just trying to install the same and having problems - I am getting the exact same errors that you were getting.

I've tried unmerging and re-emerging xft, freetype and fontconfig but still get the same errors.

Could you explain what you changed to get it to work.

Thanks.
Back to top
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Fri Feb 07, 2003 8:19 am    Post subject: Reply with quote

You should comment this:
Code:
# patch adapted from RH initial patch by <foser@gentoo.org>
# epatch ${FILESDIR}/${P}-slighthint-gentoo.patch

in /usr/portage/x11-libs/pango-1.2.1.ebuild.
Back to top
View user's profile Send private message
Twist
Guru
Guru


Joined: 03 Jan 2003
Posts: 414
Location: San Diego

PostPosted: Fri Feb 07, 2003 9:34 am    Post subject: Reply with quote

Yeah, this is due to the hint patch. Either comment out as in the above comment, or build pango-1.2.1 manually as root:

Code:

source /etc/profile
cd /somefoodir
tar xjvfp /path/to/distfiles/pango-1.2.1.tar.bz2
./configure --prefix=/usr
make
(if the make works...)
emerge -C pango
make install
emerge -i x11-libs/pango-1.2.1


and then ACCEPT_KEYWORDS="~x86" emerge gnome-2.2.ebuild

I see no discernable font fugliness without the hint patch, btw.
Back to top
View user's profile Send private message
marklynch
n00b
n00b


Joined: 07 Feb 2003
Posts: 24
Location: Sydney

PostPosted: Sat Feb 08, 2003 10:36 am    Post subject: Thanks Reply with quote

Thanks for the responses - I'll try it when I get back to work on monday.
Back to top
View user's profile Send private message
foser
Retired Dev
Retired Dev


Joined: 28 Oct 2002
Posts: 154

PostPosted: Sat Feb 08, 2003 1:48 pm    Post subject: Reply with quote

if your fontconfig is correctly built with the slighthint patch (as it should), it should give no problems.
_________________
Gentoo Gnome Desktop team
Back to top
View user's profile Send private message
justus
n00b
n00b


Joined: 16 Apr 2002
Posts: 48

PostPosted: Sun Feb 09, 2003 11:06 am    Post subject: Problem solved for me Reply with quote

Not sure if this will help anyone, but I will go through and mention it anyway.

I noticed that there were some extra include files for freetype and fontconfig in the /usr/X11R6/include directory that were from the original install of Xfree (running the latest 4.2.99 version).

I basically removed these and then pointed them to the /usr/include directories and then recompiled freetype, fontconfig, xft and then pango. (Not sure if all the recompiles were necessary, but they took only about 3 minutes to do...)

Now it compiled for me without a problem.

Hopefully that will help someone (maybe something to be added to the freetype, fontconfig ebuilds... should verify that there aren't any versions of the software installed that can cause problems, and if there are then update them accordingly.)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum