Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gcc3 env: imlib build breaks at configure (jpeglib.h etc)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
trapni
Developer
Developer


Joined: 16 May 2002
Posts: 251
Location: Germany/Berlin

PostPosted: Sun May 26, 2002 9:36 pm    Post subject: gcc3 env: imlib build breaks at configure (jpeglib.h etc) Reply with quote

hi,

I know that I have jpeglib.h in /usr/include/ and the `emerbe imlib` breaks at this point of configure anyway. Why?

I am using imlib-1.9.14, but I can remember that I got these error on a different package too. I do also get at this package the configure hint that the sys/shm.h and sys/ipc.h does not exist. Having a quick look into /usr/include/sys/ tells me that I have these files (shm.h and ipc.h).

So what's going wrong here?

please help, 'cuz I can't help my self :)

Best regards,
Christian Parpart.
Back to top
View user's profile Send private message
enesideme
n00b
n00b


Joined: 20 Apr 2002
Posts: 46
Location: france

PostPosted: Mon May 27, 2002 10:05 am    Post subject: Reply with quote

I have the same problem and I just can say that the problem has something to do with the path --prefix=/user. If you uncompress and compile the sources with default path (/usr/local) or any else path it will build without any problem but not with --prefix=/usr.
I think we should post on the developpers'mailinglist since the problem is a specific gentoo problem.
Back to top
View user's profile Send private message
trapni
Developer
Developer


Joined: 16 May 2002
Posts: 251
Location: Germany/Berlin

PostPosted: Mon May 27, 2002 1:43 pm    Post subject: Reply with quote

enesideme wrote:
I think we should post on the developpers'mailinglist since the problem is a specific gentoo problem.


I bed to find some response by the core developer here since I can't post/read any mails until my system is completed *grrr*.

Cheers,
Christian Parpart.
Back to top
View user's profile Send private message
lx
Veteran
Veteran


Joined: 28 May 2002
Posts: 1012
Location: Netherlands

PostPosted: Tue May 28, 2002 9:18 am    Post subject: Reply with quote

problem is that cpp 3.1 gives a warning when you add -I/usr/include so you should edit the configure file (line 7368) and change CPPFLAGS=$CPPFLAGS -I$includedir -I$prefix/include .. to CPPFLAGS=$CPPFLAGS .. (so remove every instance of /usr/include that's the $includedir and -I/prefix/include and configure works fine. I then used ebuild too compile install and merge the package. When a new version of imlib is realised it will probably contain a fix.

Hope it helps, Alex
_________________
"Remember there's a big difference between kneeling down and bending over.", Frank Zappa
Back to top
View user's profile Send private message
trapni
Developer
Developer


Joined: 16 May 2002
Posts: 251
Location: Germany/Berlin

PostPosted: Wed May 29, 2002 6:17 am    Post subject: Reply with quote

lx wrote:
problem is that cpp 3.1 gives a warning when you add -I/usr/include so you should edit the configure file (line 7368) and change CPPFLAGS=$CPPFLAGS -I$includedir -I$prefix/include .. to CPPFLAGS=$CPPFLAGS .. (so remove every instance of /usr/include that's the $includedir and -I/prefix/include and configure works fine. I then used ebuild too compile install and merge the package. When a new version of imlib is realised it will probably contain a fix.

Hope it helps, Alex


Well, I removed the jpeglib header check in configure.in and rebuild the configure script using autoconf, rebuild the package dist and its md5. That not fine but works too :)

C y'a,
Christian Parpart.
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Sun Aug 18, 2002 9:39 pm    Post subject: Reply with quote

From GCC3 to Portage & Programming, chosen over OTG because subject appears to be a broken ebuild.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum