Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Segfaults with glibc 2.3.1 + nvidia-kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Yama
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jul 2002
Posts: 135
Location: Sydney, Australia

PostPosted: Sat Feb 01, 2003 1:59 pm    Post subject: Segfaults with glibc 2.3.1 + nvidia-kernel Reply with quote

Before upgrading to glibc 2.3.1, I had a perfectly running Gentoo setup (including gcc-3.2.1-r6). After the upgrade, I noticed that many apps would segfault. The segfaulting is partly dependent on what is running at the time. If X isn't loaded, everything is fine. Under GNOME and KDE, having apps like OpenOffice.org, Konqueror or Evolution open makes many other apps segfault on start. Under these circumstances, even simple console tools like ls will segfault -- even if run in another user account. Even new console logins will segfault. Quite often I will load into GNOME or KDE and I can't start anything at all.

After much experimentation, I ascertained that the problem only exists when I am running X with the nvidia-kernel video driver (I have a GeForce 3 based card). Everything is very stable with the XFree86 nv driver, even if the nvidia kernel module is loaded(as long as it's not being used). To find this, I tried many (almost all) different combinations of the following:
    - glibc-2.3.1-r2 and glibc-2.3.1-r3
    - linux-2.4.19-gentoo-r7, linux-2.4.19-gentoo-r10, linux-2.4.20-gentoo-r1, and linux-2.4.20 (i.e. vanilla 2.4.20)
    - nvidia-kernel-1.0.3123, nvidia-kernel-1.0.3123-r1, nvidia-kernel-1.0.3123-r2, nvidia-kernel-1.0.4191, nvidia-kernel-1.0.4191-r1
    - In /etc/X11/XF86Config, I have tried NvAGP 0-3 (i.e. AGPGART, Nvidia's AGP and no AGP)
The result was the same every time: the nvidia-kernel driver made programmes segfault, while the nv driver didn't do any harm. This is probably a problem with Nvidia's code (meaning it is up to them to fix it), but I'm asking here in case it is something else. Until this problem can be fixed, I am stuck with the nv driver, which means I can't play any UT2003 :(

Thanks for any help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum