Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to set up ISDN on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
BackSeat
Apprentice
Apprentice


Joined: 12 Apr 2002
Posts: 242
Location: Reading, UK

PostPosted: Mon Jan 13, 2003 3:05 pm    Post subject: How to set up ISDN on Gentoo Reply with quote

I've recently set up ISDN on a few Gentoo systems, and I thought I'd post the procedure here as it seems that most of the ISDN documentation on the 'net is either in German or very old. I should point out that I am in the UK, and whilst I think these instructions should work for most of Europe they will not work for America (but then who there uses ISDN?).

You will, of course, need to use an ISDN card which is supported in the Linux kernel (see /usr/src/linux/Documentation/isdn/*). I have successfully set up ISDN using three makes of card: the BT Speedway (which is a "Fritz" card), the Asuscom "ISDNLink 128K Adapter", and a no-name card using an Winbond W6692 chip. What determines whether or not a card is supported is the chip: check the Linux kernel documentation to see if the one you want to use is supported.

The card needs to be physically installed in the system. If you want to check that the card is visible on the PCI bus, do the following:
Code:
emerge pciutils
lspci

This will list all detected PCI interfaces; the three cards listed above are identified, respectively, as:
Code:
"Network controller: AVM Audiovisuelles MKTG & Computer System GmbH Fritz"

"Asustek Computer, Inc. ISDNLink"

"Network controller: Winbond Electronics Corp W6692"

There will be other numbers and information on the same line, and of course other PCI devices will also be listed.

Next, the kernel needs to be configured. If you are not familiar with rebuilding the kernel you may want to look at the appropriate HOWTO. The following options need to be selected in the "ISDN subsystem" section. I build firewalls with monolithic (non-module) kernels; you could build these as modules but you will need to ensure that the modules are loaded when required. It's probably simpler just to build them into the kernel:
Code:
<*> ISDN support
[*] Support synchronous PPP

Under the "Passive ISDN cards" section (itself in the section referred to above):
Code:
<*> HiSax SiemensChipSet driver support
[*] Use VJ-compression with synchronous PPP
[*] HiSax Support for EURO/DSS1

and then the appropriate driver for your card. Again, for the three listed above, the options would be as follows (you only select one of these):
Code:
[*] AVM Fritz!Card PCI/PCIv2/PnP support (EXPERIMENTAL)
for the BT Speedway card

[*] HFC PCI-Bus cards
for the Asuscom card or

[*] Winbond W6692 based cards
for the Winbond chip card

Now exit, saving changes, rebuild the kernel and boot it:
Code:
make dep
make bzImage modules modules_install
mount /boot
mv /boot/bzImage /boot/bzImage-old
cp arch/i386/boot/bzImage /boot
reboot

Check that the card has been detected:
Code:
dmesg|grep HiSax

Included in the 20-odd lines of output should be something similar to the following (these lines will not necessarily be adjacent):
Code:
HiSax: Total 1 card defined
HiSax: HFC-PCI card manufacturer: Asuscom/Askey card name: 675
HiSax: 2 channels added

Of course, the exact output depends on the card used.

Next, install the Gentoo ISDN tools package:
Code:
emerge isdn4k-utils

Ensure that the local service is started by default:
Code:
ls /etc/runlevels/default/local

- should show that the file exists

Create /etc/ppp/isdn-initialise as follows:
Code:
#!/bin/bash

MYUSER=USERNAME       # my username at the ISP
REMNAME=ISPNAME       # name of ISP's system
REMMSN=ISP-NUMBER     # number of ISP
MYIP=MY-IP-ADDRESS    # my fixed IP number

/sbin/ifconfig ippp0 $MYIP pointopoint
/sbin/ifconfig ippp0 -arp -broadcast    # don't allow arps and broadcasts

/sbin/route add $MYIP ippp0
/sbin/route add default netmask 0 ippp0 # all non-local traffic goes to ippp0

/sbin/ipppd user $MYUSER remotename $REMNAME defaultroute                       

Replace USERNAME with your logon name given to you by your ISP; replace ISPNAME with the name of your ISP (this needn't be precise: it is simply used to set up ipppd, the ISDN daemon. However, do not put any spaces in the name); replace ISP-NUMBER with the telephone number of your ISP, and finally replace MY-IP-ADDRESS with the IP address assigned to you by your ISP. If you do not have a fixed IP address for your ISDN connection then put any non-local-LAN address in place of MY-IP-ADDRESS (eg, if your LAN uses 192.168.0.0/24 addresses you could put 10.0.0.1 in MY-IP-ADDRESS). ipppd will automatically overwrite the incorrect address with the correct one when you connect. Make this file executable:
Code:
chmod +x /etc/ppp/isdn-initialise

Create /etc/ppp/chap-secrets:
Code:
# Secrets for authentication using CHAP
# client    server  secret      IP addresses
USERNAME    *       PASSWORD

Replace USERNAME and PASSWORD with the details provided by the ISP.

Deny access to other than root:
Code:
chown root:root /etc/ppp/chap-secrets
chmod 600 /etc/ppp/chap-secrets

Create /etc/ppp/isdnlog-init:
Code:
#!/bin/bash
isdnlog -sS -v1 -w10 -m0x17d7 -l0x3d7 -C /dev/console -D /dev/isdnctrl

Make executable:
Code:
chmod +x /etc/ppp/isdnlog-init

Next set up ISDN and save the settings. First create isdn-setup; this script only needs to be run once, but placing it in /etc/ppp does ensure that it is available in future if required:
Code:
#!/bin/bash

MYMSN=MY-NUMBER # my number, without 0, with areacode
REMMSN=ISP-NUMBER     # number of ISP

/sbin/isdnctrl verbose 3            # verbose messages
/sbin/isdnctrl system on            # ensure ISDN system is turned on
/sbin/isdnctrl addif ippp0          # add the interface
/sbin/isdnctrl eaz ippp0 $MYMSN
/sbin/isdnctrl l2_prot ippp0 hdlc
/sbin/isdnctrl l3_prot ippp0 trans
/sbin/isdnctrl encap ippp0 syncppp  # we will use syncPPP
/sbin/isdnctrl dialmode ippp0 auto  # dial on demand
/sbin/isdnctrl addphone ippp0 out $REMMSN   # ISP's number
/sbin/isdnctrl huptimeout ippp0 10  # set timeout to 10 seconds (or whatever)
/sbin/isdnctrl dialmax ippp0 20     # set redial count to 20
/sbin/ipppd user $MYUSER remotename $REMNAME \
    defaultroute                    \
    name $MYUSER                    \
    debug                           \
    -detach                         \
    mru 1500                        \
    mtu 1500                        \
    lcp-restart 1                   \
    /dev/ippp0 &

Edit it to replace MY_NUMBER and ISP-NUMBER appropriately (note:
no leading zero for MY-NUMBER). Make the script executable:
Code:
chmod +x /etc/ppp/isdn-setup

Start the isdn4linux service, run the setup script, and stop the service to store the settings:
Code:
/etc/init.d/isdn4linux start
/etc/ppp/isdn-setup
/etc/init.d/isdn4linux stop

Edit the /etc/conf.d/local.start script to include the following line:
Code:
/etc/ppp/isdn-initialise 1>&2

Add isdn4linux service to startup:
Code:
# Initialise ISDN system
rc-update add isdn4linux default

Now we can test the setup. Connect the ISDN card to the ISDN port. Log in on a second virtual console and keep the system log on screen:
Code:
tail -f /var/log/messages

Optionally log in on a third virtual console and run the ISDN monitor
utility:
Code:
imon

Return to the first console and initialise the ISDN system:
Code:
bash /etc/conf.d/local.start

The syslog should show something similar to:
Code:
Dec  4 16:42:14 fw1 ipppd: info: no CHAP secret entry for this user!
Dec  4 16:42:14 fw1 ipppd[31007]: Found 1 device:
Dec  4 16:42:14 fw1 ipppd[31007]: ipppd i2.2.12 (isdn4linux version of pppd by MH) started
Dec  4 16:42:14 fw1 ipppd[31007]: init_unit: 0
Dec  4 16:42:14 fw1 ipppd[31007]: Connect[0]: /dev/ippp0, fd: 7

Turn on enhanced logging:
Code:
/etc/ppp/isdnlog-init

Attempt a connection:
Code:
ping some-Internet-IP-address

Check it:
Code:
isdnctrl status ippp0

...should show that ippp0 is connnected; you should also see connection details in the syslog, and the imon monitor should show "Online" for line 0. If this does not happen, read on...

If the connection does work satisfactorily, you should reboot the system to ensure that the ISDN system initialises automatically at boot. Anytime you try to access an off-LAN address an ISDN connection should be established.

NOTE: you will need to set up a name service and a firewall, which I have not covered in this document.

Troubleshooting: the following may help.

Make sure all the config files in /etc/ppp are up to date - an 'ls -a' will show any updated config files (starting "._config00").

To show configuration, manually dial, check status of connection and hangup:
Code:
isdnctrl list ippp0
isdnctrl dial ippp0
isdnctrl status ippp0
isdnctrl hangup ippp0

To reset the configuration totally:
Code:

ifconfig ippp0 down
isdnctrl delif ippp0


References: the following may help.

http://www.wurtel.cistron.nl/i4l-howto-uk.html
http://www.isdn4linux.de/
/usr/src/linux/Documentation/isdn/*

This guide was compiled from various documents on the Internet.

BS
Back to top
View user's profile Send private message
Auka
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2002
Posts: 109
Location: BaWue, Germany, Europe, Earth.

PostPosted: Sat Jan 25, 2003 10:41 am    Post subject: Reply with quote

Hello BackSeat!

Great guide, really! I just set up my ISDN connection (no dsl available here *grr*) the day before yesterday based on your guide, combined with a few other sources I found in the forums and some hours of trying around myself.

Unfortunately ISDN seems to be one of the (few) things regarding Gentoo which are not only *cough, cough* "not really" easy to set up, but also almost undocumented.

I still remember how easy it was setting up ISDN even back in the days of SuSE 6.x :( (For the protocoll: No, I would not use any post 7.x version of SuSE these days anyway... *g*)

Which is quite sad in my opionion as I know a lot of people who switched to linux (i.e. used it for the first time) just because they wanted to set up a server for their home network providing samba, apache et al. and last but not least connecting to the internet with ISDN dialup...

But anyway. Back to facts. There are a few steps I took in a different way than described in your guide:

1.) instead of using /etc/ppp/isdn-initialise I simply added an interface definition in /etc/conf.d/net:
Code:

iface_ippp0="192.168.0.1 broadcast 192.168.0.255 netmask 255.255.255.0"
gateway="ippp0/192.168.0.1"

Afterwards it is possible to initialise the ISDN interface using /etc/init.d/net.ippp0 start /stop.

2.) I did use your template /etc/ppp/isdn-setup in combination with /etc/init.d/isdn4linux start / stop to set up my ippp0 interface.
Hint: If someone gets strange errormessages "no such device" or similar, then have a look at /var/lib/isdn4linux/isdnctrl.conf and delete it if it is empty!!

3.) also configured the connection as described. (ppp secrets etc.)

I still do have to tweak a few things, e.g. it seems as if /etc/ppp/ip-down and ip-down.local are not executed properly, so my interface still has it's public ip (not the private one) after a hangup. But overall dial-on-demand works quite fine.

Once again: thanks for your well-written guide! :-)

[Edit 2003-11-02: updated "hint" it says "no such device" and not "no such interface".]


Last edited by Auka on Sun Nov 02, 2003 6:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
n0ll4k
n00b
n00b


Joined: 21 Jul 2002
Posts: 22

PostPosted: Sun Jan 26, 2003 7:18 pm    Post subject: Reply with quote

OK this guide is realy good but i have another problem. I installed gentoo with a buddy at his dsl with a router.
So what should i do do run my fritz card physically?

sorry for my bad english
Back to top
View user's profile Send private message
Auka
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2002
Posts: 109
Location: BaWue, Germany, Europe, Earth.

PostPosted: Wed Jan 29, 2003 1:27 pm    Post subject: Reply with quote

Hmm, what exactly do you mean by "physically"?
If you, e.g. have a FritzCard PCI, all you need is plug-and-play support and the driver modules activated in your kernel (as described here). In case of an older ISA FritzCard you have to additionally set the base IO address using the jumper block onboard...
Back to top
View user's profile Send private message
Captain
n00b
n00b


Joined: 29 Dec 2002
Posts: 23
Location: Greece

PostPosted: Mon Feb 03, 2003 7:03 am    Post subject: Reply with quote

Well done Backseat! Although I had already ISDN running on my TelesPnP card, I tried your method just out of curiosity, because it is a nice and tidy rule of thumb.
What I did was:
1) Compile the kernel with ISDN support as modules. Insert the hisax module in modules.autoload:
Code:
hisax id=hisax protocol=2 type=20

and reboot.
2) Emerge isdn4k-utils
3) I didn't make the isdn-initialise script. I used Auka's suggestion and edited /etc/init.d/net instead.
4) Edit all the rest of the stuff in /etc/ppp (important: you didn't mention to put the ppp login username in /etc/ppp/options.ippp0).
5) Start isdn4linux, run isdn-setup, stop isdn4linux. One important thing here is the "huptimeout". One should set it just 1 sec less than the time that the telco charges a unit. In my case, the Greek Telecom charges a unit every 266 secs, so I set it at 265 instead of 10. Be careful everybody, setting huptimeout too low would make you box place calls frequently and your phone bills big!
6) Reboot, start manually isdn4linux and net.ippp0, check that everything works.
7) Add isdn4linux and net.ippp0 at default runlevel.

I will try to find some time to continue this thread with multilink ppp (adding the second B channel) configuration.
Cheers everybody!

George
_________________
Aris Velouhiotis was right!!
Back to top
View user's profile Send private message
Excession
n00b
n00b


Joined: 26 Feb 2003
Posts: 11
Location: Peine, Germany

PostPosted: Sun Mar 02, 2003 8:08 pm    Post subject: Reply with quote

I followed the explanations right here and when i try
Code:
bash /etc/conf.d/local.start
then i get that error:

Quote:
modprobe: modprobe: can't locate module
sorry - this system lacks PPP kernel support.
check whether you configured at least the ippp0 device!


I don't understand it. I followed these instructions here and my kernel should support PPP as I compiled it with the right ISDN-features. My kernel is gentoo 2.4.19.-r5 and I've got a Fritz Card PCI. What else do I have to consider?

Backseat, after "Add isdn4linux service to startup: " you said
Quote:
Connect the ISDN card to the ISDN port.

What do you mean by that? Is that the reason for my problem?
Back to top
View user's profile Send private message
pcdg
n00b
n00b


Joined: 25 Feb 2003
Posts: 5

PostPosted: Tue Mar 11, 2003 8:34 pm    Post subject: Reply with quote

hi excession

i've got the same message after running isdn-initialise (and also surtenly have ppp in my kernel), so i ran all the individual lines by hand, and it seems the problem is in:
Code:

/sbin/ipppd user $MYUSER remotename $REMNAME defaultroute

But I got it working, but i'm not sure why it works. What I did was follow the steps described by backseat but
WITH the comments about options.ippp0 as in this forum, and a pap-secrets file (read it somewhere)
WITHOUT the isdn-initialise part
I just added the last line of isdn-setup to /etc/init.d/local.start :
Code:

/sbin/ipppd user $MYUSER remotename $REMNAME \
    defaultroute                    \
    name $MYUSER                    \
    debug                           \
    -detach                         \
    mru 1500                        \
    mtu 1500                        \
    lcp-restart 1                   \
    /dev/ippp0 &


PS I should add that i dont use the 'auto' dialing but manual, so i start my connection with 'isdnctrl dial ippp0'

Question for the Guru's why should this work at all?
Are the lines in isdn-initialise not necessary, but just better?
Back to top
View user's profile Send private message
milothurston
Apprentice
Apprentice


Joined: 01 May 2002
Posts: 231
Location: Oxford, England.

PostPosted: Sat Mar 15, 2003 2:48 pm    Post subject: Reply with quote

This looks like an excellent guide, thanks.
Presumably, though, one still needs an ethernet connection for the initial installation?
Milo.
Back to top
View user's profile Send private message
Excession
n00b
n00b


Joined: 26 Feb 2003
Posts: 11
Location: Peine, Germany

PostPosted: Sun Mar 16, 2003 8:18 pm    Post subject: Reply with quote

I dont know, what's going on at the moment..
I can't actually tell which configs I use how, because I tried out a lot of things of your several solutions. I don't understand how it can work at all. 8)

At the moment, I can go online (manually) and I always check on a second console via "imon" the actual status of my connection. Then I can connect to ICQ, can ping some servers and I can visit this site for example.
But after some time (it's changing from one to actual five minutes) and after that the connection is lost. I can assure that it isn't a fault of my ISP nor my hardware as I don't have any problems with my internet if I use some other OS which I don't want to name right here. :roll:

Right now my huptimeout is set to 255 but I also tried it with 0. What does huptimeout do in fact? And where else can a timeout be configured? (Although I changed the dialmode to manual)
Back to top
View user's profile Send private message
BackSeat
Apprentice
Apprentice


Joined: 12 Apr 2002
Posts: 242
Location: Reading, UK

PostPosted: Fri Mar 21, 2003 9:07 pm    Post subject: Reply with quote

huptimeout defines the number of seconds after which, with no traffic over the ISDN link, the line will be dropped. So currently you will drop the line after 4 minutes 15 seconds. You can only (realistically) set the timeout with huptimeout. If you want the link to stay up until you manually disconnect it then a huptimeout of 0 should do the trick, although of course if your line is unreliable the link may drop anyway.

Hope this helps a bit.

BS
Back to top
View user's profile Send private message
milothurston
Apprentice
Apprentice


Joined: 01 May 2002
Posts: 231
Location: Oxford, England.

PostPosted: Mon Mar 24, 2003 8:41 pm    Post subject: Routing/name name service &c. with ISDN Reply with quote

Following these instructions, with the difference of using /etc/conf.d/net, has proven effective in gettin ISDN working (and better than Red Hat's GUI equivalent). However, one small bit of strangeness remains.
Using 'init.d net.ippp0 start' and 'isdnctrl dial ippp0' connects, but the interface does not appear to be routed:

Code:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
no-dns-yet.demo *               255.255.255.0   U     0      0        0 ippp0
loopback        localhost.local 255.0.0.0       UG    0      0        0 lo
default         demon-du.demon. 0.0.0.0         UG    0      0        0 ippp0


I've got Demon's DNS server IP addreses in /etc/resolv.conf, so everything works, but it's not possible to use the timer button on gkrellm because of this. Any suggestions on correcting this little matter would be useful!
Thanks,
Milo.
Back to top
View user's profile Send private message
chris4linux
Apprentice
Apprentice


Joined: 13 Nov 2002
Posts: 210
Location: Germany

PostPosted: Wed Mar 26, 2003 9:23 am    Post subject: Reply with quote

works this tip also as a isdn-dial-in server (online for network connections to the internet --> a router?) ? what must change to auto dial in from clients?

thanks and the tip is very good :)

- Chris
_________________
NOTICE: alloc: /dev/null: filesystem full
Back to top
View user's profile Send private message
Excession
n00b
n00b


Joined: 26 Feb 2003
Posts: 11
Location: Peine, Germany

PostPosted: Wed Mar 26, 2003 6:30 pm    Post subject: Reply with quote

The thing with the timeout still doesn't work. Although huptimeout is 0 and dialing mode is manual, I'm still kicked after several minutes, if I don't ping something all the time.. But linux provides me six consoles, so what.. 8)

In spite of that, thank you to all, who helped me indirectly with my ISDN connection! :D
Back to top
View user's profile Send private message
Ribs
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2002
Posts: 133
Location: UK

PostPosted: Sat May 03, 2003 1:53 pm    Post subject: USB ISDN? Reply with quote

Thanks for the guide,

Has anyone tried this using the HomeHighway box from BT? I mean using the built in USB TA that comes with it. I know it's possible under Linux, as RedHat works with it automatically. How would I go about setting this up in Gentoo?

I think the TA model is "ACER P10"...

Regards,
-Ribs.
Back to top
View user's profile Send private message
Centurion610
Tux's lil' helper
Tux's lil' helper


Joined: 06 May 2003
Posts: 89
Location: Italy: Florence<->Naples

PostPosted: Tue Jul 22, 2003 10:29 am    Post subject: Reply with quote

Hi,
I use this discussion for configure ISDN on my gentoo pc, but I have some problem.
My card isdn is a Asuscom HFC-PCI .
When i start isdn4linux, and /etc/ppp/isdn-setup i have this response
Code:
 Verbose-level set to 3.
addif: No such device
EAZ/MSN for ippp0 is **********
Layer-2-Protocol for ippp0 is hdlc
Layer-3-Protocol for ippp0 is trans
Encapsulation for ippp0 is syncppp
Hangup-Timeout for ippp0 is 10 sec.
Dialmax for ippp0 is 20 times.


Help me plz, How i can resol this problem?
Tnx in advance!
Bye
Cent:eek:
Back to top
View user's profile Send private message
Auka
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2002
Posts: 109
Location: BaWue, Germany, Europe, Earth.

PostPosted: Tue Jul 22, 2003 10:43 am    Post subject: Reply with quote

Hi,

have a look at my posting it's No. 2 in this thread. There you can read:
Quote:
Hint: If someone gets strange errormessages ("no interface" or something), then have a look at /var/lib/isdn4linux/isdnctrl.conf and delete it if it is empty!!


Hope this applies and helps.
Back to top
View user's profile Send private message
Ben2040
Guru
Guru


Joined: 07 May 2003
Posts: 445
Location: UK

PostPosted: Tue Jul 22, 2003 12:28 pm    Post subject: Reply with quote

Hi
I am also using BT HomeHighway, which uses the Acer P10 something, and works under SuSE because they have their own setup system in YaST2. The actual card is in the box and is wired to the PC via USB cable. Is this impossible in Gentoo so far?


Ben
Back to top
View user's profile Send private message
Centurion610
Tux's lil' helper
Tux's lil' helper


Joined: 06 May 2003
Posts: 89
Location: Italy: Florence<->Naples

PostPosted: Tue Jul 22, 2003 5:54 pm    Post subject: Reply with quote

Auka wrote:
Hi,

have a look at my posting it's No. 2 in this thread. There you can read:
Quote:
Hint: If someone gets strange errormessages ("no interface" or something), then have a look at /var/lib/isdn4linux/isdnctrl.conf and delete it if it is empty!!


Hope this applies and helps.


Hi,
i read your post but isdnctrl.conf is not empty:
Code:
[ISDNCTRL]
INTERFACES = {

[INTEFACE]
NAME = IPPP0
EAZ = XXXXX
PHONE_OUT = XXXXX XXXXX XXXXX XXXXX
SECURE = off
DIALMODE = auto
DIALMAX = 20
HUPTIMEOUT = 10
IHUP = on
CHARGE HUP = off
L2_PROT = HDLC
L3_PROT = TRANS
ENCAP = SYNCPPP

[INTERFACE]
NAME = IPPP1
SECURE = off
DEALMODE = manual
DEALMAX = 1
HUPTIMEOUT = 10
IHUP = on
CHARGE HUP = off
L2_PROT = X75I
L3_PROT = TRANS
ENCAP = RAVIP}

XXXXX=mynumber and isp number
I delete it if it is not empty?
Bye
Cent:eek:
Back to top
View user's profile Send private message
evan-
n00b
n00b


Joined: 13 Aug 2003
Posts: 63
Location: Italy

PostPosted: Wed Aug 13, 2003 1:51 pm    Post subject: Reply with quote

when i type bash /etc/conf.d/local.start

i get this error:
sorry - this system lacks PPP kernel support.
check whether you configured at least the ippp0 device!

i followed all the steps and i tried all the "tricks" any helps?
thanks

ps: i use gentoo-source-2.4.20-r5 and gentoo-1.4-r1
Back to top
View user's profile Send private message
Pythagoras1
Guru
Guru


Joined: 29 Jul 2002
Posts: 351
Location: trailer park Vienna, Austria

PostPosted: Tue Aug 19, 2003 6:20 pm    Post subject: Reply with quote

evan- wrote:
sorry - this system lacks PPP kernel support.
check whether you configured at least the ippp0 device!

Add /dev/ippp0 to the last line of /etc/ppp/isdn-initialise
_________________
Gobo, listen to reason. We wouldn't be in the Land of Having Blown Up if we didn't blow up now would we?!? ~Wembley
Back to top
View user's profile Send private message
Wilhelm
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 149

PostPosted: Fri Aug 22, 2003 5:40 pm    Post subject: Reply with quote

Hi i'm working on my ISDN aswell and trying to see if i can make it all work.
I have an ISA Eicon Diva 2.01 isdn card which i intend to use for telephone line logging and not so much as a PPP dialup.
I used to do a PPP dialup using i4l under Suse which worked beatifully, however under gentoo you get a load of config files and no explanation how they should work.

My problem begins with the fact that when i compile my HiSax driver into the kernel it gives me a recursive timeout message at startup and basically keeps on looping. I solved this by loading it as a module.

Because i have an ISA card i need to run a modprobe. modules.autoload is run too early so i can't simply add it to modules.autoload. Modprobe must be run after isapnp to make my card work.

Here is my simple solution but somebody might like the idea.

Compile hisax as a module in your kernel.

/etc/conf.d/isdn4linux
Quote:

# Location where isdnctrl will save its configuration

ISDNCTRL_SAVE="/var/lib/isdn4linux/isdnctrl.conf"

#
# Some ISDN cards require the module to be loaded
# after isapnp before they come available.
#
I4L_LOADMODULE=yes

I4L_DRIVER=hisax
I4L_IO=0x240
I4L_IRQ=5
I4L_PROTOCOL=2
I4L_TYPE=11



adjusted /etc/init.d/isdn4linux
Quote:

#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# $Header: /home/cvsroot/gentoo-x86/net-dialup/isdn4k-utils/files/3.2_p1-r2/isdn4linux.init,v 1.2 2003/02/14 22:58:35 vapier Exp $

depend() {
use pcmcia
}

start() {

ebegin "Loading isdnctrl configuration"

# Load nessecary module
if [ ${I4L_LOADMODULE} == "yes" ]
then modprobe ${I4L_DRIVER} io=${I4L_IO} irq=${I4L_IRQ} protocol=${I4L_PROTOCOL} type=${I4L_TYPE} >/dev/null
fi

# This variable is set in /etc/conf.d/isdn4linux
[ ! -f ${ISDNCTRL_SAVE} ] || isdnctrl readconf ${ISDNCTRL_SAVE} >/dev/null

eend $?

}

stop() {

ebegin "Saving isdnctrl configuration"

isdnctrl writeconf ${ISDNCTRL_SAVE} >/dev/null
rmmod ${I4L_DRIVER}

eend $?

}



If somebody has a simpler solution to what i did please tell me.
Back to top
View user's profile Send private message
Wilhelm
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 149

PostPosted: Fri Aug 22, 2003 6:21 pm    Post subject: Reply with quote

Another mistake i found when running isdnlog is that the config file isdn.conf has loads of referenes to /usr/lib/isdn when the real directory holding the files is /usr/share/isdn.
Back to top
View user's profile Send private message
rezza
Guru
Guru


Joined: 09 Apr 2003
Posts: 434
Location: Edinburgh, UK

PostPosted: Sun Aug 24, 2003 9:08 pm    Post subject: Reply with quote

@ Ribs & Ben2040:

I think you guys are using the wrong module for the built-in HomeHighway TA. I work tech support for BT HomeHighway, and time and time again i've tried to figure out exactly what is the correct module to use from the company which supplies us with the HomeHighway boxes, but they are basically a bunch of wankers who refuse to reveal anything. I have had one user who i was chatting with who said he got it working configuring it all manually (ie he wasn't using YaST or the redhat equivalent), but i can't quite remember what he used... I'll post the module he used when i next go into work (Tuesday).
_________________
screenshots
blog
Back to top
View user's profile Send private message
Ribs
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2002
Posts: 133
Location: UK

PostPosted: Mon Aug 25, 2003 8:19 pm    Post subject: Reply with quote

rezza wrote:
I'll post the module he used when i next go into work (Tuesday).


Any more info? :)

I'm currently still using my laptop to relay the connection via WinGate for me (yeuk!). I had this crazy idea of setting up a VMWare'd Windows98 install on my Gentoo box and letting that handle the connection. It's so insane it just might work...

-Ribs.

EDIT: Look here for my previous efforts: https://forums.gentoo.org/viewtopic.php?t=53836
_________________
Ribbed for your pleasure!

AmberNet IRC network;
http://www.ambernet.org
Back to top
View user's profile Send private message
rezza
Guru
Guru


Joined: 09 Apr 2003
Posts: 434
Location: Edinburgh, UK

PostPosted: Thu Aug 28, 2003 8:50 pm    Post subject: Reply with quote

d'oh, sorry, i completely forgot!

tomorrow, i promise!

all i remember was that it was just some letters and numbers, eg something like sg5326.

in fact, let me have a play with my kernel config, i'm sure i'd remember it if i saw it.
_________________
screenshots
blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2, 3, 4, 5  Next
Page 1 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum