Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub and RAID 1 installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
astano
n00b
n00b


Joined: 04 Jul 2004
Posts: 39

PostPosted: Wed Jan 19, 2005 10:49 pm    Post subject: Grub and RAID 1 installation Reply with quote

I have a mchine with Promise S150 SX4 SATA RAID, working on RAID 1 (2 discs). What I need to know is how to configure grub to boot from the raid.
I searched the foruns and found something about installing grub on both discs. So far so good. But how do I configure the grub.conf to boot from the other disc if one fails??

A step by step instruction would be very good, since i dont understand much about grub and raid.....

If anyone can help.... plz!!!! :)
_________________
Ast@nO
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Thu Jan 20, 2005 8:15 am    Post subject: Reply with quote

Esample: I've got a (Software-)Raid1, /boot is on /dev/md0 (hda5 and hdb5)
Code:
title Gentoo
root (hd0,4)
kernel /boot/k.2.6.10 root=/dev/md1


then
Code:
grub> root (hd0,4)
 Filesystem type is ext2fs, partition type 0xfd

grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  22 sectors are embedded.
succeeded
 Running "install /boot/grub/stage1 (hd0) (hd0)1+22 p (hd0,4)/boot/grub/stage2 /boot/grub/menu.lst"... succeeded
Done.

grub> setup (hd1)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd1)"...  22 sectors are embedded.
succeeded
 Running "install /boot/grub/stage1 d (hd1) (hd1)1+22 p (hd0,4)/boot/grub/stage2 /boot/grub/menu.lst"... succeeded
Done.

so grub is installed on both harddisks, grub then wants to boot from (hd0,4) - since hd0 is the first harddisk installed, it works fine with RAID1, no matter which RAID1 disk is removed.

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum