Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trouble with bootstraping
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
alchemyx
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2003
Posts: 111
Location: Swinoujscie, Poland

PostPosted: Wed Jan 12, 2005 4:58 pm    Post subject: Trouble with bootstraping Reply with quote

Hello!

Currently I am in progress of bootstraping gentoo. I am not doing it first time, but it is first time that I can't get trough.

gandalf portage # scripts/bootstrap.sh
[... some time ...]
g++ -c -I. -I../dist/.. -I../dist/../dbinc -D_GNU_SOURCE -D_REENTRANT -O3 -march=pentium4 -pipe -fomit-frame-pointer ../dist/../cxx/cxx_db.cpp -fPIC -DPIC -o .libs/cxx_db.lo
./libtool: line 1: g++: command not found
make: *** [cxx_db.lo] Error 1

And that is true. There is no g++ anywhere. My emerge info:

Quote:
Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, unavailable, 2.4.27 i686)
=================================================================
System uname: 2.4.27 i686 Intel(R) XEON(TM) CPU 2.00GHz
Gentoo Base System version 1.4.16
Autoconf:
Automake:
Binutils: sys-devel/binutils-2.14.90.0.8-r1
Headers:
Libtools:
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X acl apache2 apm arts avi berkdb bitmap-fonts crypt cups encode foomaticdb fortran ftp gdbm gif gnome gpm gtk gtk2 ipv6 jpeg kde libwww mad mikmod motif mpeg ncurses nls oggvorbis opengl oss pam pdflib perl php png python qt quicktime readline sdl spell ssl svga tcpd truetype userlocales xml2 xmms xv zlib"

_________________
Michał Margula, alchemyx@uznam.net.pl, http://alchemyx.uznam.net.pl/
"W życiu piękne są tylko chwile" [Ryszard Riedel]
Back to top
View user's profile Send private message
kawsper
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2004
Posts: 128
Location: Copenhagen, Denmark

PostPosted: Wed Jan 12, 2005 5:27 pm    Post subject: Reply with quote

I have exactly the same problem as you. Same package and same error.

My make.conf
Code:

CFLAGS="-O2 -march=pentium3 -pipe -fstack-protector"
CHOST="i386-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"

MAKEOPTS="-j2"
GENTOO_MIRRORS="ftp://194.117.143.72/mirrors/gentoo ftp://mirror.nutsmaas.nl/gentoo/ rsync://ftp-stud.fht-esslingen.de/gentoo/ http://gentoo.mirror.icd.hu/"

USE="-X -xv -xmms -xosd -svga -trusted -usb -wxwindows -wavelan -voodoo3 -pda -pcmcia -oss -opengl -mozilla -kde -gtk2 -gtk2 -gphoto -gnome -dga -3dfz -3dnow -arts acpi apm ssl exif flash gif jpeg ftp gd mime ncurses mysql mysqli png -java -sdl"
Back to top
View user's profile Send private message
alchemyx
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2003
Posts: 111
Location: Swinoujscie, Poland

PostPosted: Wed Jan 12, 2005 5:59 pm    Post subject: Reply with quote

Wondering if I should file a bug report on bugzilla.


UPDATE: https://bugs.gentoo.org/show_bug.cgi?id=77718
_________________
Michał Margula, alchemyx@uznam.net.pl, http://alchemyx.uznam.net.pl/
"W życiu piękne są tylko chwile" [Ryszard Riedel]
Back to top
View user's profile Send private message
kawsper
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2004
Posts: 128
Location: Copenhagen, Denmark

PostPosted: Wed Jan 12, 2005 6:47 pm    Post subject: Reply with quote

I am starting a new installation on my server, with the same settings and files and all. So now i want to see what is going to happen.

Update: Im about to bootstrap in a couple of minutes.
Back to top
View user's profile Send private message
senz
n00b
n00b


Joined: 12 Jan 2005
Posts: 19
Location: Frankfurt

PostPosted: Wed Jan 12, 2005 6:56 pm    Post subject: Reply with quote

i have exactly the same problem. downloaded the bootstrap-files about 1 hour ago.
Back to top
View user's profile Send private message
kawsper
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2004
Posts: 128
Location: Copenhagen, Denmark

PostPosted: Wed Jan 12, 2005 8:29 pm    Post subject: Reply with quote

It didn't help to start over. I still experience the error:
Code:
g++ -c -I. -I../dist/.. -I../dist/../dbinc -D_GNU_SOURCE -D_REENTRANT -O2 -march=pentium3 -pipe -fstack-protector ../dist/../cxx/cxx_db.cpp  -fPIC -DPIC -o .libs/cxx_db.lo
./libtool: line 1: g++: command not found
make: *** [cxx_db.lo] Error 1

!!! ERROR: sys-libs/db-4.1.25_p1-r4 failed.
!!! Function src_compile, Line 96, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
derekking
n00b
n00b


Joined: 12 Jan 2005
Posts: 2

PostPosted: Wed Jan 12, 2005 8:39 pm    Post subject: Reply with quote

I am guessing that g++ should come from the stage1 tarball.
When I scanned through the stage1 tarball with ...

tar tvjf stage1-x86-2004.3.tar.bz2 | grep 'g++'

I didn't get any matches, but I did have gcc.
Back to top
View user's profile Send private message
derekking
n00b
n00b


Joined: 12 Jan 2005
Posts: 2

PostPosted: Wed Jan 12, 2005 9:31 pm    Post subject: Reply with quote

I downloaded an older version ( 2004.2 ) and it contained g++. So I am guessing the newest tarball is just missing g++. Does anybody know how long ago 2004.3 came out?
Back to top
View user's profile Send private message
Luthien
n00b
n00b


Joined: 12 Jan 2005
Posts: 9

PostPosted: Wed Jan 12, 2005 10:42 pm    Post subject: Reply with quote

Until it gets fixed a workaround for the issue would be :

Code:

emerge --nodeps gcc
cd /usr/portage
scripts/bootstrap.sh
Back to top
View user's profile Send private message
quantus
n00b
n00b


Joined: 30 Jul 2002
Posts: 60

PostPosted: Wed Jan 12, 2005 11:24 pm    Post subject: be weary of shared libs before the bootstrap... Reply with quote

may I suggest using static, else you might get goosed when a shared lib is sacked/updated... scripts/bootstrap.sh will recompile gcc anyway...
Code:
USE="static" emerge --nodeps gcc
cd /usr/portage
scripts/bootstrap.sh
emerge system
...
This problemo is already in bugzilla https://bugs.gentoo.org/show_bug.cgi?id=77718
Back to top
View user's profile Send private message
dextorb
n00b
n00b


Joined: 13 Jan 2005
Posts: 2

PostPosted: Thu Jan 13, 2005 6:22 pm    Post subject: same problem Reply with quote

I had the same problem, but I am wondering, because I installed just one week ago with the 2004.3 without any problem, but no I get always the same result as you.
Back to top
View user's profile Send private message
toxicnaan
n00b
n00b


Joined: 13 Nov 2004
Posts: 68

PostPosted: Thu Jan 13, 2005 6:45 pm    Post subject: Reply with quote

I'm getting the same problem installing from stage 1.

g++ missing when compiling berkley DB?
Back to top
View user's profile Send private message
n3mo
l33t
l33t


Joined: 28 Mar 2004
Posts: 657
Location: In a Cruel World

PostPosted: Thu Jan 13, 2005 6:57 pm    Post subject: Reply with quote

According with Bugzilla it seem that the workaround is:
Quote:
USE="static" emerge --nodeps gcc
scripts/bootstrap.sh

_________________
Google, really.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum