Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.10-rc1 & ati-drivers-3.14.1 -> no DRM?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Master One
l33t
l33t


Joined: 25 Aug 2003
Posts: 754
Location: Austria

PostPosted: Tue Oct 26, 2004 5:06 pm    Post subject: 2.6.10-rc1 & ati-drivers-3.14.1 -> no DRM? Reply with quote

Just upgraded to 2.6.10-rc1, because of the updated dvb-kernel, but now it seems there is something wrong with the ati-driver again:
Code:
linux # emerge ati-drivers
Calculating dependencies  ...done!
>>> emerge (1 of 1) media-video/ati-drivers-3.14.1 to /
>>> md5 src_uri ;-) fglrx-4.3.0-3.14.1.i386.rpm
 * X11 implementation is xorg-x11.
>>> Unpacking source...
>>> Unpacking fglrx-4.3.0-3.14.1.i386.rpm
>>> Source unpacked.
 * Building the DRM module...
make: Entering directory `/usr/src/linux-2.6.10-rc1'
  CC [M]  /var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agp3.o
  CC [M]  /var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/nvidia-agp.o
  CC [M]  /var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.o
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c: In Funktion »agp_generic_agp_v2_enable«:
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c:721: Warnung: implicit declaration of function `pci_find_class'
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c:722: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne Typkonvertierung
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c:843: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne Typkonvertierung
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c: In Funktion »serverworks_agp_enable«:
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c:5072: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne Typkonvertierung
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c:5170: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne Typkonvertierung
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c: In Funktion »agp_find_supported_device«:
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/agpgart_be.c:6421: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne Typkonvertierung
  CC [M]  /var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/i7505-agp.o
  CC [M]  /var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.o
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c: In Funktion »firegl_stub_putminor«:
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:516: Warnung: `inter_module_put' is deprecated (declared at include/linux/module.h:582)
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:518: Warnung: `inter_module_unregister' is deprecated (declared at include/linux/module.h:578)
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c: In Funktion »firegl_stub_register«:
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:538: Warnung: `inter_module_register' is deprecated (declared at include/linux/module.h:577)
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:569: Warnung: `inter_module_put' is deprecated (declared at include/linux/module.h:582)
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c: Auf höchster Ebene:
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:2519: Warnung: Initialisierung von inkompatiblem Zeigertyp
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c: In Funktion »__ke_vm_map«:
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:2580: Warnung: `remap_page_range' is deprecated (declared at include/linux/mm.h:767)
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:2647: Warnung: `remap_page_range' is deprecated (declared at include/linux/mm.h:767)
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:2684: Warnung: `remap_page_range' is deprecated (declared at include/linux/mm.h:767)
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c: In Funktion »__ke_agp_uninit«:
/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/firegl_public.c:3005: Warnung: `inter_module_put' is deprecated (declared at include/linux/module.h:582)
  LD [M]  /var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/fglrx.o
  Building modules, stage 2.
  MODPOST
*** Warning: "pci_find_class" [/var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/fglrx.ko] undefined!
  CC      /var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/fglrx.mod.o
  LD [M]  /var/tmp/portage/ati-drivers-3.14.1/work/lib/modules/fglrx/build_mod/fglrx.ko
make: Leaving directory `/usr/src/linux-2.6.10-rc1'
>>> Test phase [not enabled]: media-video/ati-drivers-3.14.1

>>> Install ati-drivers-3.14.1 into /var/tmp/portage/ati-drivers-3.14.1/image/ category media-video
man:
making executable: /usr/X11R6/lib/libfglrx_gamma.so.1.0
>>> Completed installing into /var/tmp/portage/ati-drivers-3.14.1/image/

>>> Merging media-video/ati-drivers-3.14.1 to /
--- /etc/
--- /etc/env.d/
>>> /etc/env.d/09ati
--- /lib/
--- /lib/modules/
--- /lib/modules/2.6.10-rc1/
--- /lib/modules/2.6.10-rc1/video/
>>> /lib/modules/2.6.10-rc1/video/fglrx.ko
--- /opt/
--- /opt/ati/
--- /opt/ati/bin/
>>> /opt/ati/bin/fglrxinfo
>>> /opt/ati/bin/fglrx_xgamma
>>> /opt/ati/bin/fglrxconfig
--- /usr/
--- /usr/lib/
--- /usr/lib/opengl/
--- /usr/lib/opengl/ati/
>>> /usr/lib/opengl/ati/lib/
>>> /usr/lib/opengl/ati/lib/libGL.so.1.2
>>> /usr/lib/opengl/ati/lib/libMesaGL.so -> libGL.so.1.2
>>> /usr/lib/opengl/ati/lib/libGL.la -> ../../xorg-x11/lib/libGL.la
>>> /usr/lib/opengl/ati/lib/libGL.so -> libGL.so.1.2
>>> /usr/lib/opengl/ati/extensions -> ../xorg-x11/extensions
>>> /usr/lib/opengl/ati/include -> ../xorg-x11/include
--- /usr/X11R6/
--- /usr/X11R6/bin/
--- /usr/X11R6/lib/
--- /usr/X11R6/lib/modules/
--- /usr/X11R6/lib/modules/dri/
>>> /usr/X11R6/lib/modules/dri/fglrx_dri.so
--- /usr/X11R6/lib/modules/linux/
>>> /usr/X11R6/lib/modules/linux/libfglrxdrm.a
--- /usr/X11R6/lib/modules/drivers/
>>> /usr/X11R6/lib/modules/drivers/fglrx_drv.o
>>> /usr/X11R6/lib/libfglrx_gamma.so.1.0
>>> /usr/X11R6/lib/libfglrx_gamma.a
--- /usr/X11R6/include/
--- /usr/X11R6/include/X11/
--- /usr/X11R6/include/X11/extensions/
>>> /usr/X11R6/include/X11/extensions/fglrx_gamma.h
--- /usr/include/
--- /usr/include/GL/
>>> /usr/include/GL/glxATI.h
>>> /usr/lib/opengl/ati/lib/libGL.so.1 -> libGL.so.1.2
>>> Safely unmerging already-installed instance...
--- !mtime obj /usr/lib/opengl/ati/lib/libGL.so.1.2
--- !mtime obj /usr/include/GL/glxATI.h
--- !mtime obj /usr/X11R6/lib/modules/linux/libfglrxdrm.a
--- !mtime obj /usr/X11R6/lib/modules/drivers/fglrx_drv.o
--- !mtime obj /usr/X11R6/lib/modules/dri/fglrx_dri.so
--- !mtime obj /usr/X11R6/lib/libfglrx_gamma.so.1.0
--- !mtime obj /usr/X11R6/lib/libfglrx_gamma.a
--- !mtime obj /usr/X11R6/include/X11/extensions/fglrx_gamma.h
--- !mtime obj /opt/ati/bin/fglrxinfo
--- !mtime obj /opt/ati/bin/fglrxconfig
--- !mtime obj /opt/ati/bin/fglrx_xgamma
--- cfgpro obj /lib/modules/2.6.10-rc1/video/fglrx.ko
--- cfgpro dir /lib/modules/2.6.10-rc1/video
--- cfgpro dir /lib/modules/2.6.10-rc1
--- !mtime obj /etc/env.d/09ati
--- cfgpro dir /etc/env.d
--- !empty dir /usr/lib/opengl/ati/lib
--- !empty dir /usr/lib/opengl/ati
--- !empty dir /usr/lib/opengl
--- !empty dir /usr/lib
--- !empty dir /usr/include/GL
--- !empty dir /usr/include
--- !empty dir /usr/X11R6/lib/modules/linux
--- !empty dir /usr/X11R6/lib/modules/drivers
--- !empty dir /usr/X11R6/lib/modules/dri
--- !empty dir /usr/X11R6/lib/modules
--- !empty dir /usr/X11R6/lib
--- !empty dir /usr/X11R6/include/X11/extensions
--- !empty dir /usr/X11R6/include/X11
--- !empty dir /usr/X11R6/include
--- !empty dir /usr/X11R6/bin
--- !empty dir /usr/X11R6
--- !empty dir /usr
--- !empty dir /opt/ati/bin
--- !empty dir /opt/ati
--- !empty dir /opt
--- !empty dir /lib/modules
--- !empty dir /lib
--- !empty dir /etc
--- !targe sym /usr/lib/opengl/ati/lib/libMesaGL.so
--- !targe sym /usr/lib/opengl/ati/lib/libGL.so.1
--- !targe sym /usr/lib/opengl/ati/lib/libGL.so
--- !targe sym /usr/lib/opengl/ati/lib/libGL.la
--- !targe sym /usr/lib/opengl/ati/include
--- !targe sym /usr/lib/opengl/ati/extensions
>>> original instance of package unmerged safely.

 * To switch to ATI OpenGL, run "opengl-update ati"
 * To change your XF86Config you can use the bundled "fglrxconfig"

 * ***
 * If you are experiencing problems with memory allocation try to add
 * this line to in your X11 configuration file:
 *              Option "KernelModuleParm"  "agplock=0"
 * That should solve the hangups you could have with Neverwinter Nights
 * ***
>>> Regenerating /etc/ld.so.cache...
 * Caching service dependencies...
>>> media-video/ati-drivers-3.14.1 merged.

>>> clean: No packages selected for removal.

>>> Auto-cleaning packages ...

>>> No outdated packages were found on your system.


 * GNU info directory index is up-to-date.

I am using xorg-x11-6.7.0-r2, because of the known problem with the ati-drivers on 6.8.x. Here is the relavant part of my Xorg.0.log:
Code:
(II) fglrx(0): doing DRIScreenInit
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
[drm] failed to load kernel module "fglrx"
(II) fglrx(0): [drm] drmOpen failed
(EE) fglrx(0): DRIScreenInit failed!
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *

Any ideas?
_________________
Las torturas mentales de la CIA
Back to top
View user's profile Send private message
dblaci
n00b
n00b


Joined: 05 Oct 2004
Posts: 29

PostPosted: Tue Oct 26, 2004 5:43 pm    Post subject: pci_get_class Reply with quote

Compiles fine, but try modprobe fglrx...
(error message in the dmesg)
In fact this is not a new problem, there's the same with the mm-sources series.
There is solution, you have to apply a patch on the ati-drivers, the simplest way is to do is using portage overlay, and modifying the ebuild.
At me:
copy
Quote:
/usr/local/portage/media-video/ati-drivers/ati-drivers-3.14.1-r2.ebuild

from the *r1.ebuild from the main portage tree, set the portage overlay dir in the /etc/make.conf :
Quote:
PORTDIR_OVERLAY=/usr/local/portage

edit the ebuild and insert a line
Quote:

(...)
src_unpack() {
local OLDBIN="/usr/X11R6/bin"

cd ${WORKDIR}
rpm_src_unpack

cd ${WORKDIR}/lib/modules/fglrx/build_mod
#THIS IS THE NEW LINE
epatch ${FILESDIR}/fglrx-3.12.0-pci_find_class.patch


copy the fglrx-3.12.0-pci_find_class.patch to the
Quote:
/usr/local/portage/media-video/ati-drivers/files

then
Quote:
ebuild /usr/local/portage/media-video/ati-drivers/ati-drivers-3.14.1-r2.ebuild digest

and
Quote:
emerge ati-drivers


I think i didn't miss anything :roll: what i've done, it works for me 2.6.10-rc1 is the first stable and good for everything kernel since 2.6.7. (cd recording, vmware etc.)

p.s. I found that patch somewhere, a forum or sg, sorry i can't remember. :oops:
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Tue Oct 26, 2004 6:18 pm    Post subject: Reply with quote

When this happens, it's not because the driver is broken, it's because you're running a very new kernel that includes some new patches that change stuff the driver relies on. The method dblaci posted is the usual way to fix things, assuming you can find or create a patch for the problem.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
Master One
l33t
l33t


Joined: 25 Aug 2003
Posts: 754
Location: Austria

PostPosted: Tue Oct 26, 2004 11:34 pm    Post subject: Reply with quote

Thank's, it's always good to know, that where's a problem, there's a patch :wink:

But in the meantime I had to go back to development-sources-2.6.9, because with 2.6.10-rc1 I had that strange random hardlock problem (too), and with 2.6.9 the unpatched ati-drivers work just fine.
_________________
Las torturas mentales de la CIA
Back to top
View user's profile Send private message
Admiral LSD
Guru
Guru


Joined: 27 Jun 2003
Posts: 522
Location: Northam, W.A., Australia

PostPosted: Wed Oct 27, 2004 8:02 am    Post subject: Reply with quote

I downloaded the patch, hacked an ebuild together, verified that it solved the problem then rebooted back to Windows. I'll give it a closer look when I can be bothered booting back into Linux.
_________________
Wasurenaide...
...watashi ga iru koto o.
Itsudatte soba ni iru yo.

Registered Linux user #319839
Back to top
View user's profile Send private message
Zyne
Guru
Guru


Joined: 08 Jun 2004
Posts: 334

PostPosted: Wed Dec 22, 2004 9:44 am    Post subject: Re: pci_get_class Reply with quote

dblaci wrote:

There is solution, you have to apply a patch on the ati-drivers, the simplest way is to do is using portage overlay, and modifying the ebuild.



thanks for this m8!!!!
I just compiled the newest rc3 kernel, and I was having the same problem...
your solution worked like a charm!!!!
Back to top
View user's profile Send private message
Luxus
Tux's lil' helper
Tux's lil' helper


Joined: 21 Nov 2002
Posts: 98
Location: Germany / Frankfurt

PostPosted: Tue Dec 28, 2004 2:10 am    Post subject: Reply with quote

is this needed in 2.6.10 final too?
Back to top
View user's profile Send private message
Zyne
Guru
Guru


Joined: 08 Jun 2004
Posts: 334

PostPosted: Tue Dec 28, 2004 9:01 am    Post subject: Reply with quote

Luxus wrote:
is this needed in 2.6.10 final too?

yes... I'm running 2.6.10 here, and the ati-drivers don't work if you don't apply the patch :(
Back to top
View user's profile Send private message
Luxus
Tux's lil' helper
Tux's lil' helper


Joined: 21 Nov 2002
Posts: 98
Location: Germany / Frankfurt

PostPosted: Tue Dec 28, 2004 7:15 pm    Post subject: Reply with quote

yep right... very strange that no dev add this patch to the ebuild
Back to top
View user's profile Send private message
MaxPolun
Tux's lil' helper
Tux's lil' helper


Joined: 28 Dec 2004
Posts: 111

PostPosted: Wed Dec 29, 2004 3:37 am    Post subject: Reply with quote

Well this seems to help everyone but me. Oh well. I tried the patch and fglrx still won't load. By the way if anyone wants to help I'm running kernel 2.6.9-gentoo-r13 and according to dmesg:
Code:

[fglrx] Maximum main memory to use for locked dma buffers: 679 MBytes.
[fglrx:firegl_init] *ERROR* Device not found!
[drm:radeon_cp_init] *ERROR* radeon_cp_init called without lock held
[drm:radeon_unlock] *ERROR* Process 13006 using kernel context 0
fglrx: Unknown symbol pci_get_class

thanks
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Wed Dec 29, 2004 2:03 pm    Post subject: Reply with quote

Check you don't have "Direct Rendering Manager" enabled under "Device drivers -> Character devices". It looks like it might be, and it can stop the ATI driver from working sometimes.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
MaxPolun
Tux's lil' helper
Tux's lil' helper


Joined: 28 Dec 2004
Posts: 111

PostPosted: Wed Dec 29, 2004 4:29 pm    Post subject: Reply with quote

Ah! I did have it enabled. time to recompile again. thanks.
Back to top
View user's profile Send private message
TheNull
n00b
n00b


Joined: 10 Aug 2004
Posts: 37

PostPosted: Thu Dec 30, 2004 1:07 pm    Post subject: Reply with quote

The patch is included in 3.14.6 now =)
_________________
Need programming help?
Visit CODEnet.
Back to top
View user's profile Send private message
DaDead
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2004
Posts: 75

PostPosted: Tue Jan 11, 2005 12:58 am    Post subject: Reply with quote

no compiley on nitro4y
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Jan 11, 2005 3:57 pm    Post subject: Reply with quote

DaDead, you got a pm reply, i sent you the nitro4 ati fixx....
Back to top
View user's profile Send private message
Teh Penguin D00d
n00b
n00b


Joined: 31 Dec 2004
Posts: 35
Location: Tampa, FL

PostPosted: Wed Jan 12, 2005 2:31 am    Post subject: Reply with quote

Tiger683 wrote:
DaDead, you got a pm reply, i sent you the nitro4 ati fixx....


Share the wealth...

...I've never had direct rendering with my ATI card....
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Wed Jan 12, 2005 6:14 pm    Post subject: Reply with quote

Anyone knows a webspace to put it?

I will have a patch as soon as I tested the best remap_page_range alternative....

NOTE:
the patch includes fixes against 2.6.10-mm2, might break for non mm sources....
I run however doom3 successfully on nitro4-sources with mm included,
non-gentoo distro(both LFS and suse 9.1)

EDIT: oh, and its against 3.14.6, not 3.14.1....
It would be nice if DaDead sent some feedback,
hmm, maybe now after the fix his card is Da DEAD *LOOOOOL*
Back to top
View user's profile Send private message
Teh Penguin D00d
n00b
n00b


Joined: 31 Dec 2004
Posts: 35
Location: Tampa, FL

PostPosted: Wed Jan 12, 2005 10:44 pm    Post subject: ... Reply with quote

I gave up on the binary drivers. In kernel DRM worked for me. Now I get to game. :-)

I'll host the patch if you wish.

PM Me for E-mail address, and I'll host it at insanetech.org. ;-)
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Thu Jan 13, 2005 12:32 pm    Post subject: Reply with quote

Nevermind that, I'll be keeping up with the 2.6.11 for this week
and monday it's.....you know what I mean....8) :twisted: 8)
Lets see if the 2.6.11 brings some surprises for the ati 8.8 version...
Back to top
View user's profile Send private message
tito4981
n00b
n00b


Joined: 12 Jun 2002
Posts: 50
Location: Paris - France

PostPosted: Tue Jan 18, 2005 6:05 pm    Post subject: LibGL pbs .. Reply with quote

Hi ,
I'm trying to get the new ati-drivers work on my gentoo amd64 machine with xorg. I've successfuly emerged the new packge.

my xorg.conf seems ok, since I get no err log and opengl-update ati went fine.

When launching Xorg server, the fglrx module loads correctly into the kernel, but then when I try one of the fgl* program I got the following :

Code:

$fgl_glxgears
fgl_glxgears: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory


When trying to find this file I got the following :
Code:
 
$locate libGL.so.1

/lib/libGL.so.1
/lib/x86_64/libGL.so.1
/usr/lib/libGL.so.1
/usr/lib/libGL.so.1.2
/usr/lib/opengl/ati/lib/libGL.so.1
/usr/lib/opengl/ati/lib/libGL.so.1.2
/usr/lib/opengl/xorg-x11/lib64/libGL.so.1
/usr/lib/opengl/xorg-x11/lib64/libGL.so.1.2
/usr/lib/x86_64/libGL.so.1
/usr/X11R6/lib/libGL.so.1.2
/usr/local/src/usr/X11R6/lib/libGL.so.1.2
/usr/local/src/usr/X11R6/lib64/libGL.so.1.2
/emul/linux/x86/usr/lib/libGL.so.1
/emul/linux/x86/usr/lib/opengl/xorg-x11/lib/libGL.so.1
/emul/linux/x86/usr/lib/opengl/xorg-x11/lib/libGL.so.1.2


I've spotted with strace that fgl* programs also look after libGL into tls directory
eg:
Code:
open("/usr/lib/tls/x86_64/libGL.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)

, but I don't think I need them .. does anyone have an idea ? :roll:
thx
Back to top
View user's profile Send private message
Henry78
Apprentice
Apprentice


Joined: 12 Jul 2004
Posts: 186
Location: Austria

PostPosted: Tue Jan 25, 2005 7:58 pm    Post subject: 2.6.11 Reply with quote

Tiger683 wrote:
Lets see if the 2.6.11 brings some surprises for the ati 8.8 version...


you might be interested in the post of bilko500 (Jan 18, 2005, 02:21 PM) at http://www.rage3d.com/board/showthread.php?mode=hybrid&t=33798874&highlight=2.6.10
Back to top
View user's profile Send private message
llama
n00b
n00b


Joined: 16 Jan 2005
Posts: 11

PostPosted: Wed Jan 26, 2005 7:27 am    Post subject: Reply with quote

So can I ask a stupid question?

How do I apply the patch posted on that site? I'm sorry, I know it's dumb...

Other than getting the ATI drivers to work here, I'm golden with my install of Gentoo. Love it!

So, if anyone at all could help me out with this last problem I'll be done!

I'm running kernel 2.6.10 and xorg-6.8.0-r1.

Thanks guys. I can post the patch I copied as well if anyone wants it.
Back to top
View user's profile Send private message
Henry78
Apprentice
Apprentice


Joined: 12 Jul 2004
Posts: 186
Location: Austria

PostPosted: Wed Jan 26, 2005 9:10 am    Post subject: Reply with quote

llama wrote:

I'm running kernel 2.6.10 and xorg-6.8.0-r1.


Hullo!
.
You shouldn't need a patch, cause the patch for the 2.6.10 is already in protage (ati-drivers-8.8.25-r1), and the patch is located here:
Code:
/usr/portage/media-video/ati-drivers/files/8.08-kernel-2.6.10.patch


what i posted was for the 2.6.11


Last edited by Henry78 on Wed Jan 26, 2005 5:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
llama
n00b
n00b


Joined: 16 Jan 2005
Posts: 11

PostPosted: Wed Jan 26, 2005 5:07 pm    Post subject: Reply with quote

Oooohhhhh....Thank you very much!

Appreciated.

llama
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum