Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Starcraft + wine 20040615: no battle.net
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Cheesepie
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 154

PostPosted: Sun Oct 10, 2004 10:02 pm    Post subject: Starcraft + wine 20040615: no battle.net Reply with quote

I can run starcraft just fine through wine, but when I try to connect to battle.net, I get the following error:

"Battle.net was unable to properly identify your application version. Please reinstall the application from the cd and then reconnect to battle.net".

If I run ethereal while doing this, a bunch of data goes back and forth between my machine and battle.net, but none of it is readable.

On another, probably completely unrelated note: when I do run starcraft, I get 100% cpuload. My machine is a 1.7ghz with 512 RAM.

I've got a dd'ed image of my starcraft cd mounted, and Ive got that mountpoint set up as a cd-rom device in wine, though I dont think that matters.


Last edited by Cheesepie on Tue Nov 10, 2015 8:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
MG-Cloud
Apprentice
Apprentice


Joined: 28 Oct 2003
Posts: 200

PostPosted: Tue Oct 12, 2004 8:14 am    Post subject: Reply with quote

How are you running starcraft?

I had the same errors until i cd'ed into ~/.wine/fake_windows/Program\ Files/Starcraft, and typed wine StarCraft.exe from there.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum