Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge sync gives "need-gnustep-gui"
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
tewlz
n00b
n00b


Joined: 28 Sep 2002
Posts: 53

PostPosted: Fri Sep 24, 2004 2:47 am    Post subject: emerge sync gives "need-gnustep-gui" Reply with quote

Quote:
wrote 845 bytes read 2229352 bytes 178415.76 bytes/sec
total size is 76336083 speedup is 34.23

>>> Updating Portage cache... |/usr/sbin/ebuild.sh: line 7: need-gnustep-gui: command not found
|/usr/sbin/ebuild.sh: line 7: need-gnustep-gui: command not found
...done!


What is this gnustep-gui I apparently need?
Back to top
View user's profile Send private message
labrador
Guru
Guru


Joined: 04 Oct 2003
Posts: 316

PostPosted: Fri Sep 24, 2004 3:23 am    Post subject: Same problem here Reply with quote

Code:
wrote 405 bytes  read 2261238 bytes  21236.08 bytes/sec
total size is 76339014  speedup is 33.75

>>> Updating Portage cache... |/usr/sbin/ebuild.sh: line 7: need-gnustep-gui: command not found
|/usr/sbin/ebuild.sh: line 7: need-gnustep-gui: command not found
  ...done!

I see the same error, on emerge sync with two different
rsync sources. There is no reference to need-gnustep
in ebuild.sh

This just happened tonight for the first time on
two of my systems.

greping for the application/script, I see it
referenced in a few ebuilds under /usr/portage:

app-gnustep/easydiff/easydiff-0.1.ebuild:need-gnustep-gui
app-gnustep/talksoup/talksoup-0.81.ebuild:need-gnustep-gui
eclass/gnustep-old.eclass:need-gnustep-gui() {
gnustep-apps/easydiff/easydiff-0.1.ebuild:need-gnustep-gui
gnustep-apps/talksoup/talksoup-0.81.ebuild:need-gnustep-gui

{... possibly more - grep not finished yet}
Back to top
View user's profile Send private message
tewlz
n00b
n00b


Joined: 28 Sep 2002
Posts: 53

PostPosted: Fri Sep 24, 2004 3:38 am    Post subject: Reply with quote

Judging by the other posts tonight, I think it's safe to say that portage is under the weather?
Back to top
View user's profile Send private message
tharasix
n00b
n00b


Joined: 06 Aug 2003
Posts: 46
Location: Minneapolis, MN

PostPosted: Fri Sep 24, 2004 5:40 am    Post subject: Reply with quote

I'll just put a "ditto" in here. emerge sync does seem to complete, but I've gotten this problem on two different boxes.

Chad Martin
Back to top
View user's profile Send private message
Isaiah
Guru
Guru


Joined: 25 Feb 2003
Posts: 359

PostPosted: Fri Sep 24, 2004 5:53 am    Post subject: Reply with quote

tharasix wrote:
I'll just put a "ditto" in here.

Ditto dat ditto - same thing here :roll:
Back to top
View user's profile Send private message
wazow
Apprentice
Apprentice


Joined: 08 Jan 2004
Posts: 182
Location: Rødovre, Denmark

PostPosted: Fri Sep 24, 2004 6:48 am    Post subject: Reply with quote

same here on x86 (stable)...

Emerge sync terminated, but I am worried about the state of my portage cache right now. Perhaps it is better if others do not sync, until some dev comments on the issue.
Back to top
View user's profile Send private message
vulcan_
n00b
n00b


Joined: 06 May 2003
Posts: 61
Location: Gent, Belgium

PostPosted: Fri Sep 24, 2004 8:09 am    Post subject: man am i some pissed < 4 days of problems Reply with quote

i finally work thru the bugs in the apache, tcl and PHP ebuilds - finished all that last night, and get the whole thing to build .. so i figure to check if anything changed in the last 4 days and do emerge sync. surprize surprize .. NOT!

someone(s) submitted a whole bunch of broken ebuilds in the last couple of days and now emerge -u world wants to download another gigabyte of files - but it cant because whoever was playing with the PHP ebuild has totoally hosed it up and it spits out errors about the php-4.3.2 ebuild that i thought was completely removed from my system.

that was last night .. this morning, hoping that some nice person in a North American timezone had fixed the problem i did emerge sync again, and now i have the problem reported in this thread and portage is totally hosed up by another bug.

man oh man this stuff pisses me off. i see lots of testimonials from people about how good the gentoo release is, and how responsive the forums are .. i say it would be a damn site better if these forums were dead because noone had problems with installing. In the last 2 years i have never had a clean emerge -u .. always bugs in the ebuilds to solve.

is anyone testing on a range of platforms before inflicting bad product on us .. or are we signing up to be alpha testers by downloading the LiveCD?

:x << not a happy camper today!!
_________________
vulcan was a Roman myth - god of smiths
Back to top
View user's profile Send private message
nyda
Apprentice
Apprentice


Joined: 12 Aug 2004
Posts: 183

PostPosted: Fri Sep 24, 2004 8:29 am    Post subject: Reply with quote

I had quite a lot of fine "emerge -u"'s. I'd even say the average ebuild quality has gotten a lot better since last year.

Quote:
or are we signing up to be alpha testers by downloading the LiveCD?


I guess you've never been an alpha tester then :-).
Back to top
View user's profile Send private message
vulcan_
n00b
n00b


Joined: 06 May 2003
Posts: 61
Location: Gent, Belgium

PostPosted: Fri Sep 24, 2004 8:45 am    Post subject: alpha - schmalpha :) Reply with quote

well, i should have griped " .. have we signed up to be _involuntary_ alpha testers .." to better convey my ironic intention ..

but i am feeling much better now that i have vented :)
_________________
vulcan was a Roman myth - god of smiths
Back to top
View user's profile Send private message
labrador
Guru
Guru


Joined: 04 Oct 2003
Posts: 316

PostPosted: Fri Sep 24, 2004 10:01 am    Post subject: redundant portage package groups Reply with quote

One problem is that the package groups gnustep-apps and
app-gnustep appear to be redundant. Looking at the modification
dates I might guess that gnustep-apps is the later one
and the other one should be removed.

It seems that the "line 7" reference must be to one of these ebuilds:
Code:

app-gnustep/easydiff/easydiff-0.1.ebuild:need-gnustep-gui
app-gnustep/talksoup/talksoup-0.81.ebuild:need-gnustep-gui
eclass/gnustep-old.eclass:need-gnustep-gui() {
gnustep-apps/easydiff/easydiff-0.1.ebuild:need-gnustep-gui
gnustep-apps/talksoup/talksoup-0.81.ebuild:need-gnustep-gui

which have this on line 7 of the ebuild:
Code:
need-gnustep-gui

My Sun Sparc gentoo box, which has not emerge sync'ed in
the last 24 hours has no package group called app-gnustep.
But being a different platform, I don't know if that is significant.
Back to top
View user's profile Send private message
gwlinden
n00b
n00b


Joined: 06 Jan 2003
Posts: 70
Location: Utrecht, The Netherlands

PostPosted: Fri Sep 24, 2004 10:47 am    Post subject: Reply with quote

I'm having the same problem, and my package cache seems corrupted. Emacs now reports as not installed (and I'm using it daily...), and I get Package in world file is not installed errors when running emerge.

Anybody know what the best course of action is?
_________________
Gwendolyn
Back to top
View user's profile Send private message
steap
n00b
n00b


Joined: 02 Oct 2003
Posts: 6
Location: near Frankfurt/Main - Germany

PostPosted: Fri Sep 24, 2004 11:02 am    Post subject: Reply with quote

gwlinden wrote:
I'm having the same problem, and my package cache seems corrupted. Emacs now reports as not installed.


I'm having the same problem...
Back to top
View user's profile Send private message
_FD_
n00b
n00b


Joined: 06 Aug 2004
Posts: 37

PostPosted: Fri Sep 24, 2004 11:03 am    Post subject: Reply with quote

I would suggest putting easydiff and talksoup to the package filter, and than emerge sync again.
Back to top
View user's profile Send private message
wazow
Apprentice
Apprentice


Joined: 08 Jan 2004
Posts: 182
Location: Rødovre, Denmark

PostPosted: Fri Sep 24, 2004 11:12 am    Post subject: Reply with quote

gwlinden wrote:
I'm having the same problem, and my package cache seems corrupted. Emacs now reports as not installed (and I'm using it daily...), and I get Package in world file is not installed errors when running emerge.


I suspect that the emacs problem is unrelated (but just suspect). On my machine the emacs problem appeared a couple of days ago, may be yesterday. Definitely before I did emerge sync this morning (though there is a slight little chance that emerge sync had problem before, and I just missed the message).

In any case I suggest you drop a comment in the thread on emacs-21.3-r3, so that it gets more attention. This way we at least know that it is not specific to some single machine (you are the third person I hear about).

Finally there was this post on gentoo user mailing list today (thread "portage problems"):

Quote:
Another emerge sync should fix it. I don't know the details, but the problem was noted and fixed a couple of hours ago; something about a deleted eclass function.


I tried and it did not help, but perhaps mirrors were not up-to-date yet. The rsync finished with the same error message about gnustep. Can anybody else try and report if it helps?

Andrzej
Back to top
View user's profile Send private message
Anarconda
n00b
n00b


Joined: 03 Mar 2003
Posts: 54

PostPosted: Fri Sep 24, 2004 11:45 am    Post subject: Reply with quote

I still have the problem.
Back to top
View user's profile Send private message
fafhrd
Retired Dev
Retired Dev


Joined: 14 May 2002
Posts: 431
Location: Hudson, MA

PostPosted: Fri Sep 24, 2004 1:43 pm    Post subject: well Reply with quote

I'm taking care of the new GNUstep ebuilds; to make a long story short, the old ones where very antiquated and such. In July or so, I used epkgmove to move the GNUstep ebuilds to new categories in the tree; I'm not sure if it was a bug or something, but app-gnustep category did not get removed.

To fix this:
Code:
# su -
# rm -Rf /usr/portage/app-gnustep
# emerege --sync               <-- (or rsync, whatever works for you)


... after doing this, you should notice the app-gnustep category has not reappeared.

Why an rsync didn't remove the category, I do not know.
_________________
jñanam bandha
Back to top
View user's profile Send private message
labrador
Guru
Guru


Joined: 04 Oct 2003
Posts: 316

PostPosted: Fri Sep 24, 2004 1:55 pm    Post subject: Tried that tip - new errors "Failed cache update" Reply with quote

I tried your tip on blowing away the old package group from /usr/portage
and then doing "emerge sync" again.

I get these errors:

Code:
Total bytes written: 5065
Total bytes read: 2388353

wrote 5065 bytes  read 2388353 bytes  41624.66 bytes/sec
total size is 76132401  speedup is 31.81

>>> Updating Portage cache... |
Failed cache update: app-dicts/babytrans-0.9.2-r2
-
Failed cache update: app-dicts/prime-dict-0.8.3
\
Failed cache update: app-dicts/prime-dict-0.8.4
-
Failed cache update: app-editors/kxmleditor-1.1.3
\
Failed cache update: app-i18n/prime-0.8.3.1
|
Failed cache update: app-i18n/prime-0.8.4
/
Failed cache update: app-i18n/prime-0.9.1
-
Failed cache update: app-i18n/prime-0.9.2

etc. { many more like it }
Back to top
View user's profile Send private message
wazow
Apprentice
Apprentice


Joined: 08 Jan 2004
Posts: 182
Location: Rødovre, Denmark

PostPosted: Fri Sep 24, 2004 2:02 pm    Post subject: Re: well Reply with quote

fafhrd wrote:
I'm taking care of the new GNUstep ebuilds; to make a long story short, the old ones where very antiquated and such. In July or so, I used epkgmove to move the GNUstep ebuilds to new categories in the tree; I'm not sure if it was a bug or something, but app-gnustep category did not get removed.

To fix this:
Code:
# su -
# rm -Rf /usr/portage/app-gnustep
# emerege --sync               <-- (or rsync, whatever works for you)


... after doing this, you should notice the app-gnustep category has not reappeared.


This seems to have worked for me. Thanks a lot! Would be good to figure out what the general problem was, though. So that it will not happen again.

Andrzej
Back to top
View user's profile Send private message
wazow
Apprentice
Apprentice


Joined: 08 Jan 2004
Posts: 182
Location: Rødovre, Denmark

PostPosted: Fri Sep 24, 2004 2:04 pm    Post subject: Re: Tried that tip - new errors "Failed cache update&qu Reply with quote

labrador wrote:
I tried your tip on blowing away the old package group from /usr/portage
and then doing "emerge sync" again.

I get these errors: [CUT]



Have not you mistakenly removed more than just app-gnustep? (no that I am sure that this would hurt. Probably depending on what you have removed.).

Andrzej
Back to top
View user's profile Send private message
labrador
Guru
Guru


Joined: 04 Oct 2003
Posts: 316

PostPosted: Fri Sep 24, 2004 2:13 pm    Post subject: At the top of the hour, it works better Reply with quote

I suspect that something was refreshed on the rsync server
at around the top of the hour (which is the window in which this
is supposed to happen). I ran emerge sync again and it
performed without an error.
Back to top
View user's profile Send private message
throck
n00b
n00b


Joined: 10 Apr 2004
Posts: 39

PostPosted: Fri Sep 24, 2004 2:31 pm    Post subject: Reply with quote

I am still unable to emerge anything. The last time I ran "emerge sync" I also got the errors of "Failed cache update" for a whole ton of packages. When I attempt to "emerge -u portage" I get a bunch of errors about "Error in <packagename> Check for syntax error or corruption in the ebuild."

If I attempt an emerge sync now, I get a message that I am up to date and do not need to sync. So I can't sync to get the latest info and I can't emerge anything.

<update>
I was able to emerge sync again, but am still getting the "Failed cache update" for all packages.
Back to top
View user's profile Send private message
fafhrd
Retired Dev
Retired Dev


Joined: 14 May 2002
Posts: 431
Location: Hudson, MA

PostPosted: Fri Sep 24, 2004 3:09 pm    Post subject: Reply with quote

throck-


the mirrors will start denying you after the 2nd rsync or so a day -- you really only need to do this once a day at most -- so this may be the cause of your errors.

and just for clarity:
Code:

emerge rsync    <-- portage 2.0.50
emerge --sync   <-- portage 2.0.51_* series

...these are not really "emerge sync" which is a different animal altogether.

Edit: actually, re-reading your post, yeah, the "error failed package check" or whatever, is a classic sign that the mirror is denying you ... chill out for a day withthe rsync's man :-) ... just wait a day, and try an emerge rsync ... if that then fails badly ... well, we'll be here :-)
_________________
jñanam bandha
Back to top
View user's profile Send private message
Anarconda
n00b
n00b


Joined: 03 Mar 2003
Posts: 54

PostPosted: Fri Sep 24, 2004 3:19 pm    Post subject: Reply with quote

Quote:

I'm taking care of the new GNUstep ebuilds; to make a long story short, the old ones where very antiquated and such. In July or so, I used epkgmove to move the GNUstep ebuilds to new categories in the tree; I'm not sure if it was a bug or something, but app-gnustep category did not get removed.

To fix this:
Código:
# su -
# rm -Rf /usr/portage/app-gnustep
# emerege --sync <-- (or rsync, whatever works for you)


... after doing this, you should notice the app-gnustep category has not reappeared.

Why an rsync didn't remove the category, I do not know.


Works for me too. Thanks.
Back to top
View user's profile Send private message
throck
n00b
n00b


Joined: 10 Apr 2004
Posts: 39

PostPosted: Fri Sep 24, 2004 3:26 pm    Post subject: Reply with quote

fafhrd - thanks!

I'll wait until tomorrow and give it a shot again.
Back to top
View user's profile Send private message
cappaberra
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2003
Posts: 77
Location: California, USA

PostPosted: Fri Sep 24, 2004 10:03 pm    Post subject: Reply with quote

thanks fafhrd... worked for me.

-cappaberra
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum