Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2215 and smbmount
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1197

PostPosted: Wed Jun 02, 2004 5:55 pm    Post subject: 2215 and smbmount Reply with quote

Okay...

I thought I had this solved on this thread:
https://forums.gentoo.org/viewtopic.php?t=178179&highlight=smbmount+2215

grooveman wrote:
Hello. I have a samba server setup with 3.0.2a-r1.

It was working just fine, then suddenly, I cannot connect to any of my shares on my server with smbmount. Everytime I try to connect, I get this error:

session setup failed: ERRDOS - 2215

I do something like this: smbmount //myserver/share /mnt/misc -o username=myself,workgroup=myworkgroup

The password prompt comes up, I put it in, it hangs for about 10 seconds, then spits out the above error.

The log file doesn't say much, but here it is:

Code:
2004/05/26 16:38:31, 0] smbd/server.c:main(747)
  smbd version 3.0.2a started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004
[2004/05/26 16:38:31, 0] smbd/server.c:main(781)
  standard input is not a socket, assuming -D option
[2004/05/26 16:38:49, 0] smbd/connection.c:register_message_flags(220)
  register_message_flags: tdb_fetch failed
[2004/05/26 16:39:19, 0] smbd/connection.c:register_message_flags(220)
  register_message_flags: tdb_fetch failed


I am totally stumped... My windows machines can still hit these shares, btw. But I cannot use smbmount.

I have tested this from several clients, with versions of sbmclient all the way down to 2.0.7.

I have mounted shares from my other servers sucessfully -- it is just when trying to mount shares from this one machine.

Any help would be greatly appreciated.

Thanks!


G



But it is back again. It seems the only way to get rid of this error is to rejoin ADS. I shouldn't have to do that... This is a production machine, I can't have it dropping off the domain periodically.

The weird thing is, it doesn't seem to affect windows users who need to hit the shares or print -- only linux users trying to smbmount.

Can someone please help here?

thanks.

G
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum