Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
opera 7.50_beta 1 + xfs memory leak?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
eNTi
Veteran
Veteran


Joined: 20 Oct 2002
Posts: 1011
Location: Salzburg, Austria

PostPosted: Tue May 04, 2004 7:11 pm    Post subject: opera 7.50_beta 1 + xfs memory leak? Reply with quote

i finnally found one of those mysterious memory leaks, i guess.

i'm running xorg x11 + xfs + opera 7.50_beta1. so far so good, about most things work as expected.

BUT! when i resized my font in opera by pressing "+" my system nearly came to a complete halt:

Code:
 
PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 9711 root      40   0 15924  11m 4476 S 70.9  1.5   0:46.51 xfs               
26285 root      25   0  411m 252m 234m R 21.3 33.4   4:59.87 X                 
26304 nt        22   0 79688 8400  18m R  2.3  1.1   2:13.78 xmms             
28713 nt        23   0  164m  38m 136m R  2.0  5.1   1:03.71 opera             
 8473 nt        22   0 79688 8400  18m S  1.0  1.1   0:01.45 xmms             
26303 nt        21   0 17980 6108  15m S  0.7  0.8   0:33.02 gkrellm2

Code:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
26285 root      22   0 1120m 619m 541m S  3.0 81.8   4:53.31 X                 
26353 nt        22   0 20260 8912  14m S  1.7  1.1   0:23.21 xchat-2   

this is most disturbing. i'll try another version of opera (7.23) and thus check out if it's an opera 7.50_beta1 related problem. if this is the case, i'll make a bug report at the opera homepage. anyone has similar findings?

update: it is not opera it seems. has there been an update to a font related lib recently?
_________________
If you fall off a cliff, you might as well try to fly. After all, you got nothing to lose.

-- John Sheridan - Babylon 5, Season 4


Last edited by eNTi on Tue May 04, 2004 7:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
blue.sca
l33t
l33t


Joined: 28 Aug 2003
Posts: 680
Location: Mainz, Germany

PostPosted: Tue May 04, 2004 7:16 pm    Post subject: Reply with quote

no problem here, using latest opera and xfree4.3... but _no_ xfs.
_________________
geek by nature, linux by choice
i want my avatar back... thank you
:wq
Back to top
View user's profile Send private message
eNTi
Veteran
Veteran


Joined: 20 Oct 2002
Posts: 1011
Location: Salzburg, Austria

PostPosted: Tue May 04, 2004 9:22 pm    Post subject: Reply with quote

i finnally tried and figured, that it is a kernel problem. i've compiled and tried linux-2.6.6-rc3-love3 today. don't know exactly what causes the problem, but it's there :).
_________________
If you fall off a cliff, you might as well try to fly. After all, you got nothing to lose.

-- John Sheridan - Babylon 5, Season 4
Back to top
View user's profile Send private message
far
Guru
Guru


Joined: 10 Mar 2003
Posts: 394
Location: Stockholm, Sweden

PostPosted: Fri May 14, 2004 7:03 pm    Post subject: Reply with quote

You think it is a kernel problem.
I think it is The Fontom of the Opera.
_________________
The Porthole Portage Frontend
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum