Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to merge KDElibs-3.2.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Rounan
n00b
n00b


Joined: 10 Apr 2004
Posts: 20

PostPosted: Sat Apr 10, 2004 7:07 pm    Post subject: Unable to merge KDElibs-3.2.1 Reply with quote

Hey!

In building a fresh gentoo system, I'm unable to merge the latest KDE. It's the first thing I've attempted to merge after "emerge system" and kernel configuration.

It craps out during emerge kdelibs-3.2.1 with the following:
------------------------------------
Many, MANY errors to the effect of:
In function 'jpeg_mem_term':
: multiple definition of 'jpeg_mem_term'
./.libs/libkbzipfilter_dummy.a(jmemnobs.o)(.text+0x55): first defined here

There are dozens of those, all having something to do with jpeg handling.

The final error messages are:
collect2: ld returned 1 exit status
make[2]: *** [kio_ghelp.la] Error 1
make[2]: Leaving directory '/var/tmp/portage/kdelibs-3.2.1/work/kdelibs-3.2.1/kdoctools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/kdelibs-3.2.1/work/kdelibs-3.2.1
make: *** [all] Error 2

!!! ERROR: kde-base/kdelibs-3.2.1 failed.
!!! Function kde_src_compile, Line 128, Exitcode 2
!!! died running emake, kde_src_compile:make
---------------------

Only strange things about my system:
I'm using udev as per the Gentoo udev guide

I'm compiling with distcc - Ran into problems merging the package directly preceding kdelibs (giflib - something to do with image processing, so it's likely connected) with distcc, so I disabled distcc to build that one, and it merged just fine.
Now, kdelibs won't merge with or without distcc, with or without the USE="-java" option, with or without optimizations (I use -O3 -march=pentium4 -pipe -fomit-frame-pointer -fprefetch-loop-arrays, so they're conservative anyway).

I've read the thread on these forums about compiling KDE and followed the directions there about the -java use flag - they also mention a -sandbox flag, but I'm not using sandbox in any case.

The system:
P4 512MB RAM
Kernel 2.6.3-gentoo (emerge gentoo-dev-sources)
GCC 3.3.2

My make.conf, for reference:

CFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer -fprefetch-loop-arrays"
CHOST="i686-pc-linux-gnu"
USE="x86 oss apm alsa arts avi -berkdb cdr crypt cups dvd encode foomaticdb gdbm gif gpm -gtk -gtk2 icq imap imlib jpeg kde -gnome libg++ libwww mad mikmod motif msn mpeg ncurses nls oggvorbis opengl pam pda pdflib png python qt quicktime readline samba sdl slang spell ssl svga tcpd truetype usb X xml2 xmms xv zlib"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j3"
FEATURES="distcc ccache"
-------------------------------------------
(as mentioned, I've also tried without distcc, no change)

Any help would be much appreciated!
--Rounan
Back to top
View user's profile Send private message
Halcy0n
Developer
Developer


Joined: 17 Sep 2003
Posts: 1682
Location: Freehold, NJ

PostPosted: Sun Apr 11, 2004 7:23 pm    Post subject: Reply with quote

There have been previous threads on this error.
Code:
emerge jpeg
and then emerge kdelibs after that.
_________________
Mark Loeser
http://www.halcy0n.com
Back to top
View user's profile Send private message
Rounan
n00b
n00b


Joined: 10 Apr 2004
Posts: 20

PostPosted: Sun Apr 11, 2004 8:28 pm    Post subject: Reply with quote

Thanks, HaLCyOn.

Sorry, I searched on these forums, on linuxquestions, and on good ol' google - came up with nothin'.

Thanks muchly for the help, redundant though you felt it to be. ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum