Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xchat kde character set?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
de4d
Apprentice
Apprentice


Joined: 12 Sep 2002
Posts: 181
Location: fr. i. br. (ger)

PostPosted: Fri Sep 20, 2002 10:03 am    Post subject: xchat kde character set? Reply with quote

im running xchat (in KDE) and have trouble about the used charcter set.
there are some guys who use special language specific characters.
xhat - instead of leaving these just blank (which i wouldnt even care) - displays each line only until to these characters. the rest of the line (where should be text) is not updated i.e. the text that was there before (usually the line above) remains. the only way to read these lines is selecting the text w/ mouse (which makes xhat update the display - the special characters are blanked).
now, what am i doing wrong?
i cant tell if this happens whith caracters other than äüöß, but that should be enuff.

thanx in advance ...
_________________
void main(){fork();main();}
Back to top
View user's profile Send private message
samppa
n00b
n00b


Joined: 15 Jun 2002
Posts: 69
Location: Finland

PostPosted: Fri Sep 20, 2002 8:39 pm    Post subject: same problem Reply with quote

I had the same problem here and started to use irssi since this problem was too irritating.

A line like: abc öä efg hig
would show in xchat as: abc

as you described.
Back to top
View user's profile Send private message
lowgitek
n00b
n00b


Joined: 08 Sep 2002
Posts: 25
Location: Tomar - Portugal

PostPosted: Fri Sep 20, 2002 9:38 pm    Post subject: Re: xchat kde character set? Reply with quote

I fixed my xchat using this charset and font settings:


-b&h-lucidatypewriter-medium-r-normal-*-12-*-*-*-m-*-iso8859-15


But the problem is not the font it self ... You have to disable the option

[] Use a font set


After that it should be working.

I hope this could help ;)
Back to top
View user's profile Send private message
bernd
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2002
Posts: 126
Location: Wilhelmshaven/Germany

PostPosted: Sat Sep 21, 2002 9:28 am    Post subject: Reply with quote

i had the same problem. a easy way to fix these is to edit /etc/profile

write at the end of the file ---> export LANG="de_DE@euro"

where de_DE@euro ist for german users (like me :) )

so use the correct language-set for your language or de_DE@euro if you are german.

After a reboot xchat will work fine.

bernd
Back to top
View user's profile Send private message
lowgitek
n00b
n00b


Joined: 08 Sep 2002
Posts: 25
Location: Tomar - Portugal

PostPosted: Sat Sep 21, 2002 12:50 pm    Post subject: but... Reply with quote

bernd wrote:
i had the same problem. a easy way to fix these is to edit /etc/profile

write at the end of the file ---> export LANG="de_DE@euro"

where de_DE@euro ist for german users (like me :) )

so use the correct language-set for your language or de_DE@euro if you are german.

After a reboot xchat will work fine.

bernd



But he also needs to disable the option

"Use a font set"

Or may still having problems in some fontsets
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum