Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ORBit2-2.10 gnome/base 2.6 fails to compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Jefklak
l33t
l33t


Joined: 26 Oct 2003
Posts: 818
Location: Belgium

PostPosted: Fri Apr 02, 2004 8:49 am    Post subject: ORBit2-2.10 gnome/base 2.6 fails to compile Reply with quote

Code:
gcc -march=pentium4 -O3 -pipe -fomit-frame-pointer -funroll-loops -ffast-math -o .libs/orbit-name-server-2 boot.o  libname-server-2.a ../../../src/orb/.libs/libORBit-2.so ./.libs/libORBitCosNaming-2.so /var/tmp/portage/ORBit2-2.10.0/work/ORBit2-2.10.0/src/orb/.libs/libORBit-2.so /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libpopt.so /usr/lib/libgobject-2.0.so /usr/lib/libgthread-2.0.so -lpthread -lm /usr/lib/libglib-2.0.so
gcc: libname-server-2.a: No such file or directory
make[5]: *** [orbit-name-server-2] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: Leaving directory `/var/tmp/portage/ORBit2-2.10.0/work/ORBit2-2.10.0/src/services/name'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/var/tmp/portage/ORBit2-2.10.0/work/ORBit2-2.10.0/src/services/name'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/ORBit2-2.10.0/work/ORBit2-2.10.0/src/services'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/ORBit2-2.10.0/work/ORBit2-2.10.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/ORBit2-2.10.0/work/ORBit2-2.10.0'
make: *** [all] Error 2

!!! ERROR: gnome-base/ORBit2-2.10.0 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure


Sigh...
abiword and gnumeric also fail to copile, what the hell is this?
libname-server-2.a DOES excist in /usr/lib....
_________________
{Linux User #333296}
Kernel 2.6.9-nitro4!
<< hurrah
Back to top
View user's profile Send private message
Jefklak
l33t
l33t


Joined: 26 Oct 2003
Posts: 818
Location: Belgium

PostPosted: Fri Apr 02, 2004 9:07 am    Post subject: Reply with quote

All right I solved it by ln -s /usr/lib/libname-server-2.a in /var/tmp/portage/work/ORBit2-2.10/src/services/name :)
_________________
{Linux User #333296}
Kernel 2.6.9-nitro4!
<< hurrah
Back to top
View user's profile Send private message
MerlinTheWizard
Apprentice
Apprentice


Joined: 06 Apr 2003
Posts: 270

PostPosted: Sat Apr 17, 2004 9:58 pm    Post subject: Thanks Reply with quote

Exact same error here!

The path in /var/... was a bit different on my comp, but your trick worked. Thanks!

The ebuild probably needs some brushing? :wink:
Back to top
View user's profile Send private message
twt
n00b
n00b


Joined: 18 Apr 2004
Posts: 3
Location: Bkk

PostPosted: Sun Apr 18, 2004 5:07 am    Post subject: same error but can't fix it Reply with quote

pleas give me more explain how to fix that am newbie
Back to top
View user's profile Send private message
joemc91
n00b
n00b


Joined: 04 Feb 2004
Posts: 38

PostPosted: Tue Apr 20, 2004 11:53 pm    Post subject: Reply with quote

OK, so I've been having this problem as well and decided to give your solution a shot. So I navigated to the .../src/services/name folder and did the linky thing. I run "emerge -v ORBit2 again and... poof, same error again. Turns out the emerge overwrote everything in the work directory. Dammit. So I go to setup again and this time, do a resume! But the freakin portage deleted libname-server-2.a from /usr/lib/!!! How do I get it back? And then, how do I get portage to NOT overwrite the work directory when running emerge? Thanks
Back to top
View user's profile Send private message
MerlinTheWizard
Apprentice
Apprentice


Joined: 06 Apr 2003
Posts: 270

PostPosted: Wed Apr 21, 2004 3:54 pm    Post subject: indeed Reply with quote

During build time, the directories are emptied again. So you need to make the link during compilation. Open another term, navigate to the mentioned directory, and watch it regularly until it begins filling up. Then, make the link (ln), and it should work. That's how I did it. Not very comfy, but it works...
Back to top
View user's profile Send private message
joemc91
n00b
n00b


Joined: 04 Feb 2004
Posts: 38

PostPosted: Wed Apr 21, 2004 4:23 pm    Post subject: Reply with quote

I figured that out after doing it the hard way. You can also navigate to the /usr/portage/distfiles directory and extract all the files. Then, add the link in the proper directory. Retar the files, get the new MD5 sum and edit digest-ORBit2-2.10.0 to have the new MD5sum. Put the new tar.bz2 file back where it belongs. Ugh. Do it the easy way, with X!
Back to top
View user's profile Send private message
twt
n00b
n00b


Joined: 18 Apr 2004
Posts: 3
Location: Bkk

PostPosted: Wed Apr 21, 2004 6:03 pm    Post subject: Reply with quote

I do ln -s /usr/lib/libname-server-2.a in /var/tmp/portage/work/ORBit2-2.10/src/services/name after emerge orbit2
and then go to /usr/portage/gnome-base/ORBit2
and run ebuild ORBit2-2.10.0.ebuild compile
then run ebuild ORBit2-2.10.0.ebuild install
then run ebuild ORBit2-2.10.0.ebuild qmerge
try!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum