Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blank windows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Heffaklumpen
n00b
n00b


Joined: 26 Feb 2004
Posts: 18
Location: Osby, Sweden

PostPosted: Tue Mar 23, 2004 11:10 pm    Post subject: Blank windows Reply with quote

I'm using XFree86 v.4.3.0.1 with Gnome 2.4.1

The problem is that some windows are blank, for example the loki installer windows are blank, the preferences window in xmms is blank

just to show how I mean

http://upl.silentwhisper.net/uplfolders/upload0/example.jpg

what can I do to fix it?
_________________
"I'm sorry Dave, I cannot let you do that"


Last edited by Heffaklumpen on Tue Mar 23, 2004 11:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
catzooka
Apprentice
Apprentice


Joined: 05 Nov 2002
Posts: 193

PostPosted: Tue Mar 23, 2004 11:15 pm    Post subject: Reply with quote

that sounds and looks suspiciously like you are having a font issue that is most likely to be associated with gtk1, since both loki installer and xmms use gtk1 (if im not mistaken). so i would suggest for you to first of all check out what gtk1 theme you are using, and the font it is using. there you may find your problem and perhaps your solution as well. good luck :)
Back to top
View user's profile Send private message
Heffaklumpen
n00b
n00b


Joined: 26 Feb 2004
Posts: 18
Location: Osby, Sweden

PostPosted: Tue Mar 23, 2004 11:26 pm    Post subject: Reply with quote

since I am a n00b :oops: I'm not sure how to do that, could you please explain a bit more.

have been draging with this problem for some time, it would be great to have it fixed
_________________
"I'm sorry Dave, I cannot let you do that"
Back to top
View user's profile Send private message
catzooka
Apprentice
Apprentice


Joined: 05 Nov 2002
Posts: 193

PostPosted: Tue Mar 23, 2004 11:39 pm    Post subject: Reply with quote

Since you're using GNOME 2.4 you could give this a try: "Main Menu" (little gnome foot) --> Applications --> Desktop Preferences --> Font. When the "Font Preferences" window has opened, the first box at the top should let you change your "Application Font," which defines what font to use in your gtk applications (it should set gtk1 and gtk2 application fonts). Change the font around and see if that fixes your problem.
Back to top
View user's profile Send private message
Heffaklumpen
n00b
n00b


Joined: 26 Feb 2004
Posts: 18
Location: Osby, Sweden

PostPosted: Tue Mar 23, 2004 11:46 pm    Post subject: Reply with quote

It doesn't seem to help, it only changes gtk2 fonts. Is there any sepate tool that configures gtk1? I will try to play around with the settings found there

I'm very glad for the help
_________________
"I'm sorry Dave, I cannot let you do that"
Back to top
View user's profile Send private message
catzooka
Apprentice
Apprentice


Joined: 05 Nov 2002
Posts: 193

PostPosted: Tue Mar 23, 2004 11:59 pm    Post subject: Reply with quote

well, i used to use an application called "gtk-theme-switch"; however, since im running version 2.00-something of gtk-theme-switch it seems to only change gtk2 apps, just like "Font Preferences" would. in any case. if you want to give it a shot, emerge gtk-theme-switch. you could perhaps even install an older 1.xx version of gtk-theme-switch which may allow you to change gtk1 application fonts. im still on the lookout for other solutions. i'll keep you posted :P

EDIT: This ebuild has been slotted, so go for:
Code:
emerge /usr/portage/x11-themes/gtk-theme-switch/gtk-theme-switch-1.0.1.ebuild


okay, i've just emerged this package. and if you run the command switch, it comes up with a dialog to let you switch gtk-themes and even apply fonts to them; however, i can't confirm if this is working (using beep-media-player-cvs, not xmms).
Back to top
View user's profile Send private message
Heffaklumpen
n00b
n00b


Joined: 26 Feb 2004
Posts: 18
Location: Osby, Sweden

PostPosted: Wed Mar 24, 2004 12:17 am    Post subject: Reply with quote

It didn't help, that program suffers from the same error :(. Can it be something I didn't install, something that perhaps is missing. I'll try emerge some files that programs that looks useful
_________________
"I'm sorry Dave, I cannot let you do that"
Back to top
View user's profile Send private message
Heffaklumpen
n00b
n00b


Joined: 26 Feb 2004
Posts: 18
Location: Osby, Sweden

PostPosted: Wed Mar 24, 2004 12:43 am    Post subject: Reply with quote

It still doesn't work, I emerged som gtk-themes but the error was still there. Very glad for help. If I find the solution I will post it here.
_________________
"I'm sorry Dave, I cannot let you do that"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum