Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No sound in tuxracer (Not seeing sdl-mixer)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
The Mighty Quinn
n00b
n00b


Joined: 17 Aug 2002
Posts: 2

PostPosted: Sat Aug 17, 2002 7:04 pm    Post subject: No sound in tuxracer (Not seeing sdl-mixer) Reply with quote

I'm a recent gentoo convert, coming over from debian, and I'm having a spot of trouble.. when I emerge tuxracer, I don't get any sound-- afterl unmerging and remerging a couple times, I figured out that it's not properly seeing sdl-mixer (even though sdl-mixer is definitely installed)
Here's the line from the ./configure -- it's the only one that looks out of the ordinary

checking for Mix_OpenAudio in -lSDL_mixer... no
*** SDL_mixer not found. Configuring without audio support.

...I haven't found any other pack-in games that display this issue, and other games and programs play sound just fine.

I've tried this on two systems, both with the same result, one using a Sound Blaster Audigy, the other using onboard nForce sound.

I have tried doc-browsing, forum searching and googling, with no luck in finding an answer-- does anyone around here have any ideas on how to fix this?
Back to top
View user's profile Send private message
Locke
n00b
n00b


Joined: 02 Aug 2002
Posts: 50
Location: Baton Rouge, LA, US

PostPosted: Thu Aug 22, 2002 6:52 am    Post subject: Reply with quote

Exact same problem here. I'm using GCC 3.1.1-r1. I even tried untarring it, running autoconf, and configuring by hand... no dice.
_________________
---BEGIN GEEK CODE BLOCK---
GH/MU d+ s+:+>+: a--- C++ UL+++>++++ P>++ L+++(++) E- W++(-) N+ o?
K+ w !O M-- !V PS+@ PE Y+ PGP t 5 X- R-@ tv- b+++ DI+ D G e>++++ h- r y
---END GEEK CODE BLOCK---
Back to top
View user's profile Send private message
scottro
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 141
Location: New York City

PostPosted: Sun Sep 08, 2002 12:21 am    Post subject: Reply with quote

I"m having the same problem with lbreakout2

See https://forums.gentoo.org/viewtopic.php?t=14407

Scott

(If you get this solved please let me know, and I'll do the same)

Among other things, tried downloading the source code from SDL's site. The documentation for lbreakout2 says that if you're receiving that error message, the reason is because the devlopment package isn't installed.)
Back to top
View user's profile Send private message
scottro
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 141
Location: New York City

PostPosted: Sun Sep 08, 2002 1:39 am    Post subject: Reply with quote

I've filed a bug (#7635) at bugzilla. Although it's only in gcc 3.2, a few folks on IRC suggested filing it against libsdl

https://bugs.gentoo.org/show_bug.cgi?id=7635


Scott
Back to top
View user's profile Send private message
The Mighty Quinn
n00b
n00b


Joined: 17 Aug 2002
Posts: 2

PostPosted: Sun Sep 15, 2002 9:14 pm    Post subject: Reply with quote

Well, at least for me, the issue seems to have been fixed. I did a system-reinstall the other day (Bad habit, I do it all the time. -_-), and now Tuxracer at least, has sound. Go fig.
Back to top
View user's profile Send private message
maor
Guru
Guru


Joined: 28 Aug 2002
Posts: 323

PostPosted: Mon Sep 16, 2002 2:35 pm    Post subject: Reply with quote

i also don't have sound on tux-racer
Back to top
View user's profile Send private message
patrickfo
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 79
Location: France

PostPosted: Fri Sep 20, 2002 3:24 pm    Post subject: no sound in lbreakout2 sdl-mixer not found solved (for me) Reply with quote

i just suppress any CFLAGS and CXXFLAFS
and do an:
emerge audiofile esound libsdl sdl-net sdl-perl smpeg sdl-mixer lbreakout2
and it worked.
no time to analyse but i think something needed by smepg in audiofile or esound is miscompiled... (just a feeling...)
patrick
please tell if this work also for you
Back to top
View user's profile Send private message
AlterEgo
Veteran
Veteran


Joined: 25 Apr 2002
Posts: 1619

PostPosted: Fri Sep 20, 2002 7:05 pm    Post subject: Re: no sound in lbreakout2 sdl-mixer not found solved (for m Reply with quote

patrickfo wrote:
i just suppress any CFLAGS and CXXFLAFS
and do an:
emerge audiofile esound libsdl sdl-net sdl-perl smpeg sdl-mixer lbreakout2
and it worked.
<snip>
please tell if this work also for you

Sorry, did not work pour moi. :(
Back to top
View user's profile Send private message
scottro
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 141
Location: New York City

PostPosted: Mon Sep 23, 2002 12:40 pm    Post subject: Reply with quote

Ok, I was able to get this working. I'm just going to paste what I posted on Gentoo-user yesterday.

Problem: Some folks, but not all, are finding that if they emerge
lbreakout2, tux-racer, penguin-command and a few others, the emerge
either fails, or if it succeeds, gives no sound.

There are two bugs on bugs.gentoo.org. Bug 6888 discusses the problem,
but has been resolved with WORKSFORME, meaning that the maintainer is
unable to reproduce the problem. However, what is happening is that
(I'll use lbreakout2 as my example, since that's where I first
discovered the issue) is during configuration, even though libsdl is
present, it's not being found--therefore, lbreakout2 was saying can't
find SDL_MIXER compiling without audio.

Bug 7573 has a patch. The issue turns out to be smpeg-0.4.4 not being
linked to libgcc_s. (Let me reiterate that I'm not a programmer--I'm
parroting what I found with a bit of searching). Through messing up in
downloading the patch, so that it wouldn't apply properly, I came up
with this solution. Please note that some steps may be unecessary, but
this is how I got it to work. Note that most of this will have to be
done as root or with root privileges.

Firstly, I unmerged lbreakout2, libsdl and smpeg
Code:

emerge -C lbreakout2 libsdl smpeg

cd /usr/portage/media-libs/smpeg
rm -rf /var/tmp/portage/smpeg-0.4.4-r4


Next, (as I'd seen this on forums, but only vaguely remember when in the
course of events one was supposed to do it) open up /etc/make.conf and
comment out your USE variables and CFLAGS. That might only be necessary
for lbreakout2, but I ~think~ I tried the below steps once, leaving them
uncommented and it didn't work.

Re-emerge libsdl as smpeg needs it
Code:

emerge libsdl
ebuild smpeg-0.4.4-r4.ebuild unpack


Change to its work directory
Code:

cd /var/tmp/portage/smpeg*/work/smpeg*


Open Makefile.am (if you're using nano, don't forget the -w option)
Around line 42 you'll see
-lsupc++
Change that line to read
Code:

-lstdc++

Go back to the /usr/portage/media-libs/smpeg directory--actually cd -
ought to do that for you.
Code:

ebuild smpeg-0.4.4-r4.ebuild compile
ebuild smpeg-0.4.4-r4.ebuild install
ebuild smpeg-0.4.4-r4.ebuild qmerge

emerge lbreakout2. 



(Actually, to see if it was going to work, I did
another ebuild lbreakout2.(version).ebuild unpack, compile install
qmerge, but I think that's probably unecessary.

No doubt, the coders might be able
to post a simpler way to do it.
Anyway, hope this is of use to some folks
Back to top
View user's profile Send private message
AlterEgo
Veteran
Veteran


Joined: 25 Apr 2002
Posts: 1619

PostPosted: Mon Sep 23, 2002 1:32 pm    Post subject: Reply with quote

Thanks for your posting scottro.
but, again, this did not work for me....
Followed your instructions step by step....no sound.
Back to top
View user's profile Send private message
scottro
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 141
Location: New York City

PostPosted: Mon Sep 23, 2002 2:03 pm    Post subject: Reply with quote

Quick and probably stupid question but---is sound working in general on the machine? (What I posted is for a box where sound is already working, just not working with programs that require SDL_MIXER

Scott
Back to top
View user's profile Send private message
AlterEgo
Veteran
Veteran


Joined: 25 Apr 2002
Posts: 1619

PostPosted: Mon Sep 23, 2002 3:58 pm    Post subject: Reply with quote

scottro wrote:
Quick and probably stupid question but---is sound working in general on the machine? (What I posted is for a box where sound is already working, just not working with programs that require SDL_MIXER

Scott

Yep, it's just tuxracer that's quiet.
I'm realy missing that stupid tune :lol:
Back to top
View user's profile Send private message
klimg
n00b
n00b


Joined: 21 Sep 2002
Posts: 55

PostPosted: Mon Sep 23, 2002 8:52 pm    Post subject: Reply with quote

Thanks, scottro - works for me.My wife was getting ready to kill me.
Back to top
View user's profile Send private message
scottro
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 141
Location: New York City

PostPosted: Mon Sep 23, 2002 9:41 pm    Post subject: Reply with quote

It seems to be working for most people. Alter ego, I'm not sure what to tell you, save to try again, and comment out all USE, CFLAGS and CXXFLAGS. The way to see if it worked is this. When you emerge lbreakout2 (or I guess, tuxracer--I don't use that one so not sure) if you go into the work directory, and do ./configure, you can see if it found the SDL_MIXER.

I'm not sure why it's not working for you--different hardware? FWIW, I use the sound module from the kernel rather than Alsa, but from some off list and off forum discussion with others, this doesn't seem to be the issue (but again, I don't know enough about it to know if that's correct).

Judging from Gentoo's track record, I'd say it'll be fixed soon anyway. I'm sorry it didn't work for you. Aside from klimg, it worked for a couple of other people after I posted on gentoo-user. :-(

Hopefully, they'll fix whatever causes the problem relatively soon.

Scott
Back to top
View user's profile Send private message
nandes
n00b
n00b


Joined: 17 Jul 2004
Posts: 1

PostPosted: Sat Jul 17, 2004 4:49 pm    Post subject: worked for me Reply with quote

Followed your instructions, and it worked for me!

although,

Quote:
Open Makefile.am (if you're using nano, don't forget the -w option)
Around line 42 you'll see
-lsupc++
Change that line to read
Código:

-lstdc++


Makefile.am does not contains "l-lsupc++" , I found it in Makefile.in around line 111 and change that to "-lstdc++"

the rest of the steps followed identically.

Thanx scottro!!!
Back to top
View user's profile Send private message
asmvday
n00b
n00b


Joined: 11 Aug 2004
Posts: 18

PostPosted: Thu Nov 18, 2004 8:20 pm    Post subject: Reply with quote

I had this problem, and it was frustrating me greatly. I tried reemerging to no avail until someone posted this on a different SDL thread:

emerge libsdl sdl-gfx sdl-image sdl-mixer sdl-net sdl-sound sdl-ttf

Apparently, that was the magic order to get SDL_Mixer working on my system.
Back to top
View user's profile Send private message
Sachankara
l33t
l33t


Joined: 11 Jun 2004
Posts: 696
Location: Stockholm, Sweden

PostPosted: Thu Dec 09, 2004 11:42 pm    Post subject: Reply with quote

I couldn't get any SDL dependent games to work on my VIA 82xx sound card, but it worked just fine when I smitched to a cs46xx based card... So for me, the problem lied in the card and the respective drivers (configuration? Never found a solution)...
_________________
Gentoo Hardened Linux 2.6.21 + svorak (Swedish dvorak)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum