Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]problema di permessi e login
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
toro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 80
Location: Savona, ITALY

PostPosted: Fri Jan 02, 2004 1:46 pm    Post subject: [Risolto]problema di permessi e login Reply with quote

ho fatto un macello... non so nemmeno io come... ma questa volta sono riuscito a mettermi i bastoni tra le ruote proprio di brutto :lol:

non riesco più a loggarmi come utente... ovvero se cerco di loggarmi con il solito utente dopo che gli dico la mia segretissima password lui mi risponde con
Code:

Unable to cd to "/home/toro"

e manco a dirlo mi ritira fuori il prompt di login... tentando invece la strada del "su toro" da root mi dice
Code:

Cannot execute /bin/bash: Permission denied

e ovviamente mi ripropone il prompt di root... tutto questo succede con qualsiasi utente del sistema e anche creando un utente nuovo succede la stessa cosa... non so come ho fatto a combinare tutto sto macello... ma di sicuro ho imparato che al mattino presto dopo una serata di gozzoviglie è bene lasciar stare il computer :D

non è che qualcuno saprebbe darmi una dritta almeno per scoprire cos'è successo?!? :)


Last edited by toro on Fri Jan 02, 2004 2:31 pm; edited 2 times in total
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Jan 02, 2004 1:50 pm    Post subject: Re: problema di permessi (credo) Reply with quote

toro wrote:

non è che qualcuno saprebbe darmi una dritta almeno per scoprire cos'è successo?!? :)


qual'é l'output di:
Code:
ls -l /home/
ls -l /bin/bash
grep toro /etc/passwd


:?:
Back to top
View user's profile Send private message
toro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 80
Location: Savona, ITALY

PostPosted: Fri Jan 02, 2004 2:02 pm    Post subject: Reply with quote

Code:

# ls -l /home
total 1
drwx------   19 toro     users         848 Jan  2 12:13 toro

Code:

# ls -l /bin/bash
-rwxr-xr-x    1 root     root       558788 Dec  3 23:12 /bin/bash

Code:

# grep toro /etc/passwd
toro:x:1000:100::/home/toro:/bin/bash

e questo è quanto :)

grazie mille per l'help! :D
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Fri Jan 02, 2004 2:16 pm    Post subject: Reply with quote

Questo post ti puo' servire magari. Ricorda di salvare i dati non si sa mai.
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Jan 02, 2004 2:20 pm    Post subject: Reply with quote

toro wrote:
Code:

# ls -l /home
total 1
drwx------   19 toro     users         848 Jan  2 12:13 toro

Code:

# ls -l /bin/bash
-rwxr-xr-x    1 root     root       558788 Dec  3 23:12 /bin/bash

Code:

# grep toro /etc/passwd
toro:x:1000:100::/home/toro:/bin/bash

e questo è quanto :)

grazie mille per l'help! :D


Sembra tutto corretto :?

Sei sicuro di non essere in single user mode? (per saperlo il comando é "runlevel" senza parametri. Se dice 1 la risposta é SI)

Cerca di ricordare cosa hai fatto di recente tra il momento in cui funzionava e adesso.... (tutto, anche le cose che sembrano banali...)
Back to top
View user's profile Send private message
toro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 80
Location: Savona, ITALY

PostPosted: Fri Jan 02, 2004 2:30 pm    Post subject: Reply with quote

sono giunto alla soluzione! :)

il problema era che i permessi della dir / erano sbagliati... ho ricambiato i permessi di / in 755 e ora tutto fila di nuovo tutto liscio come l'olio... però mi rimane ancora un dubbio... come può essere successo che siano cambiati i permessi di /?!?... io sono abbastanza sicuro di non averli cambiati... almeno non esplicitamente :)

cmq grazie mille a tutti :)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Fri Jan 02, 2004 2:33 pm    Post subject: Reply with quote

toro wrote:
sono giunto alla soluzione! :)

il problema era che i permessi della dir / erano sbagliati... ho ricambiato i permessi di / in 755 e ora tutto fila di nuovo tutto liscio come l'olio... però mi rimane ancora un dubbio... come può essere successo che siano cambiati i permessi di /?!?... io sono abbastanza sicuro di non averli cambiati... almeno non esplicitamente :)

cmq grazie mille a tutti :)

I permessi non si cambiano da soli se proprio sicuro al 100% di non avere fatto qualche chmod 700 *?
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
toro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 80
Location: Savona, ITALY

PostPosted: Fri Jan 02, 2004 2:41 pm    Post subject: Reply with quote

fedeliallalinea wrote:
I permessi non si cambiano da soli se proprio sicuro al 100% di non avere fatto qualche chmod 700 *?

giurin giurello... almeno... credo... ho dei ricordi piuttosto vaghi e confusi di quando ho acceso il computer stamattina... :)
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Jan 02, 2004 2:57 pm    Post subject: Reply with quote

toro wrote:
fedeliallalinea wrote:
I permessi non si cambiano da soli se proprio sicuro al 100% di non avere fatto qualche chmod 700 *?

giurin giurello... almeno... credo... ho dei ricordi piuttosto vaghi e confusi di quando ho acceso il computer stamattina... :)


potrebbe essere stato un chmod con uno slash e qualche spazio di troppo...

É bene usare sempre un utente normale e, in casi particolari ricorrere al "su -", ma solo per l'indispensabile!
Back to top
View user's profile Send private message
toro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 80
Location: Savona, ITALY

PostPosted: Fri Jan 02, 2004 3:05 pm    Post subject: Reply with quote

randomaze wrote:

potrebbe essere stato un chmod con uno slash e qualche spazio di troppo...

É bene usare sempre un utente normale e, in casi particolari ricorrere al "su -", ma solo per l'indispensabile!


già... perbacco... si sono uno scemo... per favore ditemi tutti in coro "SEI SCEMO!" :lol:

in effetti nel .bash_history di root ho trovato un chmod 700 / boot... :oops: :roll:

*cerca di convincersi che avvicinarsi al computer al mattino presto è pericolosissimo!*

ancora grazie mille a tutti e due! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum