Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jnu
n00b
n00b


Joined: 26 Aug 2003
Posts: 16

PostPosted: Fri Dec 05, 2003 10:21 am    Post subject: emerge not working Reply with quote

I did an "emerge system" to update packages but during the process errors started occurring. Now emerge doesn't work at all. What can I do? Here are some error messages whe emerge is run:

# emerge system
Calculating system dependencies /Traceback (most recent call last):
File "/usr/bin/emerge", line 2103, in ?
if not mydepgraph.xcreate(myaction):
File "/usr/bin/emerge", line 1034, in xcreate
if not self.create(myk):
File "/usr/bin/emerge", line 747, in create
if not self.select_dep("/",mydep["/"],myparent=mp,myuse=myuse):
File "/usr/bin/emerge", line 846, in select_dep
mycheck=portage.dep_check(depstring,self.mydbapi[myroot],myuse=myuse)
TypeError: dep_check() got an unexpected keyword argument 'myuse'


# emerge mozilla
Calculating dependencies \
!!! Problem in net-www/mozilla dependencies.
!!! dep_check() got an unexpected keyword argument 'myuse'
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9175
Location: beyond the rim

PostPosted: Fri Dec 05, 2003 10:47 am    Post subject: Reply with quote

which portage and python versions ? Please post the output of the following commands:
Code:
ls -d /var/db/pkg/dev-lang/python*
ls -d /var/db/pkg/sys-apps/portage*
emerge -V
Back to top
View user's profile Send private message
jnu
n00b
n00b


Joined: 26 Aug 2003
Posts: 16

PostPosted: Fri Dec 05, 2003 1:47 pm    Post subject: Reply with quote

In response to previous posting:

# ls -d /var/db/pkg/dev-lang/python-2.2.3-r1/
/var/db/pkg/dev-lang/python-2.2.3-r1/

# ls -d /var/db/pkg/sys-apps/portage-2.0.49-r16/
/var/db/pkg/sys-apps/portage-2.0.49-r16/

# emerge -V
Portage 2.0.49-r3 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1, 2.4.22-gentoo-test-r0)
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9175
Location: beyond the rim

PostPosted: Fri Dec 05, 2003 4:04 pm    Post subject: Reply with quote

ok, now delete all files in /usr/lib/python2.2/site-packages which are also present in /usr/lib/portage/pym.
Back to top
View user's profile Send private message
jnu
n00b
n00b


Joined: 26 Aug 2003
Posts: 16

PostPosted: Fri Dec 05, 2003 4:45 pm    Post subject: Reply with quote

Thanks - that worked!

And I shall endeavour to search more thoroughly in the future.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum