Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
spamassassin .. and oddity ..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
eltech
Guru
Guru


Joined: 05 Nov 2002
Posts: 582
Location: New York

PostPosted: Wed Nov 26, 2003 12:12 pm    Post subject: spamassassin .. and oddity .. Reply with quote

Hello ..

I have spamassassin installed with qmail, vpopmail and qmail-scanner .. all
scanning and functioning fine ..

except that it seems that spamassassin has just stopped detecting any mail
as spam .. I am running Gentoo Linux, so it seems the setup is different
then the average ..

here is a copy of my /etc/mail/spamassassin/local.cf
Code:

# How many hits before a message is considered spam.
required_hits           5.0

# Whether to change the subject of suspected spam
rewrite_subject         1

# Text to prepend to subject if rewrite_subject is used
subject_tag             ****SPAM****

# Encapsulate spam in an attachment
report_safe             1

# Use terse version of the spam report
use_terse_report        1

# Enable Bayes auto-learning
auto_learn              1

defang_mime 1
report_header 1

# Enable the Bayes system
use_bayes               1

# Enable Bayes auto-learning
auto_learn              1

# Enable or disable network checks
skip_rbl_checks         0

 Mail using languages used in these country codes will not be marked
# as being possibly spam in a foreign language.
ok_languages            all

# Mail using locales used in these country codes will not be marked
# as being possibly spam in a foreign language.
ok_locales              all

dns_available yes
dcc_add_header 1
use_dcc 1



Please note that I have included many options to try and get this working ..
so some may not be relevant

So .. I have this file as stated above, but syslog was complaining that
/var/qmail/.spamassassin/user_prefs was non existing, so I created it with
the same settings above .. still no change ..

my /etc/conf.d/spamd looks like so
Code:


SPAMD_OPTS="-c --configpath=/etc/mail/spamassassin/local.cf"



it was suggested I use the 'configpath' so that atleast I have an idea which
file it is trying to use when scanning ...

But this all still does not work .. I don't ever get anything considered to
be spam (I am happy about that) but its not all true, and it seems more that
spamassassin is screwed somewhere ..

I then create the user_prefs file in my vpopmail user dir
/var/vpopmail/domains/domain.com/user/.spamassassin/user_prefs .. no change..

I also have a .mailfilter file in my /var/vpopmail/domains/domain.com/ directory containing
Code:

import EXT
import HOST
import HOME

SPAMBOX=".Spam"
VERBOSE=1
logfile "/var/log/maildrop-filter-log"
SHELL="/bin/sh"
VHOME=`/var/vpopmail/bin/vuserinfo -d $EXT@$HOST`
VDOMHOME=`/var/vpopmail/bin/vdominfo -d $HOST`
VPOP=`cat $VDOMHOME/.qmail-default`
#VPOP="$VHOME/Maildir/"


if ((/^X-Spam-Status:.*YES/))
{
   `test -d $VHOME/Maildir/.Spam`
   if( $RETURNCODE == 1 )
   {
   `/usr/bin/maildirmake $VHOME/Maildir/.Spam;chown -R vpopmail.vpopmail $VHOME/Maildir/.Spam`
   `echo "INBOX.Spam" >> $VHOME/Maildir/courierimapsubscribed`
   }
   to "$VHOME/Maildir/.Spam/"
}

to "$VHOME/Maildir/"


and then finally my .qmail in /var/vpopmail/domains/domain.com/user contains

Code:

| /var/qmail/bin/preline /usr/bin/maildrop /var/vpopmail/domains/mailfilter


I think that's about it as far as steps I have taken and things I have done
..

anyone have any ideas?
Back to top
View user's profile Send private message
SpinDizzy
n00b
n00b


Joined: 28 May 2003
Posts: 63
Location: Moss Vale, Australia

PostPosted: Sat Nov 29, 2003 5:20 am    Post subject: Reply with quote

So, spamassassin was tagging spam and then it stopped?

What happens when you feed something you consider to be spam through spamassasssin directly?
eg:
spamassassin -t < my_saved_spam.email
Back to top
View user's profile Send private message
eltech
Guru
Guru


Joined: 05 Nov 2002
Posts: 582
Location: New York

PostPosted: Sat Nov 29, 2003 10:57 am    Post subject: Reply with quote

SpinDizzy wrote:
So, spamassassin was tagging spam and then it stopped?

What happens when you feed something you consider to be spam through spamassasssin directly?
eg:
spamassassin -t < my_saved_spam.email

no .. thats another issue .. it has never tageed any mail ..

well it seems that spamassassin is now atleat reading the config file i would like it to ..

however .. it does not seem to be catching any spam at all ..

your syntax simply spit the same results as a spamc < the.email would .. similar to below
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Sat Nov 29, 2003 7:39 pm    Post subject: Reply with quote

just a thought ,, in your config, you say that languages ok are : ALL
doesn that makes spamassassin ignore all languages ? and therefor not catching any spam ?

in my config I have ok languages DK, because well there are no spammers from Denmark.
everything else gets scaned.
Back to top
View user's profile Send private message
eltech
Guru
Guru


Joined: 05 Nov 2002
Posts: 582
Location: New York

PostPosted: Sat Nov 29, 2003 7:56 pm    Post subject: thanks for the tip .. Reply with quote

ikaro wrote:
just a thought ,, in your config, you say that languages ok are : ALL
doesn that makes spamassassin ignore all languages ? and therefor not catching any spam ?

in my config I have ok languages DK, because well there are no spammers from Denmark.
everything else gets scaned.
Thanks for the tip .. i have changed that setting, but still doesnt seem like anything is working yet ..

i just continusly get the regular output
Code:

SA: run /usr/bin/spamc  -c -f < /var/spool/qmailscan/working/new/my.domain.com10701349824267543
29/11/2003 14:43:02:7543: spamassassin: finished scan of dir "/var/spool/qmailscan/my.domain.com10701349824267543" in 0.166169 secs
Back to top
View user's profile Send private message
eltech
Guru
Guru


Joined: 05 Nov 2002
Posts: 582
Location: New York

PostPosted: Tue Dec 02, 2003 2:30 pm    Post subject: just to add Reply with quote

ok .. so a new version of qmail-scanner was available and i get ths message during compiling ..

Code:

Something like the SpamAssassin spamc is present, but not working=20
(didn't include a "X-Spam-Status" line in output) - ignoring...


Something like the SpamAssassin spamc is present, but not working=20
(didn't include a "X-Spam-Status" line in output) - ignoring...


what does this mean?

am not sure how this may be affecting my setup, but its obviously something to do with it .. google shows nothing ..
Back to top
View user's profile Send private message
guitard00d
Tux's lil' helper
Tux's lil' helper


Joined: 19 Dec 2003
Posts: 81
Location: Minatare, NE, USA, Earth

PostPosted: Sat Jan 03, 2004 11:16 pm    Post subject: Re: spamassassin .. and oddity .. Reply with quote

eltech wrote:

I also have a .mailfilter file in my /var/vpopmail/domains/domain.com/ directory containing
<snip>
Code:

| /var/qmail/bin/preline /usr/bin/maildrop /var/vpopmail/domains/mailfilter


I could be wrong (because I'm still new to qmail) but it looks like your .qmail-default is pointing to a nonexistent file. It's pointing to /var/vpopmail/domains/mailfilter when the actual file is /var/vpopmail/domains/.mailfilter

ie: .qmail-default is looking for "mailfilter" rather than ".mailfilter"
_________________
I know you believe you understand what you think I said, but I'm not sure you realize that what you heard is not what I meant...
--Richard Nixon
Back to top
View user's profile Send private message
guitard00d
Tux's lil' helper
Tux's lil' helper


Joined: 19 Dec 2003
Posts: 81
Location: Minatare, NE, USA, Earth

PostPosted: Sat Jan 03, 2004 11:23 pm    Post subject: Re: spamassassin .. and oddity .. Reply with quote

eltech...Unless I'm overlooking something, I don't see anything in any of your configuration file examples that call spamc or spamassassin, so that would explain why your messages aren't getting checked for spam and tagged accordingly.
_________________
I know you believe you understand what you think I said, but I'm not sure you realize that what you heard is not what I meant...
--Richard Nixon
Back to top
View user's profile Send private message
guitard00d
Tux's lil' helper
Tux's lil' helper


Joined: 19 Dec 2003
Posts: 81
Location: Minatare, NE, USA, Earth

PostPosted: Tue Jan 06, 2004 2:44 am    Post subject: Reply with quote

ikaro wrote:
in my config I have ok languages DK, because well there are no spammers from Denmark.


Heh heh heh...If you really believe that, you should check out this page.

http://www.spamcop.net/w3m?action=blcheck&ip=213.170.244.11
_________________
I know you believe you understand what you think I said, but I'm not sure you realize that what you heard is not what I meant...
--Richard Nixon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum