Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
power off in shutdown proces
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Fri Aug 02, 2002 8:32 pm    Post subject: power off in shutdown proces Reply with quote

how can i get gentoo to shutdown my box propely, i mean it switch's poweroff in the end of halt.

i tryed acpi in kernel and emerging acpid but no luck. and it should be possible because redhat,suse does it
Back to top
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1378
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Fri Aug 02, 2002 8:33 pm    Post subject: Reply with quote

You really should search the forums before posting, there is a lot in the forums about this. Here is a good place to start.

Hope you get it working!!! Good luck!

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
Guest






PostPosted: Sat Aug 03, 2002 5:57 am    Post subject: Reply with quote

i did read it before posting,they didin't work for me.
here's what i tryed:
acpid in kernel and emerged acpid
gives boot erros about my harddrive

apm in kernel and emerged apmd
boot goes normally but doesn't shutdown comp,i tryes it as when it's done
the shutdown proecess my power button doesn't work,only reset button.

and they can't be both installed? atleast kernel help say's that which is first
loaded will be used.
Back to top
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1378
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Mon Aug 05, 2002 7:00 pm    Post subject: Reply with quote

It is true that you cannot use both at the same time. You can enable both, however the first one loaded will be the only active one. What motherboard do you have? Does it support ACPI? Basically ACPI is the newer standard and replaces APM. APM is older and therefore is correct on older hardware. If you board supports both use ACPI, not APM. This is what has worked best for me on many different systems. When all else fails look on google for information about your specific hardware and usually some nice fellow/lady has posted thier own experiences with that exact hardware.

Good luck!!

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
strawbeard
n00b
n00b


Joined: 05 Oct 2002
Posts: 11
Location: Basel (region), Switzerland

PostPosted: Sat Oct 19, 2002 9:54 pm    Post subject: Reply with quote

BonezTheGoon wrote:
You really should search the forums before posting, there is a lot in the forums about this. Here is a good place to start.
....


I'd say it's a good place to get confused, completely, utterly :twisted:

'halt' powers off the hard disk (after approx. msg: "IDE devices flushed"), maybe CD-R & CD-RW too (not running then), but nothing else. :roll: Windows 2000 Prof. has no problems there (ASUS TUSL2-C, Pentium-III).
Back to top
View user's profile Send private message
Qubax
Guru
Guru


Joined: 19 Jul 2002
Posts: 451
Location: Tirol, Austria

PostPosted: Sun Oct 20, 2002 3:09 pm    Post subject: Reply with quote

somewhere i've read that smp support (processor features) disables apm - so have a look at that - after disabling smp apm works for me (asus a7v)
if it reports an error during compiling the kernel use a
Code:
make rmproper
- don't forget to save your config somewhere before
Back to top
View user's profile Send private message
zwik
Apprentice
Apprentice


Joined: 08 Sep 2002
Posts: 167
Location: NL, NB, Liempde

PostPosted: Tue Oct 22, 2002 12:50 pm    Post subject: Reply with quote

Qubax wrote:
somewhere i've read that smp support (processor features) disables apm - so have a look at that - after disabling smp apm works for me (asus a7v)
if it reports an error during compiling the kernel use a
Code:
make rmproper
- don't forget to save your config somewhere before


That should be:

Code:
make mrproper


:wink: .
_________________
Daily life and stuff.
Back to top
View user's profile Send private message
eric.cheminot
n00b
n00b


Joined: 03 Jul 2002
Posts: 47

PostPosted: Tue Oct 22, 2002 2:26 pm    Post subject: Reply with quote

Hello,

I also had this problem. After searching the Web, it seemed that this oftenly occurs when using GRUB 0.90. Then I just enabled APM in the kernel, unmask GRUB 0.92, and now shutdown -h works properly.

-ec
Back to top
View user's profile Send private message
mvr_rennes
Apprentice
Apprentice


Joined: 23 Oct 2002
Posts: 155

PostPosted: Thu Oct 24, 2002 11:23 am    Post subject: Re: power off in shutdown proces Reply with quote

What hardware are you running on?
I have an HP Pavillion, and I have the same problem with Gentoo _and_ RH
Windoze does turn it off, however...

Cheers,
Martin

Anonymous wrote:
how can i get gentoo to shutdown my box propely, i mean it switch's poweroff in the end of halt.

i tryed acpi in kernel and emerging acpid but no luck. and it should be possible because redhat,suse does it
Back to top
View user's profile Send private message
strawbeard
n00b
n00b


Joined: 05 Oct 2002
Posts: 11
Location: Basel (region), Switzerland

PostPosted: Fri Oct 25, 2002 12:29 am    Post subject: Re: power off in shutdown proces Reply with quote

mvr_rennes wrote:
What hardware are you running on?
I have an HP Pavillion, and I have the same problem with Gentoo _and_ RH
Windoze does turn it off, however...


I'm not the person you asked 8) - but I want to answer: My PC has an ASUS TUSL2-C motherboard, running a P-III/1GHz with 512MB RAM. I Use Windows 2000 and - as an experimental setup - Gentoo. Gentoo only powered down the IDE-Devices (harddisk).
After I configured the kernel simply for APM without any of its sub-options, I got a complete shutdown. I also emerged apmd, a power watchdog demon and installed it. I'll try next whether I really need that thing for my simple needs. :?
Back to top
View user's profile Send private message
Cloim
Tux's lil' helper
Tux's lil' helper


Joined: 02 Aug 2002
Posts: 99

PostPosted: Fri Oct 25, 2002 12:30 am    Post subject: Reply with quote

Quote:
I have an HP Pavillion, and I have the same problem with Gentoo _and_ RH

Under "Processor Type and Features"
Disable
Code:
Symmetric multi-processing support

Then enable APM (just APM, none of the other APM options) and see if it works. That's all I had to do on my Pavillion.
This is discussed on the thread that was previously referenced.
Back to top
View user's profile Send private message
Zzoot
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jan 2003
Posts: 98
Location: Iowa.

PostPosted: Sat Apr 05, 2003 4:31 pm    Post subject: ACPI APM SMP ---Awwww, Crud... Reply with quote

Yeah-- This is what I've been beating my head against the keyboard about for a while now...

Here's what I know...

1) by Default in (most) kernels, APM is disabled for SMP. AC apparantly says it's 'unsafe', although with his (-AC) kernels, you can enable it..."Hey, it's your data to lose"---Kinda scary in an ominous sorta way...

2) ACPI seems to have some of the same problems...at least with the newer 2.4.20 gentoo-sources.

3) In the Gentoo Sources 2.4.19, there was (I think) an AC patch applied that allowed my system to power down WITH smp...I was so happy, and then so peeved when I recompiled with 2.4.20...

4) Almost every other thread I've read seems to indicate ACPI is the way to go if you have SMP, otherwise, disable smp and you have no problems.

5) Don't forget to 'rc-update add <acpid or apmd> default' or none a this will work...

6) There's no better fix for your problem than rolling up your sleeves and DOING it...Cause I've seen tons of contradicting advice on these forums, because everyone's hardware is different...Go do some experiments, cause that's the only that that'll tell you if it really works... Which is what I'm doing now...maybe I can figure how to go back to the 2.4.19 kernel...hmmmmm.... :wink:
Back to top
View user's profile Send private message
Zzoot
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jan 2003
Posts: 98
Location: Iowa.

PostPosted: Fri May 16, 2003 12:19 am    Post subject: ACPI and SMP...I am so screwed.... Reply with quote

Hi all...
Minor update to the last post here... I have had ZERO success with acpi or apm poweroff after shutdown and about 6 different kernels...even going back to 2.4.19 didn't help...
ANd I'm getting pretty torqued about it...

I mean, it WAS working. Then a BIG screwup and re-install (Made the system unuseable...OOPS!) I'm about 2 days away from a wipe and re-install...but I suppose in the early days of working with any distro that probably happens fairly frequently...My 'first days' are just stretching out a bit long...

I suppose it'll give me time to tear down the box and try to quiet down those dang scsi drives if I can... (If anyone has any SCSI insights into that "new Adaptec" driver that keeps hanging the boot process, pass it along, too, eh?)

At any rate, If anyone else is reading this and has any insight, I'm all ears... But I'll also post after the grand-reinstallation project to let anyone know about how it went...

The box:
ECS D6Vaa SMP mobo w/ dual p3-800's
Geforce2 gts
Adaptec 2940uw Scsi and 3 IBM 18 gig UW drives
SB Live
3com 3c905 (Can't be beat for universal compatability, baby!)

Power Management sux.
Back to top
View user's profile Send private message
dotcom
n00b
n00b


Joined: 17 Feb 2003
Posts: 20
Location: Sweden

PostPosted: Fri May 16, 2003 9:52 am    Post subject: Reply with quote

I think I know what you are feeling like... I had (as many others) the same problem which I could solve.
the solution is now THAT EASY - as you mentioned - everybody has different hardware.

I had to play with different kernel sources, trying vanilla, gentoo, ac, ... until I finally tested the :arrow: gaming-sources which work with SMP (although I run a single CPU system the new nvidia drivers need smp), AMP (to power off properly) and ACPI (just to proof if it is possible...) enabled (don't ask me why; - the other ones didn't work with my ataraid system or did not power off properly). I don't have to start apmd or acpid.

I have read most of the other posts as well and couldn't find another solution to the problem.

I hope you'll find time to test this as well before the "grand re-installation" - it might help.
_________________
Man who walk through airport turnstile sideways going to Bangkok...
Back to top
View user's profile Send private message
Zzoot
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jan 2003
Posts: 98
Location: Iowa.

PostPosted: Fri May 16, 2003 11:40 pm    Post subject: Gamingb SOurces...Same story Reply with quote

Hi there Dotcom...Yep- I tried the gaming sources as well....Thanks for the thought. I did actually really like the responsiveness improvement that kernel gives, but not much help on the poweroff front. The messages are still telling me acpi or apm support has not been compiled into the kernel (Which I know dang well I did!)

(grumble-grumble-grumble...)

This is a good thing, though. In the last couple of days of a "Known-to-be-doomed" install, you can try quite a lot of goofy stuff without any real fears of really borking your system... I just compiled gnome to see what it's like these days...pretty sharp actually. So it's a very informative process, at least.

Ah well...Where did I put that gentoo boot disk? See you on the other side!
Back to top
View user's profile Send private message
Zzoot
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jan 2003
Posts: 98
Location: Iowa.

PostPosted: Mon May 26, 2003 8:07 pm    Post subject: WOO-HOO!!! GOTIT!!! Reply with quote

After much blood, sweat, and re-compiling of kernels, I HAVE THE ANSWER!!!

And yes, it was odd, yet simple...

I'm now using the gaming-sources 2.4.20-r3.
I have SMP enabled and working.
I have NOT compiled ACPI at all...
I HAVE compiled in APM (checking only the use real-mode call to power off option).

With all of this, my dmesg output is still saying APM is not SMP safe, APM is disabled...

The FIX:
Append the text
Code:
apm=power-off
at the end of the kernel line in the grub.conf file.

dmesg now reads:
Quote:
apm: disabled - APM is not SMP safe (power off active)


I got to the commandline and typed in "poweroff", and it DID!!!
Woo-hoo!!!!!
Okay...Now to re-install everything else...It was worth it, though. (I also finally got the newer aicxxx scsi driver running!)
Back to top
View user's profile Send private message
Zzoot
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jan 2003
Posts: 98
Location: Iowa.

PostPosted: Tue Jul 01, 2003 9:58 pm    Post subject: Here I go replying to my own post again.... Reply with quote

Hey...One more update... as an FYI to anyone else who gets any benefit from this--

This whole fiasco doesn't seem to be entirely successful... but I think only because I actually have 2 CPUs.

Apparantly there is some truth to the whole "APM is not SMP safe" bit...

About 1 time out of 3, doing a "poweroff" or "shutdown -h now" will cause a panic...Probably because of the whole "which processor is handling what" issue.
But MOSTLY it works...and for me at least, it was more of a convenience issue, as I stuck my loud computer in the closet WAY OVER THERE with some long cables for KVM.

It's about equivalent to having a non-functioning power button on the tv's remote control. :wink:

Given the pain all this has caused me, though, I am more than satisfied to put up with occaisionally manually pushing the button...At least until I upgrade to the 2.5 or 2.6(stable?) Kernel series...I hear that actually has acpi code that WORKS...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum