Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd!!! Invalid
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
tjbates
n00b
n00b


Joined: 17 Oct 2003
Posts: 37
Location: Birmingham, UK

PostPosted: Tue Nov 11, 2003 11:44 pm    Post subject: !!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd!!! Invalid Reply with quote

i get the message:

!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd

everytime i emerge a package!

Does anyone know what is it or how to resolve to error!

Thanks,

Tom

:oops:
Back to top
View user's profile Send private message
Kloeri
Retired Dev
Retired Dev


Joined: 02 Sep 2002
Posts: 144

PostPosted: Wed Nov 12, 2003 12:00 am    Post subject: Reply with quote

This is easy to solve.

Just rm -r /var/db/pkg/sys-fs/devfsd and remerge sys-fs/devfsd.
Back to top
View user's profile Send private message
tjbates
n00b
n00b


Joined: 17 Oct 2003
Posts: 37
Location: Birmingham, UK

PostPosted: Wed Nov 12, 2003 12:40 am    Post subject: Reply with quote

i followed your exact instructions and it still does not remove the message??

ARGHHH

Tom
Back to top
View user's profile Send private message
Kloeri
Retired Dev
Retired Dev


Joined: 02 Sep 2002
Posts: 144

PostPosted: Thu Nov 13, 2003 10:22 am    Post subject: Reply with quote

Try running /var/lib/portage/bin/fix-db.py. That will scan /var/db/pkg/* for errors and will (hopefully) tell you how to fix them.

Hope this helps.
Back to top
View user's profile Send private message
phelan
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2002
Posts: 110
Location: Zürich, Switzerland

PostPosted: Thu Nov 13, 2003 11:57 am    Post subject: Reply with quote

Kloeri wrote:
Try running /var/lib/portage/bin/fix-db.py. That will scan /var/db/pkg/* for errors and will (hopefully) tell you how to fix them.


This one worked for me but the correct path was:

/usr/lib/portage/bin/fix-db.py
Back to top
View user's profile Send private message
Kloeri
Retired Dev
Retired Dev


Joined: 02 Sep 2002
Posts: 144

PostPosted: Thu Nov 13, 2003 2:08 pm    Post subject: Reply with quote

Sorry about the typo :(

Glad it worked though :D
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3829
Location: Essen, Germany

PostPosted: Mon Dec 01, 2003 12:13 pm    Post subject: Reply with quote

Moved to 'Portage & Programming' and made this one sticky.
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
ronmon
Veteran
Veteran


Joined: 15 Apr 2002
Posts: 1043
Location: Key West, FL

PostPosted: Mon Dec 01, 2003 2:50 pm    Post subject: Reply with quote

I've had a similar problem on my laptop for about two months now, the desktop and router boxes are fine. The error I get at the end of any emerge is:
Code:

>>> Auto-cleaning packages ...
['net-mail/mailbase', '0.00', 'r5'] ['net-mail/mailbase-0.00-r5', 'net-mail/mailbase-0.00-r6']
!!! COUNTER file is missing for net-mail/mailbase-0.00-r5 in /var/db.
!!! Please run /usr/lib/portage/bin/fix-db.pl or
!!! Please run /usr/lib/portage/bin/fix-db.py or
!!! remerge the package.

The perl script runs without error, but the python version returns:
Code:

ERROR: Contents file is missing from the package directory.
       'net-mail/mailbase-0.00-r5' is corrupt and should be deleted.
ERROR: COUNTER file missing from 'net-mail/mailbase-0.00-r5'.
ERROR: SLOT file missing from 'net-mail/mailbase-0.00-r5'.
       RE-MERGE this exact package version or unmerge and remerge.

net-mail/mailbase-0.00-r5: (damaged/invalid) []
   CONTENTS is missing
   COUNTER is missing
   SLOT is missing

All combinations of emerge'ing and unmerge'ing end with pretty much the same results:
Code:

!!! Unable to remove db entry for this package.
!!! It is possible that a directory is in this one. Portage will still
!!! register this package as installed as long as this directory exists.
!!! You may delete this directory with 'rm -Rf /var/db/pkg/net-mail/mailbase-0.00-r5'
!!! [Errno 2] No such file or directory: '/var/db/pkg/net-mail/mailbase-0.00-r5/CBUIL@'

No sweat, just rm -Rf the directory, right? Wrong:
Code:

rm: cannot remove directory `/var/db/pkg/net-mail/mailbase-0.00-r5': Directory not empty


Despite having followed the dozen or so threads on this topic, reading all the documentation I could find and doing some intense Googling, I'm still stuck with that fscking directory. Even booting from a rescue CD didn't work.

Fortunately, this doesn't actually break the system. But it is extremely annoying. Any ideas will be greatly appreciated.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Dec 02, 2003 2:17 pm    Post subject: Reply with quote

Probably a silly question, but have you tried rm'ing the contents of the directory? Make sure you check for hidden files, then try rm'ing the directory. Although a rm -Rf _should_ get rid of everything. Other than that have you tried moving the directory to a different name, this should at least let you re-emerge mailbase and fix the db problem. Also the inject (-i) option of emerge may be of use.

These are all things off the top of my head so may be completely wrong.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
ronmon
Veteran
Veteran


Joined: 15 Apr 2002
Posts: 1043
Location: Key West, FL

PostPosted: Tue Dec 02, 2003 9:24 pm    Post subject: Reply with quote

Thanks for the ideas tomk, but yeah, I have tried removing the contents, renaming it and moving it to another directory. Everything fails in different ways.

I've managed to unmerge the package but I'm still stuck with the hosed directory.

UPDATE: It turns out that I was sniffing up the wrong tree (pun intended) ;) . I booted again from a rescue CD and ran reiserfsck. Bingo! It found an error that could only be fixed with --rebuild-tree. The offending directory is now history.
Back to top
View user's profile Send private message
nukem996
l33t
l33t


Joined: 13 Nov 2003
Posts: 774

PostPosted: Thu Dec 04, 2003 6:03 am    Post subject: Reply with quote

Im having the same problem getting the following error
!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd
I am running an ext3 system and the power does sometimes go out around here. Do you think its a file system problem? If it is what is the command I should run to fix it and can it screw up any of my files?

Thanks
nuke
Back to top
View user's profile Send private message
Halanegri
Guru
Guru


Joined: 03 Mar 2003
Posts: 351
Location: Reykjavík, Iceland

PostPosted: Sat Dec 06, 2003 6:28 am    Post subject: Reply with quote

nukem996 wrote:
Im having the same problem getting the following error
!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd
I am running an ext3 system and the power does sometimes go out around here. Do you think its a file system problem? If it is what is the command I should run to fix it and can it screw up any of my files?

Thanks
nuke


This has already been answered above:
Code:
# /usr/lib/portage/bin/fix-db.py
Back to top
View user's profile Send private message
kKDu
Apprentice
Apprentice


Joined: 18 Aug 2003
Posts: 187

PostPosted: Sat Dec 06, 2003 10:45 am    Post subject: Reply with quote

When I run /usr/lib/portage/bin/fix-db.py, I get this:

Code:
Traceback (most recent call last):
  File "./fix-db.py", line 54, in ?
    pkgdirlist = os.listdir(pkgdir)
OSError: [Errno 20] Not a directory: '/var/db/pkg/sys-kernel/-MERGING-gentoo-dev-sources-2.6.0_beta11-r1.portage_lockfile/'


When I run /usr/lib/portage/bin/fix-db.pl, I get this:

Code:
Grabbing db contents...
Grabbing mtimes...
fix-db: fatal: couldn't open /var/db/pkg/x11-themes/gtk-engines-mgicchikn-1.0.0/CONTENTS: No such file or directory


Also I have this problem: https://forums.gentoo.org/viewtopic.php?t=112522
Back to top
View user's profile Send private message
nukem996
l33t
l33t


Joined: 13 Nov 2003
Posts: 774

PostPosted: Sun Dec 07, 2003 12:30 am    Post subject: Reply with quote

I finally fixed everything but this

/usr/lib/portage/bin/fix-db.pl
Grabbing db contents...
Grabbing mtimes...
fix-db: fatal: insufficient data for net-print/foomatic-3.0.0

Remove this package's directory from /var/db/pkg to fix this, then start this
script again. If everything worked correctly, you must remerge
net-print/foomatic-3.0.0 to not mess up any dependencies.

I remerged foomatic but I still get this error. How would I fix it?
Back to top
View user's profile Send private message
phelan
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2002
Posts: 110
Location: Zürich, Switzerland

PostPosted: Mon Dec 08, 2003 8:41 am    Post subject: Reply with quote

kKDu wrote:
When I run /usr/lib/portage/bin/fix-db.py, I get this:

Code:
Traceback (most recent call last):
  File "./fix-db.py", line 54, in ?
    pkgdirlist = os.listdir(pkgdir)
OSError: [Errno 20] Not a directory: '/var/db/pkg/sys-kernel/-MERGING-gentoo-dev-sources-2.6.0_beta11-r1.portage_lockfile/'

[/code]


I had the same problem. I just deleted the "-MERGING-"-files that caused an error.
Back to top
View user's profile Send private message
Dalcius
n00b
n00b


Joined: 05 Dec 2002
Posts: 37
Location: Austin, TX

PostPosted: Tue Dec 09, 2003 5:59 pm    Post subject: Reply with quote

To add to the mess...

Quote:

cmillard root # /usr/lib/portage/bin/fix-db.py
Traceback (most recent call last):
File "/usr/lib/portage/bin/fix-db.py", line 54, in ?
pkgdirlist = os.listdir(pkgdir)
OSError: [Errno 20] Not a directory: '/var/db/pkg/dev-libs/-MERGING-openssl-0.9.7c.portage_lockfile/'


I ran the perl script (/usr/lib/portage/bin/fix-db.pl) and it seemed to work fine.
I have only gotten that invalid db entry once, though, at the end of my upgrade to portage -R18.
_________________
-Dalcius
Back to top
View user's profile Send private message
Promit
Guru
Guru


Joined: 15 Nov 2003
Posts: 344

PostPosted: Tue Dec 09, 2003 11:24 pm    Post subject: Reply with quote

Anybody know why this happens?
_________________
Windows, Linux, whatever.
Back to top
View user's profile Send private message
gOA-pSY
n00b
n00b


Joined: 20 Jun 2003
Posts: 6

PostPosted: Fri Dec 12, 2003 1:21 pm    Post subject: Re: Anybody know why this happens? Reply with quote

while emerging/compiling nessus, my ssh connection to the gentoo box got broken. therefore the emerging process was aborted resulting in this error with the "-MERGING-" and lock files in /var/db/pkg
Back to top
View user's profile Send private message
binkley
n00b
n00b


Joined: 17 Dec 2002
Posts: 37
Location: Houston, TX

PostPosted: Sat Dec 13, 2003 6:37 pm    Post subject: At last Reply with quote

phelan wrote:
Kloeri wrote:
Try running /var/lib/portage/bin/fix-db.py. That will scan /var/db/pkg/* for errors and will (hopefully) tell you how to fix them.


This one worked for me but the correct path was:

/usr/lib/portage/bin/fix-db.py


This is no go for me. I've had the complaint about sys-fs/devfsd for months to my great annoyance so when I found this thread I was pretty happy. But fix-db.py produces no output beyond several empty lines. I also tried the trick of removing /var/db/pkd/sys-fs/devfsd and reemerging the package. Now that did work so I'm pretty happy about it.

I wonder why fix-db didn't report problems?
Back to top
View user's profile Send private message
junco
n00b
n00b


Joined: 09 Jun 2003
Posts: 41

PostPosted: Mon Dec 29, 2003 4:36 pm    Post subject: Reply with quote

I've tried both of the aforementioned solutions to this and still get the same problems. it doesn't happen with every package i emerge, but most. i've also tried removing the /var/.../devfsd directory, running the fix-db script, and then emerge devfsd. if anyone else has any ideas it would be really appreciated.

or perhaps maybe just someone knows if this error message is at all damaging ? (to dependncy trees or whatnot)... i wouldn't mind it so much if i knew it was harmless. thanks.

Matt
Back to top
View user's profile Send private message
pranyi
Apprentice
Apprentice


Joined: 06 Mar 2003
Posts: 293
Location: Germany

PostPosted: Tue Dec 30, 2003 11:55 pm    Post subject: Reply with quote

I had the same problem.

Reemerging devfsd helped.
Back to top
View user's profile Send private message
pranyi
Apprentice
Apprentice


Joined: 06 Mar 2003
Posts: 293
Location: Germany

PostPosted: Wed Dec 31, 2003 2:14 am    Post subject: Reply with quote

I have to correct myself:

It helped for a while, but the bug came back :(
Back to top
View user's profile Send private message
TheCoop
Veteran
Veteran


Joined: 15 Jun 2002
Posts: 1814
Location: Where you least expect it

PostPosted: Wed Dec 31, 2003 3:38 pm    Post subject: Reply with quote

I've got:
Code:
nervada simon # emerge -pUD world
>>> --upgradeonly implies --update... adding --update to options.

These are the packages that I would merge, in order:

!!! Invalid db entry: /var/db/pkg/./x11-plugins
!!! Invalid db entry: /var/db/pkg/./sys-kernel
!!! Invalid db entry: /var/db/pkg/./games-puzzle
!!! Invalid db entry: /var/db/pkg/./x11-base
!!! Invalid db entry: /var/db/pkg/./x11-libs
!!! Invalid db entry: /var/db/pkg/./x11-misc
!!! Invalid db entry: /var/db/pkg/./dev-games
!!! Invalid db entry: /var/db/pkg/./games-strategy
!!! Invalid db entry: /var/db/pkg/./dev-tcltk
!!! Invalid db entry: /var/db/pkg/./x11-terms
!!! Invalid db entry: /var/db/pkg/./app-admin
!!! Invalid db entry: /var/db/pkg/./app-dicts
!!! Invalid db entry: /var/db/pkg/./app-crypt
!!! Invalid db entry: /var/db/pkg/./app-games
!!! Invalid db entry: /var/db/pkg/./x11-themes
!!! Invalid db entry: /var/db/pkg/./gnome-base
!!! Invalid db entry: /var/db/pkg/./app-arch
!!! Invalid db entry: /var/db/pkg/./app-misc
!!! Invalid db entry: /var/db/pkg/./app-text
!!! Invalid db entry: /var/db/pkg/./net-firewall
!!! Invalid db entry: /var/db/pkg/./app-portage
!!! Invalid db entry: /var/db/pkg/./sys-devel
!!! Invalid db entry: /var/db/pkg/./dev-db
!!! Invalid db entry: /var/db/pkg/./kde-base
!!! Invalid db entry: /var/db/pkg/./media-gfx
!!! Invalid db entry: /var/db/pkg/./net-dns
!!! Invalid db entry: /var/db/pkg/./net-ftp
!!! Invalid db entry: /var/db/pkg/./net-irc
!!! Invalid db entry: /var/db/pkg/./net-p2p
!!! Invalid db entry: /var/db/pkg/./net-nds
!!! Invalid db entry: /var/db/pkg/./net-www
!!! Invalid db entry: /var/db/pkg/./media-libs
!!! Invalid db entry: /var/db/pkg/./games-roguelike
!!! Invalid db entry: /var/db/pkg/./sys-apps
!!! Invalid db entry: /var/db/pkg/./sys-boot
!!! Invalid db entry: /var/db/pkg/./sys-libs
!!! Invalid db entry: /var/db/pkg/./app-emulation
!!! Invalid db entry: /var/db/pkg/./net-fs
!!! Invalid db entry: /var/db/pkg/./net-im
!!! Invalid db entry: /var/db/pkg/./net-libs
!!! Invalid db entry: /var/db/pkg/./net-mail
!!! Invalid db entry: /var/db/pkg/./net-misc
!!! Invalid db entry: /var/db/pkg/./net-zope
!!! Invalid db entry: /var/db/pkg/./net-print
!!! Invalid db entry: /var/db/pkg/./app-office
!!! Invalid db entry: /var/db/pkg/./x11-wm
!!! Invalid db entry: /var/db/pkg/./dev-java
!!! Invalid db entry: /var/db/pkg/./dev-lang
!!! Invalid db entry: /var/db/pkg/./dev-libs
!!! Invalid db entry: /var/db/pkg/./dev-perl
!!! Invalid db entry: /var/db/pkg/./dev-util
!!! Invalid db entry: /var/db/pkg/./dev-python
!!! Invalid db entry: /var/db/pkg/./app-benchmarks
!!! Invalid db entry: /var/db/pkg/./net-wireless
!!! Invalid db entry: /var/db/pkg/./app-editors
!!! Invalid db entry: /var/db/pkg/./sys-fs
!!! Invalid db entry: /var/db/pkg/./app-shells
!!! Invalid db entry: /var/db/pkg/./media-sound
!!! Invalid db entry: /var/db/pkg/./media-video
!!! Invalid db entry: /var/db/pkg/./gnome-extra
!!! Invalid db entry: /var/db/pkg/./app-cdr
!!! Invalid db entry: /var/db/pkg/./app-doc
!!! Invalid db entry: /var/db/pkg/./app-sci
!!! Invalid db entry: /var/db/pkg/./games-kids
!!! Invalid db entry: /var/db/pkg/./games-misc
!!! Invalid db entry: /var/db/pkg/./games-util
!!! Invalid db entry: /var/db/pkg/./games-emulation
!!! Invalid db entry: /var/db/pkg/./media-plugins
!!! Invalid db entry: /var/db/pkg/./media-tv
!!! Invalid db entry: /var/db/pkg/./games-simulation
!!! Invalid db entry: /var/db/pkg/./net-analyzer
!!! Invalid db entry: /var/db/pkg/./games-action
!!! Invalid db entry: /var/db/pkg/./games-fps
!!! Invalid db entry: /var/db/pkg/./games-rpg
Calculating world dependencies ...done!
[ebuild     UD] dev-python/PyOpenGL-2.0.0.44 [2.0.0.44-r1]
[ebuild     U ] net-nds/portmap-5b-r8 [5b-r7]

nervada simon #

Help?
_________________
95% of all computer errors occur between chair and keyboard (TM)

"One World, One web, One program" - Microsoft Promo ad.
"Ein Volk, Ein Reich, Ein Führer" - Adolf Hitler

Change the world - move a rock
Back to top
View user's profile Send private message
alinv
Guru
Guru


Joined: 19 Nov 2002
Posts: 395
Location: Bucharest

PostPosted: Tue Jan 06, 2004 6:19 pm    Post subject: Reply with quote

What about this one:
Code:
emerge something
...........................................
>>> Auto-cleaning packages ...
!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd
!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd
!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd
!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd

*sys-fs ? Nice :?
_________________
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.
S.B.
Back to top
View user's profile Send private message
nathanm
n00b
n00b


Joined: 04 May 2003
Posts: 1
Location: Minneapolis, MN

PostPosted: Wed Jan 07, 2004 1:49 pm    Post subject: Reply with quote

kKDu wrote:
When I run /usr/lib/portage/bin/fix-db.py, I get this:

Code:
Traceback (most recent call last):
  File "./fix-db.py", line 54, in ?
    pkgdirlist = os.listdir(pkgdir)
OSError: [Errno 20] Not a directory: '/var/db/pkg/sys-kernel/-MERGING-gentoo-dev-sources-2.6.0_beta11-r1.portage_lockfile/'


When I run /usr/lib/portage/bin/fix-db.pl, I get this:

Code:
Grabbing db contents...
Grabbing mtimes...
fix-db: fatal: couldn't open /var/db/pkg/x11-themes/gtk-engines-mgicchikn-1.0.0/CONTENTS: No such file or directory


Also I have this problem: https://forums.gentoo.org/viewtopic.php?t=112522


The same thing happened to me (don't remember which packages though). The problem was that some package names weren't the same as the entry in /var/db/pkg/, so my solution was to create symlinks every time they (both fix-db.py & fix-db.pl) encountered a problem until it ran through completely without dying. Not the ideal fix, but it worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum