Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
i915 no dual monitor
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Fri Dec 16, 2011 8:28 am    Post subject: i915 no dual monitor Reply with quote

Hello,
on my new notebook I have an intel integrated graphics card.
Code:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Actually it's working with i915 module (lsmod tells the module is loaded), but without KMS.
Code:
lsmod | grep i915
i915                  502411  0
drm_kms_helper         25630  1 i915
drm                   187399  2 i915,drm_kms_helper
i2c_algo_bit            4756  1 i915
cfbcopyarea             3061  1 i915
cfbimgblt               2212  1 i915
cfbfillrect             3089  1 i915
video                  12032  1 i915

If I enable KMS I obtain a freezed black screen after kdm login.
But the real problem is that no external screen is detected.
If I connect the HDMI cable no event is reported on dmesg and xrandr still reports only default output.
Code:
xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080       0.0*
   1280x1024       0.0 
   1024x768        0.0 
   800x600         0.0 
   640x480         0.0

I googled a lot before reporting the problem here, but on every page I read they have xrandr recognizing the output or they use a custom xorg.conf.
I tryed with xorg.conf, but every output name I try it results as not used...
Code:
[    21.529] (WW) VESA(0): Option "Monitor-DVI-0" is not used
[    21.529] (WW) VESA(0): Option "Monitor-DVI-1" is not used

What am I missing?
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Fri Dec 16, 2011 10:02 am    Post subject: Re: i915 no dual monitor Reply with quote

dracula1985 wrote:
What am I missing?

KMS. The Intel X driver won't work without it. Because you've deactivated KMS, you're using VESA now, so of course no dual-screen.
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Fri Dec 16, 2011 10:49 am    Post subject: Re: i915 no dual monitor Reply with quote

Gusar wrote:
dracula1985 wrote:
What am I missing?

KMS. The Intel X driver won't work without it. Because you've deactivated KMS, you're using VESA now, so of course no dual-screen.

Ok, but with KMS enabled I have black screen after KDE loading...
On my old PC I had the same problem with the radeon drivers, but the problem was the opposite, I solved enabling KMS by default.
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14716

PostPosted: Fri Dec 16, 2011 11:08 pm    Post subject: Reply with quote

Do you also get a black screen if you enable KMS with a minimal X configuration, such as just an xterm and no window manager?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2875
Location: Bay Area, CA

PostPosted: Sat Dec 17, 2011 4:22 am    Post subject: Re: i915 no dual monitor Reply with quote

dracula1985 wrote:
Gusar wrote:
dracula1985 wrote:
What am I missing?

KMS. The Intel X driver won't work without it. Because you've deactivated KMS, you're using VESA now, so of course no dual-screen.

Ok, but with KMS enabled I have black screen after KDE loading...
This is the problem you should try to troubleshoot and address. The dual monitor thing will fall in place once you fix this.

Make sure kernel and user space are latest as far as graphics is concerned. This means typically, look at pckages: gentoo/vanilla-sources, libdrm, xf86-video-intel, mesa, xorg-server. A black screen is typically an incompatibility. Don't be afraid to go ~amd64 for these packages if you need to. I use ~amd64 and have all these packages working in a dual display setting.
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Sat Dec 17, 2011 11:40 am    Post subject: Reply with quote

Hu wrote:
Do you also get a black screen if you enable KMS with a minimal X configuration, such as just an xterm and no window manager?

Yes, using a minimal xsession KMS works fine
Code:
xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080      60.0*+   40.0 
   1400x1050      60.0 
   1280x1024      60.0 
   1280x960       60.0 
   1024x768       60.0 
   800x600        60.3     56.2 
   640x480        59.9 
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)

_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Sat Dec 17, 2011 11:48 am    Post subject: Re: i915 no dual monitor Reply with quote

devsk wrote:
dracula1985 wrote:
Gusar wrote:
dracula1985 wrote:
What am I missing?

KMS. The Intel X driver won't work without it. Because you've deactivated KMS, you're using VESA now, so of course no dual-screen.

Ok, but with KMS enabled I have black screen after KDE loading...
This is the problem you should try to troubleshoot and address. The dual monitor thing will fall in place once you fix this.

Make sure kernel and user space are latest as far as graphics is concerned. This means typically, look at pckages: gentoo/vanilla-sources, libdrm, xf86-video-intel, mesa, xorg-server. A black screen is typically an incompatibility. Don't be afraid to go ~amd64 for these packages if you need to. I use ~amd64 and have all these packages working in a dual display setting.

I'm already in ~amd64:
Code:
emerge --info
Portage 2.1.10.41 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r1, 3.1.5-gentoo x86_64)
=================================================================
System uname: Linux-3.1.5-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Fri, 16 Dec 2011 08:00:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.7
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1-r1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula dlj-1.1 PUEL AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mcx16 -msahf -maes -mpclmul -mpopcnt -mavx --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=generic -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -mcx16 -msahf -maes -mpclmul -mpopcnt -mavx --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=generic -O2"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="assume-digests binpkg-logs candy distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl addbookmarks alias alsa amd64 amr amuled apache2 audiofile autoreplace avi bash-completion berkdb bluetooth boost branding browserplugin bzip2 cdaudio cdb cdda cddb cdinstall cdio cdparanoia cdr cleartype cli clucene codecs connectionstatus contactnotes cracklib crypt css ctype cups curl custom-optimization cxx dbus decibel dga divx4linux dlloader dri dts dv dvb dvd dvdr dvdread edl emul-linux-x86 encode exif extensions faad fam fame ffmpeg filter firefox flac fontconfig fortran ftp gadu gcj gd gdbm ggi gif gimp gimpprint git glib glitz gnutls gpm groupwise gstreamer highlight history hou iconv idn ieee1394 imagemagick imap imlib inquisitio insecure-drivers ipv6 irc ithreads jack java javascript jingle jpeg jpeg2k kde lame lcd lcdfilter libcaca libnotify live lm_sensors lzo mad matroska messenger mikmod mime mjpeg mmx mmxext modules monkey moodbar mozbranding mozdevelop mozilla mp3 mp4 mpeg msn msword mudflap multilib musepack musicbrainz mysql mysqli mythtv ncurses nepomuk netmeeting nls nodrm nowin nowlistening nptl nptlonly nsplugin objc objc++ objc-gc offensive ogg oggvorbis opengl openmp pam pcre pdf phonon php plasma png ppds pppd qt qt-copy qt3support qt4 quicktime rar rdesktop readline remote replytolist samba sametime scanner sdl semantic-desktop sensord session slp smp sms sndfile sou sound speex sqlite sse sse2 ssl startup-notification statistics subversion svg sysfs taglib tcpd telepathy texteffect tga theora threads tidy tiff tokenizer translator truetype truetype-fonts udev unicode upnp usb v4l v4l2 vcd video videos visualization vnc vorbis wavpack webdav webpresence wifi winpopup wlm xanim xattr xcb xcomposite xine xinerama xml xmlpatterns xmlreader xmlwriter xorg xscreensaver xv xvid xvmc yahoo zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


The packages you mentioned:
Code:
emerge -pv gentoo-sources libdrm xf86-video-intel mesa xorg-server

These are the packages that would be merged, in order:

Calculating dependencies              ... done!
[ebuild   R    ] x11-libs/libdrm-2.4.29  USE="libkms -static-libs" VIDEO_CARDS="intel -nouveau -radeon -vmware" 0 kB                                           
[ebuild   R    ] media-libs/mesa-7.11.2  USE="classic egl gallium llvm nptl shared-glapi -bindist -debug -gbm -gles -motif -openvg -osmesa -pax_kernel -pic (-selinux) -shared-dricore" VIDEO_CARDS="intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -tdfx -via -vmware" 0 kB                                           
[ebuild   R    ] sys-kernel/gentoo-sources-3.1.5  USE="-build -deblob -symlink" 0 kB
[ebuild   R    ] x11-base/xorg-server-1.11.2-r2  USE="ipv6 nptl udev xorg -dmx -doc -kdrive -minimal -static-libs -tslib -xnest -xvfb" 0 kB                     
[ebuild   R    ] x11-drivers/xf86-video-intel-2.17.0-r3  USE="dri -sna" 0 kB

Total: 5 packages (5 reinstalls), Size of downloads: 0 kB


Maybe I'm missing some firmware package?
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Sat Dec 17, 2011 12:02 pm    Post subject: Re: i915 no dual monitor Reply with quote

dracula1985 wrote:
Maybe I'm missing some firmware package?

Nope, intel graphics don't require firmware. If a minimal X works, then I'd say the issue is in KDE somewhere.
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Sat Dec 17, 2011 12:40 pm    Post subject: Re: i915 no dual monitor Reply with quote

Gusar wrote:
dracula1985 wrote:
Maybe I'm missing some firmware package?

Nope, intel graphics don't require firmware. If a minimal X works, then I'd say the issue is in KDE somewhere.

Actually I solved disabling KDE desktop effects.
I'll continue searching for a better solution...
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Sat Dec 17, 2011 5:34 pm    Post subject: Reply with quote

I've found found another italian user with my problem: https://forums.gentoo.org/viewtopic-t-904846.html?sid=c3432474cb1a18e0d055345b25df47b1
It seems related only to >=kde-4.7.3 (I have kde-4.7.4).
I'll open a bug on the bugtracker
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Mon Dec 19, 2011 8:23 am    Post subject: Reply with quote

Disabling desktop effects isn't really a solution, some actions still randomly cause xorg to freeze.
For now it seems only minimizing/maximizing the skype window...

I'll try this solution: https://wiki.archlinux.org/index.php/Intel#X_freeze.2Fcrash_with_intel_driver
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Mon Dec 19, 2011 8:48 am    Post subject: Reply with quote

Even worse, Xorg freezed switching focus between windows...
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Mon Dec 19, 2011 1:08 pm    Post subject: Reply with quote

I'm trying the NoAccel option, but I can't get any result, Xorg.0.log reports:
Code:
[    25.112] (WW) intel(0): Option "NoAccel" is not used

_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum