Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[VMWARE] failed to load service (I think it's a network pb)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Thu Apr 09, 2009 4:50 pm    Post subject: [VMWARE] failed to load service (I think it's a network pb) Reply with quote

Hi everyone

I try to make VMwareWorkstation 6.5.2.156735 work but I cannot start the /etc/init.d/vmware service correctly and I don't know why !

I'm running a 64 bit Gentoo with the 2.6.27-gentoo-r8 kernel.

Quote:
* Starting VMware services: [ ok ]
* Virtual machine monitor [ !! ]
* Virtual machine communication interface [ !! ]
* Blocking file system [ !! ]
* Virtual ethernet [ !! ]


Quote:
app-emulation/vmware-modules
Available versions: 1.0.0.15-r1 1.0.0.15-r2 1.0.0.23 {kernel_linux}
Installed versions: 1.0.0.23(18:20:20 09/04/2009)(kernel_linux)
Homepage: http://www.vmware.com/
Description: Modules for Vmware Programs




There is absolutely nothing in dmesg :

Quote:
NVRM: loading NVIDIA UNIX x86_64 Kernel Module 180.44 Tue Mar 24 05:46:32 PST 2009
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda3, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting. Commit interval 5 seconds
EXT3 FS on sdb1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
sky2 eth0: enabling interface
sky2 eth0: Link is up at 1000 Mbps, full duplex, flow control both
Adding 1502068k swap on /dev/sda2. Priority:-1 extents:1 across:1502068k
NET: Registered protocol family 10
eth0: no IPv6 routers present
process `skype' is using obsolete setsockopt SO_BSDCOMPAT


lsmod :

Quote:
# lsmod
Module Size Used by
acpi_cpufreq 8144 0
ipv6 276904 20
bridge 44112 0
stp 2948 1 bridge
snd_seq_midi 7744 0
snd_seq_dummy 3460 0
snd_seq_oss 34688 0
snd_seq_midi_event 7616 2 snd_seq_midi,snd_seq_oss
snd_seq 56736 6 snd_seq_midi,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 43968 0
snd_mixer_oss 16896 2 snd_pcm_oss
snd_virtuoso 11076 10
nvidia 8113752 26
snd_oxygen_lib 33536 1 snd_virtuoso
snd_pcm 81416 5 snd_pcm_oss,snd_oxygen_lib
snd_timer 23184 5 snd_seq,snd_pcm
snd_page_alloc 8848 1 snd_pcm
snd_mpu401_uart 8384 1 snd_oxygen_lib
snd_rawmidi 23680 2 snd_seq_midi,snd_mpu401_uart
snd_seq_device 7572 5 snd_seq_midi,snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd 64136 24 snd_seq_dummy,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_virtuoso,snd_oxygen_lib, \
...snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device


There is nothing in syslog / kern.log / messages


Quote:
# cd /opt/vmware/workstation/bin
#./vmware-networks --status
Bridge networking on vmnet0 is not running
DHCP service on vmnet1 is not running
Hostonly virtual adapter on vmnet1 is disabled
DHCP service on vmnet8 is not running
NAT service on vmnet8 is not running
Hostonly virtual adapter on vmnet8 is disabled
Network detection service is not running
Some/All of the configured services are not running


Quote:
# ls /dev/vm*
ls: ne peut accéder /dev/vm*: Aucun fichier ou dossier de ce type


If I manually insert the module "vmmon" "vmnet" and "vmci" the virtual machine will boot fine, but without network.


Quote:

# ls /dev/vm* -l
crw-rw---- 1 root root 10, 59 avril 9 18:45 /dev/vmci
crw-rw---- 1 root vmware 10, 165 avril 9 18:45 /dev/vmmon
# lsmod
Module Size Used by
vmci 52584 0
vmnet 36900 0
vmmon 71856 0
acpi_cpufreq 8144 0
ipv6 276904 20
bridge 44112 0
stp 2948 1 bridge
snd_seq_midi 7744 0
snd_seq_dummy 3460 0
snd_seq_oss 34688 0
snd_seq_midi_event 7616 2 snd_seq_midi,snd_seq_oss
snd_seq 56736 6 snd_seq_midi,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 43968 0
snd_mixer_oss 16896 2 snd_pcm_oss
snd_virtuoso 11076 10
nvidia 8113752 26
snd_oxygen_lib 33536 1 snd_virtuoso
snd_pcm 81416 5 snd_pcm_oss,snd_oxygen_lib
snd_timer 23184 5 snd_seq,snd_pcm
snd_page_alloc 8848 1 snd_pcm
snd_mpu401_uart 8384 1 snd_oxygen_lib
snd_rawmidi 23680 2 snd_seq_midi,snd_mpu401_uart
snd_seq_device 7572 5 snd_seq_midi,snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd 64136 24 snd_seq_dummy,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_virtuoso,snd_oxygen_lib, \
...snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device



Quote:
emerge --config vmware-workstation


Configuring pkg...

Stopped all configured services on all networks
Backed up existing network settings to backup file "/tmp/vmware.Esqf2w"
Restored network settings




I have already try to change the kernel (-> 2.6.28. ), to install/reinstall ALL vmware but it's always the same...

Does anybody have a little idea please ? it will be greatly appreciate !


gaga

Mod edit: Wrapped long lines. --timeBandit
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Fri Apr 10, 2009 5:50 am    Post subject: Do you have the build log Reply with quote

Do you have the build log from when you emerged the workstation ebuild? It smells like the build of the kernel modules didn't go well.

I recently installed a vmware server 2.0 on that exact kernel on a Core 2 Duo box without any problems. However I did a manual install to /usr/local using the vmware installation script from their generic tarball.
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Fri Apr 10, 2009 7:52 am    Post subject: Reply with quote

Hi

Quote:
# emerge vmware-workstation
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 2) app-emulation/vmware-modules-1.0.0.23
* vmware-modules-1.0.0.23.amd64.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found sources for kernel version:
* 2.6.27-gentoo-r8_Shuttle_SP35P2_Pro
>>> Unpacking source...
>>> Unpacking vmware-modules-1.0.0.23.amd64.tar.bz2 to /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work
>>> Unpacking ./vmware-modules-1.0.0.23/vmmon.tar to /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work
* Converting vmmon-only/Makefile to use M= instead of SUBDIRS= ... [ ok ]
>>> Unpacking ./vmware-modules-1.0.0.23/vmnet.tar to /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work
* Converting vmnet-only/Makefile to use M= instead of SUBDIRS= ... [ ok ]
>>> Unpacking ./vmware-modules-1.0.0.23/vmblock.tar to /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work
* Converting vmblock-only/Makefile to use M= instead of SUBDIRS= ... [ ok ]
>>> Unpacking ./vmware-modules-1.0.0.23/vmci.tar to /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work
* Converting vmci-only/Makefile to use M= instead of SUBDIRS= ... [ ok ]
>>> Unpacking ./vmware-modules-1.0.0.23/vsock.tar to /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work
* Converting vsock-only/Makefile to use M= instead of SUBDIRS= ... [ ok ]
* Applying 1.0.0.23-makefile-kernel-dir.patch ... [ ok ]
>>> Source unpacked in /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work
>>> Compiling source in /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work ...
* Preparing vmmon module
make -j5 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= auto-build VMWARE_VER=VME_V65 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/usr/src/linux
Using 2.6.x kernel build system.
make -C /usr/src/linux M=$PWD SRCROOT=$PWD/. modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
make[1]: AVERTISSEMENT: serveur de tâches n'est pas disponible: utilisation de -j1. Ajouter « + » à la règle parent du make.
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/linux/driver.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/linux/driverLog.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/linux/hostif.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/common/comport.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/common/cpuid.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/common/hashFunc.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/common/memtrack.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/common/phystrack.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/common/task.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/common/vmx86.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/vmcore/moduleloop.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/vmmon.o
Building modules, stage 2.
MODPOST 1 modules
CC /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/vmmon.mod.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmmon-only/vmmon.ko
make[1]: quittant le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
cp -f vmmon.ko ./../vmmon.o
* Preparing vmnet module
make -j5 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= auto-build VMWARE_VER=VME_V65 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/usr/src/linux
Using 2.6.x kernel build system.
make -C /usr/src/linux M=$PWD SRCROOT=$PWD/. modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
make[1]: AVERTISSEMENT: serveur de tâches n'est pas disponible: utilisation de -j1. Ajouter « + » à la règle parent du make.
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/driver.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/hub.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/userif.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/netif.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/bridge.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/filter.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/procfs.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/smac_compat.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/smac.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/vnetEvent.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/vnetUserListener.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/vmnet.o
Building modules, stage 2.
MODPOST 1 modules
CC /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/vmnet.mod.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmnet-only/vmnet.ko
make[1]: quittant le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
cp -f vmnet.ko ./../vmnet.o
* Preparing vmblock module
make -j5 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= auto-build VMWARE_VER=VME_V65 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/usr/src/linux
Using 2.6.x kernel build system.
make -C /usr/src/linux M=$PWD SRCROOT=$PWD/. modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
make[1]: AVERTISSEMENT: serveur de tâches n'est pas disponible: utilisation de -j1. Ajouter « + » à la règle parent du make.
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/block.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/control.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/dbllnklst.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/dentry.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/file.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/filesystem.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/inode.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/module.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/stubs.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/linux/super.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/vmblock.o
Building modules, stage 2.
MODPOST 1 modules
CC /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/vmblock.mod.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmblock-only/vmblock.ko
make[1]: quittant le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
cp -f vmblock.ko ./../vmblock.o
* Preparing vmci module
make -j5 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= auto-build VMWARE_VER=VME_V65 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/usr/src/linux
Using 2.6.x kernel build system.
make -C /usr/src/linux M=$PWD SRCROOT=$PWD/. modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
make[1]: AVERTISSEMENT: serveur de tâches n'est pas disponible: utilisation de -j1. Ajouter « + » à la règle parent du make.
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/linux/driver.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/linux/driverLog.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/linux/vmciKernelIf.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciContext.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciDatagram.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciDriver.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciDs.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciEvent.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciGroup.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciHashtable.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciProcess.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciQueuePair.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/common/vmciResource.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/vmci.o
Building modules, stage 2.
MODPOST 1 modules
CC /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/vmci.mod.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vmci-only/vmci.ko
make[1]: quittant le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
cp -f vmci.ko ./../vmci.o
* Preparing vsock module
make -j5 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= auto-build VMWARE_VER=VME_V65 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/usr/src/linux
Using 2.6.x kernel build system.
make -C /usr/src/linux M=$PWD SRCROOT=$PWD/. modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
make[1]: AVERTISSEMENT: serveur de tâches n'est pas disponible: utilisation de -j1. Ajouter « + » à la règle parent du make.
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/linux/af_vsock.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/linux/driverLog.o
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/linux/util.o
/dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/linux/util.c: In function ‘VSockVmciLogPkt’:
/dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/linux/util.c:157: attention : le format n'est pas une chaîne littérale et pas d'argument de format
CC [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/linux/vsockAddr.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/vsock.o
Building modules, stage 2.
MODPOST 1 modules
CC /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/vsock.mod.o
LD [M] /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/work/vsock-only/vsock.ko
make[1]: quittant le répertoire « /usr/src/linux-2.6.27-gentoo-r8 »
cp -f vsock.ko ./../vsock.o
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/vmware-modules-1.0.0.23

>>> Install vmware-modules-1.0.0.23 into /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/image/ category app-emulation
* Installing vmmon module
* Installing vmnet module
* Installing vmblock module
* Installing vmci module
* Installing vsock module
>>> Completed installing vmware-modules-1.0.0.23 into /dev/shm/portage/app-emulation/vmware-modules-1.0.0.23/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment
lib/modules/2.6.27-gentoo-r8_Shuttle_SP35P2_Pro/vsock.ko
lib/modules/2.6.27-gentoo-r8_Shuttle_SP35P2_Pro/vmci.ko
lib/modules/2.6.27-gentoo-r8_Shuttle_SP35P2_Pro/vmblock.ko
lib/modules/2.6.27-gentoo-r8_Shuttle_SP35P2_Pro/vmnet.ko
lib/modules/2.6.27-gentoo-r8_Shuttle_SP35P2_Pro/vmmon.ko
>>> Done.

>>> Installing app-emulation/vmware-modules-1.0.0.23
* Updating module dependencies for 2.6.27-gentoo-r8_Shuttle_SP35P2_Pro ... [ ok ]
* Adding module to moduledb.

>>> Emerging (2 of 2) app-emulation/vmware-workstation-6.5.2.156735

* VMware-Workstation-6.5.2-156735.x86_64.bundle RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
>>> Unpacking source...
Unbundling /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/distdir/VMware-Workstation-6.5.2-156735.x86_64.bundle
* Applying vmware-workstation-6.5.2.156735-installer.patch ... [ ok ]
>>> Source unpacked in /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work
>>> Compiling source in /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/vmware-workstation-6.5.2.156735

>>> Install vmware-workstation-6.5.2.156735 into /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/image/ category app-emulation
Traceback (most recent call last):
File "/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work/payload/install/vmware-installer/vmware-installer.py", line 17, in <module>
from vmis.core.component import ComponentTypes
File "/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work/payload/install/vmware-installer/vmis/core/component.py", line 11, in <module>
from lxml import etree
ImportError: No module named lxml
* VMware installation seems to have rolled back.
* Please include the contents of /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work/vmware-installer.log
* in any bug reports you file.
*
* ERROR: app-emulation/vmware-workstation-6.5.2.156735 failed.
* Call stack:
* ebuild.sh, line 48: Called src_install
* environment, line 2708: Called die
* The specific snippet of code:
* die "VMware installation rolled back.";
* The die message:
* VMware installation rolled back.

*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/build.log'.
* The ebuild environment file is located at '/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/environment'.
*

>>> Failed to emerge app-emulation/vmware-workstation-6.5.2.156735, Log file:

>>> '/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/build.log'

* Messages for package app-emulation/vmware-workstation-6.5.2.156735:

* VMware installation seems to have rolled back.
* Please include the contents of /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work/vmware-installer.log
* in any bug reports you file.
*
* ERROR: app-emulation/vmware-workstation-6.5.2.156735 failed.
* Call stack:
* ebuild.sh, line 48: Called src_install
* environment, line 2708: Called die
* The specific snippet of code:
* die "VMware installation rolled back.";
* The die message:
* VMware installation rolled back.
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/build.log'.
* The ebuild environment file is located at '/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/environment'.
*

* GNU info directory index is up-to-date.


O_o !! Now I cannot build vmware-workstation.... I just update python from 2.5 to 2.6...

Quote:
# cat temp/build.log
>>> Unpacking source...
Unbundling /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/distdir/VMware-Workstation-6.5.2-156735.x86_64.bundle
* Applying vmware-workstation-6.5.2.156735-installer.patch ... [ ok ]
>>> Source unpacked in /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work
>>> Compiling source in /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/vmware-workstation-6.5.2.156735

>>> Install vmware-workstation-6.5.2.156735 into /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/image/ category app-emulation
Traceback (most recent call last):
File "/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work/payload/install/vmware-installer/vmware-installer.py", line 17, in <module>
from vmis.core.component import ComponentTypes
File "/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work/payload/install/vmware-installer/vmis/core/component.py", line 11, in <module>
from lxml import etree
ImportError: No module named lxml
* VMware installation seems to have rolled back.
* Please include the contents of /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work/vmware-installer.log
* in any bug reports you file.
*
* ERROR: app-emulation/vmware-workstation-6.5.2.156735 failed.
* Call stack:
* ebuild.sh, line 48: Called src_install
* environment, line 2708: Called die
* The specific snippet of code:
* die "VMware installation rolled back.";
* The die message:
* VMware installation rolled back.
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/build.log'.
* The ebuild environment file is located at '/dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/environment'.



About the module, I don't see any error during the building... and I cannot found the log for vmware-modules.


Now I will try to resolve the problem with python

thank you
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Fri Apr 10, 2009 8:02 am    Post subject: Reply with quote

I forgot the emerge --info :

Quote:
# emerge --info
Portage 2.1.6.11 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.27-gentoo-r8_Shuttle_SP35P2_Pro x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.0.0
Timestamp of tree: Thu, 09 Apr 2009 16:00:17 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash: 4.0_p10-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python: 2.4.4-r13, 2.5.4-r2, 2.6.1-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake: 2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc: 0.4.3-r1
sys-apps/sandbox: 1.6
sys-devel/autoconf: 2.13, 2.63
sys-devel/automake: 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils: 2.19, 2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6a
virtual/os-headers: 2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages loadpolicy maketest manifest multilib parallel-fetch protect-owned repoman sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://epia/Gentoo"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr en us"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/science /usr/local/portage/layman/pro-audio /usr/local/portage/layman/games /usr/local/portage/layman/lila-theme /usr/local/portage/layman/liquidx /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="1 X a52 aac aalib accessibility acl acpi alsa amd64 amuled apache apache2 arts artswrappersuid audacious audiofile automount avahi bash-completion berkdb bidi bluetooth boo bzip2 cairo cdda cddb cdio cli cpudetection cracklib crypt ctype cups curl cursors daap dbus dc1394 dirac dri dssi dts dv dvb dvd dvdr dvdread emacs emovix enca encode ffmpeg filter flac fluidsynth foomaticdb fortran ftp gcj gd gdbm ggi gif gimp glitz gnome gnutls gphoto2 gpm gstreamer gtk gtk+ gtkhtml hal hddtemp httpd icons iconv id3tag imagemagick ipod ipv6 isdnlog jack java java5 java6 jpeg jpeg2k kde kdm kqemu ladspa lcms ldap libcaca libdvdread libffi libnotify libsamplerate libwww lirc live lm_sensors lua mad matroska mdnsresponder-compat midi mikmod mjpeg mmx mmxext mng modplug mono mp2 mp3 mpeg mplayer mpm-prefork mtp mudflap multilib multislot musepack musicbrainz mysql nas ncurses nls nptl nptlonly nsplugin nxclient objc objc++ objc-gc odbc ogg opengl openmp oss pam pcre pdf perl php png podcast ppds pppd pulseaudio pvr python qt3 qt3support qt4 quicktime radio rar readline reflection rtsp ruby samba sdl sdl-image server session shout skins smp soundtouch speex spell spl sqlite srt sse sse2 ssl stream svg swat sysfs syslog taglib tcl tcpd theora threads tiff tk truetype twolame ucs2 unicode upnp url usb utempter v4l v4l2 vamp vcd vcdx vhook vlm vorbis wavpack wininst wmf wxwindows x264 xcb xine xinerama xinetd xml xorg xosd xprint xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="virtuoso" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en us" USERLAND="GNU" VIDEO_CARDS="vesa nvidia nv"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Fri Apr 10, 2009 8:24 am    Post subject: Reply with quote

I remove python 2.6 and I still have a problem...



Quote:
# emerge vmware-workstation
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-emulation/vmware-workstation-6.5.2.156735
* VMware-Workstation-6.5.2-156735.x86_64.bundle RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
>>> Unpacking source...
Unbundling /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/distdir/VMware-Workstation-6.5.2-156735.x86_64.bundle
* Applying vmware-workstation-6.5.2.156735-installer.patch ... [ ok ]
>>> Source unpacked in /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work
>>> Compiling source in /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/vmware-workstation-6.5.2.156735

>>> Install vmware-workstation-6.5.2.156735 into /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/image/ category app-emulation
Module Patcher: patching file /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/tmpbbu4VI/.installer/vmware-vix.py
Module Patcher: patching file /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/tmpbbu4VI/.installer/vmware-player-extras.py
Module Patcher: patching file /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/tmpbbu4VI/.installer/vmware-player.py
Module Patcher: patching file /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/temp/tmpbbu4VI/.installer/vmware-workstation.py
You must accept the EULA to continue. Press enter to proceed.q
Do you agree? [yes/no]: yes

Installing VMware Player 2.5.2
Configuring...Traceback (most recent call last):
File "/usr/lib64/python2.5/logging/handlers.py", line 73, in emit ] 56%
if self.shouldRollover(record):
File "/usr/lib64/python2.5/logging/handlers.py", line 146, in shouldRollover
msg = "%s\n" % self.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 630, in format
return fmt.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 421, in format
s = self._fmt % record.__dict__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 11: ordinal not in range(128)
Traceback (most recent call last):
File "/usr/lib64/python2.5/logging/handlers.py", line 73, in emit
if self.shouldRollover(record):
File "/usr/lib64/python2.5/logging/handlers.py", line 146, in shouldRollover
msg = "%s\n" % self.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 630, in format
return fmt.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 421, in format
s = self._fmt % record.__dict__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 17: ordinal not in range(128)
Traceback (most recent call last):
File "/usr/lib64/python2.5/logging/handlers.py", line 73, in emit
if self.shouldRollover(record):
File "/usr/lib64/python2.5/logging/handlers.py", line 146, in shouldRollover
msg = "%s\n" % self.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 630, in format
return fmt.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 421, in format
s = self._fmt % record.__dict__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 81: ordinal not in range(128)
Traceback (most recent call last):
File "/usr/lib64/python2.5/logging/handlers.py", line 73, in emit
if self.shouldRollover(record):
File "/usr/lib64/python2.5/logging/handlers.py", line 146, in shouldRollover
msg = "%s\n" % self.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 630, in format
return fmt.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 421, in format
s = self._fmt % record.__dict__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 74: ordinal not in range(128)
Traceback (most recent call last):
File "/usr/lib64/python2.5/logging/handlers.py", line 73, in emit
if self.shouldRollover(record):
File "/usr/lib64/python2.5/logging/handlers.py", line 146, in shouldRollover
msg = "%s\n" % self.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 630, in format
return fmt.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 421, in format
s = self._fmt % record.__dict__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 24: ordinal not in range(128)
Traceback (most recent call last):
File "/usr/lib64/python2.5/logging/handlers.py", line 73, in emit
if self.shouldRollover(record):
File "/usr/lib64/python2.5/logging/handlers.py", line 146, in shouldRollover
msg = "%s\n" % self.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 630, in format
return fmt.format(record)
File "/usr/lib64/python2.5/logging/__init__.py", line 421, in format
s = self._fmt % record.__dict__
Installing VMware Workstation 6.5.2
Configuring...
[######################################################################] 100%
Installation was successful
* The following installation segment takes a *very* long time.
* Please be patient.
>>> Completed installing vmware-workstation-6.5.2.156735 into /dev/shm/portage/app-emulation/vmware-workstation-6.5.2.156735/image/

ecompressdir: bzip2 -9 /opt/vmware/workstation/share/man
>>> Done.

>>> Installing app-emulation/vmware-workstation-6.5.2.156735
* >>> SetUID: [chmod go-r] /opt/vmware/workstation/sbin/vmware-authd ... [ ok ]
* >>> SetUID: [chmod go-r] /opt/vmware/workstation/lib/vmware/bin/vmware-vmx ... [ ok ]
* >>> SetUID: [chmod go-r] /opt/vmware/workstation/lib/vmware/bin/vmware-vmx-stats ... [ ok ]
* >>> SetUID: [chmod go-r] /opt/vmware/workstation/lib/vmware/bin/vmware-vmx-debug ... [ ok ]
* Updating desktop mime database ...
* Updating icons cache ... [ ok ]
* Before you can use vmware-player, you must configure a default
* network setup.
* You can do this by running 'emerge --config vmware-workstation'.

>>> Recording app-emulation/vmware-workstation in "world" favorites file...

* Messages for package app-emulation/vmware-workstation-6.5.2.156735:

* The following installation segment takes a *very* long time.
* Please be patient.
* Before you can use vmware-player, you must configure a default
* network setup.
* You can do this by running 'emerge --config vmware-workstation'.
>>> Auto-cleaning packages...
* waiting for lock on /var/db/.pkg.portage_lockfile
... [ ok ]

>>> No outdated packages were found on your system.

* Regenerating GNU info directory index...
* Processed 277 info files.
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Fri Apr 10, 2009 12:15 pm    Post subject: Reply with quote

here is my /etc/init.d/vmware

Quote:
# cat vmware
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/files/vmware-workstation-6.5.rc,v 1.1 2008/11/09 20:56:55 ikelos Exp $

depend() {
need localmount
use logger net hald
after samba
}

vmware_prettify() {
# Yea, the code is ugly but the output is pretty
state=$1
waserror=0
msgtype=0
while read line
do
[ "${line}" = "" ] && continue
if [ ${msgtype} -le 0 ]
then
if [ ${msgtype} -eq -1 ]
then
ewarn ${line}
continue
fi
case ${line} in
*:*)
einfon ${line}
echo
eend 0
msgtype=1;;
*)
ewarn ${line}
msgtype=-1
waserror=1;;
esac
continue
fi

# Strip out anything after the <esc> code
message=`echo ${line} | sed -e "s/^\(.*\)*$/\1/"`
einfon " ${message}"
echo

echo ${line} | grep -q done
status=$?
eend ${status}

if [ ${status} -eq 0 ]
then
logger -p local0.err -t vmware-${state} "${line}"
waserror=${status}
fi
done
if [ "${msgtype}" = "-1" ]
then
eend 1 "VMware is not properly configured! See above."
fi
return ${waserror}
}

start() {
test -x /etc/vmware/init.d/vmware || \
eend 1 "vmware init script not found. Aborting" || return 1

/etc/vmware/init.d/vmware start | vmware_prettify start
return $?
}

stop() {
/etc/vmware/init.d/vmware stop | vmware_prettify stop
return $?
}
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Fri Apr 10, 2009 11:01 pm    Post subject: python may have been the problem Reply with quote

I'm still on 2.5 on that box I have vmware on.

When you installed python 2.6 did you run the python-updater? Failure to do that can break all sorts of ebuilds.
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Fri Apr 10, 2009 11:09 pm    Post subject: Reply with quote

It's ok I use eselect to switch back to python 2.5 so I think I don't need to run python-updater... or not ?
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Sat Apr 11, 2009 1:58 am    Post subject: maybe Reply with quote

That depends... You may have had some ebuilds already brought forward into 2.6 and others left back in 2.5 from a portage update. That can still cause problems when you flip back to 2.5 and unmerge 2.6. The 2.6 built modules are now left broken. There will also be issues when a 2.5 environment module is trying to import a 2.6 module and vice versa since they will not see each others search path.
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Sat Apr 11, 2009 8:04 am    Post subject: Reply with quote

So what do you propose to do ? to switch to the 2.6 version with python-updater ?
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Sun Apr 12, 2009 3:45 am    Post subject: go with python 2.6 Reply with quote

I just finished doing my weekly emerge and got python 2.6 on my unstable boxes (one does kvm). After doing the following:

Code:
emerge -uD --newuse world

(some stuff fails due to python problems)

Code:
python-updater


(had to take care of some stale ebuilds and conflicts from that)

Code:
emerge -uD --newuse world

and

Code:
revdep-rebuild -i


I'm having no problems at all with my Windows guest in kvm. Since my vmware server is a work and is on a normally stable amd64 setup, I won't know until much later whether there will be any problem with python 2.6.
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Tue Apr 14, 2009 3:43 pm    Post subject: Reply with quote

Hi

I just have finished to do the "emerge -uD --newuse world " and the "revdep-rebuild -i" (it takes one day for me because of openoffice)

But finally it's exactly the same ! nothing change !

any other idea ?
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Wed Apr 15, 2009 1:24 am    Post subject: dunno Reply with quote

You might want to try to go my route and just use the vmware tarball and their installer to setup things in /usr/local. Are you having any other problems that might be related to python not being built all of the way?

It will be some time before I have python 2.6 running on a system where I have vmware. Most of what I use at work where I would also use vmware is on the stable amd64 with some expceptions (app-emulation builds for kvm, etc and Xorg for new Intel gma support).

I'm also deciding to go with kvm on my work desktop for now since I have the hardware virtualization capability and have gotten things working. It feels faster than vmware 2. I also want to look into running a kvm session for my primary vm and then seeing how things might work using a qemu system for another. It would be great to show legacy sparc apps running there.
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Wed Apr 15, 2009 8:24 pm    Post subject: Reply with quote

I try to use qemu, but I've got a problem :

Quote:
$ qemu-system-x86_64 -cdrom 00_Data/07_Linux/Distributions/Ubuntu/ubuntu-8.10-desktop-i386.iso -m 512 -smp 4 -boot d -enable-kvm
failed to initialize KVM


with a 2.6.29-r1 kernel, and kvm-intel compiled in.

:(
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Thu Apr 16, 2009 4:47 am    Post subject: make it a module Reply with quote

Make your virtualization modules modules and not baked in with the kernel. I think qemu will have heartburn otherwise. Besides, if you do it this way, you still have the option to just reboot and flip over to vmware if you need to. vmware doesn't like seeing kvm support in an active kernel.

I don't even put the kvm and kvm_intel or kvm_amd modules into the autoload.d and just modprobe them manually when I want to use kvm for a given boot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum