Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem emerging media-libs/svgalib-1.9.19
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
no-use
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 76
Location: Belgium

PostPosted: Sat Jul 17, 2004 1:20 pm    Post subject: problem emerging media-libs/svgalib-1.9.19 Reply with quote

while updating media-libs/svgalib-1.9.19 I get this error


Code:
ACCESS DENIED  open_wr:   /usr/src/linux-2.6.6-rc1/.__modpost.cmd
/bin/sh: line 1: ./.__modpost.cmd: Permission denied
make[2]: *** [__modpost] Error 1
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.6-rc1'
make: *** [default] Error 2

!!! ERROR: media-libs/svgalib-1.9.19 failed.
!!! Function src_compile, Line 83, Exitcode 2
!!! Failed to build kernel module!

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-media-libs_-_svgalib-1.9.19-13048.log"

open_wr:   /usr/src/linux-2.6.6-rc1/.__modpost.cmd
--------------------------------------------------------------------------------


how can I fix this ?

greetz
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Sat Jul 17, 2004 1:46 pm    Post subject: Reply with quote

Code:
FEATURES="-sandbox -usersandbox" emerge --oneshot "=media-libs/svgalib-1.9.19"

_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
skoduser
n00b
n00b


Joined: 07 Aug 2003
Posts: 13
Location: Denmark

PostPosted: Mon Jul 19, 2004 2:28 pm    Post subject: Reply with quote

I also get an error during compile:
Code:
gcc -O2 -DLINUX -Dlinux -D__KERNEL__ -DMODULE   -I/include -I. -I/usr/src/linux/include -I/usr/src/linux/include/asm/mach-default -DSVGALIB_HELPER_MAJOR=209 -DMODVERSIONS -DCONFIG_MODVERSIONS=1   -c -o main.o main.c
main.c: In function `remap_cache':
main.c:462: warning: passing arg 1 of `remap_page_range' makes integer from pointer without a cast
main.c:462: error: incompatible type for argument 4 of `remap_page_range'
main.c:462: error: too many arguments to function `remap_page_range'
distcc[8027] ERROR: compile on skod1.skjoldhoej.dk failed
make: *** [main.o] Error 1

!!! ERROR: media-libs/svgalib-1.9.19 failed.
!!! Function src_compile, Line 81, Exitcode 2
!!! Failed to build kernel module!

Anyone got a solution?
Back to top
View user's profile Send private message
no-use
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 76
Location: Belgium

PostPosted: Mon Jul 19, 2004 2:31 pm    Post subject: Reply with quote

mine was solved btw thx to moocha :D

skoduser: I got no idea ..
Back to top
View user's profile Send private message
ddoherty03
n00b
n00b


Joined: 24 Feb 2004
Posts: 38

PostPosted: Mon Jul 19, 2004 3:49 pm    Post subject: svgalib compile issue---thanks, moocha Reply with quote

moochas gracias to moocha for the solution to the svgalib compile issue.

fixed mine too.
Back to top
View user's profile Send private message
Arplar
n00b
n00b


Joined: 19 Aug 2003
Posts: 13
Location: BC, Canada

PostPosted: Mon Jul 19, 2004 6:13 pm    Post subject: Reply with quote

I have the same problem as skoduser..
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Mon Jul 19, 2004 9:02 pm    Post subject: Reply with quote

Please post the output of
Code:
emerge info
- without that most likely nobody will be able to help you when facing compiler errors.
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
Arplar
n00b
n00b


Joined: 19 Aug 2003
Posts: 13
Location: BC, Canada

PostPosted: Mon Jul 19, 2004 9:11 pm    Post subject: Reply with quote

Code:

Gentoo Base System version 1.4.16
Portage 2.0.50-r9 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3.20040420-r0, 2.6.0)
=================================================================
System uname: 2.6.0 i686 AMD Athlon(TM) XP 2400+
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -O3 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb cdr crypt cups encode esd foomaticdb gdbm gif gpm gtk gtk2 imlib java jpeg kde libg++ libwww mad mikmod motif mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime radeon readline sdl slang spell ssl svga tcpd truetype video_cards_radeon x86 xml2 xmms xv zlib"

Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Mon Jul 19, 2004 10:32 pm    Post subject: Reply with quote

Try clearing your compiler cache (if you're using ccache that is) via
Code:
ccache -C
and then try re-emerging your linux-headers package (or linux26-headers, depending on which one you use) via
Code:
emerge --oneshot linux-headers
or
Code:
emerge --oneshot linux26-headers
respectively. Does the problem still persist then?

Edit: Typo, should be -C not -Z
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
don quixada
l33t
l33t


Joined: 15 May 2003
Posts: 738

PostPosted: Mon Jul 19, 2004 11:38 pm    Post subject: Reply with quote

I was having the same problems and this worked for me:

Code:

USE=build emerge svgalib


dq
Back to top
View user's profile Send private message
Arplar
n00b
n00b


Joined: 19 Aug 2003
Posts: 13
Location: BC, Canada

PostPosted: Tue Jul 20, 2004 1:04 am    Post subject: Reply with quote

Don quixada, thanks, that did it. Thanks for helping as well moocha.
Back to top
View user's profile Send private message
dsat
n00b
n00b


Joined: 18 Jul 2004
Posts: 5

PostPosted: Wed Jul 21, 2004 7:33 pm    Post subject: Reply with quote

I had the following problem:

Code:

include/linux/pci.h:471: error: storage size of `dev' isn't known
/var/tmp/portage/svgalib-1.9.19/work/svgalib-1.9.19/kernel/svgalib_helper/main.c:524: error: storage size of `svgalib_helper_fops' isn't known
make[2]: *** [/var/tmp/portage/svgalib-1.9.19/work/svgalib-1.9.19/kernel/svgalib_helper/main.o] Error 1
make[1]: *** [_module_/var/tmp/portage/svgalib-1.9.19/work/svgalib-1.9.19/kernel/svgalib_helper] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.7-gentoo-r8'
make: *** [default] Error 2

!!! ERROR: media-libs/svgalib-1.9.19 failed.
!!! Function src_compile, Line 83, Exitcode 2
!!! Failed to build kernel module!


I have also solved the problem with the help of don quixada - thanx.
So I hope that now emerge -e world works...
Back to top
View user's profile Send private message
MHD
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2003
Posts: 88

PostPosted: Mon Jul 26, 2004 12:44 am    Post subject: Reply with quote

Cheers don quixada! That worked for me
Back to top
View user's profile Send private message
don quixada
l33t
l33t


Joined: 15 May 2003
Posts: 738

PostPosted: Tue Jul 27, 2004 2:43 am    Post subject: Reply with quote

I don't want to take the credit for this, I found it in the forums somewhere. I'm not even sure what it means: 'USE=build'.

But there's no harm in posting a solution twice... *grin*

dq
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum