Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
errors with promise 20267 and 2.6 kernels
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
taskara
Advocate
Advocate


Joined: 10 Apr 2002
Posts: 3763
Location: Australia

PostPosted: Wed Apr 28, 2004 11:57 am    Post subject: errors with promise 20267 and 2.6 kernels Reply with quote

anyone had problems with promise 20267 ide controller (Ultra 100 PCI card) and 2.6 kernel?

booting to a livecd with 2.6 kernel I get hde status not ready errors while doing things.

booting to latest livecd (2.4.x kernel) it works well.

but I have configured 2.6.5 vanilla kernel on my system and when trying to emerge apache and things it is crashing out with inode errors, and seek errors similar to when I had booted with the 2.6 kernel enabled livecd. I even had the problem when trying to re-compile 2.6 and 2.4 kernels, but when I boot to the 2.4 kernel livecd and chroot in I have no errors!

So I think there might be a problem with promise and 2.6 kernels - I was emerging apache, and the machine crashed with numberous hard drive errors, and now after hardbooting the box I can't emerge anything cause I get
Code:
/usr/bin/python: error while loading shared libraries libstdc++
:evil:

Any ideas?

I guess I need to re-build my system unless I can find a fix for the python error - has anyone else had problems with these controllers and 2.6 kernels?

thanks!

EDIT: the libstdc++ error is now fixed.

I managed to get 2.4.26 kernel emerged and configured by using the 2.4 kernel livecd and chrooting in.

system seems stable - no hard drive errors as yet - emerging apache and samba cups etc..

will update.

I'm thinking the promise driver in 2.6.5 is borked..?
_________________
Kororaa install method - have Gentoo up and running quickly and easily, fully automated with an installer!
Back to top
View user's profile Send private message
Passe-Poil
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2004
Posts: 139
Location: Québec, QC, Canada

PostPosted: Wed Apr 28, 2004 4:30 pm    Post subject: Reply with quote

Quote:

I'm thinking the promise driver in 2.6.5 is borked..?


You are right... I never even got to the point of mounting my root partition on a 2.6 kernel.
_________________
Violence is the last refuge of the incompetent.
Back to top
View user's profile Send private message
taskara
Advocate
Advocate


Joined: 10 Apr 2002
Posts: 3763
Location: Australia

PostPosted: Wed Apr 28, 2004 10:59 pm    Post subject: Reply with quote

thank God I'm not crazy ;)

well I sure found out the hard way!

do the kernel devs know of this bug?
_________________
Kororaa install method - have Gentoo up and running quickly and easily, fully automated with an installer!
Back to top
View user's profile Send private message
Passe-Poil
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2004
Posts: 139
Location: Québec, QC, Canada

PostPosted: Thu Apr 29, 2004 1:30 am    Post subject: Reply with quote

yep probably

I only guess they have a LOT of things on their minds
_________________
Violence is the last refuge of the incompetent.
Back to top
View user's profile Send private message
taskara
Advocate
Advocate


Joined: 10 Apr 2002
Posts: 3763
Location: Australia

PostPosted: Thu Apr 29, 2004 1:36 am    Post subject: Reply with quote

so long as they know ;)
_________________
Kororaa install method - have Gentoo up and running quickly and easily, fully automated with an installer!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum