Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-auth/pambase
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Moonday
n00b
n00b


Joined: 25 Oct 2012
Posts: 35

PostPosted: Tue Sep 09, 2014 7:41 am    Post subject: sys-auth/pambase Reply with quote

Hi
Thank you for your respond!
I have a conflict in install Gnome:
sys-auth/pambase required systemd . Message is something like this:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-auth/pambase:0

  (sys-auth/pambase-20120417-r3::gentoo, installed) pulled in by
     (no parents that aren't satisfied by other packages in this slot)

    (sys-auth/pambase-20120417-r3::gentoo, ebuild scheduled for merge) pulled in by
         sys-auth/pambase[systemd?] required by (gnome-base/gdm-3.12.2::gentoo, ebuild scheduled for merge)


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specifiec suggestion.

Thank you for your time and help!
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8080
Location: ~Brussels - Belgique

PostPosted: Tue Sep 09, 2014 7:55 am    Post subject: Reply with quote

Hello,

Do you have the gnome profile enabled ? Normally, the systemd USE flag should be globally enabled.

Please give the output of
Code:
eselect profile list
Code:
emerge -pv sys-auth/pambase
and
Code:
emerge --info


if you switched to the Gnome profile, don't forget to update your world set:
Code:
emerge -DuNav @world

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Moonday
n00b
n00b


Joined: 25 Oct 2012
Posts: 35

PostPosted: Tue Sep 09, 2014 8:42 am    Post subject: Reply with quote

Thank you!
I set my profile to :
Code:

[4]  default/linux/x86/13.0/desktop/gnome *

and
Code:

>>> Messages generated by process 14987 on 2014-09-08 22:41:04 IRDT for package sys-kernel/gentoo-sources-3.14.16:

LOG: postinst
If you are upgrading from a previous kernel, you may be interested
in the following document:
  - General upgrade guide: http://www.gentoo.org/doc/en/kernel-upgrade.xml

>>> Messages generated by process 16662 on 2014-09-09 01:58:22 IRDT for package sys-boot/grub-2.00_p5107-r2:


>>> Messages generated by process 24754 on 2014-09-08 06:46:51 IRDT for package dev-db/unixODBC-2.3.1:

QA: other
QA Notice: Package triggers severe warnings which indicate that it
           may exhibit random runtime failures.
SQLBindCol.c:79:3: warning: incompatible implicit declaration of built-in function 'memset' [enabled by default]
SQLBindParameter.c:102:3: warning: incompatible implicit declaration of built-in function 'memset' [enabled by default]
SQLDescribeCol.c:49:15: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
SQLDescribeCol.c:60:3: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
SQLError.c:47:3: warning: incompatible implicit declaration of built-in function 'strcpy' [enabled by default]
SQLError.c:67:3: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
SQLError.c:71:14: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
SQLFetch.c:65:3: warning: incompatible implicit declaration of built-in function 'memset' [enabled by default]
SQLFetch.c:91:10: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
SQLGetData.c:88:9: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
SQLPutData.c:40:14: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
SQLPutData.c:61:3: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
connect.c:141:6: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
connect.c:214:12: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
connect.c:219:12: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
connect.c:232:2: warning: incompatible implicit declaration of built-in function 'strncat' [enabled by default]
connect.c:233:2: warning: incompatible implicit declaration of built-in function 'strcat' [enabled by default]
connect.c:266:39: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
connect.c:301:35: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
connect.c:318:4: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
connect.c:351:11: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
connect.c:377:36: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
connect.c:396:5: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
convert.c:49:10: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
convert.c:56:2: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
convert.c:67:10: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
convert.c:72:2: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
convert.c:84:10: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
convert.c:89:2: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
convert.c:268:8: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
convert.c:275:3: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
convert.c:344:11: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
convert.c:349:2: warning: incompatible implicit declaration of built-in function 'strcpy' [enabled by default]
prepare.c:81:32: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
yyparse.y:822:8: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
yyparse.y:948:3: warning: incompatible implicit declaration of built-in function 'memset' [enabled by default]
yyparse.y:1058:3: warning: incompatible implicit declaration of built-in function 'memset' [enabled by default]
yystmt.c:32:2: warning: incompatible implicit declaration of built-in function 'memset' [enabled by default]
yystmt.c:582:2: warning: incompatible implicit declaration of built-in function 'strncpy' [enabled by default]
nndate.c:30:6: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
nndate.c:124:6: warning: incompatible implicit declaration of built-in function 'strlen' [enabled by default]
Please do not file a Gentoo bug and instead report the above QA
issues directly to the upstream developers of this software.
Homepage: http://www.unixodbc.org/

>>> Messages generated by process 24754 on 2014-09-08 07:30:29 IRDT for package dev-libs/nss-3.16.3:

QA: other
QA Notice: Package triggers severe warnings which indicate that it
           may exhibit random runtime failures.
mpi/mpcpucache.c:634:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
mpi/mpcpucache.c:635:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
mpi/mpcpucache.c:636:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
mpi/mpcpucache.c:681:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
mpi/mpcpucache.c:682:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
mpi/mpcpucache.c:683:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1232:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1233:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1234:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1235:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1236:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1237:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1238:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1239:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1240:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1241:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1242:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1243:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1244:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1584:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1585:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1586:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1587:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1588:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1589:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1590:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1591:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1592:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1593:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1594:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1595:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
sslsnce.c:1596:5: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:690:2: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:694:6: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:695:6: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:717:6: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:722:6: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:723:6: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:761:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:784:11: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:785:4: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
jarfile.c:786:4: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
Please do not file a Gentoo bug and instead report the above QA
issues directly to the upstream developers of this software.
Homepage: http://www.mozilla.org/projects/security/pki/nss/



>>> Messages generated by process 24754 on 2014-09-08 10:57:30 IRDT for package x11-apps/xinit-1.3.3:

WARN: postinst
If you use startx to start X instead of a login manager like gdm/kdm,
you can set the XSESSION variable to anything in /etc/X11/Sessions/ or
any executable. When you run startx, it will run this as the login session.
You can set this in a file in /etc/env.d/ for the entire system,
or set it per-user in ~/.bash_profile (or similar for other shells).
Here's an example of setting it for the whole system:
    echo XSESSION="Gnome" > /etc/env.d/90xsession
    env-update && source /etc/profile



when I emerge panbase:
Code:

* Error: The above package list countains packages wich cannot be
* installed at the same time on the same system.

   (sys-apps/systemd-215-r3::gentoo, ....

   (sys-fs/eudev-1.9-r2::gentoo, ...

   (sys-fs/udev-215-r1::gentoo, ...
.
.
.
 
for more information about Blocked packages, please refer to the following ...


Sorry for my writing summary! I forget place of log files and I just type aal of them! :)

I'm in install a fresh linux on system! still this is important to emerge -DuNav @world ?
Code:


USE="a52 aac aalib acpi aiglx alsa ao audiofile bash_completion bzip2 cairo cdr cgi clamav css cups curl dbus dga dts dv dvd dvdr encode fam ffmpeg flac gd gif gphoto2 gnome gnutls gstreamer gtk idn jpeg lcms libcaca libnotify nsplugin mad mpeg mp3 mp4 mono mozilla nptl odbc openal opengl pam pdf png portaudio ppds samba slp sqlite sndfile sound speex spell sse sse2 svg symlink tcl theora tidy tiff threads truetype unicode usb win32codecs wmf xml xvid X x264 xorg xscreensaver xv xcomposite -kde -arts -qt3 -qt4 -doc -examples -xine -ipv6"



Back to top
View user's profile Send private message
Moonday
n00b
n00b


Joined: 25 Oct 2012
Posts: 35

PostPosted: Tue Sep 09, 2014 8:56 am    Post subject: Reply with quote

Is this a confilct by my INPUT_DEVICES="evdev synaptics" ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8080
Location: ~Brussels - Belgique

PostPosted: Tue Sep 09, 2014 8:57 am    Post subject: Reply with quote

This is important because you switched of profile, which will force certain options and packages.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum