Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Having trouble with NFSROOT's robustness to network problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
CrazyCasta
n00b
n00b


Joined: 01 Sep 2011
Posts: 26

PostPosted: Fri Sep 05, 2014 5:01 am    Post subject: Having trouble with NFSROOT's robustness to network problems Reply with quote

I've installed a diskless install according to the instructions here. Everything seems great except that from time to time my system freezes. I've noticed this seems to happen most when there's lots of disk access. I've found that I can cause this problem by disconnecting the network cable, running ls, and then reconnecting the network cable (no long wait or anything). I'm guessing that something's happening to the mount, but I'm not sure what. The nfs version is 4. I've tried both udp and tcp protos and both fail (in the same way).

Any suggestions would be appreciated.
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1717

PostPosted: Fri Sep 05, 2014 7:37 am    Post subject: Reply with quote

Several clients with root on NFS can simply overload your LAN.
100 MB is only enough for 2 clients accessing disk at any time. And clients tend to access disk pretty often because they expect NFS shares to be changed from other location so they don't do much caching.

And yes, unpluging the wire will cause freez on client, because it needs to read the share again before performing whatever action you want.
Also, if NFS server's IP changes, it will break connection. Even if you mount using hostname, it will resolve name to IP and bind that IP rather than name.
Back to top
View user's profile Send private message
CrazyCasta
n00b
n00b


Joined: 01 Sep 2011
Posts: 26

PostPosted: Fri Sep 05, 2014 2:39 pm    Post subject: Reply with quote

Okay, that doesn't seem to answer my question.


  • There's only one client at the moment.
  • It's a gigabit connection.
  • You make it sound like it should only temporarily stall when I unplug the wire. It's permanently frozen.
  • And finally, the server's IP is static.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum