Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] I am no systemd nor sys-power, but emerge wants
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
lalebarde
Guru
Guru


Joined: 03 Sep 2006
Posts: 464
Location: France, Haute-Garonne

PostPosted: Thu Sep 04, 2014 5:22 pm    Post subject: [SOLVED] I am no systemd nor sys-power, but emerge wants Reply with quote

Hi all,

I have upgraded my kernel from 2.6.37-tuxonice to gentoo-sources-3.8.13. Then I try to upgrade system and world. I have many conflicts with systemd. I read this post:
https://forums.gentoo.org/viewtopic-t-992290.html
where it is recommended to choose between sys-power/upower-pm-utils or >=sys-power/upower-0.99.0 for all non-systemd users. I use the first one.

So I have checked my settings:
  • I have -systemd in /etc/make.conf USE flags declaration statement,
  • I have checked for every package possibly using the systemd use flag to unset it,
  • I have checked that sys-power/upower-pm-utils is installed and not sys-power/upower
  • I have checked that no package depends on sys-power/upower (cf below)
  • I have masked systemd and sys-power/upower


Here is the result for "no package depends on sys-power/upower":
Code:
# equery depends sys-power/upower
kde-base/kdelibs-4.12.5-r2 (upower ? >=sys-power/upower-0.9.23)
net-im/telepathy-mission-control-5.16.2 (upower ? <sys-power/upower-0.99)
xfce-base/xfce4-session-4.10.0-r1 (>=sys-power/upower-0.9.15)
xfce-extra/xfce4-power-manager-1.2.0-r1 (>=sys-power/upower-0.9.16)
xfce-extra/xfce4-systemload-plugin-1.1.1 (>=sys-power/upower-0.9.16)
xfce-extra/xfce4-weather-plugin-0.8.3 (>=sys-power/upower-0.9.19)


partially covered by:
Code:
# equery depends sys-power/upower-pm-utils
kde-base/kdelibs-4.12.5-r2 (upower ? sys-power/upower-pm-utils)
net-im/telepathy-mission-control-5.16.2 (upower ? sys-power/upower-pm-utils)


So I assume xfce-base/xfce4-session, xfce-extra/xfce4-power-manager, xfce-extra/xfce4-systemload-plugin, xfce-extra/xfce4-weather-plugin cannot build without sys-power/upower?

What shall I do? If I add a -upower use flag to them, shall I assume there won't be power management any more under XFCE, or will it use sys-power/upower-pm-utils silently?

In part of my long and difficult update process, I have this:

Code:
# emerge --backtrack=30 -auv1 media-libs/libart_lgpl net-nds/openldap gnome-base/gsettings-desktop-schemas sys-apps/accountsservice media-libs/gst-plugins-good media-libs/gst-plugins-bad sys-apps/dbus sys-apps/acl media-libs/gst-plugins-base gnome-base/gdm

[ebuild  N     ] net-misc/mobile-broadband-provider-info-20120614  72 kB
[ebuild  N     ] media-fonts/cantarell-0.0.15  USE="X" 289 kB
[ebuild     U  ] x11-proto/xextproto-7.3.0 [7.2.1-r1] USE="-doc" ABI_X86="(64) -32 (-x32)" 224 kB
[ebuild     U  ] x11-libs/xtrans-1.3.3 [1.2.7] USE="-doc" 174 kB
[ebuild  N     ] x11-apps/xmodmap-1.0.8  138 kB
[ebuild     U  ] x11-base/xorg-drivers-1.15 [1.14] INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -elographics -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="nv nvidia v4l -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -modesetting -neomagic -nouveau (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)" 0 kB
[ebuild     U  ] media-libs/libart_lgpl-2.3.21-r2 [2.3.21-r1] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  N     ] dev-libs/libgee-0.14.0:0.8  USE="introspection" 627 kB
[ebuild  NS    ] dev-lang/spidermonkey-24.2.0-r2:24 [1.8.5-r4:0/mozjs185] USE="system-icu -debug -icu -jit -minimal -static-libs {-test}" 15,259 kB
[ebuild  N     ] net-dialup/ppp-2.4.5-r3  USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls -radius" 738 kB
[ebuild     U  ] dev-python/pygobject-3.12.2:3 [3.2.2-r1:3] USE="threads -cairo -examples {-test}" PYTHON_TARGETS="python2_7 python3_3%* -python3_2* (-python3_4) (-python2_6%*) (-python3_1%)" 686 kB
[ebuild  N     ] x11-themes/gnome-icon-theme-symbolic-3.12.0  226 kB
[ebuild     U  ] x11-base/xorg-server-1.15.0:0/1.15.0 [1.14.3:0/1.14.3] USE="ipv6 kdrive nptl suid udev xorg xvfb -dmx -doc -minimal (-selinux) -static-libs -tslib -unwind% -xnest" 5,417 kB
[ebuild     U  ] net-nds/openldap-2.4.38-r2 [2.4.35-r1] USE="berkdb crypt gnutls ipv6 kerberos samba slp ssl syslog tcpd -cxx -debug -experimental -icu -iodbc -minimal -odbc -overlays -perl -sasl (-selinux) -smbkrb5passwd" ABI_X86="(64%*) (-32) (-x32)" 5,390 kB
[ebuild  N     ] dev-python/pycurl-7.19.0-r4  USE="ssl -examples" CURL_SSL="openssl -gnutls -nss" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 70 kB
[ebuild  N     ] dev-python/pyatspi-2.12.0  PYTHON_TARGETS="python2_7 python3_3 -python3_2" 294 kB
[ebuild  N     ] dev-python/pycups-1.9.63  USE="-doc -examples" PYTHON_TARGETS="python2_7 (-pypy)" 52 kB
[ebuild     U  ] sys-auth/pambase-20120417-r3 [20101024-r2] USE="consolekit cracklib sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd%" 4 kB
[ebuild     U  ] sys-apps/acl-2.2.52-r1 [2.2.51] USE="nls -static-libs (-nfs%)" ABI_X86="(64%*) (-32) (-x32)" 378 kB
[ebuild     U  ] media-libs/gstreamer-0.10.36-r2:0.10 [0.10.36:0.10] USE="introspection nls orc {-test}" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  N     ] media-libs/cogl-1.18.2:1.0/20  USE="introspection opengl pango -debug -examples -gles2 (-gstreamer) {-test}" 1,598 kB
[ebuild  N     ] dev-libs/gjs-1.40.1  USE="gtk -cairo -examples {-test}" 438 kB
[ebuild  N     ] dev-libs/libpwquality-1.2.3  USE="pam -python -static-libs" PYTHON_TARGETS="python2_7" 360 kB
[ebuild   R    ] media-libs/gst-plugins-base-1.2.4-r1:1.0  USE="X alsa introspection nls ogg orc pango theora* vorbis -ivorbis" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild     U  ] media-libs/gst-plugins-base-0.10.36-r1:0.10 [0.10.36:0.10] USE="introspection nls orc" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  N     ] media-libs/clutter-1.18.2:1.0  USE="gtk introspection -debug -doc {-test}" 5,093 kB
[ebuild     U  ] sys-apps/accountsservice-0.6.37 [0.6.29-r1] USE="introspection -doc (-selinux) -systemd (-vala%)" 355 kB
[ebuild  N     ] gnome-base/dconf-0.20.0  USE="X {-test}" 381 kB
[ebuild  N     ] net-im/telepathy-logger-0.8.0:0/3  USE="introspection {-test}" 528 kB
[ebuild  NS    ] gnome-base/gnome-menus-3.10.1-r1:3 [2.30.5-r1:0] USE="introspection -debug {-test}" 419 kB
[ebuild  N     ] media-libs/grilo-0.2.10:0.2/1  USE="gtk introspection network -examples -playlist {-test} -vala" 592 kB
[ebuild  N     ] gnome-base/libgnomekbd-3.6.0  USE="introspection {-test}" 365 kB
[ebuild  N     ] net-print/cups-pk-helper-0.2.5  150 kB
[ebuild  N     ] media-video/gnome-video-effects-0.4.1  142 kB
[ebuild     U  ] media-libs/gst-plugins-good-0.10.31-r1:0.10 [0.10.31:0.10] USE="nls orc" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] media-libs/gst-plugins-bad-0.10.23-r2:0.10 [0.10.23-r1:0.10] USE="nls orc" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  N     ] app-i18n/ibus-1.5.5  USE="X gtk gtk3 introspection nls python -deprecated -gconf {-test} -vala -wayland" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 2,016 kB
[ebuild  N     ] media-libs/clutter-gtk-1.5.2:1.0  USE="introspection -debug -examples" 306 kB
[ebuild  N     ] sci-geosciences/geocode-glib-3.12.2  USE="introspection {-test}" 342 kB
[ebuild  N     ] app-admin/system-config-printer-common-1.4.3  USE="policykit -doc" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 872 kB
[ebuild  N     ] app-admin/system-config-printer-gnome-1.4.3-r1  USE="-gnome-keyring" LINGUAS="fr -ar -as -bg -bn -bn_IN -br -bs -ca -cs -cy -da -de -el -en_GB -es -et -fa -fi -gu -he -hi -hr -hu -hy -id -is -it -ja -ka -kn -ko -lo -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -uk -vi -zh_CN -zh_TW" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild  N     ] gnome-extra/gnome-color-manager-3.12.3  USE="(-packagekit) -raw {-test}" 2,558 kB
[ebuild  N    #] sys-apps/systemd-215-r3:0/2  USE="acl firmware-loader gudev introspection kmod pam policykit seccomp -audit -cryptsetup -doc -elfutils -gcrypt -http (-kdbus) -lzma -python -qrcode (-selinux) (-ssl) {-test} -vanilla" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3 (-python3_4)" PYTHON_TARGETS="python2_7 python3_3 -python3_2 (-python3_4)" 0 kB
[ebuild   R    ] sys-apps/dbus-1.8.6  USE="X systemd* -debug -doc (-selinux) -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] sys-apps/gentoo-systemd-integration-4  52 kB
[ebuild     U  ] media-libs/gst-plugins-bad-1.2.4-r1:1.0 [1.0.5:1.0] USE="introspection%* nls orc -egl% -vnc%" ABI_X86="(64%*) (-32) (-x32)" 3,197 kB
[ebuild     U  ] media-libs/gst-plugins-good-1.2.4-r1:1.0 [1.0.5:1.0] USE="nls orc" ABI_X86="(64%*) (-32) (-x32)" 2,815 kB
[blocks b      ] <media-libs/gst-plugins-good-1.1:1.0 ("<media-libs/gst-plugins-good-1.1:1.0" is blocking media-libs/gst-plugins-bad-1.2.4-r1)
[ebuild  N     ] media-libs/clutter-gst-2.0.12:2.0  USE="introspection -debug -examples" 348 kB
[ebuild  N     ] media-plugins/gst-plugins-jpeg-1.2.4-r1:1.0  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N     ] media-plugins/gst-plugins-vpx-1.2.4-r1:1.0  ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild  N    #] sys-power/upower-0.99.0-r1:0/2  USE="introspection -ios" 420 kB
[uninstall     ] sys-power/upower-pm-utils-0.9.23-r2  USE="introspection -ios"
[blocks b      ] sys-power/upower ("sys-power/upower" is blocking sys-power/upower-pm-utils-0.9.23-r2)
[ebuild  N     ] net-misc/networkmanager-0.9.8.10-r1  USE="consolekit dhcpcd introspection modemmanager nss ppp wext -avahi -bluetooth -connection-sharing -dhclient -gnutls -resolvconf -systemd {-test} -vala -wifi" 1,969 kB
[ebuild  N     ] gnome-extra/nm-applet-0.9.8.10-r1  USE="introspection -bluetooth -gconf -modemmanager" 1,206 kB
[ebuild     U  ] gnome-base/gsettings-desktop-schemas-3.12.2 [3.4.2] USE="introspection" 470 kB
[ebuild  NS    ] gnome-base/gnome-desktop-3.12.2:3/10 [2.32.1:2] USE="introspection -debug" 1,069 kB
[ebuild  N     ] app-accessibility/caribou-0.4.13  PYTHON_TARGETS="python2_7" 396 kB
[ebuild  N     ] gnome-base/gnome-settings-daemon-3.12.2  USE="colord cups i18n policykit short-touchpad-timeout udev -debug (-openrc-force) (-packagekit) -smartcard {-test}" INPUT_DEVICES="-wacom" 1,634 kB
[ebuild  N     ] x11-wm/mutter-3.12.2  USE="introspection -debug {-test}" 1,656 kB
[ebuild  N     ] media-video/cheese-3.12.2-r1:0/7  USE="introspection {-test}" 1,737 kB
[ebuild  N     ] gnome-base/gnome-session-3.12.1  USE="ipv6 -debug -doc -gconf -systemd" 702 kB
[ebuild  N     ] gnome-base/gnome-control-center-3.12.1-r1:2  USE="colord cups gnome-online-accounts i18n kerberos v4l -bluetooth -debug" INPUT_DEVICES="-wacom" 6,706 kB
[ebuild  N     ] gnome-base/gnome-shell-3.12.2  USE="i18n networkmanager -bluetooth (-openrc-force)" PYTHON_TARGETS="python2_7" 1,505 kB
[ebuild     U  ] gnome-base/gdm-3.12.2 [2.20.11-r1] USE="branding introspection%* ipv6 tcpd xinerama -accessibility -audit% -debug% -fprint% -plymouth% (-selinux) -smartcard% -systemd% {-test%} -wayland% (-afs%) (-consolekit%*) (-dmx%) (-gnome-keyring%) (-pam%*) (-remote%)" 1,487 kB
[blocks b      ] <gnome-base/gdm-3.8 ("<gnome-base/gdm-3.8" is blocking gnome-base/gsettings-desktop-schemas-3.12.2)
[blocks b      ] <gnome-base/gdm-2.91.94 ("<gnome-base/gdm-2.91.94" is blocking gnome-base/gnome-control-center-3.12.1-r1)
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/gentoo-systemd-integration-4, sys-apps/systemd-215-r3)
[blocks B      ] <sys-apps/shadow-4.1.5-r1 ("<sys-apps/shadow-4.1.5-r1" is blocking sys-auth/pambase-20120417-r3)
[blocks B      ] <gnome-base/gnome-menus-3.0.1-r1:0 ("<gnome-base/gnome-menus-3.0.1-r1:0" is blocking gnome-base/gnome-menus-3.10.1-r1)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-208-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-208-r1)

Total: 63 packages (18 upgrades, 40 new, 3 in new slots, 2 reinstalls, 1 uninstall), Size of downloads: 73,895 kB
Conflict: 9 blocks (5 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/dbus:0

  (sys-apps/dbus-1.8.6::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/dbus-1.6.8-r1:0[systemd] required by (sys-apps/systemd-215-r3::gentoo, ebuild scheduled for merge)

  (sys-apps/dbus-1.8.6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/gst-plugins-base:1.0

  (media-libs/gst-plugins-base-1.2.4-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/gst-plugins-base-1.2.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/gst-plugins-base:1.0[introspection?,ogg,pango,theora,vorbis,X] required by (media-video/cheese-3.12.2-r1::gentoo, ebuild scheduled for merge)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.14.3::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.14.3= required by (x11-drivers/xf86-input-mouse-1.9.0::gentoo, installed)
    x11-base/xorg-server:0/1.14.3= required by (x11-drivers/xf86-video-nv-2.1.20-r1::gentoo, installed)
    x11-base/xorg-server:0/1.14.3= required by (x11-drivers/xf86-input-keyboard-1.7.0::gentoo, installed)
    x11-base/xorg-server:0/1.14.3= required by (x11-drivers/xf86-input-evdev-2.8.1::gentoo, installed)
    >=x11-base/xorg-server-1.7:0/1.14.3=[-minimal] required by (x11-drivers/xf86-video-virtualbox-4.2.26::gentoo, installed)

  (x11-base/xorg-server-1.15.0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.14.3-r1 required by (gnome-base/gdm-3.12.2::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-auth/pambase-20120417-r3::gentoo, ebuild scheduled for merge) pulled in by
    sys-auth/pambase required by (sys-auth/polkit-0.110::gentoo, installed)
    sys-auth/pambase required by (app-admin/sudo-1.8.6_p7::gentoo, installed)
    sys-auth/pambase required by (sys-libs/pam-1.1.6-r2::gentoo, installed)
    sys-auth/pambase required by (sys-apps/openrc-0.12.4::gentoo, installed)
    >=sys-auth/pambase-20081028 required by (net-misc/openssh-6.6_p1-r1::gentoo, installed)
    sys-auth/pambase[systemd?] (sys-auth/pambase) required by (gnome-base/gdm-3.12.2::gentoo, ebuild scheduled for merge)
    >=sys-auth/pambase-20101024-r2 required by (x11-misc/lightdm-1.4.0::gentoo, installed)
    >=sys-auth/pambase-20080219.1 required by (sys-apps/shadow-4.1.4.3::gentoo, installed)

  (gnome-base/gnome-menus-2.30.5-r1::gentoo, installed) pulled in by
    >=gnome-base/gnome-menus-2.27.92:0[python] required by (x11-misc/alacarte-0.13.2::gentoo, installed)
    gnome-base/gnome-menus:0 required by (x11-misc/keytouch-2.4.1::gentoo, installed)
    >=gnome-base/gnome-menus-2.27.92:0 required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed)

  (sys-fs/udev-208-r1::gentoo, installed) pulled in by
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1::gentoo, installed)
    >=sys-fs/udev-208-r1 required by (virtual/udev-215::gentoo, installed)
    sys-fs/udev required by (app-misc/media-player-info-17::gentoo, installed)
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-)]) required by (virtual/libudev-215-r1::gentoo, installed)
    >=sys-fs/udev-171-r6[gudev] required by (app-cdr/xfburn-0.4.3_p20121021::gentoo, installed)

  (sys-apps/systemd-215-r3::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.12.2::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.12.2::gentoo, ebuild scheduled for merge)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.8.6::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.12.1-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge)

  (sys-apps/shadow-4.1.4.3::gentoo, installed) pulled in by
    >=sys-apps/shadow-4.1 required by (virtual/shadow-0::gentoo, installed)

  (gnome-base/gnome-menus-3.10.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    gnome-base/gnome-menus:3 required by (gnome-base/gnome-control-center-3.12.1-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by gnome-base/gnome-settings-daemon-3.12.2
# required by gnome-base/gnome-control-center-3.12.1-r1
# required by gnome-base/gnome-shell-3.12.2
# required by gnome-base/gdm-3.12.2
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/standard:
# http://forums.gentoo.org/viewtopic-t-992424.html
=sys-power/upower-0.99.0-r1
# required by sys-apps/dbus-1.8.6[systemd]
# required by sys-apps/dbus (argument)
# /etc/portage/package.mask/standard:
# http://forums.gentoo.org/viewtopic-t-992424.html
=sys-apps/systemd-215-r3

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-apps/systemd-215-r3
# required by gnome-base/gnome-settings-daemon-3.12.2
# required by gnome-base/gnome-control-center-3.12.1-r1
# required by gnome-base/gnome-shell-3.12.2
# required by gnome-base/gdm-3.12.2
# required by @selected
# required by @world (argument)
>=sys-apps/dbus-1.8.6 systemd


Is it still possible to go on without systemd? I need some insight please to go on, two full days and nights and still blocked.


Last edited by lalebarde on Thu Sep 11, 2014 7:48 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7050
Location: almost Mile High in the USA

PostPosted: Thu Sep 04, 2014 11:33 pm    Post subject: Reply with quote

First off... DON'T USE gentoo-sources-3.8.13. It is a BAD kernel. If you got this as latest, please emerge --sync.

Question: do you have USE=openrc-force ? You'll need it to use Gnome3/gdm without systemd. Read the disclaimers that are written to the screen when this is set and portage merges gnome3.

If you don't want gnome 3, please emerge --depclean gnome2. It will make cleaning up the dependencies much easier if it isn't impossible already.
Back to top
View user's profile Send private message
lalebarde
Guru
Guru


Joined: 03 Sep 2006
Posts: 464
Location: France, Haute-Garonne

PostPosted: Fri Sep 05, 2014 7:53 am    Post subject: Reply with quote

Thanks eccerr0r. I realize that I started upgrading the kernel a while ago, and went on with it now without looking for newer ones :oops:

For the remaining, I don't have USE=openrc-force, nor Gnome2 nor Gnome at all. I use XFCE.

From where I am, what do you advice, systemd or openrc-force, ws the amount of work and risk ?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7050
Location: almost Mile High in the USA

PostPosted: Fri Sep 05, 2014 1:00 pm    Post subject: Reply with quote

I don't know why you have some Gnome2 components installed like gnome-desktop, this is what's causing a lot of crap to be pulled in. You shouldn't even need gdm... can you use some other login manager?

Theoretically you should need neither USE=openrc-force or systemd. I don't need either on my xfce4 boxes.

I'd start scrutinizing your world file to see if there are any gnome packages that you don't really want.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
lalebarde
Guru
Guru


Joined: 03 Sep 2006
Posts: 464
Location: France, Haute-Garonne

PostPosted: Thu Sep 11, 2014 7:45 am    Post subject: Reply with quote

Code:
equery has USE systemd
shows the last packages installed with systemd. Then
Code:
emerge -auNv1 <package list>
enables to definitely suppress systemd from the system (of course, with -systemd in the USE entry of /etc/make.conf, and after having suppressed all systemd that may remain in /etc/portage/package.use).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum