Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] kmail 4.14.0 refuses to download email
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 373
Location: Buckinghamshire

PostPosted: Thu Sep 04, 2014 10:24 am    Post subject: [Solved] kmail 4.14.0 refuses to download email Reply with quote

Hi,

I've just installed kde 4.14.0 and kmail has stopped downloading email from my imap server.

I've tried setting up a new (kde) user, and the folders download, but none of the emails.

The server has not changed, ad still happily serves email to my Android phone and webmail.

Any suggestions, please?
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln


Last edited by Herring42 on Fri Sep 05, 2014 10:19 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4403

PostPosted: Thu Sep 04, 2014 10:52 am    Post subject: Reply with quote

mysql user?
Did you rebuild dev-qt/qtsql after mysql/mariadb update?
What does the akonadi log say?
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 373
Location: Buckinghamshire

PostPosted: Thu Sep 04, 2014 11:28 am    Post subject: Reply with quote

I'm using an external mariadb database server. I've confirmed this is running, and the user is correct.

Log .local/share/akonadi/akonadi_control.error
Code:
Executable "akonadi_nepomuk_feeder" for agent "akonadi_nepomuk_feeder" could not be found!
Executable "akonadi_folderarchive_agent" for agent "akonadi_folderarchive_agent" could not be found!


I'll try rebuilding dev-qt/qtsql
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6822
Location: Austria

PostPosted: Thu Sep 04, 2014 11:58 am    Post subject: Reply with quote

Did you (not) update akonadi-server at the same time?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 373
Location: Buckinghamshire

PostPosted: Thu Sep 04, 2014 12:13 pm    Post subject: Reply with quote

I did a full upgrade, so akonadi server etc all updated.

I'm connecting to three different servers, and kmail won't fetch mail from any of them.

It is connecting (I see this in the server logs), and as a new user will download email folders from the server, just not the emails themselves.

Further, I get a notification box with an exclamation mark, but no text for each server.

qtsql rebuild has not had an effect. I'm current rebuilding all of kde-base/ to see if that helps.
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 373
Location: Buckinghamshire

PostPosted: Thu Sep 04, 2014 1:45 pm    Post subject: Reply with quote

Reboot had no effect. Still broken.

:(
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Thu Sep 04, 2014 4:15 pm    Post subject: Reply with quote

Have a look
https://forum.kde.org/viewtopic.php?f=215&t=122643
https://bugs.kde.org/show_bug.cgi?id=338186
I don't know if it is related to your problem but a workaround is to downgrade kdepim-runtime to 4.13.3
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 373
Location: Buckinghamshire

PostPosted: Fri Sep 05, 2014 10:19 am    Post subject: Reply with quote

Ahh!

Thank you. That sorted it.

Note to other readers: 4.14.0 doesn't like courier-imap servers.

Hopefully they'll put in a fix soon.
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum