Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-color-manager ebuild fails when creating manual
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 14 May 2012
Posts: 103

PostPosted: Sun Aug 24, 2014 9:57 am    Post subject: gnome-color-manager ebuild fails when creating manual Reply with quote

I have a world update stalling on gnome-color-manager. I downgraded to the previous version which had previously installed successfully, but that will not install either. Grateful for any help

The specific error message is:

Making all in man
make[2]: Entering directory '/var/tmp/portage/gnome-extra/gnome-color-manager-3.12.3/work/gnome-color-manager-3.12.3/man'
docbook2man gcm-calibrate.sgml > /dev/null
Makefile:589: recipe for target 'gcm-calibrate.1' failed
make[2]: *** [gcm-calibrate.1] Error 8
make[2]: Leaving directory '/var/tmp/portage/gnome-extra/gnome-color-manager-3.12.3/work/gnome-color-manager-3.12.3/man'
Makefile:495: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/gnome-extra/gnome-color-manager-3.12.3/work/gnome-color-manager-3.12.3'
Makefile:426: recipe for target 'all' failed
make: *** [all] Error 2
* ERROR: gnome-extra/gnome-color-manager-3.12.3::gentoo failed (compile phase):

The full build log is here

Here is emerge --info

Portage 2.2.12 (python 3.3.5-final-0, default/linux/x86/13.0, gcc-4.8.3, glibc-2.19-r1, 3.11.6-gentoo i686)
System Settings
System uname: Linux-3.11.6-gentoo-i686-AMD_Athlon-tm-_II_X4_6400e_Processor-with-gentoo-2.2
KiB Mem: 3234892 total, 298616 free
KiB Swap: 3147772 total, 2543056 free
Timestamp of tree: Sat, 23 Aug 2014 22:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash: 4.2_p47
dev-java/java-config: 2.2.0
dev-lang/python: 2.7.8, 3.2.5-r6, 3.3.5-r1, 3.4.1
dev-util/pkgconfig: 0.28-r2
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.13.1
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4, 1.14.1
sys-devel/binutils: 2.24-r3
sys-devel/gcc: 4.5.3-r2, 4.8.3
sys-devel/gcc-config: 1.8
sys-devel/libtool: 2.4.2-r1
sys-devel/make: 4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc: 2.19-r1
Repositories: gentoo
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3"
CFLAGS="-march=amdfam10 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CPPFLAGS="-march=amdfam10 -O2 -pipe -I/usr/include/nspr"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
FCFLAGS="-march=amdfam10 -O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-march=amdfam10 -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X a52 aac acl acpi alsa apache2 auto-hinter avahi berkdb bindist bluetooth branding bzip2 cairo cdb cddb cdparanoia cdr cli corefonts cpudetection cracklib crypt css cups cxx daap dbus djvu dri dts dv dvb dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg firefox flac fortran fuse gdbm gif gnome gstreamer gtk hal iconv ipv6 isdnlog jack java javascript joystick jpeg jpeg2k lame latin1 libnotify libsamplerate lm_sensors mad mdnsresponder-compat midi mikmod mmx mmxext modules mp3 mpeg mtp mudflap mysql mythtv nautilus ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png posix ppds pppd pulseaudio python qt3 qt3support qt4 quicktime readline reflection rss samba sdl session spell spl sqlite sse sse2 sse3 ssl startup-notification svg sysfs systemd tcpd tiff transcode truetype twolame type1 unicode usb v4l vcd vdpau virtualbox vorbis wifi wma x264 x86 xcomposite xine xml xorg xv xvid xvmc zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2 canon fuji panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859sony_dscf1 sony_dscf55" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en" LIRC_DEVICES="alsa_usb audio audio_alsa creative creative_infracd hauppauge hauppauge_dvb" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Back to top
View user's profile Send private message

Joined: 14 Oct 2006
Posts: 6193

PostPosted: Sun Aug 24, 2014 5:50 pm    Post subject: Reply with quote

As long as that '>/dev/null' is appended, we really can't say much.
Back to top
View user's profile Send private message

Joined: 12 Dec 2005
Posts: 11

PostPosted: Mon Aug 25, 2014 11:05 am    Post subject: Reply with quote

having exact same issue here in a new installation -
who also had the issue . at this time they solved it by
fixed it. Emerged docbook2K and all is good.

tried to find dockook2k - but have not the package - found docbook2X and installed it but still same issue ...

found another threat that says it could be caused by docbook-sgml is not installed automatically, so also installed it, but still same error -

what can I do to further investigate and get rid of this?
Back to top
View user's profile Send private message

Joined: 12 Dec 2005
Posts: 11

PostPosted: Mon Aug 25, 2014 5:04 pm    Post subject: [SOLVED] running "emerge @preserved-rebuild" Reply with quote

:idea: ok - looks like for me I found the error ....
as per there was a bug that SGMLSpm package
was not installed - I checked but it was installed - anyway I installed it again and it sayed that
some perl libs are not updated due to a dependics of vim - as emerge suggests I ran :arrow:
emerge @preserved-rebuild

which repaired some dependics of vim and when it was finished I ran :arrow:
emerge SGMLSpm

again and now gnome-color-manager-3.12.3 is compiling and installing itself without an error :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum