Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cant connect to wireless, device not ready
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
aegir314
n00b
n00b


Joined: 21 Aug 2014
Posts: 3

PostPosted: Thu Aug 21, 2014 9:52 am    Post subject: Cant connect to wireless, device not ready Reply with quote

I just installed gentoo for the first time so im probably missing something. I've followed wiki on wifi and network manager to the letter but cannot detect any wireless networks and nm-applet says that device is not ready. I've googled and checked wiki and forum topics but nothing worked :(

Code:

iwconfig

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off



Code:

ifconfig -a

eth0      Link encap:Ethernet  HWaddr e8:11:32:d2:fa:3c 
          inet addr:192.168.5.102  Bcast:192.168.5.255  Mask:255.255.255.0
          inet6 addr: fe80::ea11:32ff:fed2:fa3c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26069 errors:0 dropped:1 overruns:0 frame:0
          TX packets:19828 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:30544248 (29.1 MiB)  TX bytes:2285903 (2.1 MiB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1440 (1.4 KiB)  TX bytes:1440 (1.4 KiB)

wlan0     Link encap:Ethernet  HWaddr dc:a9:71:55:c6:4d 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Code:

lspci -k

02:00.0 Network controller: Intel Corporation Centrino Wireless-N 130 (rev 34)
   Subsystem: Intel Corporation Centrino Wireless-N 130 BGN
   Kernel driver in use: iwlwifi
   Kernel modules: iwlwifi



Code:

nmcli dev status
DEVICE     TYPE              STATE       
eth0       802-3-ethernet    connected   
wlan0      802-11-wireless   unavailable
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7556
Location: Goose Creek SC

PostPosted: Thu Aug 21, 2014 6:08 pm    Post subject: Reply with quote

Code:
dmesg | grep -i iwl
dmesg | grep -i wlan0
anything interesting?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
aegir314
n00b
n00b


Joined: 21 Aug 2014
Posts: 3

PostPosted: Fri Aug 22, 2014 7:47 am    Post subject: Reply with quote

Thanks for replying :)

Code:

dmesg | grep -i iwl

[   25.381913] iwlwifi 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[   25.382236] iwlwifi 0000:02:00.0: irq 44 for MSI/MSI-X
[   26.023309] iwlwifi 0000:02:00.0: firmware: direct-loading firmware iwlwifi-6000g2b-6.ucode
[   26.023783] iwlwifi 0000:02:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[   26.118218] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   26.118222] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[   26.118225] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[   26.118229] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N 130 BGN, REV=0xB0
[   26.118397] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[   26.285747] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   40.259935] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[   40.266921] iwlwifi 0000:02:00.0: Radio type=0x2-0x2-0x1
[   40.347448] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
[   40.354431] iwlwifi 0000:02:00.0: Radio type=0x2-0x2-0x1

Code:

dmesg | grep -i wlan0

[   40.471278] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Back to top
View user's profile Send private message
aegir314
n00b
n00b


Joined: 21 Aug 2014
Posts: 3

PostPosted: Sat Aug 23, 2014 1:12 pm    Post subject: Reply with quote

I finally solved it, forgot to install wpa-supplicant :oops:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum